[jitsi-users] Problems with discountvoip.co.uk


#1

Hello Jitsi-List,

I am a great fan of Jitsi. I am using it for many years now. The feature I like the most, is that it enables me to start a shell-script for incoming calls etc. ... very great feature and no other sipphone has it! :wink:

Now I have two sip-providers: sipgate.de and discountvoip.co.uk.

Jitsi works perfectly with sipgate, but I just cannot manage to make calls with discountvoip.co.uk.

Jitsi says both accounts are online.

But when I try to make a call with discountvoip.co.uk it opens the little call-window, it says: "Preparing the call." And after a minute or so it says: "The remote party has not replied. The call will be disconnected."

With other sipphones this is not an issue.

Is this a known issue with jitsi? Can you help me with this?

Best greetings from Germany,

Thomas


#2

If you鈥榬e using UDP to connect to discountvoip, try to disable some of the codecs. Disable video entirely if you don鈥榯 use it (likely for SIP). This reduces the size if the invite packets and may suffice.
Otherwise we鈥榣l need your logs.

Ingo

Freundliche Gr眉sse,
Ingo Bauersachs

-- sent from my mobile

路路路

On 18 Jan 2018, at 15:29, Thomas von der Elbe <ThomasvonderElbe@gmx.de> wrote:

Hello Jitsi-List,

I am a great fan of Jitsi. I am using it for many years now. The feature I like the most, is that it enables me to start a shell-script for incoming calls etc. ... very great feature and no other sipphone has it! :wink:

Now I have two sip-providers: sipgate.de and discountvoip.co.uk.

Jitsi works perfectly with sipgate, but I just cannot manage to make calls with discountvoip.co.uk.

Jitsi says both accounts are online.

But when I try to make a call with discountvoip.co.uk it opens the little call-window, it says: "Preparing the call." And after a minute or so it says: "The remote party has not replied. The call will be disconnected."

With other sipphones this is not an issue.

Is this a known issue with jitsi? Can you help me with this?

Best greetings from Germany,

Thomas

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Dear Ingo, ... sorry for replying directly to you instead of to the list.

I attach the log-zip to this email.

And for the archive here my last email, which went the wrong way:

Hello Ingo,

I stay with English, so someone else may profit from our conversation
too! ;- )

Thank you for your fast reply!

Yes, in the connection information window it says, I'm using UDP.

I couldn't find the checkbox to disable video, but I guess, since I have no
camera installed, this is no issue!?

Now I tried probably all the audio-codecs and at least a few of them worked
at least sometimes.

The best seem to me (in this order) Opus 48000, AMR-WB 16000 and speedx 8000.

With Opus 48000 about 4 of 10 trys go through and make connection.

Now, I am not sure, what you meant by logs.

...

Herzlichen Gruss,

Thomas

2018-01-19@10.58.31-logs.zip (130 KB)

路路路

Am 18.01.2018 um 12:20 schrieb Ingo Bauersachs:

If you鈥榬e using UDP to connect to discountvoip, try to disable some of the codecs. Disable video entirely if you don鈥榯 use it (likely for SIP). This reduces the size if the invite packets and may suffice.
Otherwise we鈥榣l need your logs.

Ingo

Freundliche Gr眉sse,
Ingo Bauersachs

-- sent from my mobile

On 18 Jan 2018, at 15:29, Thomas von der Elbe <ThomasvonderElbe@gmx.de > <mailto:ThomasvonderElbe@gmx.de>> wrote:

Hello Jitsi-List,

I am a great fan of Jitsi. I am using it for many years now. The feature I like the most, is that it enables me to start a shell-script for incoming calls etc. ... very great feature and no other sipphone has it! :wink:

Now I have two sip-providers: sipgate.de <http://sipgate.de> and discountvoip.co.uk <http://discountvoip.co.uk>.

Jitsi works perfectly with sipgate, but I just cannot manage to make calls with discountvoip.co.uk <http://discountvoip.co.uk>.

Jitsi says both accounts are online.

But when I try to make a call with discountvoip.co.uk <http://discountvoip.co.uk> it opens the little call-window, it says: "Preparing the call." And after a minute or so it says: "The remote party has not replied. The call will be disconnected."

With other sipphones this is not an issue.

Is this a known issue with jitsi? Can you help me with this?

Best greetings from Germany,

Thomas

_______________________________________________
users mailing list
users@jitsi.org <mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

In these logs I see at least one call connected. The codec used for discountvoip is PCMU, so you can disable all codecs except PCMU and telephone-event. The video-codecs are still being offered to receive video, so disable h264 (and possibly vp8) as well.

Ingo

路路路

-----Original Message-----
From: users [mailto:users-bounces@jitsi.org] On Behalf Of Thomas von der Elbe
Sent: Freitag, 19. Januar 2018 17:18
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Problems with discountvoip.co.uk
Dear Ingo, ... sorry for replying directly to you instead of to the list.

I attach the log-zip to this email.

And for the archive here my last email, which went the wrong way:

Hello Ingo,

I stay with English, so someone else may profit from our conversation
too! ;- )

Thank you for your fast reply!

Yes, in the connection information window it says, I'm using UDP.

I couldn't find the checkbox to disable video, but I guess, since I have no
camera installed, this is no issue!?

Now I tried probably all the audio-codecs and at least a few of them worked
at least sometimes.

The best seem to me (in this order) Opus 48000, AMR-WB 16000 and speedx 8000.

With Opus 48000 about 4 of 10 trys go through and make connection.

Now, I am not sure, what you meant by logs.

...

Herzlichen Gruss,

Thomas

Am 18.01.2018 um 12:20 schrieb Ingo Bauersachs:

聽聽If you鈥榬e using UDP to connect to discountvoip, try to disable some of
the codecs. Disable video entirely if you don鈥榯 use it (likely for SIP). This
reduces the size if the invite packets and may suffice.
聽聽Otherwise we鈥榣l need your logs.

聽聽Ingo

聽聽Freundliche Gr眉sse,
聽聽Ingo Bauersachs

聽聽-- sent from my mobile

聽聽On 18 Jan 2018, at 15:29, Thomas von der Elbe <ThomasvonderElbe@gmx.de > <mailto:ThomasvonderElbe@gmx.de> > wrote:

聽聽聽聽Hello Jitsi-List,

聽聽聽聽I am a great fan of Jitsi. I am using it for many years now. The
feature I like the most, is that it enables me to start a shell-script for
incoming calls etc. ... very great feature and no other sipphone has it! :wink:

聽聽聽聽Now I have two sip-providers: sipgate.de <http://sipgate.de>
and discountvoip.co.uk <http://discountvoip.co.uk> .

聽聽聽聽Jitsi works perfectly with sipgate, but I just cannot manage to
make calls with discountvoip.co.uk <http://discountvoip.co.uk> .

聽聽聽聽Jitsi says both accounts are online.

聽聽聽聽But when I try to make a call with discountvoip.co.uk
<http://discountvoip.co.uk> it opens the little call-window, it says:
"Preparing the call." And after a minute or so it says: "The remote party has
not replied. The call will be disconnected."

聽聽聽聽With other sipphones this is not an issue.

聽聽聽聽Is this a known issue with jitsi? Can you help me with this?

聽聽聽聽Best greetings from Germany,

聽聽聽聽Thomas

聽聽聽聽_______________________________________________ users mailing list
聽聽聽聽users@jitsi.org <mailto:users@jitsi.org> Unsubscribe instructions
and other list options: http://lists.jitsi.org/mailman/listinfo/users

聽聽_______________________________________________ users mailing list
聽聽users@jitsi.org <mailto:users@jitsi.org> Unsubscribe instructions and
other list options: http://lists.jitsi.org/mailman/listinfo/users


#5

Dear Ingo, thank you very much! The problem is solved! :slight_smile:

I did test only the global codec-setting but the local was set to override the global. So all my testing was worthless. I didn't know, that there were two places for the codecs. I got suspicious when you wrote about the video-codec still being offered, because they where definatly disabled in global. ... this way I finally understood!

Thank you very much for your help!

I wish you a very nice weekend!

:wink:

路路路

Am 19.01.2018 um 16:47 schrieb Ingo Bauersachs:

In these logs I see at least one call connected. The codec used for discountvoip is PCMU, so you can disable all codecs except PCMU and telephone-event. The video-codecs are still being offered to receive video, so disable h264 (and possibly vp8) as well.

Ingo

-----Original Message-----
From: users [mailto:users-bounces@jitsi.org] On Behalf Of Thomas von der Elbe
Sent: Freitag, 19. Januar 2018 17:18
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Problems with discountvoip.co.uk
Dear Ingo, ... sorry for replying directly to you instead of to the list.

I attach the log-zip to this email.

And for the archive here my last email, which went the wrong way:

Hello Ingo,

I stay with English, so someone else may profit from our conversation
too! ;- )

Thank you for your fast reply!

Yes, in the connection information window it says, I'm using UDP.

I couldn't find the checkbox to disable video, but I guess, since I have no
camera installed, this is no issue!?

Now I tried probably all the audio-codecs and at least a few of them worked
at least sometimes.

The best seem to me (in this order) Opus 48000, AMR-WB 16000 and speedx 8000.

With Opus 48000 about 4 of 10 trys go through and make connection.

Now, I am not sure, what you meant by logs.

...

Herzlichen Gruss,

Thomas

Am 18.01.2018 um 12:20 schrieb Ingo Bauersachs:

聽聽If you鈥榬e using UDP to connect to discountvoip, try to disable some of
the codecs. Disable video entirely if you don鈥榯 use it (likely for SIP). This
reduces the size if the invite packets and may suffice.
聽聽Otherwise we鈥榣l need your logs.

聽聽Ingo

聽聽Freundliche Gr眉sse,
聽聽Ingo Bauersachs

聽聽-- sent from my mobile

聽聽On 18 Jan 2018, at 15:29, Thomas von der Elbe <ThomasvonderElbe@gmx.de >> <mailto:ThomasvonderElbe@gmx.de> > wrote:

聽聽聽聽Hello Jitsi-List,

聽聽聽聽I am a great fan of Jitsi. I am using it for many years now. The
feature I like the most, is that it enables me to start a shell-script for
incoming calls etc. ... very great feature and no other sipphone has it! :wink:

聽聽聽聽Now I have two sip-providers: sipgate.de <http://sipgate.de>
and discountvoip.co.uk <http://discountvoip.co.uk> .

聽聽聽聽Jitsi works perfectly with sipgate, but I just cannot manage to
make calls with discountvoip.co.uk <http://discountvoip.co.uk> .

聽聽聽聽Jitsi says both accounts are online.

聽聽聽聽But when I try to make a call with discountvoip.co.uk
<http://discountvoip.co.uk> it opens the little call-window, it says:
"Preparing the call." And after a minute or so it says: "The remote party has
not replied. The call will be disconnected."

聽聽聽聽With other sipphones this is not an issue.

聽聽聽聽Is this a known issue with jitsi? Can you help me with this?

聽聽聽聽Best greetings from Germany,

聽聽聽聽Thomas

聽聽聽聽_______________________________________________ users mailing list
聽聽聽聽users@jitsi.org <mailto:users@jitsi.org> Unsubscribe instructions
and other list options: http://lists.jitsi.org/mailman/listinfo/users

聽聽_______________________________________________ users mailing list
聽聽users@jitsi.org <mailto:users@jitsi.org> Unsubscribe instructions and
other list options: http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users