[jitsi-users] Problems using Jitsi Meet with LDAP (cyrus-sasl provider)


#1

Hi!

I'm trying to get Jitsi Meet to authenticate against LDAP (through
prosody and sasl) without success... I don't even receive an
authentication dialog when joining a conference room.

Everything is working fine when I use the "authentication = anonymous"
configuration.

What I've done:

- Using prosody-0.8.2-7.el6.x86_64 (CentOS 6)

- Installed lua-cyrussasl (lua-cyrussasl-1.0.0-1.el6.x86_64)

- Contents of file /etc/sasl2/prosody.conf

pwcheck_method: saslauthd
mech_list: PLAIN

- Relevant configuration on prosody.cfg.lua

modules_enabled = {
                "saslauth"; -- Authentication for clients and servers.
Recommended if you want to log in.
...
}

allow_registration = false
authentication = "cyrus"

- Authentication is working fine outside prosody:

$ testsaslauthd -u USER -p PASSWORD -s prosody
0: OK "Success."

- prosody user is also on sasl group. He has access to the local socket.

- Relevant log entries when I start prosody:

From auth syslog:

Dec 4 23:03:59 server1 lua: auxpropfunc error invalid parameter supplied
Dec 4 23:03:59 server1 lua: _sasl_plugin_load failed on
sasl_auxprop_plug_init for plugin: ldapdb

From prosody logs:

Dec 04 23:03:59 meet.example.com:auth_cyrus debug Available
Cyrus SASL mechanisms: PLAIN
Dec 04 23:03:59 auth_cyrus debug initializing default
authentication provider for host 'meet.example.com'
Dec 04 23:03:59 usermanager debug host 'meet.example.com' now
set to use user provider 'cyrus'

···

-

I couldn't find any more "errors" or sasl related messages.

Any ideas?
Thanks!

--
[]'s
Hugo Cisneiros (Eitch)