[jitsi-users] Problems running Jitsi Meet


#1

Hi everyone,

I'd like to run Jitsi Meet on my own server, but I can't get it to work.

I rented a $3 virtual private server with Ubuntu 14.04, default network
security only restricts outbound SMTP ports, all other ports are open.

I tried 4 ways:

1) With Docker. There's this unofficial docker container for Jitsi Meet:
https://hub.docker.com/r/robertoandrade/jitsi-meet/. It uses the Jitsi Meet
nightly debian installer. When running that, and using the server's IP
address as host name, I can connect to the web interface via https and
start a room, others can connect, but audio and video doesn't work.

2) With Docker, but changed the run.sh from the robertoandrade/jitsi-meet
container so that the stable installer gets used, and changed the docker
run command so that all ports mentioned in the Dockerfile get forwarded (80,
443, 5347, 10000/udp-10010/udp). Same result as 1.

3) New server, tried installing with the "quick installation" here:
https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md, so
using "https://download.jitsi.org stable" and "apt-get -y install
jitsi-meet". When using the server's IP address as host name, it's the same
result as 1 and 2.

4) New server, this time during the installation I used the public DNS name
of the server instead of its IP address. Now I can visit via http, which
shows the default nginx page, but the browser can't connect to https at all.

I could try the manual installation steps in
https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md, but
I'd prefer to figure out why the debian installer doesn't work for me.

What am I doing wrong? Does the debian installer work for you?

Kind regards,
Philipp


#2

Hi,

···

On Feb 26, 2017, at 14:50, Philipp Gillé <philipp.gille@gmail.com> wrote:

Hi everyone,

I'd like to run Jitsi Meet on my own server, but I can't get it to work.

I rented a $3 virtual private server with Ubuntu 14.04, default network security only restricts outbound SMTP ports, all other ports are open.

I tried 4 ways:

1) With Docker. There's this unofficial docker container for Jitsi Meet: https://hub.docker.com/r/robertoandrade/jitsi-meet/. It uses the Jitsi Meet nightly debian installer. When running that, and using the server's IP address as host name, I can connect to the web interface via https and start a room, others can connect, but audio and video doesn't work.

2) With Docker, but changed the run.sh from the robertoandrade/jitsi-meet container so that the stable installer gets used, and changed the docker run command so that all ports mentioned in the Dockerfile get forwarded (80, 443, 5347, 10000/udp-10010/udp). Same result as 1.

3) New server, tried installing with the "quick installation" here: https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md, so using "https://download.jitsi.org <https://download.jitsi.org/> stable" and "apt-get -y install jitsi-meet". When using the server's IP address as host name, it's the same result as 1 and 2.

4) New server, this time during the installation I used the public DNS name of the server instead of its IP address. Now I can visit via http, which shows the default nginx page, but the browser can't connect to https at all.

I could try the manual installation steps in https://github.com/jitsi/jitsi-meet/blob/master/doc/manual-install.md, but I'd prefer to figure out why the debian installer doesn't work for me.

What am I doing wrong? Does the debian installer work for you?

Definitely. I’d say the easiest is to stick to option 4. On the default installation HTTP will redirect to HTTPS and you should get the welcome page there. Did you manually tweak any web server settings?

Cheers,

--
Saúl


#3

Hi,

I think you need an DNS name .. (check your 3 point)
The XMMP domain is the DNS name !

By

···

On Mon, Feb 27, 2017 at 10:06 AM, Saúl Ibarra Corretgé < scorretge@atlassian.com> wrote:

Hi,

On Feb 26, 2017, at 14:50, Philipp Gillé <philipp.gille@gmail.com> wrote:

Hi everyone,

I'd like to run Jitsi Meet on my own server, but I can't get it to work.

I rented a $3 virtual private server with Ubuntu 14.04, default network
security only restricts outbound SMTP ports, all other ports are open.

I tried 4 ways:

1) With Docker. There's this unofficial docker container for Jitsi Meet:
https://hub.docker.com/r/robertoandrade/jitsi-meet/. It uses the Jitsi
Meet nightly debian installer. When running that, and using the server's IP
address as host name, I can connect to the web interface via https and
start a room, others can connect, but audio and video doesn't work.

2) With Docker, but changed the run.sh from the robertoandrade/jitsi-meet
container so that the stable installer gets used, and changed the docker
run command so that all ports mentioned in the Dockerfile get forwarded (80,
443, 5347, 10000/udp-10010/udp). Same result as 1.

3) New server, tried installing with the "quick installation" here:
https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md, so
using "https://download.jitsi.org stable" and "apt-get -y install
jitsi-meet". When using the server's IP address as host name, it's the same
result as 1 and 2.

4) New server, this time during the installation I used the public DNS
name of the server instead of its IP address. Now I can visit via http,
which shows the default nginx page, but the browser can't connect to https
at all.

I could try the manual installation steps in https://github.com/jitsi/
jitsi-meet/blob/master/doc/manual-install.md, but I'd prefer to figure
out why the debian installer doesn't work for me.

What am I doing wrong? Does the debian installer work for you?

Definitely. I’d say the easiest is to stick to option 4. On the default
installation HTTP will redirect to HTTPS and you should get the welcome
page there. Did you manually tweak any web server settings?

Cheers,

--
Saúl

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--

[image: Andrea Magatti on about.me]

Andrea Magatti
about.me/amagatti
  <http://about.me/amagatti>