[jitsi-users] Problem with JVB serving meet on 443


#1

Hello everybody,

I have a small problem, and seek for guidances…

In order to make my instance of jitsi-meet usable behins a firewalln I
tried to setup JVB to serve meet in place of nginx, as described in the
comment of https://github.com/jitsi/jitsi-meet/issues/324 (and associated
link to jitsi-dev mailing list). I departed from a working configuration
with nginx.

As my machine has no IPv6, I had to replace
org.jitsi.videobridge.rest.jetty.host=::
with
org.jitsi.videobridge.rest.jetty.host=myserver.fqdn.net
in sip-communicator.properties.

I use openjdk 1.8 on debian,
jitsi-videobri 801-1,
jitsi-meet 1.0.1217-1,
prosody 0.9.7-2+deb8,

It almost works : I have no error in jvb logs and some part of the web
frontend is loading, but without images and javascript (and thus I'm unable
to launch a conference).
The jvb log shows some warnings :

JVB 2016-09-26 12:20:49.862 WARNING: [5950]
org.jitsi.videobridge.IceUdpTransportManager.log() Cannot get transport
type.

Does somebody have any idea on how to diagnose further the problem ?

Thanks for any tip, suggestion or direction.

-Mathieu


#2

Hi,

Just created an ubuntu 16.04 vm on digitalocean and by using instructions:
https://jitsi.org/Main/DebianNightlyRepository
it produces a working jitsi-meet deployment using jetty in jvb. So
there should be some problem in your jitsi-meet ... you can check the
js console in the browser to see what is missing and check those.

Regards
damencho

···

On Tue, Sep 27, 2016 at 7:07 AM, Mathieu Clabaut <mathieu@clabaut.net> wrote:

Hello everybody,

I have a small problem, and seek for guidances…

In order to make my instance of jitsi-meet usable behins a firewalln I
tried to setup JVB to serve meet in place of nginx, as described in the
comment of https://github.com/jitsi/jitsi-meet/issues/324 (and associated
link to jitsi-dev mailing list). I departed from a working configuration
with nginx.

As my machine has no IPv6, I had to replace
org.jitsi.videobridge.rest.jetty.host=::
with
org.jitsi.videobridge.rest.jetty.host=myserver.fqdn.net
in sip-communicator.properties.

I use openjdk 1.8 on debian,
jitsi-videobri 801-1,
jitsi-meet 1.0.1217-1,
prosody 0.9.7-2+deb8,

It almost works : I have no error in jvb logs and some part of the web
frontend is loading, but without images and javascript (and thus I'm unable
to launch a conference).
The jvb log shows some warnings :

JVB 2016-09-26 12:20:49.862 WARNING: [5950]
org.jitsi.videobridge.IceUdpTransportManager.log() Cannot get transport
type.

Does somebody have any idea on how to diagnose further the problem ?

Thanks for any tip, suggestion or direction.

-Mathieu

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Thanks,

I'll try to reinstall from scratch now that the default installation does
not use nginx anymore, and keep you inform of the results.

···

On Tue, Sep 27, 2016 at 4:54 PM Damian Minkov <damencho@jitsi.org> wrote:

Hi,

Just created an ubuntu 16.04 vm on digitalocean and by using instructions:
https://jitsi.org/Main/DebianNightlyRepository
it produces a working jitsi-meet deployment using jetty in jvb. So
there should be some problem in your jitsi-meet ... you can check the
js console in the browser to see what is missing and check those.

Regards
damencho

On Tue, Sep 27, 2016 at 7:07 AM, Mathieu Clabaut <mathieu@clabaut.net> > wrote:
>
> Hello everybody,
>
> I have a small problem, and seek for guidances…
>
> In order to make my instance of jitsi-meet usable behins a firewalln I
> tried to setup JVB to serve meet in place of nginx, as described in the
> comment of https://github.com/jitsi/jitsi-meet/issues/324 (and
associated
> link to jitsi-dev mailing list). I departed from a working configuration
> with nginx.
>
> As my machine has no IPv6, I had to replace
> org.jitsi.videobridge.rest.jetty.host=::
> with
> org.jitsi.videobridge.rest.jetty.host=myserver.fqdn.net
> in sip-communicator.properties.
>
> I use openjdk 1.8 on debian,
> jitsi-videobri 801-1,
> jitsi-meet 1.0.1217-1,
> prosody 0.9.7-2+deb8,
>
> It almost works : I have no error in jvb logs and some part of the web
> frontend is loading, but without images and javascript (and thus I'm
unable
> to launch a conference).
> The jvb log shows some warnings :
>
> JVB 2016-09-26 12:20:49.862 WARNING: [5950]
> org.jitsi.videobridge.IceUdpTransportManager.log() Cannot get transport
> type.
>
> Does somebody have any idea on how to diagnose further the problem ?
>
> Thanks for any tip, suggestion or direction.
>
> -Mathieu
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

That's unrelated and probably harmless (although I don't know why it happens).

Boris

···

On 27/09/16 15:07, Mathieu Clabaut wrote:

Hello everybody,

I have a small problem, and seek for guidances…

In order to make my instance of jitsi-meet usable behins a firewalln I
tried to setup JVB to serve meet in place of nginx, as described in the
comment of https://github.com/jitsi/jitsi-meet/issues/324 (and
associated link to jitsi-dev mailing list). I departed from a working
configuration with nginx.

As my machine has no IPv6, I had to replace
org.jitsi.videobridge.rest.jetty.host=::
with
org.jitsi.videobridge.rest.jetty.host=myserver.fqdn.net
<http://myserver.fqdn.net>
in sip-communicator.properties.

I use openjdk 1.8 on debian,
jitsi-videobri 801-1,
jitsi-meet 1.0.1217-1,
prosody 0.9.7-2+deb8,

It almost works : I have no error in jvb logs and some part of the web
frontend is loading, but without images and javascript (and thus I'm
unable to launch a conference).
The jvb log shows some warnings :

JVB 2016-09-26 12:20:49.862 WARNING: [5950]
org.jitsi.videobridge.IceUdpTransportManager.log() Cannot get transport
type.


#5

Hello,

For the record, digging the debian install script, I finally found that I
had two missing lines in my sip-communicator.properties file :

org.jitsi.videobridge.rest.jetty.SSIResourceHandler.paths=/
org.jitsi.videobridge.rest.jetty.ResourceHandler.alias./interface_config.js=/usr/share/jitsi-meet/interface_config.js

Now the missing javascript files are served as expected.

I still have a problem related to focus conference, but that’s another
point.

Thanks to all.

···

On Mon, Oct 3, 2016 at 9:27 AM Boris Grozev <boris@jitsi.org> wrote:

On 27/09/16 15:07, Mathieu Clabaut wrote:
>
> Hello everybody,
>
> I have a small problem, and seek for guidances…
>
> In order to make my instance of jitsi-meet usable behins a firewalln I
> tried to setup JVB to serve meet in place of nginx, as described in the
> comment of https://github.com/jitsi/jitsi-meet/issues/324 (and
> associated link to jitsi-dev mailing list). I departed from a working
> configuration with nginx.
>
> As my machine has no IPv6, I had to replace
> org.jitsi.videobridge.rest.jetty.host=::
> with
> org.jitsi.videobridge.rest.jetty.host=myserver.fqdn.net
> <http://myserver.fqdn.net>
> in sip-communicator.properties.
>
> I use openjdk 1.8 on debian,
> jitsi-videobri 801-1,
> jitsi-meet 1.0.1217-1,
> prosody 0.9.7-2+deb8,
>
> It almost works : I have no error in jvb logs and some part of the web
> frontend is loading, but without images and javascript (and thus I'm
> unable to launch a conference).
> The jvb log shows some warnings :
>
> JVB 2016-09-26 12:20:49.862 WARNING: [5950]
> org.jitsi.videobridge.IceUdpTransportManager.log() Cannot get transport
> type.

That's unrelated and probably harmless (although I don't know why it
happens).

Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users