[jitsi-users] problem with jitsi-meet and NAT


#1

hi everyone,

firstly, thanks for developing Jitsi - it's appreciated :slight_smile:

i've just used the quick install
<https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md>
method to install Jitsi Meet at a hosting provider.

Whilst I can connect to the initial portal, as well as to the meeting room,
I cannot see other participant videos. Chat works, as does setting of names
etc. In effect I have two participants in the same room that can only see
local video.

There's NAT at the client end, so I have set up a server (coturn) and have
configured prosody to use it as per these instructions
<https://github.com/jitsi/jitsi-meet/pull/76/files?short_path=cd00439>
(enable turncredentials and set values in sip-communicator.properties etc).

I know the TURN server is up, and is listening, although i see no attempts
by anyone to access it despite setting config for prosody and jitsi.

On the client end:
I can see that POST events are occurring successfully to http-bind

I am getting Jingle errors in the console:
Jingle error Object {source: "answer"}app.bundle.js?v=34:13019
JingleSession.onJingleErrorapp.bundle.js?v=34:12445 (anonymous
function)strophe.min.js?v=1:1 (anonymous function)strophe.min.js?v=1:1
Strophe.TimedHandler.runstrophe.min.js?v=1:1 Strophe.Connection._onIdle

Jingle error Object {source: "transportinfo"}app.bundle.js?v=34:13019
JingleSession.onJingleErrorapp.bundle.js?v=34:12164 (anonymous
function)strophe.min.js?v=1:1 (anonymous function)strophe.min.js?v=1:1
Strophe.TimedHandler.runstrophe.min.js?v=1:1 Strophe.Connection._onIdle

Any ideas on how I can get this fixed?

···

--

Regards,

Andrew