[jitsi-users] Problem installing/running Jitsi meet on Debian/Nginx on local network


#1

Hello,

We are new to Jitsi Meet and would like to install and run Jitsi Meet for
our local network only. We installed it on Debian with Nginx installed
separately before.

Our host is debian.unigone.local, we followed the quick install. We chose to
generate a new self-signed certificate as proposed by the installation.

Once installation is done, there seems to be errors but one user can
successfully access the Jitsi meet page. As soon as the second user tries to
enter the room, the connection fails for both (and tries to reconnect
periodically).

I have attached the logs.

If someone can have a look at them and let me know what is wrong in our
installation, thank you!

Bruno

error.log (63 Bytes)

jicofo.log (62.9 KB)

jvb.log (529 KB)

prosody.err (486 Bytes)

prosody.log (8.08 KB)

access.log (126 KB)


#2

Hi,

So Jicofo healthcheck jvb periodically and if it is unhealthy it is
removed from the pool of jvbs that it can use. In the logs(jicofo and
jvb) there is an exception and the response to the filed healthcheck:
<iq to="focus@auth.debian.unigone.local/focus5608788710339"
from="jitsi-videobridge.debian.unigone.local" id="HO3kk-746"
type="error"><error type="cancel"><internal-server-error
xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"></internal-server-error><text
xmlns="urn:ietf:params:xml:ns:xmpp-stanzas" xml:lang="en">Failed to
bind even a single host candidate for component:Component id=1 parent
stream=stream
no local candidates.
no remote candidates. preferredPort=10769 minPort=10769
maxPort=10869</text></error></iq>

As your jvb has only one interface (excluding local addresses like
localhost and link-local), at the moment when this happend this
interface was down.
So restarting jicofo will fix the problem.

Thanks for the report. We will fix the exception, at least it should
not happen, and maybe add some log so we can more easily identify such
problems. But this case is valid one if there are no usable interfaces
- jvb is unhealthy.

Regards
damencho

···

On Thu, Mar 22, 2018 at 9:28 AM, Bruno Konik <bruno.konik@unigone.com> wrote:

Hello,

We are new to Jitsi Meet and would like to install and run Jitsi Meet for
our local network only. We installed it on Debian with Nginx installed
separately before.

Our host is debian.unigone.local, we followed the quick install. We chose to
generate a new self-signed certificate as proposed by the installation.

Once installation is done, there seems to be errors but one user can
successfully access the Jitsi meet page. As soon as the second user tries to
enter the room, the connection fails for both (and tries to reconnect
periodically).

I have attached the logs.

If someone can have a look at them and let me know what is wrong in our
installation, thank you!

Bruno

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Thank you Damencho,

So I understand we would need to restart jicofo to make it work. We will try this and let you know.

Thanks again for your very efficient support!

Bruno

···

-----Message d'origine-----
De : users [mailto:users-bounces@jitsi.org] De la part de Damian Minkov
Envoyé : vendredi 23 mars 2018 20:15
À : Jitsi Users <users@jitsi.org>
Objet : Re: [jitsi-users] Problem installing/running Jitsi meet on Debian/Nginx on
local network

Hi,

So Jicofo healthcheck jvb periodically and if it is unhealthy it is removed from the
pool of jvbs that it can use. In the logs(jicofo and
jvb) there is an exception and the response to the filed healthcheck:
<iq to="focus@auth.debian.unigone.local/focus5608788710339"
from="jitsi-videobridge.debian.unigone.local" id="HO3kk-746"
type="error"><error type="cancel"><internal-server-error
xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"></internal-server-error><text
xmlns="urn:ietf:params:xml:ns:xmpp-stanzas" xml:lang="en">Failed to bind even a
single host candidate for component:Component id=1 parent stream=stream no
local candidates.
no remote candidates. preferredPort=10769 minPort=10769
maxPort=10869</text></error></iq>

As your jvb has only one interface (excluding local addresses like localhost and
link-local), at the moment when this happend this interface was down.
So restarting jicofo will fix the problem.

Thanks for the report. We will fix the exception, at least it should not happen, and
maybe add some log so we can more easily identify such problems. But this case
is valid one if there are no usable interfaces
- jvb is unhealthy.

Regards
damencho

On Thu, Mar 22, 2018 at 9:28 AM, Bruno Konik <bruno.konik@unigone.com> > wrote:
> Hello,
>
>
>
> We are new to Jitsi Meet and would like to install and run Jitsi Meet
> for our local network only. We installed it on Debian with Nginx
> installed separately before.
>
>
>
> Our host is debian.unigone.local, we followed the quick install. We
> chose to generate a new self-signed certificate as proposed by the installation.
>
>
>
> Once installation is done, there seems to be errors but one user can
> successfully access the Jitsi meet page. As soon as the second user
> tries to enter the room, the connection fails for both (and tries to
> reconnect periodically).
>
>
>
> I have attached the logs.
>
>
>
> If someone can have a look at them and let me know what is wrong in
> our installation, thank you!
>
>
>
> Bruno
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users