[jitsi-users] problem in Jitsi Meet quick install on ubuntu 16


#1

hello, i follow this doc (https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md) on my ubuntu server, server is in a LAN network ,no public ip address or port。 when i finish “apt-get -y install jitsi-meet” no asked me to enter the hostname of the Jitsi Meet instance.so many config file is localhost. when i run “/usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh” there is a problem “The request message was malformed :: Error creating new authz :: DNS name does not have enough labels” detail is :2018-01-06 01:29:49,024:DEBUG:requests.packages.urllib3.connectionpool:https://acme-v01.api.letsencrypt.org:443 “POST /acme/new-authz HTTP/1.1” 400 137
2018-01-06 01:29:49,025:DEBUG:acme.client:Received response:
HTTP 400
Server: nginx
Content-Type: application/problem+json
Content-Length: 137
Boulder-Requester: 23656936
Replay-Nonce: TGnqj_NW_5VD1Ki6nyTpZt2xFRJEJ00_NR78oz3DKd0
Expires: Sat, 06 Jan 2018 01:29:49 GMT
Cache-Control: max-age=0, no-cache, no-store
Pragma: no-cache
Connection: close

{
"type": "urn:acme:error:malformed",
"detail": "Error creating new authz :: DNS name does not have enough labels",
"status": 400
}
how can i do,Thanks!

···

Date: Sat, 06 Jan 2018 01:29:49 GMT


#2

You cannot register a TLS cert for a “localhost” domain using Let’s Encrypt, in need to be a valid domain. If you are going to be doing some testing, use a self-signed certificate and accept the exception in your browser when prompted.

Cheers,

···

On Jan 6, 2018, at 04:06, configure <configure@aliyun.com> wrote:

hello,
        i follow this doc (https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md) on my ubuntu server, server is in a LAN network ,no public ip address or port。
        when i finish "apt-get -y install jitsi-meet" no asked me to enter the hostname of the Jitsi Meet instance.so many config file is localhost.
        when i run "/usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh" there is a problem "The request message was malformed :: Error creating new authz :: DNS name does not have enough labels"
        
        detail is :
2018-01-06 01:29:49,024:DEBUG:requests.packages.urllib3.connectionpool:https://acme-v01.api.letsencrypt.org:443 "POST /acme/new-authz HTTP/1.1" 400 137
2018-01-06 01:29:49,025:DEBUG:acme.client:Received response:
HTTP 400
Server: nginx
Content-Type: application/problem+json
Content-Length: 137
Boulder-Requester: 23656936
Replay-Nonce: TGnqj_NW_5VD1Ki6nyTpZt2xFRJEJ00_NR78oz3DKd0
Expires: Sat, 06 Jan 2018 01:29:49 GMT
Cache-Control: max-age=0, no-cache, no-store
Pragma: no-cache
Date: Sat, 06 Jan 2018 01:29:49 GMT
Connection: close

{
  "type": "urn:acme:error:malformed",
  "detail": "Error creating new authz :: DNS name does not have enough labels",
  "status": 400
}

    how can i do,Thanks!

--
Saúl