[jitsi-users] Problem connecting to the XMPP server


#1

Dear vide bridge gurus,

I was trying to bring up Jitsi video bridge on my local machine. And everything went more or less
smooth (beside missing slf4j-nop.jar, which I resolved). But when I tried to launch the bridge I got
"Connection refused" error, which I assume is failed attempt to connect to the XMPP server. Here
is more extended output I got:

Exception in thread "main" org.xmpp.component.ComponentException: java.net.ConnectException: Connection refused
     at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:272)
     at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)
     at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)
     at org.jitsi.videobridge.Main.main(Main.java:159)
Caused by: java.net.ConnectException: Connection refused
     at java.net.PlainSocketImpl.socketConnect(Native Method)
     at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
     at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
     at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
     at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
     at java.net.Socket.connect(Socket.java:529)
     at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:151)

Here is all the information which might be relevant:

1. I am running on ubuntu 10.04 (I tried both 32-bit and 64-bit installations). My hostname is "ubuntu".

2. I am using ejabberd XMPP server running also locally on the same machine, and here is the only change I made to
the ejabberd.cfg file as Jitsi website suggested:

{5275, ejabberd_service, [{host, "jitsi-videobridge.ubuntu", [{password, "password1234"}]}]},

3. The way I am trying to launch the video bridge is the following:

./jvb.sh --secret=password1234 --domain='ubuntu'

I did try various combinations and permutations of the command line parameters but to no avail.

4. There is absolutely nothing in the ejabberd log (/var/log/ejabberd/ejabberd.log) which would help to identify the
problem. Beside the following error which appears on the start of the service:

=ERROR REPORT==== 2014-01-03 20:00:06 ===
C(<0.253.0>:ejabberd_captcha:331) : The option captcha_cmd is not configured, but some module wants to use the CAPTCHA feature.

Please let me know if there is anything else I can provide. I will greatly appreciate any piece of advise as I would like to be able to start using the video conference as soon as possible.

Thanks
Yan


#2

I apologize for the unintended spam. As soon as I posted a question I figured out that I was editing
the wrong ejabberd.cfg file. I got the connection now. I might get other problems down the road but
at least this one is solved.

Thanks again
Yan

···

On 01/04/2014 08:18 AM, Yan Brenman wrote:

Dear vide bridge gurus,

I was trying to bring up Jitsi video bridge on my local machine. And everything went more or less
smooth (beside missing slf4j-nop.jar, which I resolved). But when I tried to launch the bridge I got
"Connection refused" error, which I assume is failed attempt to connect to the XMPP server. Here
is more extended output I got:

Exception in thread "main" org.xmpp.component.ComponentException: java.net.ConnectException: Connection refused
    at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:272)

    at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)

    at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)

    at org.jitsi.videobridge.Main.main(Main.java:159)
Caused by: java.net.ConnectException: Connection refused
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
    at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
    at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
    at java.net.Socket.connect(Socket.java:529)
    at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:151)

Here is all the information which might be relevant:

1. I am running on ubuntu 10.04 (I tried both 32-bit and 64-bit installations). My hostname is "ubuntu".

2. I am using ejabberd XMPP server running also locally on the same machine, and here is the only change I made to
the ejabberd.cfg file as Jitsi website suggested:

{5275, ejabberd_service, [{host, "jitsi-videobridge.ubuntu", [{password, "password1234"}]}]},

3. The way I am trying to launch the video bridge is the following:

./jvb.sh --secret=password1234 --domain='ubuntu'

I did try various combinations and permutations of the command line parameters but to no avail.

4. There is absolutely nothing in the ejabberd log (/var/log/ejabberd/ejabberd.log) which would help to identify the
problem. Beside the following error which appears on the start of the service:

=ERROR REPORT==== 2014-01-03 20:00:06 ===
C(<0.253.0>:ejabberd_captcha:331) : The option captcha_cmd is not configured, but some module wants to use the CAPTCHA feature.

Please let me know if there is anything else I can provide. I will greatly appreciate any piece of advise as I would like to be able to start using the video conference as soon as possible.

Thanks
Yan

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hello,

I apologize for the unintended spam. As soon as I posted a question I
figured out that I was editing
the wrong ejabberd.cfg file. I got the connection now. I might get other
problems down the road but
at least this one is solved.

Glad to hear that you solved the problem.

Have in mind that running your XMPP server without a real domain name
will likely cause issues later on. For example, you will have to
explicitly change the Jitsi account configuration, overriding the
"connect server" with the IP address of the server. Just adding it to
/etc/hosts will not work.

Regards,
Boris

···

On 1/4/14 5:58 PM, Yan Brenman wrote:


#4

Boris,

thank you very much for your comment. Quick question: which Jitsi account configuration are you talking about?
Where does this configuration getting stored? Please keep in my I am completely new to Jitsi.

Is this in any way related to what website mentioning as "
In order to organize a Jitsi Videobridge conference, you should open the "Tools" menu of the main window and select "Create a video bridge..."
Where does this "main window" exist? Is there a web interface to the conference bridge?

Thanks
Yan

···

On 1/4/2014 9:26 AM, Boris Grozev wrote:

Hello,

On 1/4/14 5:58 PM, Yan Brenman wrote:

I apologize for the unintended spam. As soon as I posted a question I
figured out that I was editing
the wrong ejabberd.cfg file. I got the connection now. I might get other
problems down the road but
at least this one is solved.

Glad to hear that you solved the problem.

Have in mind that running your XMPP server without a real domain name
will likely cause issues later on. For example, you will have to
explicitly change the Jitsi account configuration, overriding the
"connect server" with the IP address of the server. Just adding it to
/etc/hosts will not work.

Regards,
Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Hello,

Boris,

thank you very much for your comment. Quick question: which Jitsi
account configuration are you talking about?

Where does this configuration getting stored? Please keep in my I am
completely new to Jitsi.

Is this in any way related to what website mentioning as "
In order to organize a Jitsi Videobridge conference, you should open the
�Tools� menu of the main window and select �Create a video bridge�"
Where does this "main window" exist?

Yes, my comment refers to the case in which you would use Jitsi to
connect to the XMPP server and organize a conference.

Is there a web interface to the
conference bridge?

There's the jitmeet[1] application, which allows you to make conferences
from your browser (currently only chrome) and uses Jitsi Videobridge.

Regards,
Boris

[1] https://github.com/jitsi/jitmeet

···

On 1/5/14 5:41 PM, Yan Brenman wrote:


#6

Also available for use here:

https://meet.jit.si

Emil

···

On 05.01.14, 20:25, Boris Grozev wrote:

There's the jitmeet[1] application, which allows you to make conferences
from your browser (currently only chrome) and uses Jitsi Videobridge.

--
https://jitsi.org


#7

Hi Boris,

thanks for the reply. Unfortunately I am afraid I didn't make my questions clear. Can we please go again:

1. Where is that "connect server" jitsi account configuration options which needs to be overwritten with the IP address of the server
located? This is for the case If I am running XMPP server just on the "localhost" without the real domain name.

2. Is there any configuration to be entered on the videobridge side? That's what my question regard the web/admin interface to the
video bridge was referring to, not the client to be used with the video bridge. Looks like there answer is "no".

3. It would be extremely helpful to get the values for the configuration parameters in the config.js file ("domain", "muc", "bridge" and "bosh")
for the configuration where XMPP server and videobridge are running on the same "localhost" with no domain name assigned. And web
client is accessing this machine from another machine by it's IP address in the URL.

Thanks again for your help
Yan

···

On 1/5/2014 10:25 AM, Boris Grozev wrote:

Hello,

On 1/5/14 5:41 PM, Yan Brenman wrote:

Boris,

thank you very much for your comment. Quick question: which Jitsi
account configuration are you talking about?

Where does this configuration getting stored? Please keep in my I am
completely new to Jitsi.

Is this in any way related to what website mentioning as "
In order to organize a Jitsi Videobridge conference, you should open the
“Tools” menu of the main window and select “Create a video bridge…"
Where does this "main window" exist?

Yes, my comment refers to the case in which you would use Jitsi to
connect to the XMPP server and organize a conference.

Is there a web interface to the
conference bridge?

There's the jitmeet[1] application, which allows you to make conferences
from your browser (currently only chrome) and uses Jitsi Videobridge.

Regards,
Boris

[1] https://github.com/jitsi/jitmeet

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Hello,

Hi Boris,

thanks for the reply. Unfortunately I am afraid I didn't make my
questions clear. Can we please go again:

Sorry if I confused you.

1. Where is that "connect server" jitsi account configuration options
which needs to be overwritten with the IP address of the server
located? This is for the case If I am running XMPP server just on the
"localhost" without the real domain name.

That would be in the Jitsi client. You go to Settings->Accounts and
select your XMPP account. It's in the Connection tab.

2. Is there any configuration to be entered on the videobridge side?
That's what my question regard the web/admin interface to the
video bridge was referring to, not the client to be used with the video
bridge. Looks like there answer is "no".

You are right, the answer is "no".

3. It would be extremely helpful to get the values for the configuration
parameters in the config.js file ("domain", "muc", "bridge" and "bosh")
for the configuration where XMPP server and videobridge are running on
the same "localhost" with no domain name assigned. And web
client is accessing this machine from another machine by it's IP address
in the URL.

I don't know about the configuration for the web app.

However it is my understanding that a domain name is always needed for
XMPP. For ejabberd, a list of domain names is configured in ejabberd.cfg
(search for "hosts"), and a default value ("localhost" or the machine
hostname) is usually set by the package system.

Regards,
Boris

···

On 1/6/14 9:20 PM, Yan Brenman wrote: