[jitsi-users] Problem configuring secure rooms


#1

Hello!
I have been trying to configure the secure room feature of Jitsi-Meet for
the past few days and have been facing an error GET_SESSION_ID_ERROR after
the authorized user logs in. This is how I have reached here:

1. Installed Jitsi-Meet on a fresh VM installation of Ubuntu 16.04.1 LTS. I
have a FQDN as well as a Live IP for the VM and after the installation I
have a running version of Jitsi-Meet- *without the secure room *option.
2. I have tried to configure the secure-room option using the instructions
available at https://github.com/jitsi/jicofo#secure-domain
Basically I made changes to three files:
/etc/prosody/conf.d/mydomain.cfg.lua <https://pastebin.com/5qCgLyEY> , part
of /etc/jitsi/meet/mydomain-config.js <https://pastebin.com/itK0fRPZ> and
/etc/jitsi/jicofo/sip-communicator.properties files as required.(I have
uploaded the relevant parts of the file on pastebin)
3. I added the 'roomadmin@auth.mydomain' using *prosodyctl register*, as
required and restarted prosody.
4. I restarted jicofo as well as apache. I have even restarted the VM a
number of times.
5. Upon accessing the meeting url I am asked if I am the host (as expected)
but upon entering the username/passowrd as
*roomadmin@auth.mydomain/roomadminpassword* I am presented with the above
mentioned error <https://i.imgur.com/QHIAarg.png> while the developer
option window looks like this <https://i.imgur.com/N8QPuaB.png>. Since
entering the wrong ID/pwd information does not let me in, I think that at
least the log-in part is working just fine.
6. The prosody.log <https://pastebin.com/Aj1hmEcZ> and jicofo.log
<https://pastebin.com/7mdHiAxM> are linked herewith.

I have come across others facing the same issue but it does not look like
it has been resolved so far. Some of the links showing people facing the
same problem are:
https://github.com/jitsi/jicofo/issues/191 and
http://lists.jitsi.org/pipermail/users/2017-March/012642.html

I even tried installing the unstable version of Jitsi-Meet but got caught
up in the LetsEncrypt certificate errors for my server, since it was
already configured for the same IP/domain name...but I guess that is an
issue for another day.

Please let me know if anyone has been able to find a solution to the
problem. Also let me know if any more input from my side can be of help to
the developers and debuggers.

Cheers!
Gaurav Kumar

ยทยทยท

--
Scientist/Engineer
Regional Remote Sensing Centre
NRSC/ISRO/DOS
CAZRI Campus
Jodhpur, Rajasthan