[jitsi-users] problem adding sip account with full email address in username


#1

Dear All,

I would like to report a bug that's observed using Jitsi 2.2.4603.9615
under linux x64.

Basically I'm trying to use a SIP account with Jitsi. When adding an
account it asks for SIP id in the form of "username@registrar.com" now
in my case username is a full email address (e.g.
email.user@server.com) already, so the id will end up looking like
"email.user@server.com@registrar.com" this is later interpreted by
Jitsi incorrectly, such that either the registrar becomes
"server.com@registrar.com" or if I manually specify that to the
correct "sip.registrar.com" the username is truncated to "email.user".

The issue is always reproducible. Please advise me how to solve it!

Thanks a lot,
Kristof


#2

Hey there,

You should enter your SIP address when creating the account. This could
only look like user@example.com. You can then specify custom values for
username and proxy.

Emil

--sent from my mobile

···

On Aug 12, 2013 12:27 PM, "kristof.ralovich@gmail.com" < kristof.ralovich@gmail.com> wrote:

Dear All,

I would like to report a bug that's observed using Jitsi 2.2.4603.9615
under linux x64.

Basically I'm trying to use a SIP account with Jitsi. When adding an
account it asks for SIP id in the form of "username@registrar.com" now
in my case username is a full email address (e.g.
email.user@server.com) already, so the id will end up looking like
"email.user@server.com@registrar.com" this is later interpreted by
Jitsi incorrectly, such that either the registrar becomes
"server.com@registrar.com" or if I manually specify that to the
correct "sip.registrar.com" the username is truncated to "email.user".

The issue is always reproducible. Please advise me how to solve it!

Thanks a lot,
Kristof

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hi Emil,

this is exactly what I'm doing. My SIP address is
"email.user@server.com@registrar.com". I guess Jitsi is taking the
first "@" as separator of this string and that causes the problem,
looking for the last occurrence of "@" would allow for a correct
split. If you could point me in the sources where this happens, I
could try out my own theory to change the way the sip address is
split.

Thanks,
Kristof

···

On Mon, Aug 12, 2013 at 12:57 PM, Emil Ivov <emcho@jitsi.org> wrote:

Hey there,

You should enter your SIP address when creating the account. This could only
look like user@example.com. You can then specify custom values for username
and proxy.

Emil

--sent from my mobile

On Aug 12, 2013 12:27 PM, "kristof.ralovich@gmail.com" > <kristof.ralovich@gmail.com> wrote:

Dear All,

I would like to report a bug that's observed using Jitsi 2.2.4603.9615
under linux x64.

Basically I'm trying to use a SIP account with Jitsi. When adding an
account it asks for SIP id in the form of "username@registrar.com" now
in my case username is a full email address (e.g.
email.user@server.com) already, so the id will end up looking like
"email.user@server.com@registrar.com" this is later interpreted by
Jitsi incorrectly, such that either the registrar becomes
"server.com@registrar.com" or if I manually specify that to the
correct "sip.registrar.com" the username is truncated to "email.user".

The issue is always reproducible. Please advise me how to solve it!

Thanks a lot,
Kristof

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Hey Kristof,

Hi Emil,

this is exactly what I'm doing. My SIP address is
"email.user@server.com@registrar.com".

This cannot be your SIP address because it is not a valid SIP URI.
Your address should be something like:

userpart@registrar.com

As explained in my previous e-mail, you can then add the server.com
server in the advanced settings.

I guess Jitsi is taking the
first "@" as separator of this string and that causes the problem,
looking for the last occurrence of "@" would allow for a correct
split. If you could point me in the sources where this happens, I
could try out my own theory to change the way the sip address is
split.

What actually should happen in this case is that we should simply be
throwing an error and refusing the string as invalid because of the
two "@" signs. The code is in the sipaccregwiz plugin if you'd like to
take a stab at that.

Cheers,
Emil

···

On Mon, Aug 12, 2013 at 1:02 PM, kristof.ralovich@gmail.com <kristof.ralovich@gmail.com> wrote:

Thanks,
Kristof

On Mon, Aug 12, 2013 at 12:57 PM, Emil Ivov <emcho@jitsi.org> wrote:

Hey there,

You should enter your SIP address when creating the account. This could only
look like user@example.com. You can then specify custom values for username
and proxy.

Emil

--sent from my mobile

On Aug 12, 2013 12:27 PM, "kristof.ralovich@gmail.com" >> <kristof.ralovich@gmail.com> wrote:

Dear All,

I would like to report a bug that's observed using Jitsi 2.2.4603.9615
under linux x64.

Basically I'm trying to use a SIP account with Jitsi. When adding an
account it asks for SIP id in the form of "username@registrar.com" now
in my case username is a full email address (e.g.
email.user@server.com) already, so the id will end up looking like
"email.user@server.com@registrar.com" this is later interpreted by
Jitsi incorrectly, such that either the registrar becomes
"server.com@registrar.com" or if I manually specify that to the
correct "sip.registrar.com" the username is truncated to "email.user".

The issue is always reproducible. Please advise me how to solve it!

Thanks a lot,
Kristof

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31