[jitsi-users] Possible Memory Leak in Windows 10?


#1

Hello there,

I have been using Jitsi for a few days now on Windows 10 64bit (looks
great despite this mail!). At some point while idle, Windows will notify
me that it needs to close apps to prevent memory loss. I only see about
80% RAM utilization at the time so it's odd. Windows will strt by
closing Videos in browser, then the web browsers, followed by the Video
driver. Ultimately resulting in all apps closed and a reboot needed to
recover. I cnan try to debug further with some suggestions or guidance
if provided.

Additionally I have not been able to receive Audio from my VoIP server
despite the device sound settings being correct and confirm, I can hear
the ringing audio from Jitsi and have ensured proper codecs are in use.
This may be the way Jitsi is doing NAT but the SIP packets are valid and
NAT seems not to be the issue. Perhaps its another bug with Windows 10
somehow..

Thank you.

Matt M.


#2

This is not related to windows 10. Please search the mailarchive of this
list for this topic :

"jitsi crashes with out of memory errors taking the system to a collapse"

···

Am 27.10.2015 um 20:44 schrieb Matthew Martin:

Hello there,

I have been using Jitsi for a few days now on Windows 10 64bit (looks
great despite this mail!). At some point while idle, Windows will
notify me that it needs to close apps to prevent memory loss. I only
see about 80% RAM utilization at the time so it’s odd. Windows will
strt by closing Videos in browser, then the web browsers, followed by
the Video driver. Ultimately resulting in all apps closed and a reboot
needed to recover. I cnan try to debug further with some suggestions
or guidance if provided.

-------------------------------------------------------------------------------------

if you encounter the following problem :

your using sipgate.de/at/ch/com or a similar SIP telephone company,
and the online/offline state is switching frequently by itself,
and your system is crashing after some hours with OOM (outofmemory) errors,
and you see repeatedly this message in the logfile :

"Invalid transport: UDP" + a java stracktrace about an
illegalArgumentException

this is your workaround until it gets fixed:

1. switch from stable to nightly build 2.9.5454++ ( just to get sure,
may work with 2.8 stable too )
2. Disable MWI in your SIP account settings: Options->Connection-> MWI
( Messages Waiting / Anrufbeantworter in german)

-------------------------------------------------------------------------------------

marius