[jitsi-users] Permissions on /etc/jitsi/jicofo


#1

Symptom: the very first startup of Jitsi Meet works, but the following
startups won't.

This occurred to me a couple of days ago during my Docker attempts
(Debian 8 amd64; jicofo Debian package 1.0-152-1), and it's still valid
right now (jicofo 1.0-160-1, jitsi-meet 1.0.710-1):

1 - install the jitsi-meet package but do not start anything yet
2 - the permissions on the directory /etc/jitsi/jicofo are correct: 750
3 - /etc/init.d/jicofo start
4 - now the permissions are 700 (the group "jitsi" has no longer the
right to read and to traverse the directory).

Result: the processes run, but there are NO logs, on the Jitsi Meet web
interface you see "Conference focus" error boxes.

I suspected first some mismatch between the jicofo and prosody
authentications, but it turned out that the directory permissions were
wrong. A simple
    chmod g+rx /etc/jitsi/jicofo
was sufficient to make everything work well again.

I realise that some of this may be specific to Docker. If it's any help,
I'll try to spin up a "real VM".

All the best,
Viktor.


#2

we run jitsi meet on bare metal and did never encounter such permission
issues.

···

Am 25.10.2015 um 23:09 schrieb Viktor Horvath:

Symptom: the very first startup of Jitsi Meet works, but the following
startups won't.

This occurred to me a couple of days ago during my Docker attempts
(Debian 8 amd64; jicofo Debian package 1.0-152-1), and it's still valid
right now (jicofo 1.0-160-1, jitsi-meet 1.0.710-1):

1 - install the jitsi-meet package but do not start anything yet
2 - the permissions on the directory /etc/jitsi/jicofo are correct: 750
3 - /etc/init.d/jicofo start
4 - now the permissions are 700 (the group "jitsi" has no longer the
right to read and to traverse the directory).

Result: the processes run, but there are NO logs, on the Jitsi Meet web
interface you see "Conference focus" error boxes.

I suspected first some mismatch between the jicofo and prosody
authentications, but it turned out that the directory permissions were
wrong. A simple
    chmod g+rx /etc/jitsi/jicofo
was sufficient to make everything work well again.

I realise that some of this may be specific to Docker. If it's any help,
I'll try to spin up a "real VM".

All the best,
Viktor.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users