[jitsi-users] Overriding Chrome audio constraints


#1

Hello,

I have an amped wireless mic that doesn't like auto gain. It breaks up terribly with even a little increase. I didn't notice any AGC activity on Windows but on Chrome Ubuntu it happens consistently (tested up to v56).

I see in the code where the constraint googAutoGainControl is set to true. Is it possible to override this value with a config or URL parameter?

Thanks,

John


#2

Hi,

I’m afraid that’s not something that can be configured. As a workaround, you can try to use Firefox, which doesn’t have those audio constraints.

Cheers,

···

On Feb 15, 2017, at 20:23, John Lightfoot <john@vizhn.com> wrote:

Hello,
I have an amped wireless mic that doesn't like auto gain. It breaks up terribly with even a little increase. I didn't notice any AGC activity on Windows but on Chrome Ubuntu it happens consistently (tested up to v56).

I see in the code where the constraint googAutoGainControl is set to true. Is it possible to override this value with a config or URL parameter?

--
Saúl


#3

Thanks for the response, Saul. I was concerned about switching to Firefox due to the mandatory IQ decrease of a few points (https://en.wikipedia.org/wiki/Intelligence_Quotient_(IQ)_and_Browser_Usage). I really can't afford that so I dug a little deeper on the Chrome AGC issue. It turns out AGC increases the gain a little in cases where the volume is set low (i.e., when your mic is already amped). If you launch Chrome with the --agc-startup-min-volume=12 option, it leaves the gain value alone. 12, by the way, is the lowest value. That might be a useful tidbit if anyone else has similar issues.

John

···

________________________________
From: users <users-bounces@jitsi.org> on behalf of Saúl Ibarra Corretgé <scorretge@atlassian.com>
Sent: Thursday, February 16, 2017 1:15:43 AM
To: Jitsi Users
Subject: Re: [jitsi-users] Overriding Chrome audio constraints

On Feb 15, 2017, at 20:23, John Lightfoot <john@vizhn.com<mailto:john@vizhn.com>> wrote:

Hello,
I have an amped wireless mic that doesn't like auto gain. It breaks up terribly with even a little increase. I didn't notice any AGC activity on Windows but on Chrome Ubuntu it happens consistently (tested up to v56).

I see in the code where the constraint googAutoGainControl is set to true. Is it possible to override this value with a config or URL parameter?

Hi,

I’m afraid that’s not something that can be configured. As a workaround, you can try to use Firefox, which doesn’t have those audio constraints.

Cheers,

--
Saúl