[jitsi-users] Outstanding problems


#1

I posted about each of these problems separately in the past but don't
seem to have had any replies, so I'll bundle them up in the hope of
getting them noticed.

1. I've got "Log chat history" unticked in Options - General, so why when
I click on a contact's name does it show the conversation I had on the
18 December?

I need to know that any secure call/chat program I use won't log my
conversations as well as protect them in transmission and I'm rather
surprised and disappointed that Jitsi fails on this front.

2. I keep finding that users I've already authorized will be marked as
"Waiting for authorization" either when I start Jitsi, or as just
happened when I move the user to a group. It's still like that after
several restarts now (it's a Jabber.org contact)

3. Yahoo e-mail notifications don't work at all for me, even though
they apparently should.

4. I got my friend to install Jitsi on his MAC and we had the
following problems.

He added me as a Yahoo contact and I Authorized him and then saw him
listed twice in my Jitsi. I deleted one, which left the other OK.

The Authenticate buddy window is confusing as it says "Please enter
the fingerprint you received from x" but this doesn't appear to be
necessary as just selecting "I have" and clicking Authenticate seems
to work. If it were necessary to enter the fingerprint, it should be
possible to copy and paste it from above (we verified over the phone)
rather than having to type it manually.

After authenticating, we still couldn't secure chat. When I tried my
window said "You sent an unreadable encrypted message". My friends
Preferences - Security tab showed no fingerprint for his account and
he had to restart Jitsi. After that, on his PC the Security tab shows
two entries for my account both with the same fingerprint. I was able
to start a secure chat with him though (at least I think I did, his
contact in my Jitsi is set to Require Private Messaging and the End Private
Conversation option is showing. Would be good if there was some lock
indicator in the chat window).

He also signed up for a @jabber.org account when installing Jitsi and
I have a @jit.si account so he tried to add me and I got the
Authorisation pop-up but his account just shows in my Jitsi as Waiting
for Authorisation and he doesn't receive a pop-up, even if I click
Re-request authorisation. He got my contact listed twice in his Jitsi
this time, so he had to delete one of them.

I'm running build 3967. I imagine he's just downloaded the stable version.