[jitsi-users] OTR Decode not working on linux deb x64


#1

Hi,

starting build 2.5.5013 to actual build 2.5.5016 , the OTR decode function isn't working anymore.
Padlock is showed open and gray , I tried to delete and add again the fingerprint but that has no effect.


#2

Hi,

starting build 2.5.5011 to actual build 2.5.5016, the type of device (mobile or desktop) isn't showed correctly that prevents from doing videocalls .
A solution is restarting the program but it randomly reappeared.


#3

In build 2.5.5012 enabling OTR results into error then appearing a crashed padlock.


#4

Hello mrk,

We are very sorry about the problems that you are experiencing with the OTR!

starting build 2.5.5013 to actual build 2.5.5016 , the OTR decode function

isn't working anymore.
Padlock is showed open and gray , I tried to delete and add again the
fingerprint but that has no effect.

If I understand correctly, the padlock icon of the Contact that you are
trying to chat with is open and gray. This means that the OTR with this
particular Contact is *disabled. *In this case you will not be able to
establish OTR encrypted session (you won't be able to click on the Padlock
because its disabled) and also the remote party won't be able to start OTR
with you.

In order to enable the OTR function for the particular Contact that you are
trying to chat with, you have to click on Secure chat -> Choose the
appropriate contact (this is only in case you have merged several contacts
into one) -> Enable private messaging. Once you enable the OTR the Padlock
will become clickable and you will be able to establish OTR sessions.

I hope this was helpful!

If you experience any further problems please feel free to contact me!

Best regards,
Marin

···

On Sat, Jan 11, 2014 at 3:42 PM, mrk <marcorossi2k@gmail.com> wrote:

Hi,

starting build 2.5.5013 to actual build 2.5.5016 , the OTR decode function
isn't working anymore.
Padlock is showed open and gray , I tried to delete and add again the
fingerprint but that has no effect.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Hey Marin,

···

On Sat, Jan 11, 2014 at 6:19 PM, Marin Dzhigarov <marin@jitsi.org> wrote:

In order to enable the OTR function for the particular Contact that you are
trying to chat with, you have to click on Secure chat -> Choose the
appropriate contact (this is only in case you have merged several contacts
into one) -> Enable private messaging.

This doesn't sound right. I don't think we have discussed such a
change so could you please explain the reason?

Right now this seems like an unnecessary extra step with no obvious benefit.

Emil

--
https://jitsi.org


#6

Hi there ,

I just tried build 2.5.5022, padlock isn't still clickable but i can set up a secure chat thru the menu with label "secure" .
My question : Is this the expected action for this feature and padlock icon will be just a status icon not for secure/unsecure the chat's content?

Thanks.


#7

Hello,

This doesn't sound right. I don't think we have discussed such a

change so could you please explain the reason?

Right now this seems like an unnecessary extra step with no obvious
benefit.

This is not something new. OTR has always had the possibility of being
enabled/disabled. It is enabled by default though.

Thanks for the reply but i know how that works , both have otr enable,

there's no problem with previous versions just in the range i said on my
previous message and it's still present on latest build 2.5.5019.
I see only the OTR coded message when i talk to my contacts, that's why i
think there's something wrong with the otr decode function or with the
decrypting key.

I will need some more information here:
1] What protocol are you using? Is it XMPP or something else?
2] Do you see an open padlock when you chat with your contacts?
3] If the answer to 2] is 'yes' then do your contacts receive your messages
unencrypted?
4] You are saying that you see the messages that your contacts send you as
encrypted. Do you have any idea whether theirs padlock is open?
5] Could you please reproduce the issue and send me the logs to
marin@jitsi.org?

Thanks in advance!

Best regards,
Marin

···

On Sun, Jan 12, 2014 at 2:19 AM, Emil Ivov <emcho@jitsi.org> wrote:

Hey Marin,

On Sat, Jan 11, 2014 at 6:19 PM, Marin Dzhigarov <marin@jitsi.org> wrote:
> In order to enable the OTR function for the particular Contact that you
are
> trying to chat with, you have to click on Secure chat -> Choose the
> appropriate contact (this is only in case you have merged several
contacts
> into one) -> Enable private messaging.

This doesn't sound right. I don't think we have discussed such a
change so could you please explain the reason?

Right now this seems like an unnecessary extra step with no obvious
benefit.

Emil

--
https://jitsi.org

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Now padlock results clickable and can be open and close .

Thanks for the fix.

···

On 12/01/2014 14:30, mrk wrote

Hi there ,

I just tried build 2.5.5022, padlock isn't still clickable but i can set up a secure chat thru the menu with label "secure" .
My question : Is this the expected action for this feature and padlock icon will be just a status icon not for secure/unsecure the chat's content?

Thanks.


#9

This doesn't sound right. I don't think we have discussed such a
change so could you please explain the reason?

Right now this seems like an unnecessary extra step with no obvious
benefit.

This is not something new. OTR has always had the possibility of
being enabled/disabled. It is enabled by default though.

Yes. The change that I was referring to is the fact that now one needs
to regularly go through the (relatively hidden) menu in order to allow
oneself the option of starting OTR.

I realize that this might not be intentional but the problem does
occur with your latest update.

Could you please explain the change that you made there?

Emil

···

On Sun, Jan 12, 2014 at 3:45 AM, Marin Dzhigarov <marin@jitsi.org> wrote:

Hello,

This doesn't sound right. I don't think we have discussed such a
change so could you please explain the reason?

Right now this seems like an unnecessary extra step with no obvious
benefit.

This is not something new. OTR has always had the possibility of being
enabled/disabled. It is enabled by default though.

Thanks for the reply but i know how that works , both have otr enable,
there's no problem with previous versions just in the range i said on my
previous message and it's still present on latest build 2.5.5019.
I see only the OTR coded message when i talk to my contacts, that's why i
think there's something wrong with the otr decode function or with the
decrypting key.

I will need some more information here:
1] What protocol are you using? Is it XMPP or something else?
2] Do you see an open padlock when you chat with your contacts?
3] If the answer to 2] is 'yes' then do your contacts receive your messages
unencrypted?
4] You are saying that you see the messages that your contacts send you as
encrypted. Do you have any idea whether theirs padlock is open?
5] Could you please reproduce the issue and send me the logs to
marin@jitsi.org?

Thanks in advance!

Best regards,
Marin

On Sun, Jan 12, 2014 at 2:19 AM, Emil Ivov <emcho@jitsi.org> wrote:

Hey Marin,

On Sat, Jan 11, 2014 at 6:19 PM, Marin Dzhigarov <marin@jitsi.org> wrote:
> In order to enable the OTR function for the particular Contact that you
> are
> trying to chat with, you have to click on Secure chat -> Choose the
> appropriate contact (this is only in case you have merged several
> contacts
> into one) -> Enable private messaging.

This doesn't sound right. I don't think we have discussed such a
change so could you please explain the reason?

Right now this seems like an unnecessary extra step with no obvious
benefit.

Emil

--
https://jitsi.org

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31


#10

Hello, Thanks for your replies here the answers:

1) Protocol is XMPP from jit.si account
2) Yes I see a gray open padlock but clicking on it has no effect , it doesnt open nor close
3) My contacts (have a build prior to 5012) can read my messages but i still receive the OTR coded from them
4) Padlock on the other part is closed and green checked.
5) Yes i can send you logs but im not sure i'm able to do it today since im not home.

Regards,
Mark ( mrK )

···

I will need some more information here:
1] What protocol are you using? Is it XMPP or something else?
2] Do you see an open padlock when you chat with your contacts?
3] If the answer to 2] is 'yes' then do your contacts receive your messages unencrypted?
4] You are saying that you see the messages that your contacts send you as encrypted. Do you have any idea whether theirs padlock is open?
5] Could you please reproduce the issue and send me the logs to marin@jitsi.org <mailto:marin@jitsi.org>?

Thanks in advance!

Best regards,
Marin


#11

Yes. The change that I was referring to is the fact that now one needs
to regularly go through the (relatively hidden) menu in order to allow
oneself the option of starting OTR.
I realize that this might not be intentional but the problem does
occur with your latest update.
Could you please explain the change that you made there?

Sorry for the misunderstanding.

I took a deeper look and found out what the cause of this is.

In builds 2.5.5012 and older, the padlock checked whether both "ALLOW_V1"
and "ALLOW_V2" policy bits were set and if that was the case it enabled
itself.
However, now that we support version 3 of the protocol we also have the
policy bit "ALLOW_V3". Now the padlock is checking for all three bits
"ALLOW_V1", "ALLOW_V2" and "ALLOW_V3" in order to enable itself. But the
"ALLOW_V3" bit is not automatically set for the users.

I'm going to provide a fix in the next hour.

Sorry for the inconvinience!

Regards,
Marin

···

On Sun, Jan 12, 2014 at 10:46 AM, Emil Ivov <emcho@jitsi.org> wrote:

>> This doesn't sound right. I don't think we have discussed such a
>> change so could you please explain the reason?
>>
>> Right now this seems like an unnecessary extra step with no obvious
>> benefit.
>
>
> This is not something new. OTR has always had the possibility of
> being enabled/disabled. It is enabled by default though.

Yes. The change that I was referring to is the fact that now one needs
to regularly go through the (relatively hidden) menu in order to allow
oneself the option of starting OTR.

I realize that this might not be intentional but the problem does
occur with your latest update.

Could you please explain the change that you made there?

Emil

On Sun, Jan 12, 2014 at 3:45 AM, Marin Dzhigarov <marin@jitsi.org> wrote:
> Hello,
>
>> This doesn't sound right. I don't think we have discussed such a
>> change so could you please explain the reason?
>>
>> Right now this seems like an unnecessary extra step with no obvious
>> benefit.
>
>
> This is not something new. OTR has always had the possibility of being
> enabled/disabled. It is enabled by default though.
>
>> Thanks for the reply but i know how that works , both have otr enable,
>> there's no problem with previous versions just in the range i said on my
>> previous message and it's still present on latest build 2.5.5019.
>> I see only the OTR coded message when i talk to my contacts, that's why
i
>> think there's something wrong with the otr decode function or with the
>> decrypting key.
>
>
> I will need some more information here:
> 1] What protocol are you using? Is it XMPP or something else?
> 2] Do you see an open padlock when you chat with your contacts?
> 3] If the answer to 2] is 'yes' then do your contacts receive your
messages
> unencrypted?
> 4] You are saying that you see the messages that your contacts send you
as
> encrypted. Do you have any idea whether theirs padlock is open?
> 5] Could you please reproduce the issue and send me the logs to
> marin@jitsi.org?
>
> Thanks in advance!
>
> Best regards,
> Marin
>
>
>
> On Sun, Jan 12, 2014 at 2:19 AM, Emil Ivov <emcho@jitsi.org> wrote:
>>
>> Hey Marin,
>>
>> On Sat, Jan 11, 2014 at 6:19 PM, Marin Dzhigarov <marin@jitsi.org> > wrote:
>> > In order to enable the OTR function for the particular Contact that
you
>> > are
>> > trying to chat with, you have to click on Secure chat -> Choose the
>> > appropriate contact (this is only in case you have merged several
>> > contacts
>> > into one) -> Enable private messaging.
>>
>> This doesn't sound right. I don't think we have discussed such a
>> change so could you please explain the reason?
>>
>> Right now this seems like an unnecessary extra step with no obvious
>> benefit.
>>
>> Emil
>>
>> --
>> https://jitsi.org
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#12

Hello,

The problem that Emil mentioned should be fixed in build 2.5.5022

Regards,
Marin

···

On Sun, Jan 12, 2014 at 12:42 PM, Marin Dzhigarov <marin@jitsi.org> wrote:

Yes. The change that I was referring to is the fact that now one needs

to regularly go through the (relatively hidden) menu in order to allow
oneself the option of starting OTR.
I realize that this might not be intentional but the problem does
occur with your latest update.
Could you please explain the change that you made there?

Sorry for the misunderstanding.

I took a deeper look and found out what the cause of this is.

In builds 2.5.5012 and older, the padlock checked whether both "ALLOW_V1"
and "ALLOW_V2" policy bits were set and if that was the case it enabled
itself.
However, now that we support version 3 of the protocol we also have the
policy bit "ALLOW_V3". Now the padlock is checking for all three bits
"ALLOW_V1", "ALLOW_V2" and "ALLOW_V3" in order to enable itself. But the
"ALLOW_V3" bit is not automatically set for the users.

I'm going to provide a fix in the next hour.

Sorry for the inconvinience!

Regards,
Marin

On Sun, Jan 12, 2014 at 10:46 AM, Emil Ivov <emcho@jitsi.org> wrote:

>> This doesn't sound right. I don't think we have discussed such a
>> change so could you please explain the reason?
>>
>> Right now this seems like an unnecessary extra step with no obvious
>> benefit.
>
>
> This is not something new. OTR has always had the possibility of
> being enabled/disabled. It is enabled by default though.

Yes. The change that I was referring to is the fact that now one needs
to regularly go through the (relatively hidden) menu in order to allow
oneself the option of starting OTR.

I realize that this might not be intentional but the problem does
occur with your latest update.

Could you please explain the change that you made there?

Emil

On Sun, Jan 12, 2014 at 3:45 AM, Marin Dzhigarov <marin@jitsi.org> wrote:
> Hello,
>
>> This doesn't sound right. I don't think we have discussed such a
>> change so could you please explain the reason?
>>
>> Right now this seems like an unnecessary extra step with no obvious
>> benefit.
>
>
> This is not something new. OTR has always had the possibility of being
> enabled/disabled. It is enabled by default though.
>
>> Thanks for the reply but i know how that works , both have otr enable,
>> there's no problem with previous versions just in the range i said on
my
>> previous message and it's still present on latest build 2.5.5019.
>> I see only the OTR coded message when i talk to my contacts, that's
why i
>> think there's something wrong with the otr decode function or with the
>> decrypting key.
>
>
> I will need some more information here:
> 1] What protocol are you using? Is it XMPP or something else?
> 2] Do you see an open padlock when you chat with your contacts?
> 3] If the answer to 2] is 'yes' then do your contacts receive your
messages
> unencrypted?
> 4] You are saying that you see the messages that your contacts send you
as
> encrypted. Do you have any idea whether theirs padlock is open?
> 5] Could you please reproduce the issue and send me the logs to
> marin@jitsi.org?
>
> Thanks in advance!
>
> Best regards,
> Marin
>
>
>
> On Sun, Jan 12, 2014 at 2:19 AM, Emil Ivov <emcho@jitsi.org> wrote:
>>
>> Hey Marin,
>>
>> On Sat, Jan 11, 2014 at 6:19 PM, Marin Dzhigarov <marin@jitsi.org> >> wrote:
>> > In order to enable the OTR function for the particular Contact that
you
>> > are
>> > trying to chat with, you have to click on Secure chat -> Choose the
>> > appropriate contact (this is only in case you have merged several
>> > contacts
>> > into one) -> Enable private messaging.
>>
>> This doesn't sound right. I don't think we have discussed such a
>> change so could you please explain the reason?
>>
>> Right now this seems like an unnecessary extra step with no obvious
>> benefit.
>>
>> Emil
>>
>> --
>> https://jitsi.org
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users