[jitsi-users] Opus codec


#1

Hello,
I'm trying to make a call between the baresip client on OSX, and jitsi on windows. The baresip client reports this error: "no common audio codecs - rejected".
I looked at the traces, and it seems that jitsi offers PCMA as only codec (a=rtpmap:8 PCMA/8000/1). Moreover if I uncheck the PCMA codec I get a message from jitsi telling me that there's no voice codec anymore.
So is jitsi expecting to find an opus .dll somewhere? or is the opus .dll and the bridge to jitsi regrouped in the jnopus.dll ?
Anyway, I need help because I can't get a call with opus working :frowning:


#2

Hello,

Hello,
I'm trying to make a call between the baresip client on OSX, and jitsi
on windows. The baresip client reports this error: "no common audio
codecs - rejected".
I looked at the traces, and it seems that jitsi offers PCMA as only
codec (a=rtpmap:8 PCMA/8000/1). Moreover if I uncheck the PCMA codec I
get a message from jitsi telling me that there's no voice codec
anymore.

Opus is enabled in the configuration, right?

So is jitsi expecting to find an opus .dll somewhere? or is the opus
.dll and the bridge to jitsi regrouped in the jnopus.dll ?

Jnopus.dll includes everything that is needed.

You might want to make sure that you are using the jitsi package for the correct architecture (depending on your operating system). If that is the case, we will need to have a look at the complete logs to troubleshoot further.

Regards,
Boris

···

On September 17, 2014 1:35:30 AM EEST, Julien CURRO <liohau@hotmail.fr> wrote:

Anyway, I need help because I can't get a call with opus working :frowning:
         
------------------------------------------------------------------------

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Sent from a mobile. Please excuse my brevity.


#3

Yes opus is enabled in the configuration.
Since i'm using jitsi on a windows 64, I took the "jitsi-2.4-latest-x86.exe" installer from the jitsi downloads page. I did not see a 64bit installer, is there one somewhere that I missed?The opus i'm using on baresip is compiled by myself from the 1.1 sources, maybe jitsi use a different opus version ?
Also the two SIP accounts I am using are provided by my ISP, so is it possible that the "a=rtpmap:8 PCMA/8000/1" line is added by the SIP servers of my ISP (maybe it only supports this codec), and the other a= lines containing opus codec especially are removed by it? I don't know if SIP server are only relays or if they can be like a converter :s
Anyway I'll try a new call as soon as possible and look at the logs, if I don't find anything, I'll paste the call trace here.

···

Subject: Re: [jitsi-users] Opus codec
From: boris@jitsi.org
Date: Wed, 17 Sep 2014 02:20:36 +0300
To: users@jitsi.org; liohau@hotmail.fr; users@jitsi.org

Hello,

On September 17, 2014 1:35:30 AM EEST, Julien CURRO <liohau@hotmail.fr> wrote:
>Hello,
>I'm trying to make a call between the baresip client on OSX, and jitsi
>on windows. The baresip client reports this error: "no common audio
>codecs - rejected".
>I looked at the traces, and it seems that jitsi offers PCMA as only
>codec (a=rtpmap:8 PCMA/8000/1). Moreover if I uncheck the PCMA codec I
>get a message from jitsi telling me that there's no voice codec
>anymore.

Opus is enabled in the configuration, right?

>So is jitsi expecting to find an opus .dll somewhere? or is the opus
>.dll and the bridge to jitsi regrouped in the jnopus.dll ?

Jnopus.dll includes everything that is needed.

You might want to make sure that you are using the jitsi package for the correct architecture (depending on your operating system). If that is the case, we will need to have a look at the complete logs to troubleshoot further.

Regards,
Boris
>Anyway, I need help because I can't get a call with opus working :frowning:
>
>
>------------------------------------------------------------------------
>
>_______________________________________________
>users mailing list
>users@jitsi.org
>Unsubscribe instructions and other list options:
>http://lists.jitsi.org/mailman/listinfo/users

--
Sent from a mobile. Please excuse my brevity.