[jitsi-users] One way audio with Jigasi but works in Jitsi desktop


#1

Hi,

With the Jitsi Desktop application I am able to call a phone over PSTN and the audio works both ways. However, in my Jitsi-Meet application, the audio only works from the phone to the browser but not the other way. The logs in Jicofo, Jigasi and Videobridge don't seem to have any relevant errors. I have traced packets inside the Jitsi-Meet instance and I can see that packets are sent both ways. The codec used between Jigasi and the SIP trunk is PCMA/8000 and I have tried with both Opus and PCMA/8000 between the browser and Jitsi, but it doesn't make a difference. In addition to this, quite often audio isn't heard in either end. In this case I can see that the packets sent from the SIP trunk to Jigasi but they are not forwarded to the browser. I am building the application from master branch sources and my OS is Ubuntu 16.04.

Can anybody help me with this?

Best regards,
Markus


#2

Hi,

Yep, this is hard to debug problem. The flow is:
SIP <-> Jigasi <-> Jvb <-> Meet. You need to verify in case of one-way
audio, where is the point where the audio stops and do not reach the
SIP side.
Can you also send your config here?

Regards
damencho

···

On Wed, Mar 7, 2018 at 7:30 AM, <markus.kullberg@teliacompany.com> wrote:

Hi,

With the Jitsi Desktop application I am able to call a phone over PSTN and
the audio works both ways. However, in my Jitsi-Meet application, the audio
only works from the phone to the browser but not the other way. The logs in
Jicofo, Jigasi and Videobridge don’t seem to have any relevant errors. I
have traced packets inside the Jitsi-Meet instance and I can see that
packets are sent both ways. The codec used between Jigasi and the SIP trunk
is PCMA/8000 and I have tried with both Opus and PCMA/8000 between the
browser and Jitsi, but it doesn’t make a difference. In addition to this,
quite often audio isn’t heard in either end. In this case I can see that the
packets sent from the SIP trunk to Jigasi but they are not forwarded to the
browser. I am building the application from master branch sources and my OS
is Ubuntu 16.04.

Can anybody help me with this?

Best regards,

Markus

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hello,

I have verified that the packets are sent out from the Jitsi host to the SIP proxy, which makes me suspect that there is something wrong with the payload. I don't think the problem is with the SIP proxy since audio works when using Jitsi desktop.

I am including my config below.

/etc/jitsi/videobridge/sip-communicator.properties:

org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.public_ip/.*
org.jitsi.impl.neomedia.transform.dtls.DtlsPacketTransformer.dropUnencryptedPkts=false
org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=172.17.0.10
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=<public_ip>
# the callstats credentials
io.callstats.sdk.CallStats.appId=<id>
io.callstats.sdk.CallStats.appSecret=<secret>

# the id of the videobridge
io.callstats.sdk.CallStats.bridgeId=jitsi

# enable statistics and callstats statistics and the report interval
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_INTERVAL.callstats.io=30000
org.jitsi.videobridge.STATISTICS_TRANSPORT=callstats.io

/etc/jitsi/jigasi/sip-communicator.properties:

#Sample config with one XMPP and one SIP account configured
# Replace {sip-pass-hash} with SIP user password hash
# as well as other account properties

# Name of default JVB room that will be joined if no special header is included
# in SIP invite
org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest

net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false

# Should be enabled when using translator mode
#net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioSilenceCaptureDevice:noTransferData"]

# Adjust opus encoder complexity
net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10

net.java.sip.communicator.impl.protocol.sip.acc1515408626603=acc1515408626603
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ACCOUNT_UID=SIP\:<<JIGASI_SIPUSER>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PASSWORD=<<JIGASI_SIPPWD>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.AUTHORIZATION_NAME=<<AUTHORIZATION_NAME>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.DEFAULT_ENCRYPTION=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.DEFAULT_SIPZRTP_ATTRIBUTE=true
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.DTMF_METHOD=AUTO_DTMF
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.DTMF_MINIMAL_TONE_DURATION=70
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_PROTOCOL.DTLS-SRTP=2
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_PROTOCOL.SDES=1
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_PROTOCOL.ZRTP=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_PROTOCOL_STATUS.DTLS-SRTP=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_PROTOCOL_STATUS.SDES=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_PROTOCOL_STATUS.ZRTP=true
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.AMR-WB/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.G722/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.G723/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.GSM/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.H264/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.PCMA/8000=600
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.PCMU/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.SILK/12000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.SILK/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.SILK/24000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.SILK/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.VP8/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.iLBC/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.opus/48000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.red/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.rtx/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.speex/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.speex/32000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.speex/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.telephone-event/8000=1
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.ulpfec/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.FORCE_P2P_MODE=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.FORCE_PROXY_BYPASS=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.IS_ACCOUNT_DISABLED=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.IS_PRESENCE_ENABLED=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.IS_SERVER_OVERRIDDEN=true
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.KEEP_ALIVE_INTERVAL=30
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.KEEP_ALIVE_METHOD=REGISTER
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.OPT_CLIST_SERVER_URI=
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.OPT_CLIST_USER=
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.OPT_CLIST_USE_SIP_CREDETIALS=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.OVERRIDE_ENCODINGS=true
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.POLLING_PERIOD=30
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PREFERRED_TRANSPORT=UDP
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PROTOCOL_NAME=SIP
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PROXY_ADDRESS=<<PROXY_ADDRESS>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PROXY_AUTO_CONFIG=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PROXY_PORT=5060
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.SAVP_OPTION=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.SDES_CIPHER_SUITES=AES_CM_128_HMAC_SHA1_80,AES_CM_128_HMAC_SHA1_32
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.SERVER_ADDRESS=<<JIGASI_SIPSERVER>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.SERVER_PORT=5060
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.SUBSCRIPTION_EXPIRATION=3600
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.USER_ID=<<JIGASI_SIPUSER>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.VOICEMAIL_CHECK_URI=
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.VOICEMAIL_ENABLED=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.VOICEMAIL_URI=
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.XCAP_ENABLE=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.XIVO_ENABLE=false

# The following two props assume we are using jigasi on the same machine as
# the xmpp server.
org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true

# Activate this property if you are using self-signed certificates or other
# type of non-trusted certicates. In this mode your service trust in the
# remote certificates always.
net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true

-Markus

···

-----Original Message-----
From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 7. maaliskuuta 2018 16:14
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] One way audio with Jigasi but works in Jitsi desktop

Hi,

Yep, this is hard to debug problem. The flow is:
SIP <-> Jigasi <-> Jvb <-> Meet. You need to verify in case of one-way audio, where is the point where the audio stops and do not reach the SIP side.
Can you also send your config here?

Regards
damencho

On Wed, Mar 7, 2018 at 7:30 AM, <markus.kullberg@teliacompany.com> wrote:

Hi,

With the Jitsi Desktop application I am able to call a phone over PSTN
and the audio works both ways. However, in my Jitsi-Meet application,
the audio only works from the phone to the browser but not the other
way. The logs in Jicofo, Jigasi and Videobridge don’t seem to have any
relevant errors. I have traced packets inside the Jitsi-Meet instance
and I can see that packets are sent both ways. The codec used between
Jigasi and the SIP trunk is PCMA/8000 and I have tried with both Opus
and PCMA/8000 between the browser and Jitsi, but it doesn’t make a
difference. In addition to this, quite often audio isn’t heard in
either end. In this case I can see that the packets sent from the SIP
trunk to Jigasi but they are not forwarded to the browser. I am
building the application from master branch sources and my OS is Ubuntu 16.04.

Can anybody help me with this?

Best regards,

Markus

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Hi,

After some more researching I found out that the reason why audio sometimes (most of the times) didn't work either way was because of a docker interface. After I disabled all of my docker interfaces the calls work one way every time. Is there a workaround to make them compatible? I have a back end service running inside docker which I need.

As I said earlier I can see the UDP packets being sent out from the Jitsi host to the SIP proxy. After further investigation I can see that the length of the packets sent from the SIP proxy are 172 bytes, while the payload sent from Jitsi are 180 bytes. Is it possible that my SIP proxy is expecting the payload length to be 172 bytes and therefore they get dropped?

-Markus

···

-----Original Message-----
From: users [mailto:users-bounces@jitsi.org] On Behalf Of markus.kullberg@teliacompany.com
Sent: 12. maaliskuuta 2018 8:53
To: users@jitsi.org
Subject: Re: [jitsi-users] One way audio with Jigasi but works in Jitsi desktop

Hello,

I have verified that the packets are sent out from the Jitsi host to the SIP proxy, which makes me suspect that there is something wrong with the payload. I don't think the problem is with the SIP proxy since audio works when using Jitsi desktop.

I am including my config below.

/etc/jitsi/videobridge/sip-communicator.properties:

org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.public_ip/.*
org.jitsi.impl.neomedia.transform.dtls.DtlsPacketTransformer.dropUnencryptedPkts=false
org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=172.17.0.10
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=<public_ip>
# the callstats credentials
io.callstats.sdk.CallStats.appId=<id>
io.callstats.sdk.CallStats.appSecret=<secret>

# the id of the videobridge
io.callstats.sdk.CallStats.bridgeId=jitsi

# enable statistics and callstats statistics and the report interval org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_INTERVAL.callstats.io=30000
org.jitsi.videobridge.STATISTICS_TRANSPORT=callstats.io

/etc/jitsi/jigasi/sip-communicator.properties:

#Sample config with one XMPP and one SIP account configured # Replace {sip-pass-hash} with SIP user password hash # as well as other account properties

# Name of default JVB room that will be joined if no special header is included # in SIP invite org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest

net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false

# Should be enabled when using translator mode #net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioSilenceCaptureDevice:noTransferData"]

# Adjust opus encoder complexity
net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10

net.java.sip.communicator.impl.protocol.sip.acc1515408626603=acc1515408626603
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ACCOUNT_UID=SIP\:<<JIGASI_SIPUSER>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PASSWORD=<<JIGASI_SIPPWD>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.AUTHORIZATION_NAME=<<AUTHORIZATION_NAME>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.DEFAULT_ENCRYPTION=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.DEFAULT_SIPZRTP_ATTRIBUTE=true
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.DTMF_METHOD=AUTO_DTMF
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.DTMF_MINIMAL_TONE_DURATION=70
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_PROTOCOL.DTLS-SRTP=2
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_PROTOCOL.SDES=1
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_PROTOCOL.ZRTP=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_PROTOCOL_STATUS.DTLS-SRTP=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_PROTOCOL_STATUS.SDES=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_PROTOCOL_STATUS.ZRTP=true
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.AMR-WB/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.G722/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.G723/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.GSM/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.H264/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.PCMA/8000=600
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.PCMU/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.SILK/12000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.SILK/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.SILK/24000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.SILK/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.VP8/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.iLBC/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.opus/48000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.red/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.rtx/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.speex/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.speex/32000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.speex/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.telephone-event/8000=1
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.ulpfec/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.FORCE_P2P_MODE=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.FORCE_PROXY_BYPASS=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.IS_ACCOUNT_DISABLED=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.IS_PRESENCE_ENABLED=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.IS_SERVER_OVERRIDDEN=true
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.KEEP_ALIVE_INTERVAL=30
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.KEEP_ALIVE_METHOD=REGISTER
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.OPT_CLIST_SERVER_URI=
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.OPT_CLIST_USER=
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.OPT_CLIST_USE_SIP_CREDETIALS=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.OVERRIDE_ENCODINGS=true
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.POLLING_PERIOD=30
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PREFERRED_TRANSPORT=UDP
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PROTOCOL_NAME=SIP
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PROXY_ADDRESS=<<PROXY_ADDRESS>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PROXY_AUTO_CONFIG=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PROXY_PORT=5060
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.SAVP_OPTION=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.SDES_CIPHER_SUITES=AES_CM_128_HMAC_SHA1_80,AES_CM_128_HMAC_SHA1_32
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.SERVER_ADDRESS=<<JIGASI_SIPSERVER>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.SERVER_PORT=5060
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.SUBSCRIPTION_EXPIRATION=3600
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.USER_ID=<<JIGASI_SIPUSER>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.VOICEMAIL_CHECK_URI=
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.VOICEMAIL_ENABLED=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.VOICEMAIL_URI=
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.XCAP_ENABLE=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.XIVO_ENABLE=false

# The following two props assume we are using jigasi on the same machine as # the xmpp server.
org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true

# Activate this property if you are using self-signed certificates or other # type of non-trusted certicates. In this mode your service trust in the # remote certificates always.
net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true

-Markus

-----Original Message-----
From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 7. maaliskuuta 2018 16:14
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] One way audio with Jigasi but works in Jitsi desktop

Hi,

Yep, this is hard to debug problem. The flow is:
SIP <-> Jigasi <-> Jvb <-> Meet. You need to verify in case of one-way audio, where is the point where the audio stops and do not reach the SIP side.
Can you also send your config here?

Regards
damencho

On Wed, Mar 7, 2018 at 7:30 AM, <markus.kullberg@teliacompany.com> wrote:

Hi,

With the Jitsi Desktop application I am able to call a phone over PSTN
and the audio works both ways. However, in my Jitsi-Meet application,
the audio only works from the phone to the browser but not the other
way. The logs in Jicofo, Jigasi and Videobridge don’t seem to have any
relevant errors. I have traced packets inside the Jitsi-Meet instance
and I can see that packets are sent both ways. The codec used between
Jigasi and the SIP trunk is PCMA/8000 and I have tried with both Opus
and PCMA/8000 between the browser and Jitsi, but it doesn’t make a
difference. In addition to this, quite often audio isn’t heard in
either end. In this case I can see that the packets sent from the SIP
trunk to Jigasi but they are not forwarded to the browser. I am
building the application from master branch sources and my OS is Ubuntu 16.04.

Can anybody help me with this?

Best regards,

Markus

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Hi again,

Sorry for the spam, this will be the last update for today. I believe I have found the reason to why audio doesn't work from Jitsi->SIP. The information I provided earlier was a bit wrong - RTP payload is 160 bytes in both cases, which it should be for PCMA. The discrepancy between the packet sizes were partly in the Ethernet layer; they are a bit different when captured with tcpdump compared to wireshark. To reiterate I am comparing packets sent from the Jitsi Desktop client and packets sent from Jigasi.

However, there is also a difference in the RTP headers. The RTP packets sent from Jigasi include the header "Contributing Source identifiers" and in my case it has 2 items. My knowledge of RTC is limited but one thing that comes to mind is that it could related to WebRTC bundling policy. Another difference in the IP layer is that Jigasi sets the "Don't fragment" flag to 1 whereas in the Jitsi Desktop app it is 0, but I don't know if this is relevant.

Hope this information helps resolve the problem.

Regards,
Markus

···

-----Original Message-----
From: users [mailto:users-bounces@jitsi.org] On Behalf Of markus.kullberg@teliacompany.com
Sent: 12. maaliskuuta 2018 11:19
To: users@jitsi.org
Subject: Re: [jitsi-users] One way audio with Jigasi but works in Jitsi desktop

Hi,

After some more researching I found out that the reason why audio sometimes (most of the times) didn't work either way was because of a docker interface. After I disabled all of my docker interfaces the calls work one way every time. Is there a workaround to make them compatible? I have a back end service running inside docker which I need.

As I said earlier I can see the UDP packets being sent out from the Jitsi host to the SIP proxy. After further investigation I can see that the length of the packets sent from the SIP proxy are 172 bytes, while the payload sent from Jitsi are 180 bytes. Is it possible that my SIP proxy is expecting the payload length to be 172 bytes and therefore they get dropped?

-Markus

-----Original Message-----
From: users [mailto:users-bounces@jitsi.org] On Behalf Of markus.kullberg@teliacompany.com
Sent: 12. maaliskuuta 2018 8:53
To: users@jitsi.org
Subject: Re: [jitsi-users] One way audio with Jigasi but works in Jitsi desktop

Hello,

I have verified that the packets are sent out from the Jitsi host to the SIP proxy, which makes me suspect that there is something wrong with the payload. I don't think the problem is with the SIP proxy since audio works when using Jitsi desktop.

I am including my config below.

/etc/jitsi/videobridge/sip-communicator.properties:

org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.public_ip/.*
org.jitsi.impl.neomedia.transform.dtls.DtlsPacketTransformer.dropUnencryptedPkts=false
org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=172.17.0.10
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=<public_ip>
# the callstats credentials
io.callstats.sdk.CallStats.appId=<id>
io.callstats.sdk.CallStats.appSecret=<secret>

# the id of the videobridge
io.callstats.sdk.CallStats.bridgeId=jitsi

# enable statistics and callstats statistics and the report interval org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_INTERVAL.callstats.io=30000
org.jitsi.videobridge.STATISTICS_TRANSPORT=callstats.io

/etc/jitsi/jigasi/sip-communicator.properties:

#Sample config with one XMPP and one SIP account configured # Replace {sip-pass-hash} with SIP user password hash # as well as other account properties

# Name of default JVB room that will be joined if no special header is included # in SIP invite org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest

net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false

# Should be enabled when using translator mode #net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=["AudioSilenceCaptureDevice:noTransferData"]

# Adjust opus encoder complexity
net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10

net.java.sip.communicator.impl.protocol.sip.acc1515408626603=acc1515408626603
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ACCOUNT_UID=SIP\:<<JIGASI_SIPUSER>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PASSWORD=<<JIGASI_SIPPWD>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.AUTHORIZATION_NAME=<<AUTHORIZATION_NAME>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.DEFAULT_ENCRYPTION=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.DEFAULT_SIPZRTP_ATTRIBUTE=true
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.DTMF_METHOD=AUTO_DTMF
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.DTMF_MINIMAL_TONE_DURATION=70
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_PROTOCOL.DTLS-SRTP=2
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_PROTOCOL.SDES=1
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_PROTOCOL.ZRTP=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_PROTOCOL_STATUS.DTLS-SRTP=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_PROTOCOL_STATUS.SDES=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_PROTOCOL_STATUS.ZRTP=true
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.AMR-WB/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.G722/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.G723/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.GSM/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.H264/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.PCMA/8000=600
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.PCMU/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.SILK/12000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.SILK/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.SILK/24000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.SILK/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.VP8/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.iLBC/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.opus/48000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.red/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.rtx/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.speex/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.speex/32000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.speex/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.telephone-event/8000=1
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.ulpfec/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.FORCE_P2P_MODE=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.FORCE_PROXY_BYPASS=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.IS_ACCOUNT_DISABLED=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.IS_PRESENCE_ENABLED=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.IS_SERVER_OVERRIDDEN=true
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.KEEP_ALIVE_INTERVAL=30
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.KEEP_ALIVE_METHOD=REGISTER
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.OPT_CLIST_SERVER_URI=
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.OPT_CLIST_USER=
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.OPT_CLIST_USE_SIP_CREDETIALS=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.OVERRIDE_ENCODINGS=true
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.POLLING_PERIOD=30
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PREFERRED_TRANSPORT=UDP
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PROTOCOL_NAME=SIP
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PROXY_ADDRESS=<<PROXY_ADDRESS>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PROXY_AUTO_CONFIG=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PROXY_PORT=5060
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.SAVP_OPTION=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.SDES_CIPHER_SUITES=AES_CM_128_HMAC_SHA1_80,AES_CM_128_HMAC_SHA1_32
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.SERVER_ADDRESS=<<JIGASI_SIPSERVER>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.SERVER_PORT=5060
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.SUBSCRIPTION_EXPIRATION=3600
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.USER_ID=<<JIGASI_SIPUSER>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.VOICEMAIL_CHECK_URI=
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.VOICEMAIL_ENABLED=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.VOICEMAIL_URI=
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.XCAP_ENABLE=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.XIVO_ENABLE=false

# The following two props assume we are using jigasi on the same machine as # the xmpp server.
org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true

# Activate this property if you are using self-signed certificates or other # type of non-trusted certicates. In this mode your service trust in the # remote certificates always.
net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true

-Markus

-----Original Message-----
From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 7. maaliskuuta 2018 16:14
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] One way audio with Jigasi but works in Jitsi desktop

Hi,

Yep, this is hard to debug problem. The flow is:
SIP <-> Jigasi <-> Jvb <-> Meet. You need to verify in case of one-way audio, where is the point where the audio stops and do not reach the SIP side.
Can you also send your config here?

Regards
damencho

On Wed, Mar 7, 2018 at 7:30 AM, <markus.kullberg@teliacompany.com> wrote:

Hi,

With the Jitsi Desktop application I am able to call a phone over PSTN
and the audio works both ways. However, in my Jitsi-Meet application,
the audio only works from the phone to the browser but not the other
way. The logs in Jicofo, Jigasi and Videobridge don’t seem to have any
relevant errors. I have traced packets inside the Jitsi-Meet instance
and I can see that packets are sent both ways. The codec used between
Jigasi and the SIP trunk is PCMA/8000 and I have tried with both Opus
and PCMA/8000 between the browser and Jitsi, but it doesn’t make a
difference. In addition to this, quite often audio isn’t heard in
either end. In this case I can see that the packets sent from the SIP
trunk to Jigasi but they are not forwarded to the browser. I am
building the application from master branch sources and my OS is Ubuntu 16.04.

Can anybody help me with this?

Best regards,

Markus

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

Hi,
What is your sip server side, is it possible that it have problems
interpreting rtp extenions, we have seen such media stacks.
If I remember correctly there was a property to disable csrc extensions,
I'm just away from computer this week to check it.

Regards
damencho

Hi again,

Sorry for the spam, this will be the last update for today. I believe I
have found the reason to why audio doesn't work from Jitsi->SIP. The
information I provided earlier was a bit wrong - RTP payload is 160 bytes
in both cases, which it should be for PCMA. The discrepancy between the
packet sizes were partly in the Ethernet layer; they are a bit different
when captured with tcpdump compared to wireshark. To reiterate I am
comparing packets sent from the Jitsi Desktop client and packets sent from
Jigasi.

However, there is also a difference in the RTP headers. The RTP packets
in my case it has 2 items. My knowledge of RTC is limited but one thing
that comes to mind is that it could related to WebRTC bundling policy.
Another difference in the IP layer is that Jigasi sets the "Don't fragment"
flag to 1 whereas in the Jitsi Desktop app it is 0, but I don't know if
this is relevant.

Hope this information helps resolve the problem.

Regards,
Markus

markus.kullberg@teliacompany.com

···

On Mar 12, 2018 02:26, <markus.kullberg@teliacompany.com> wrote:
sent from Jigasi include the header "Contributing Source identifiers" and
-----Original Message-----
From: users [mailto:users-bounces@jitsi.org] On Behalf Of
Sent: 12. maaliskuuta 2018 11:19
To: users@jitsi.org
Subject: Re: [jitsi-users] One way audio with Jigasi but works in Jitsi
desktop

Hi,

After some more researching I found out that the reason why audio sometimes
(most of the times) didn't work either way was because of a docker
interface. After I disabled all of my docker interfaces the calls work one
way every time. Is there a workaround to make them compatible? I have a
back end service running inside docker which I need.

As I said earlier I can see the UDP packets being sent out from the Jitsi
host to the SIP proxy. After further investigation I can see that the
length of the packets sent from the SIP proxy are 172 bytes, while the
payload sent from Jitsi are 180 bytes. Is it possible that my SIP proxy is
expecting the payload length to be 172 bytes and therefore they get dropped?

-Markus

-----Original Message-----
From: users [mailto:users-bounces@jitsi.org] On Behalf Of
markus.kullberg@teliacompany.com
Sent: 12. maaliskuuta 2018 8:53
To: users@jitsi.org
Subject: Re: [jitsi-users] One way audio with Jigasi but works in Jitsi
desktop

Hello,

I have verified that the packets are sent out from the Jitsi host to the
SIP proxy, which makes me suspect that there is something wrong with the
payload. I don't think the problem is with the SIP proxy since audio works
when using Jitsi desktop.

I am including my config below.

/etc/jitsi/videobridge/sip-communicator.properties:

org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.public_ip/.*
org.jitsi.impl.neomedia.transform.dtls.DtlsPacketTransformer.
dropUnencryptedPkts=false
org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=172.17.0.10
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=<public_ip>
# the callstats credentials
io.callstats.sdk.CallStats.appId=<id>
io.callstats.sdk.CallStats.appSecret=<secret>

# the id of the videobridge
io.callstats.sdk.CallStats.bridgeId=jitsi

# enable statistics and callstats statistics and the report interval
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_INTERVAL.callstats.io=30000
org.jitsi.videobridge.STATISTICS_TRANSPORT=callstats.io

/etc/jitsi/jigasi/sip-communicator.properties:

#Sample config with one XMPP and one SIP account configured # Replace
{sip-pass-hash} with SIP user password hash # as well as other account
properties

# Name of default JVB room that will be joined if no special header is
included # in SIP invite org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest

net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.
enabled=false

# Should be enabled when using translator mode #net.java.sip.communicator.
impl.neomedia.audioSystem.audiosilence.captureDevice_list=["
AudioSilenceCaptureDevice:noTransferData"]

# Adjust opus encoder complexity
net.java.sip.communicator.impl.neomedia.codec.audio.
opus.encoder.COMPLEXITY=10

net.java.sip.communicator.impl.protocol.sip.acc1515408626603=
acc1515408626603
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ACCOUNT_UID=
SIP\:<<JIGASI_SIPUSER>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PASSWORD=<<
JIGASI_SIPPWD>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.
AUTHORIZATION_NAME=<<AUTHORIZATION_NAME>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.DEFAULT_
ENCRYPTION=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.DEFAULT_
SIPZRTP_ATTRIBUTE=true
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.DTMF_METHOD=
AUTO_DTMF
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.DTMF_MINIMAL_
TONE_DURATION=70
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_
PROTOCOL.DTLS-SRTP=2
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_
PROTOCOL.SDES=1
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_
PROTOCOL.ZRTP=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_
PROTOCOL_STATUS.DTLS-SRTP=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_
PROTOCOL_STATUS.SDES=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.ENCRYPTION_
PROTOCOL_STATUS.ZRTP=true
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.
AMR-WB/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.
G722/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.
G723/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.
GSM/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.
H264/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.
PCMA/8000=600
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.
PCMU/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.
SILK/12000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.
SILK/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.
SILK/24000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.
SILK/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.
VP8/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.
iLBC/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.
opus/48000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.
red/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.
rtx/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.
speex/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.
speex/32000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.
speex/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.
telephone-event/8000=1
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.Encodings.
ulpfec/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.FORCE_P2P_
MODE=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.FORCE_PROXY_
BYPASS=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.IS_ACCOUNT_
DISABLED=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.IS_PRESENCE_
ENABLED=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.IS_SERVER_
OVERRIDDEN=true
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.KEEP_ALIVE_
INTERVAL=30
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.KEEP_ALIVE_
METHOD=REGISTER
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.OPT_CLIST_
SERVER_URI=
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.OPT_CLIST_USER=
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.OPT_CLIST_
USE_SIP_CREDETIALS=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.OVERRIDE_
ENCODINGS=true
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.POLLING_
PERIOD=30
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PREFERRED_
TRANSPORT=UDP
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PROTOCOL_
NAME=SIP
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PROXY_
ADDRESS=<<PROXY_ADDRESS>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PROXY_AUTO_
CONFIG=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.PROXY_PORT=5060
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.SAVP_OPTION=0
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.SDES_CIPHER_
SUITES=AES_CM_128_HMAC_SHA1_80,AES_CM_128_HMAC_SHA1_32
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.SERVER_
ADDRESS=<<JIGASI_SIPSERVER>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.SERVER_PORT=
5060
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.SUBSCRIPTION_
EXPIRATION=3600
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.USER_ID=<<
JIGASI_SIPUSER>>
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.VOICEMAIL_
CHECK_URI=
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.VOICEMAIL_
ENABLED=false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.VOICEMAIL_URI=
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.XCAP_ENABLE=
false
net.java.sip.communicator.impl.protocol.sip.acc1515408626603.XIVO_ENABLE=
false

# The following two props assume we are using jigasi on the same machine as
# the xmpp server.
org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true

# Activate this property if you are using self-signed certificates or other
# type of non-trusted certicates. In this mode your service trust in the #
remote certificates always.
net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true

-Markus

-----Original Message-----
From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: 7. maaliskuuta 2018 16:14
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] One way audio with Jigasi but works in Jitsi
desktop

Hi,

Yep, this is hard to debug problem. The flow is:
SIP <-> Jigasi <-> Jvb <-> Meet. You need to verify in case of one-way
audio, where is the point where the audio stops and do not reach the SIP
side.
Can you also send your config here?

Regards
damencho

On Wed, Mar 7, 2018 at 7:30 AM, <markus.kullberg@teliacompany.com> wrote:

Hi,

With the Jitsi Desktop application I am able to call a phone over PSTN
and the audio works both ways. However, in my Jitsi-Meet application,
the audio only works from the phone to the browser but not the other
way. The logs in Jicofo, Jigasi and Videobridge don’t seem to have any
relevant errors. I have traced packets inside the Jitsi-Meet instance
and I can see that packets are sent both ways. The codec used between
Jigasi and the SIP trunk is PCMA/8000 and I have tried with both Opus
and PCMA/8000 between the browser and Jitsi, but it doesn’t make a
difference. In addition to this, quite often audio isn’t heard in
either end. In this case I can see that the packets sent from the SIP
trunk to Jigasi but they are not forwarded to the browser. I am
building the application from master branch sources and my OS is Ubuntu

16.04.

Can anybody help me with this?

Best regards,

Markus

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users