[jitsi-users] Odd Deb install issue


#1

Hello,

I am trying to do a first install of the full Jitsi package on a Ubuntu
16.04 Server. When running the install, I receive the following error. Any
help appreciated!

This is a base server install, with only SSH and Samba added.

sudo apt-get -y install jitsi-meet

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

jitsi-meet : Depends: jitsi-meet-prosody (= 1.0.2441-1) but it is not going
to be installed

E: Unable to correct problems, you have held broken packages.

Regards,

SteveP


#2

Have you added the jitsi repo to your sources.list?

Neil

···

On 30 Nov 2017, at 16:42, Steve Pritchard <s_pritchard@shaw.ca> wrote:

I am trying to do a first install of the full Jitsi package on a Ubuntu 16.04 Server. When running the install, I receive the following error. Any help appreciated!

__________

Neil Brown

e: neil@neilzone.co.uk <mailto:neil@neilzone.co.uk>
w: https://neilzone.co.uk <http://neilzone.co.uk/>
sip: neil@neilzone.co.uk <mailto:neil@sip.neilzone.co.uk>


#3

Sorry, I should post full details.

I have followed all instructions on this page:
https://jitsi.org/downloads/ubuntu-debian-installations-instructions/

I have added the GPG key and Jitsi-stable.list created per the instructions,
and performed a full apt-get update.

GPG key add gave me an OK result. Manually checked content of
jitsi-stable.list.

I have also attempted to install the prosody .deb file manually, and hit the
same error on install, which felt like there was some internal issue with
this version of that particular file?

My goal is to build a dev system to test jitsi in-house. I do not need all
of the functions, simply video conference, chat, private messaging. Not SIP
functionality. So am happy to install a subset. I simply assumed the full
install would be simpler.

Thanks for the quick reply Neil.

Steve

···

From: users [mailto:users-bounces@jitsi.org] On Behalf Of
jitsi@neilzone.co.uk
Sent: November 30, 2017 8:46 AM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Odd Deb install issue

On 30 Nov 2017, at 16:42, Steve Pritchard <s_pritchard@shaw.ca <mailto:s_pritchard@shaw.ca> > wrote:

I am trying to do a first install of the full Jitsi package on a Ubuntu
16.04 Server. When running the install, I receive the following error. Any
help appreciated!

Have you added the jitsi repo to your sources.list?

Neil

__________

Neil Brown

e: neil@neilzone.co.uk <mailto:neil@neilzone.co.uk>
w: https://neilzone.co.uk <http://neilzone.co.uk>
sip: neil@neilzone.co.uk <mailto:neil@sip.neilzone.co.uk>


#4

In that case, I do not know, I’m afraid – I went through the process quite recently on a Debian VM, and I’m pretty sure that installing jitsi-meet pulled in prosody too…

Sorry :frowning:

Neil

···

On 30 Nov 2017, at 17:30, Steve Pritchard <s_pritchard@shaw.ca> wrote:

I have followed all instructions on this page: https://jitsi.org/downloads/ubuntu-debian-installations-instructions/

__________

Neil Brown

e: neil@neilzone.co.uk <mailto:neil@neilzone.co.uk>
w: https://neilzone.co.uk <http://neilzone.co.uk/>
sip: neil@neilzone.co.uk <mailto:neil@sip.neilzone.co.uk>


#5

Thanks Neil. I am running it as a VM as well. It’s odd.

Steve

···

From: users [mailto:users-bounces@jitsi.org] On Behalf Of jitsi@neilzone.co.uk
Sent: November 30, 2017 9:35 AM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Odd Deb install issue

On 30 Nov 2017, at 17:30, Steve Pritchard <s_pritchard@shaw.ca <mailto:s_pritchard@shaw.ca> > wrote:

I have followed all instructions on this page: https://jitsi.org/downloads/ubuntu-debian-installations-instructions/

In that case, I do not know, I’m afraid – I went through the process quite recently on a Debian VM, and I’m pretty sure that installing jitsi-meet pulled in prosody too…

Sorry :frowning:

Neil

__________

Neil Brown

e: neil@neilzone.co.uk <mailto:neil@neilzone.co.uk>
w: https://neilzone.co.uk <http://neilzone.co.uk>
sip: neil@neilzone.co.uk <mailto:neil@sip.neilzone.co.uk>


#6

Thanks Damian! I'll do a fresh install of Ubuntu and redo the install.

Steve

···

-----Original Message-----
From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: November 30, 2017 10:15 AM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Odd Deb install issue

Hi Steve,

I just made a quick test on fresh 16.04 Ubuntu VM using the instructions from that page.
Adding the debian repo and doing 'sudo apt-get -y install jitsi-meet'
worked just fine.

Regards
damencho

On Thu, Nov 30, 2017 at 11:39 AM, Steve Pritchard <s_pritchard@shaw.ca> wrote:

Thanks Neil. I am running it as a VM as well. It’s odd.

Steve

From: users [mailto:users-bounces@jitsi.org] On Behalf Of
jitsi@neilzone.co.uk
Sent: November 30, 2017 9:35 AM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Odd Deb install issue

On 30 Nov 2017, at 17:30, Steve Pritchard <s_pritchard@shaw.ca> wrote:

I have followed all instructions on this page:
https://jitsi.org/downloads/ubuntu-debian-installations-instructions/

In that case, I do not know, I’m afraid – I went through the process
quite recently on a Debian VM, and I’m pretty sure that installing
jitsi-meet pulled in prosody too…

Sorry :frowning:

Neil

__________

Neil Brown

e: neil@neilzone.co.uk
w: https://neilzone.co.uk
sip: neil@neilzone.co.uk

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

Hi Steve,

I just made a quick test on fresh 16.04 Ubuntu VM using the
instructions from that page.
Adding the debian repo and doing 'sudo apt-get -y install jitsi-meet'
worked just fine.

Regards
damencho

···

On Thu, Nov 30, 2017 at 11:39 AM, Steve Pritchard <s_pritchard@shaw.ca> wrote:

Thanks Neil. I am running it as a VM as well. It’s odd.

Steve

From: users [mailto:users-bounces@jitsi.org] On Behalf Of
jitsi@neilzone.co.uk
Sent: November 30, 2017 9:35 AM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Odd Deb install issue

On 30 Nov 2017, at 17:30, Steve Pritchard <s_pritchard@shaw.ca> wrote:

I have followed all instructions on this page:
https://jitsi.org/downloads/ubuntu-debian-installations-instructions/

In that case, I do not know, I’m afraid – I went through the process quite
recently on a Debian VM, and I’m pretty sure that installing jitsi-meet
pulled in prosody too…

Sorry :frowning:

Neil

__________

Neil Brown

e: neil@neilzone.co.uk
w: https://neilzone.co.uk
sip: neil@neilzone.co.uk

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Thank You Damian, reinstall of the VM and Jitsi worked perfectly!

I Appreciate the help!

···

-----Original Message-----
From: users [mailto:users-bounces@jitsi.org] On Behalf Of Steve Pritchard
Sent: November 30, 2017 10:24 AM
To: 'Jitsi Users' <users@jitsi.org>
Subject: Re: [jitsi-users] Odd Deb install issue

Thanks Damian! I'll do a fresh install of Ubuntu and redo the install.

Steve

-----Original Message-----
From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: November 30, 2017 10:15 AM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Odd Deb install issue

Hi Steve,

I just made a quick test on fresh 16.04 Ubuntu VM using the instructions from that page.
Adding the debian repo and doing 'sudo apt-get -y install jitsi-meet'
worked just fine.

Regards
damencho

On Thu, Nov 30, 2017 at 11:39 AM, Steve Pritchard <s_pritchard@shaw.ca> wrote:

Thanks Neil. I am running it as a VM as well. It’s odd.

Steve

From: users [mailto:users-bounces@jitsi.org] On Behalf Of
jitsi@neilzone.co.uk
Sent: November 30, 2017 9:35 AM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Odd Deb install issue

On 30 Nov 2017, at 17:30, Steve Pritchard <s_pritchard@shaw.ca> wrote:

I have followed all instructions on this page:
https://jitsi.org/downloads/ubuntu-debian-installations-instructions/

In that case, I do not know, I’m afraid – I went through the process
quite recently on a Debian VM, and I’m pretty sure that installing
jitsi-meet pulled in prosody too…

Sorry :frowning:

Neil

__________

Neil Brown

e: neil@neilzone.co.uk
w: https://neilzone.co.uk
sip: neil@neilzone.co.uk

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users