[jitsi-users] Not automatically initiating private conversation


#1

There still seems to be issues with Jitsi failing to auto-initiate private
conversations.

I just installed Jitsi stable on a new PC build and logged into a new
account, added myself as a contact and verified the contacts at both ends
(both ch3kr.net accounts). I enabled all the options to require private
messaging, auto-initiate, etc. I'm running 2.9.5441 but I wanted to avoid
issues and frequent updates on the new build as it's for someone not very
technically minded, so that has the stable 2.8.5426.

Starting a chat from the new PC and it did not auto-initiate a private
conversation. In fact, trying to do so manually timed-out but it still says
"Private conversation started". Trying to send a message failed with the
warning that "private messaging is required" so that part worked. If I end
the private conversation manually, the lock still shows it's trying to
establish a connection for some time and only times out a bit later, so the
two options don't seem to be syncronised.

Starting the chat from my PC and it did show immediately that the lock was
engaged and I was able to sent a secured message and then it was enabled on
the other end and I could send one back. Having said that, there weren't
any lock signs next to each message as it came through, which I thought I
saw before but maybe I'm getting confused with another program.

However, after I ended the chat and then re-opened it from my PC, there was
no longer even a Secure Chat tab in the menu or the lock icon to click. I
ended the secure chat from the main window (which incidentally toggles off
the auto-initiate setting) and after fiddling about a bit, I managed to get
the missing options to show up again when I opened the chat window but even
though I re-enabled auto-initiate, it no longer does that.

After I ended the chat from the new PC, opening the chat window from my old
PC the first time showed "x has ended the private conversation, you should
do the same" but if I'm opening the window it's because I want to chat, so
it should re-initiate the private conversation automatically, not make me
manually end it and then restart it. After I closed the window (without
doing anything) and re-opened it, the Secure Chat and lock icon entries had
disappeared again but they came back after closing and re-opening it a
couple more times.

I hope this feedback helps improve Jitsi.


#2

Hi,

Thanks for reporting this.

One thing first. Please check if you have "message carbons" support
enabled or disabled? You can do this by editing your XMPP chat account.
Go to tab "Connection" and see if "Disable message carbons" is checked
or not. In my experience, OTR is more reliable/understandable with
message carbons disabled. I'm saying "understandable" because some
issues are related to a wrong setting in the UI, as both XMPP and OTR
provide ways of selecting sessions and it is not always as intuitive to
select the right session (combination) as we would (or at least I would)
like. When both OTR sessions and XMPP session are in play, it can become
quite confusing.

Further response in line ...

Kind regards,
Danny

There still seems to be issues with Jitsi failing to auto-initiate
private conversations.

I just installed Jitsi stable on a new PC build and logged into a new
account, added myself as a contact and verified the contacts at both
ends (both ch3kr.net <http://ch3kr.net> accounts). I enabled all the
options to require private messaging, auto-initiate, etc. I'm running
2.9.5441 but I wanted to avoid issues and frequent updates on the new
build as it's for someone not very technically minded, so that has the
stable 2.8.5426.

Starting a chat from the new PC and it did not auto-initiate a private
conversation. In fact, trying to do so manually timed-out but it still
says "Private conversation started".

This could be related to multiple XMPP sessions. The OTR session may be
active but not selected by default. The right-bottom select box in the
chat window should provide a mechanism to select another OTR session. If
not, do check the left-bottom select box to select your XMPP session.

Trying to send a message failed with the warning that "private
messaging is required" so that part worked. If I end the private
conversation manually, the lock still shows it's trying to establish a
connection for some time and only times out a bit later, so the two
options don't seem to be syncronised.

Same, this may be due to not having the encrypted session selected.

Starting the chat from my PC and it did show immediately that the lock
was engaged and I was able to sent a secured message and then it was
enabled on the other end and I could send one back. Having said that,
there weren't any lock signs next to each message as it came through,
which I thought I saw before but maybe I'm getting confused with
another program.

If you mean an indicator to show you that the message was received
through an encrypted channel by showing an icon next to it. Jitsi does
not do that.

However, after I ended the chat and then re-opened it from my PC,
there was no longer even a Secure Chat tab in the menu or the lock
icon to click. I ended the secure chat from the main window (which
incidentally toggles off the auto-initiate setting) and after fiddling
about a bit, I managed to get the missing options to show up again
when I opened the chat window but even though I re-enabled
auto-initiate, it no longer does that.

IIRC, explicitly disabling an OTR session disables auto-initiate for
that contact. Otherwise you would be prohibited from ever chatting in
plain text again, even though the other user might not have OTR
capabilities atm.

After I ended the chat from the new PC, opening the chat window from
my old PC the first time showed "x has ended the private conversation,
you should do the same" but if I'm opening the window it's because I
want to chat, so it should re-initiate the private conversation
automatically, not make me manually end it and then restart it.

Well, technically the OTR session is still active. What OTR is doing is
saying: Hey, you are in an OTR-encrypted session, but the other side
left. You should probably leave too, because the other user cannot
decrypt your messages anymore. The OTR spec actually specifically
describes this state.

After I closed the window (without doing anything) and re-opened it,
the Secure Chat and lock icon entries had disappeared again but they
came back after closing and re-opening it a couple more times.

So I don't complete get this, I think. What do you mean with "secure
chat (menu?) and lock icon entries had disappeared"? Do you mean the
literal: the controls are gone from the UI? Or do you mean that they are
disabled?

ยทยทยท

On 29-04-15 14:12, Derek Moss wrote:

I hope this feedback helps improve Jitsi.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users