[jitsi-users] No video or sound on Xubuntu/ARM (Samsung Chromebook). Can't build .deb either.


#1

Hello,

Firstly, a big THANK YOU to all who've contributed to Jitsi so far!

I have a Samsung Chromebook, with an Exynos 5 dual-core 1.7 GHz ARM
processor. I've installed Xubuntu 13.04 on it, as per these instructions:
http://www.whatthetech.info/installing-ubuntu-13-04-samsung-chromebook/

"uname -a" reports my kernel version as:
Linux uju 3.4.0-5-chromebook #5-Ubuntu SMP Wed Feb 20 14:59:17 UTC 2013
armv7l armv7l armv7l GNU/Linux

Overall, the Chromebook is working great so far. I'd sure like to use Jitsi
on it (as I highly doubt Microsoft will ever make a version of Skype for
Linux, for the ARM processor).

After not finding either pre-compiled Ubuntu packages for the ARM, nor any
step-by-step instructions on how to build Jitsi from source, I searched the
mailing lists. All I found was this long, old thread (Subject was “Building
jitsi on ARM platform”):

https://java.net/projects/jitsi/lists/users/archive/2012-01/message/48

I gleaned enough info from that thread build Jitsi on my own. It built
successfully, running into none of the problems encountered in that thread.
That is to say, it seems that that thread is now totally obsolete.

Here are the minimal steps I used to build Jitsi from source. Perhaps this
can act as a “Mini-HOWTO” (for those newbies who would appreciate the
help), until eventually perhaps more official documentation can be created
in the correct place (somewhere at http://jitsi.org, or within the .zip
file of the source code itself).

1) Do these commands in a Terminal, as a regular, non-root user (who IS in
the sudo group):

sudo apt-get install default-jdk ant-gcj libbsf-java liboro-java
liblog4j1.2-java libxerces2-java-gcj dpkg-dev debhelper javahelper
mkdir -p ~/src
cd ~/src

2) Now in your web browser, visit:
https://download.jitsi.org/jitsi/nightly/src/

Right-click on the zip file of the version you'd like to download, and
choose “Copy Link Location”. (Myself, I copied the URL for
jitsi-src-2.2.4611.9630.zip)

3) Back in the Terminal:

wget [paste in the URL here, with Ctrl+Shift+V]
unzip jitsi-src-[correct.versioning.here].zip
cd jitsi
ant rebuild
# [wait about 3 min 40 sec for successful build]
ant run

After about a 20 second wait, Jitsi should now launch! Yay!

···

-----

But now I've run into 3 problems (and any help would be appreciated):

Problem 1)

Once I set up my jit.si XMPP account, then go into “Tools” Menu ->
“Options” -> Video, then I see “Camera” has only <No Device> listed. Note
that my webcam DOES work using the “Cheese“ software package. Because
“Cheese” works, I'm tempted to blame Jitsi, instead of the kernel. Or
perhaps am I missing some java-related Ubuntu package (that will allow
webcam usage)? As a wild guess, I tried installing the “libwebcam0” Ubuntu
package, and rebuilding, but no luck. If it is the kernel which is to
blame, then perhaps this problem might just go away on its own, as the
linux kernel gains more support for my specific processor and video
chipset. (Note: Hardware acceleration for video isn't supported yet,
either.)

Problem 2)

Sound doesn't work. In “Options” -> “Audio”, the Audio System has only the
choice “None”. I assume that Jitsi requires the use of Pulse Audio. Am I
right?

Note: This one isn't too surprising, as only ALSA sound is currently
supported in this version of the linux kernel, given my particular ARM
processor. For example, currently my “gmusicbrowser” software can
successfully play MP3's, but “audacious” can't.

Problem 3)

I wasn't able to create a Debian package, with the command:

ant deb

The resulting error message says this:

...
[exec] dh_strip
[exec] Can't exec "x86_64-linux-gnu-strip": No such file or directory at
/usr/share/perl5/Debian/Debhelper/Dh_Lib.pm line 215.
[exec] dh_strip: x86_64-linux-gnu-strip --remove-section=.comment
--remove-section=.note --strip-unneeded
debian/jitsi/usr/share/jitsi/lib/native/libjnspeex.so failed to to execute:
No such file or directory
[exec] make: *** [binary] Error 2
[exec] dpkg-buildpackage: error: fakeroot debian/rules binary gave error
exit status 2
[exec] x86_64-linux-gnu-strip --remove-section=.comment
--remove-section=.note --strip-unneeded
debian/jitsi/usr/share/jitsi/lib/native/libjnspeex.so
[exec] Result: 2
...

Should I somehow disable, or change the need to use
“x86_64-linux-gnu-strip” (as I'm using an ARM processor, after all)? If so,
where and how should I do that? I can't successfully “apt-cache search” for
anything like “linux-gnu-strip”. As a wild guess, installing the “elfutils”
Ubuntu package, and retrying to “ant deb” didn't work either.

Cheers,
-Esbeeb