[jitsi-users] No video nor audio with Jitsi intance deployed with docker


#1

Hi everyone,

I would like to deploy a Jitsi instance on my local machine using docker.
I found the following repository which proposed a configure instance,
where the only thing I had to do is to specify a hostname (set to
localhost) and to use self-signed certificate.

My container is working I can connect to it with the ip address of my
docker host (I maped the docker host port 443 to the port 443 of my Jitsi
container), however, when I try to create a room, I have no video nor
audio, with the following errors in my navigator :

strophe.js:4842OPTIONS https://127.0.0.1/http-bind?room=test
net::ERR_CONNECTION_REFUSED

sendFunc @ strophe.js:4842_processRequest @
strophe.js:4854_throttledRequestHandler @ strophe.js:5006_connect @
strophe.js:4342connect @ strophe.js:2424XMPP._connect @
xmpp.js:158XMPP.connect @ xmpp.js:186JitsiConnection.connect @
JitsiConnection.js:29checkForAttachParametersAndConnect @
connection.js:27(anonymous function) @ connection.js:90connect @
connection.js:60openConnection @ connection.js:134connect @
conference.js:42(anonymous function) @ conference.js:327
Logger.js:89[/modules/xmpp/strophe.util.js] <Object.Strophe.log>: Strophe:
request id 1.1 error 0 happened

I don't understand where this error is coming from, can someone help me
with that ?

Thanks in advance

Jimmy Kasprzak


#2

See the "bosh" variable in config.js.

Boris

···

On 08/06/16 09:09, Jimmy Kasprzak wrote:

Hi everyone,

I would like to deploy a Jitsi instance on my local machine using docker.
I found the following repository which proposed a configure instance,
where the only thing I had to do is to specify a hostname (set to
localhost) and to use self-signed certificate.

My container is working I can connect to it with the ip address of my
docker host (I maped the docker host port 443 to the port 443 of my
Jitsi container), however, when I try to create a room, I have no video
nor audio, with the following errors in my navigator :

strophe.js:4842OPTIONS https://127.0.0.1/http-bind?room=test


#3

Hi,

thanks for the answer, it was actually a problem with the host name I set
for jitsi when starting my container ; it must be set to the ip address of
the docker host and not simply the localhost of the container itself. Your
answer gave me an indication about what the problem could be.

Jimmy

···

2016-06-08 16:21 GMT+02:00 Boris Grozev <boris@jitsi.org>:

On 08/06/16 09:09, Jimmy Kasprzak wrote:

Hi everyone,

I would like to deploy a Jitsi instance on my local machine using docker.
I found the following repository which proposed a configure instance,
where the only thing I had to do is to specify a hostname (set to
localhost) and to use self-signed certificate.

My container is working I can connect to it with the ip address of my
docker host (I maped the docker host port 443 to the port 443 of my
Jitsi container), however, when I try to create a room, I have no video
nor audio, with the following errors in my navigator :

strophe.js:4842OPTIONS https://127.0.0.1/http-bind?room=test

See the "bosh" variable in config.js.

Boris

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev