[jitsi-users] No sound


#1

I saw an incoming call popup, I heard it ringing... I couldn't find the right window to answer it in time (6 virtual desktops, 35 windows)... It stopped ringing just as I answered it.

After, there was nothing to indicate this call in the history. I restarted jitsi. Since I saw the popup I knew who was calling and I attempted to call back. No sound - no ringing, no audio of any kind.

I quit jitsi and started up sflphone, which had no problems. skype also had no problems. I restarted jitsi... still no sound.

ubuntu 12.04.4
Qt: 4.8.2
KDE Development Platform: 4.12.0
Jitsi 2.4.4997


#2

Thanks for the response. You sparked an idea... I don't have pavucontrol installed, but I do have alsamixer.

Sure enough, I started it up and I happened to notice something called "surround" aka "surround jack mode". I assume it has something to do with the program called JACK, which I do NOT have installed.

It has two settings, "independent" and "shared". I changed it to "shared". Now I have audio again.

No idea how or why that worked, but it did. Why sflphone and skype don't care about that setting, but Jitsi does...I don't know. May have something to do with the fact that jitsi uses portaudio, and sflphone uses either ALSA or pulse audio (configurable by user). Not sure what skype uses, ALSA I think.

Thanks again!

···

________________________________
From: luna <luna@xmail.net>
To: AB <andy_90254@yahoo.com>; Jitsi Users <users@jitsi.org>
Sent: Thursday, January 23, 2014 12:58 PM
Subject: Re: [jitsi-users] No sound

When I got problems with sound and Jitsi on ubuntu 12:10., I use that
tool pavucontrol .

AB:

I saw an incoming call popup, I heard it ringing... I couldn't find the right window to answer it in time (6 virtual desktops, 35 windows)... It stopped ringing just as I answered it.

After, there was nothing to indicate this call in the history. I restarted jitsi. Since I saw the popup I knew who was calling and I attempted to call back. No sound - no ringing, no audio of any kind.

I quit jitsi and started up sflphone, which had no problems. skype also had no problems. I restarted jitsi... still no sound.

ubuntu 12.04.4
Qt: 4.8.2
KDE Development Platform: 4.12.0
Jitsi 2.4.4997

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hi Andy,
it has nothing to do with jack (the sound server) or jack (the obscure
CD burning program). I quickly found some description of what this
setting does here:
http://forums.gentoo.org/viewtopic-t-816879-view-next.html

I generally recommend to use PulseAudio instead of PortAudio, I have
had far fewer problems with it.

Regards,
Philipp

···

On Thu, 23 Jan 2014 15:12:01 -0800 (PST) AB <andy_90254@yahoo.com> wrote:

Thanks for the response. You sparked an idea... I don't have
pavucontrol installed, but I do have alsamixer.

Sure enough, I started it up and I happened to notice something
called "surround" aka "surround jack mode". I assume it has
something to do with the program called JACK, which I do NOT have
installed.

It has two settings, "independent" and "shared". I changed it to
"shared". Now I have audio again.

No idea how or why that worked, but it did. Why sflphone and skype
don't care about that setting, but Jitsi does...I don't know. May
have something to do with the fact that jitsi uses portaudio, and
sflphone uses either ALSA or pulse audio (configurable by user). Not
sure what skype uses, ALSA I think.

Thanks again!

--
JID: murks@jit.si