[jitsi-users] No incoming sound on Windows 7


#1

Hello there.

Just got the latest Jitsi (64bit) and installed on my Windows 7 64bit. On
a call i see the microphone bar moving and on the info window, the
outcoming bandwidth moving, however i got no incoming sound and no incoming
bandwidth. I changed codecs, i also tried other softphones (more than 4),
they all worked but on Jitsi no incoming sound.

On audio options i got WASAPI, no microphone bar and no sound on the play
buttons, if i change to portoaudio (isn't it a linux thing!?), they work
there, but not on the call.

Any idea about this?


#2

OK, Jitsi is connected to an Asterisk server that i control on the
internet, Jitsi is on my laptop behind a router. It looks Asterisk is
sending the sound stream to my internal ip! Even on sip show peers, my
internal ip is there instead of my public ip. Why it has my internal ip and
not my public ip? Any ideas? This is not a audio config issue afterall.

···

On Mon, Sep 15, 2014 at 4:59 PM, Santos <sansancasd@gmail.com> wrote:

Hello there.

Just got the latest Jitsi (64bit) and installed on my Windows 7 64bit. On
a call i see the microphone bar moving and on the info window, the
outcoming bandwidth moving, however i got no incoming sound and no incoming
bandwidth. I changed codecs, i also tried other softphones (more than 4),
they all worked but on Jitsi no incoming sound.

On audio options i got WASAPI, no microphone bar and no sound on the play
buttons, if i change to portoaudio (isn't it a linux thing!?), they work
there, but not on the call.

Any idea about this?


#3

This is entirely a matter of Asterisk configuration. You need to tell
asterisk to provide NAT traversal services for Jitsi. That's something that
Asterisk supports and does quite well.

--sent from my mobile

···

On 16 Sep 2014 12:42 AM, "Santos" <sansancasd@gmail.com> wrote:

OK, Jitsi is connected to an Asterisk server that i control on the
internet, Jitsi is on my laptop behind a router. It looks Asterisk is
sending the sound stream to my internal ip! Even on sip show peers, my
internal ip is there instead of my public ip. Why it has my internal ip and
not my public ip? Any ideas? This is not a audio config issue afterall.

On Mon, Sep 15, 2014 at 4:59 PM, Santos <sansancasd@gmail.com> wrote:

Hello there.

Just got the latest Jitsi (64bit) and installed on my Windows 7 64bit.
On a call i see the microphone bar moving and on the info window, the
outcoming bandwidth moving, however i got no incoming sound and no incoming
bandwidth. I changed codecs, i also tried other softphones (more than 4),
they all worked but on Jitsi no incoming sound.

On audio options i got WASAPI, no microphone bar and no sound on the play
buttons, if i change to portoaudio (isn't it a linux thing!?), they work
there, but not on the call.

Any idea about this?

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Ok, but why Jitsi was the only softphone to fail like this? Plus, i'm not
even calling another phone behind a firewall, i'm calling a IVR on the
asterisk itself.

···

On Mon, Sep 15, 2014 at 11:49 PM, Emil Ivov <emcho@jitsi.org> wrote:

This is entirely a matter of Asterisk configuration. You need to tell
asterisk to provide NAT traversal services for Jitsi. That's something that
Asterisk supports and does quite well.

--sent from my mobile
On 16 Sep 2014 12:42 AM, "Santos" <sansancasd@gmail.com> wrote:

OK, Jitsi is connected to an Asterisk server that i control on the
internet, Jitsi is on my laptop behind a router. It looks Asterisk is
sending the sound stream to my internal ip! Even on sip show peers, my
internal ip is there instead of my public ip. Why it has my internal ip and
not my public ip? Any ideas? This is not a audio config issue afterall.

On Mon, Sep 15, 2014 at 4:59 PM, Santos <sansancasd@gmail.com> wrote:

Hello there.

Just got the latest Jitsi (64bit) and installed on my Windows 7 64bit.
On a call i see the microphone bar moving and on the info window, the
outcoming bandwidth moving, however i got no incoming sound and no incoming
bandwidth. I changed codecs, i also tried other softphones (more than 4),
they all worked but on Jitsi no incoming sound.

On audio options i got WASAPI, no microphone bar and no sound on the
play buttons, if i change to portoaudio (isn't it a linux thing!?), they
work there, but not on the call.

Any idea about this?

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users