[jitsi-users] No answer dialog for inbound calls


#1

I'm running Jitsi 2.3.4858 on MacOS 10.8.5. I set up a subscription to iptel.org, and have registered successfully. I have a DID mapped to my iptel account. When I call the DID, Jitsi notifies me that there is a call with a popup dialog and sound. However, when I switch to Jitsi, there is no "answer call" dialog, and no other obvious way to answer the call.

Is this a known issue?

Thanks.

-Pete


#2

Hi,

Yes we have a change in the code that opens the received call dialog
in build 4858, but seem ok on my side. Do you reproduce this reliably,
on every call?
Regards
damencho


#3

Hello Damian. So far I reproduce the issue 100% of the time. However, I just configured Jitsi with a SIP account today, so I'm not sure if this is always going to repro for me or not. Quitting Jitsi and restarting it does not resolve the issue.

I'm happy to try running a development build to test, etc.

-Pete

···

On Oct 11, 2013, at 10:08 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

Yes we have a change in the code that opens the received call dialog
in build 4858, but seem ok on my side. Do you reproduce this reliably,
on every call?
Regards
damencho

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Hi,

Thanks for the quick report. I've just reverted the patch introduced
with build 4858. So this will be fixed in next build.

Thanks
damencho

···

On Sat, Oct 12, 2013 at 8:14 AM, Peter Loron <peterl@standingwave.org> wrote:

Hello Damian. So far I reproduce the issue 100% of the time. However, I just configured Jitsi with a SIP account today, so I'm not sure if this is always going to repro for me or not. Quitting Jitsi and restarting it does not resolve the issue.

I'm happy to try running a development build to test, etc.

-Pete

On Oct 11, 2013, at 10:08 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

Yes we have a change in the code that opens the received call dialog
in build 4858, but seem ok on my side. Do you reproduce this reliably,
on every call?
Regards
damencho

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Cool, thanks.

I also note an additional issue. I just placed a call that caused Jitsi to ring. I was able to answer the call successfully with the CTRL-SHIFT-A shortcut.

However, the "active call" dialog did not appear, and the Jitsi popup in the corner of the screen did not go away. Also, I cannot close the Jitsi popup dialog by clicking the "X" in the corner. Maybe the event handler bound to the widget is getting removed too early?

-Pete

···

On Oct 11, 2013, at 10:25 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

Thanks for the quick report. I've just reverted the patch introduced
with build 4858. So this will be fixed in next build.

Thanks
damencho

On Sat, Oct 12, 2013 at 8:14 AM, Peter Loron <peterl@standingwave.org> wrote:

Hello Damian. So far I reproduce the issue 100% of the time. However, I just configured Jitsi with a SIP account today, so I'm not sure if this is always going to repro for me or not. Quitting Jitsi and restarting it does not resolve the issue.

I'm happy to try running a development build to test, etc.

-Pete

On Oct 11, 2013, at 10:08 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

Yes we have a change in the code that opens the received call dialog
in build 4858, but seem ok on my side. Do you reproduce this reliably,
on every call?
Regards
damencho

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

Hi,

the fix I introduced in 4858, was wrong and broke showing received
call dialog. I discovered it on Saturday morning, so for a quick fix I
reverted it (reverted in build 4861). Will take a second look later
this week.

Regards
damencho

···

On Mon, Oct 14, 2013 at 12:21 AM, Peter Loron <peterl@standingwave.org> wrote:

Cool, thanks.

I also note an additional issue. I just placed a call that caused Jitsi to ring. I was able to answer the call successfully with the CTRL-SHIFT-A shortcut.

However, the "active call" dialog did not appear, and the Jitsi popup in the corner of the screen did not go away. Also, I cannot close the Jitsi popup dialog by clicking the "X" in the corner. Maybe the event handler bound to the widget is getting removed too early?

-Pete

On Oct 11, 2013, at 10:25 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

Thanks for the quick report. I've just reverted the patch introduced
with build 4858. So this will be fixed in next build.

Thanks
damencho

On Sat, Oct 12, 2013 at 8:14 AM, Peter Loron <peterl@standingwave.org> wrote:

Hello Damian. So far I reproduce the issue 100% of the time. However, I just configured Jitsi with a SIP account today, so I'm not sure if this is always going to repro for me or not. Quitting Jitsi and restarting it does not resolve the issue.

I'm happy to try running a development build to test, etc.

-Pete

On Oct 11, 2013, at 10:08 PM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

Yes we have a change in the code that opens the received call dialog
in build 4858, but seem ok on my side. Do you reproduce this reliably,
on every call?
Regards
damencho

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

Hi,

checkout build 4875.

Regards
damencho

···

On Mon, Oct 14, 2013 at 8:02 AM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

the fix I introduced in 4858, was wrong and broke showing received
call dialog. I discovered it on Saturday morning, so for a quick fix I
reverted it (reverted in build 4861). Will take a second look later
this week.

Regards
damencho

On Mon, Oct 14, 2013 at 12:21 AM, Peter Loron <peterl@standingwave.org> > wrote:
> Cool, thanks.
>
> I also note an additional issue. I just placed a call that caused Jitsi
to ring. I was able to answer the call successfully with the CTRL-SHIFT-A
shortcut.
>
> However, the "active call" dialog did not appear, and the Jitsi popup in
the corner of the screen did not go away. Also, I cannot close the Jitsi
popup dialog by clicking the "X" in the corner. Maybe the event handler
bound to the widget is getting removed too early?
>
> -Pete
>
> On Oct 11, 2013, at 10:25 PM, Damian Minkov <damencho@jitsi.org> wrote:
>
>> Hi,
>>
>> Thanks for the quick report. I've just reverted the patch introduced
>> with build 4858. So this will be fixed in next build.
>>
>> Thanks
>> damencho
>>
>>
>> On Sat, Oct 12, 2013 at 8:14 AM, Peter Loron <peterl@standingwave.org> > wrote:
>>> Hello Damian. So far I reproduce the issue 100% of the time. However,
I just configured Jitsi with a SIP account today, so I'm not sure if this
is always going to repro for me or not. Quitting Jitsi and restarting it
does not resolve the issue.
>>>
>>> I'm happy to try running a development build to test, etc.
>>>
>>> -Pete
>>>
>>> On Oct 11, 2013, at 10:08 PM, Damian Minkov <damencho@jitsi.org> > wrote:
>>>
>>>> Hi,
>>>>
>>>> Yes we have a change in the code that opens the received call dialog
>>>> in build 4858, but seem ok on my side. Do you reproduce this reliably,
>>>> on every call?
>>>> Regards
>>>> damencho
>>>>
>>>> _______________________________________________
>>>> users mailing list
>>>> users@jitsi.org
>>>> Unsubscribe instructions and other list options:
>>>> http://lists.jitsi.org/mailman/listinfo/users
>>>>
>>>
>>>
>>> _______________________________________________
>>> users mailing list
>>> users@jitsi.org
>>> Unsubscribe instructions and other list options:
>>> http://lists.jitsi.org/mailman/listinfo/users
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users


#8

A quick test indicates that the bug is fixed with build 4875. The "call" dialog now shows up properly. I will post to the list if I find it not working after more testing.

Thanks!

-Pete

···

On Oct 25, 2013, at 12:19 AM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

checkout build 4875.

Regards
damencho

On Mon, Oct 14, 2013 at 8:02 AM, Damian Minkov <damencho@jitsi.org> wrote:
Hi,

the fix I introduced in 4858, was wrong and broke showing received
call dialog. I discovered it on Saturday morning, so for a quick fix I
reverted it (reverted in build 4861). Will take a second look later
this week.

Regards
damencho

On Mon, Oct 14, 2013 at 12:21 AM, Peter Loron <peterl@standingwave.org> wrote:
> Cool, thanks.
>
> I also note an additional issue. I just placed a call that caused Jitsi to ring. I was able to answer the call successfully with the CTRL-SHIFT-A shortcut.
>
> However, the "active call" dialog did not appear, and the Jitsi popup in the corner of the screen did not go away. Also, I cannot close the Jitsi popup dialog by clicking the "X" in the corner. Maybe the event handler bound to the widget is getting removed too early?
>
> -Pete
>
> On Oct 11, 2013, at 10:25 PM, Damian Minkov <damencho@jitsi.org> wrote:
>
>> Hi,
>>
>> Thanks for the quick report. I've just reverted the patch introduced
>> with build 4858. So this will be fixed in next build.
>>
>> Thanks
>> damencho
>>
>>
>> On Sat, Oct 12, 2013 at 8:14 AM, Peter Loron <peterl@standingwave.org> wrote:
>>> Hello Damian. So far I reproduce the issue 100% of the time. However, I just configured Jitsi with a SIP account today, so I'm not sure if this is always going to repro for me or not. Quitting Jitsi and restarting it does not resolve the issue.
>>>
>>> I'm happy to try running a development build to test, etc.
>>>
>>> -Pete
>>>
>>> On Oct 11, 2013, at 10:08 PM, Damian Minkov <damencho@jitsi.org> wrote:
>>>
>>>> Hi,
>>>>
>>>> Yes we have a change in the code that opens the received call dialog
>>>> in build 4858, but seem ok on my side. Do you reproduce this reliably,
>>>> on every call?
>>>> Regards
>>>> damencho
>>>>
>>>> _______________________________________________
>>>> users mailing list
>>>> users@jitsi.org
>>>> Unsubscribe instructions and other list options:
>>>> http://lists.jitsi.org/mailman/listinfo/users
>>>>
>>>
>>>
>>> _______________________________________________
>>> users mailing list
>>> users@jitsi.org
>>> Unsubscribe instructions and other list options:
>>> http://lists.jitsi.org/mailman/listinfo/users
>>
>> _______________________________________________
>> users mailing list
>> users@jitsi.org
>> Unsubscribe instructions and other list options:
>> http://lists.jitsi.org/mailman/listinfo/users
>>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users