[jitsi-users] New install


#1

Hello all-

Sorry if this has been asked, but I have been working on the Jitsi load
balance for hours now and cannot seem to get it resolved. I followed the
example here:

https://github.com/jitsi/jicofo/blob/master/doc/load_balancing.md

For reference, Jitsi works great, but just want to incorporate additional
bridges.

The error message is as follows:

*Jicofo 2017-09-02 23:54:12.202 INFO: [75]
org.jitsi.impl.protocol.xmpp.OpSetSubscriptionImpl.doSubscribe().373
Subscribing to sharedStatsNode node at chat.example.com
<http://chat.example.com>*
*Jicofo 2017-09-02 23:54:12.205 SEVERE: [75]
org.jitsi.impl.protocol.xmpp.OpSetSubscriptionImpl.doSubscribe().392 Failed
to subscribe to sharedStatsNode at chat.example.com
<http://chat.example.com> error: item-not-found(-1)*

Jicofo 2017-09-02 23:47:12.070 WARNING: [16]
org.jitsi.jicofo.BridgeSelector.addJvbAddress().260 *No pub-sub node mapped
for jitsi-videobridge.chat.example.com
<http://jitsi-videobridge.chat.example.com>*
Jicofo 2017-09-02 23:47:12.073 INFO: [16]
org.jitsi.jicofo.ComponentsDiscovery.scheduleRediscovery().186 Services
re-discovery interval: 30000
Jicofo 2017-09-02 23:47:12.076 INFO: [16]
org.jitsi.jicofo.ComponentsDiscovery.start().446 Bridges will be discovered
through PubSub stats on node: sharedStatsNode
Jicofo 2017-09-02 23:47:12.076 INFO: [16]
org.jitsi.jicofo.ComponentsDiscovery.start().458 Max stats age: 15000 ms
Jicofo 2017-09-02 23:47:12.077 INFO: [40] org.jitsi.jicofo.JvbDoctor.log()
Scheduled health-check task for: jitsi-videobridge.chat.example.com
Jicofo 2017-09-02 23:47:12.083 SEVERE: [16]
org.jitsi.impl.protocol.xmpp.OpSetSubscriptionImpl.getItems().244 Failed to
fetch PubSub items of: sharedStatsNode, reason: item-not-found(-1)

root@chat:/etc/jitsi/videobridge# cat sip-communicator.properties
org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=
focus@auth.chat.example.com/.*

org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.PUBSUB_SERVICE=chat.example.com
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode

Thank you!

Alex


#2

At first jicofo and the bridge can have an error for item not found, before
creating the pubsub node.
Make sure in the list of admins in prosody you have jicofo and all your jvb
component addresses.

Regards
damencho

···

On Sep 2, 2017 23:00, "Alex Evonosky" <alex.evonosky@gmail.com> wrote:

Hello all-

Sorry if this has been asked, but I have been working on the Jitsi load
balance for hours now and cannot seem to get it resolved. I followed the
example here:

https://github.com/jitsi/jicofo/blob/master/doc/load_balancing.md

For reference, Jitsi works great, but just want to incorporate additional
bridges.

The error message is as follows:

*Jicofo 2017-09-02 23:54:12.202 INFO: [75]
org.jitsi.impl.protocol.xmpp.OpSetSubscriptionImpl.doSubscribe().373
Subscribing to sharedStatsNode node at chat.example.com
<http://chat.example.com>*
*Jicofo 2017-09-02 23:54:12.205 SEVERE: [75]
org.jitsi.impl.protocol.xmpp.OpSetSubscriptionImpl.doSubscribe().392 Failed
to subscribe to sharedStatsNode at chat.example.com
<http://chat.example.com> error: item-not-found(-1)*

Jicofo 2017-09-02 23:47:12.070 WARNING: [16] org.jitsi.jicofo.
BridgeSelector.addJvbAddress().260 *No pub-sub node mapped for
jitsi-videobridge.chat.example.com
<http://jitsi-videobridge.chat.example.com>*
Jicofo 2017-09-02 23:47:12.073 INFO: [16] org.jitsi.jicofo.
ComponentsDiscovery.scheduleRediscovery().186 Services re-discovery
interval: 30000
Jicofo 2017-09-02 23:47:12.076 INFO: [16] org.jitsi.jicofo.
ComponentsDiscovery.start().446 Bridges will be discovered through PubSub
stats on node: sharedStatsNode
Jicofo 2017-09-02 23:47:12.076 INFO: [16] org.jitsi.jicofo.
ComponentsDiscovery.start().458 Max stats age: 15000 ms
Jicofo 2017-09-02 23:47:12.077 INFO: [40] org.jitsi.jicofo.JvbDoctor.log()
Scheduled health-check task for: jitsi-videobridge.chat.example.com
Jicofo 2017-09-02 23:47:12.083 SEVERE: [16] org.jitsi.impl.protocol.xmpp.
OpSetSubscriptionImpl.getItems().244 Failed to fetch PubSub items of:
sharedStatsNode, reason: item-not-found(-1)

root@chat:/etc/jitsi/videobridge# cat sip-communicator.properties
org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus
@auth.chat.example.com/.*

org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.PUBSUB_SERVICE=chat.example.com
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode

Thank you!

Alex

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Damian-

Thank you for the response.. The auth was there for the admins, however
doing some packet sniffing, it was noticed that some of prosody components
were only listening on the local loopback, so adding the "local_interfaces"
option under prosody brought it up. Thank you for the guidance.

Alex

···

On Sun, Sep 3, 2017 at 10:24 AM, Damian Minkov <damencho@damencho.com> wrote:

At first jicofo and the bridge can have an error for item not found,
before creating the pubsub node.
Make sure in the list of admins in prosody you have jicofo and all your
jvb component addresses.

Regards
damencho

On Sep 2, 2017 23:00, "Alex Evonosky" <alex.evonosky@gmail.com> wrote:

Hello all-

Sorry if this has been asked, but I have been working on the Jitsi load
balance for hours now and cannot seem to get it resolved. I followed the
example here:

https://github.com/jitsi/jicofo/blob/master/doc/load_balancing.md

For reference, Jitsi works great, but just want to incorporate additional
bridges.

The error message is as follows:

*Jicofo 2017-09-02 23:54:12.202 INFO: [75]
org.jitsi.impl.protocol.xmpp.OpSetSubscriptionImpl.doSubscribe().373
Subscribing to sharedStatsNode node at chat.example.com
<http://chat.example.com>*
*Jicofo 2017-09-02 23:54:12.205 SEVERE: [75]
org.jitsi.impl.protocol.xmpp.OpSetSubscriptionImpl.doSubscribe().392 Failed
to subscribe to sharedStatsNode at chat.example.com
<http://chat.example.com> error: item-not-found(-1)*

Jicofo 2017-09-02 23:47:12.070 WARNING: [16]
org.jitsi.jicofo.BridgeSelector.addJvbAddress().260 *No pub-sub node
mapped for jitsi-videobridge.chat.example.com
<http://jitsi-videobridge.chat.example.com>*
Jicofo 2017-09-02 23:47:12.073 INFO: [16] org.jitsi.jicofo.ComponentsDis
covery.scheduleRediscovery().186 Services re-discovery interval: 30000
Jicofo 2017-09-02 23:47:12.076 INFO: [16] org.jitsi.jicofo.ComponentsDiscovery.start().446
Bridges will be discovered through PubSub stats on node: sharedStatsNode
Jicofo 2017-09-02 23:47:12.076 INFO: [16] org.jitsi.jicofo.ComponentsDiscovery.start().458
Max stats age: 15000 ms
Jicofo 2017-09-02 23:47:12.077 INFO: [40] org.jitsi.jicofo.JvbDoctor.log()
Scheduled health-check task for: jitsi-videobridge.chat.example.com
Jicofo 2017-09-02 23:47:12.083 SEVERE: [16] org.jitsi.impl.protocol.xmpp.O
pSetSubscriptionImpl.getItems().244 Failed to fetch PubSub items of:
sharedStatsNode, reason: item-not-found(-1)

root@chat:/etc/jitsi/videobridge# cat sip-communicator.properties
org.jitsi.videobridge.AUTHORIZED_SOURCE_REGEXP=focus@auth.
chat.example.com/.*

org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=pubsub
org.jitsi.videobridge.PUBSUB_SERVICE=chat.example.com
org.jitsi.videobridge.PUBSUB_NODE=sharedStatsNode

Thank you!

Alex

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users