[jitsi-users] New audio device random popup


#1

Every now and then, Jitsi pops up it's "New audio device connected"
dialog, even though I haven't connected/disconnected anything.

Normally this is just an annoyance but it happened tonight and messed
with Eventghost, causing that to receive constant phantom remote
keypresses (D-pad left it seems) which caused Mediaportal to try and
rewind the video I was watching! As it was constantly holding the key,
it was only after I killed Eventghost that the key was released and
then it rewound to the beginning of the video and I had to kill Jitsi,
restart Eventghost and then re-start playing the video and advance to
the position I was at before this happened.


#2

Hello Derek,

Every now and then, Jitsi pops up it's "New audio device connected"
dialog, even though I haven't connected/disconnected anything.

This pop-up notifies that "portaudio" (the audio library used by Jitsi) has found a new device, or that a device has been disconnected. To disable this notification, you just have to uncheck "Preferences -> Events -> Device configuration change".

Normally this is just an annoyance but it happened tonight and messed
with Eventghost, causing that to receive constant phantom remote
keypresses (D-pad left it seems) which caused Mediaportal to try and
rewind the video I was watching! As it was constantly holding the key,
it was only after I killed Eventghost that the key was released and
then it rewound to the beginning of the video and I had to kill Jitsi,
restart Eventghost and then re-start playing the video and advance to
the position I was at before this happened.

I can not help you about Evenghost, but maybe you can look at "Preferences -> Audio" to see which device have an intermittent connection.

Best regards,
Vincent

ยทยทยท

On 11/8/12 11:42 PM, Derek Moss wrote:

--
Vincent Lucas, Ph.D. Jitsi developer
chenzo@jitsi.org http://jitsi.org


#3

Hi Vincent

This pop-up notifies that "portaudio" (the audio library used by Jitsi) has
found a new device, or that a device has been disconnected. To disable this
notification, you just have to uncheck "Preferences -> Events -> Device
configuration change".

Under Options -> Events, I don't have anything like "Device
configuration change".

I can not help you about Evenghost, but maybe you can look at "Preferences
-> Audio" to see which device have an intermittent connection.

Under Options -> Audio, for all three dropdowns (Audio In, Audio Out,
Notifications), it lists most of the devices twice (but with cutoff
names), which doesn't seem right. EG, under Audio In it has

Microphone (2 - Realtek High Def
Microsoft Sound Mapper - Input
Microphone (2 - USB Camera-B4.09
Primary Sound Capture Driver
Microphone (2 - Realtek High Definition Audio)
Microphone (2 - USB Camera-B4.09.24.1)

Regards

Derek