[jitsi-users] NAT Traversal with SIP (Was: Alright, I give up!)


#1

Adding to everything that's been said:

Given that Jitsi does not currently have ICE with SIP you need to rely
on servers doing Hosted NAT Traversal [0] (HNT) for you. Most SIP
servers will do this and it will work reliably as long as UDP packets
are not completely filtered out by your firewall. Resorting to manual
port redirection could only be a problem.

Taking Jitsi out on a public IP address will not change many things:
as long as the remote end is also behind a NAT, the server would act
exactly the same way and provide HNT for you. If it didn't then we'd
have another problem because Jitsi does not do latching itself (that's
a server's job).

Now, what I'd advise you to do here is: rather than trying to find a
solution for your NAT problem, first try to determine whether you
actually have a NAT problem. Check the traffic and verify whether it
is in both directions at both sides. If it isn't, check out if one of
the endpoints could be streaming in the wrong direction.

You can also try other SIP servers like ippi.com and sip2sip.info.

Cheers,
Emil

[0] http://tools.ietf.org/html/draft-ietf-mmusic-latching

···

On Mon, Jun 3, 2013 at 9:09 AM, Boris Grozev <boris@jitsi.org> wrote:

Hey,

On 6/3/13 2:26 AM, Anthony Papillion wrote:

On 06/02/2013 06:05 PM, Lee Sharp wrote:

On 06/02/2013 04:21 PM, Anthony Papillion wrote:

I've tried Twinkle and Ekiga as well and they did the same thing so it's
likely not Jitsi. It's my network and that is going to be interesting to
resolve.

Thanks again for the help! Much appreciated.

So, you may want to look into a firewall where you can more directly
control the NAT properties. Both m0n0wall and pfSense allow you to do a
lot of NAT customizing. Still not trivial, but do-able.

I've done one better. I've completely removed NAT from the picture. I've
called AT&T and got a few static public IP's for my use. Now, I hope, I
won't have these problems. I used IPTables to open the following ports
on my firewall:

udp/5004
udp/10000
udp/tcp/5900
udp/tcp/5061
udp/tcp/5062
udp/tcp/8000
udp/tcp/3478-3479

Correct me if I'm wrong, bu unless you are talking about outgoing
connections, I don't think you need to open any ports at all. If you run
into problems again, you could temporarily open up everything in order to
rule out a filtering issue.

Regards,
Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
http://jitsi.org FAX: +33.1.77.62.47.31


#2

HI,

Emil said

You can also try other SIP servers like ippi.com and sip2sip.info.

If these two are not enough there is also

antisip.com who has a SIP server at

sip.antisip.com

they also have a SIP client if needed for comparison tests.

Good luck finding the problem.

Regards, Earl


#3

Hello,

if one needs other sip server for testing, I have set up one recently at openrcs.com (https://www.openrcs.com) which I tested a lot with Jitsi behind NAT (besides voice, video, text messaging, it has enabled SIMPLE presence and XCAP server which I tested with Jitsi as well).

Cheers,
Daniel

···

On 6/3/13 11:26 AM, Earl wrote:

HI,

Emil said

You can also try other SIP servers like ippi.com and sip2sip.info.

If these two are not enough there is also

antisip.com who has a SIP server at

sip.antisip.com

they also have a SIP client if needed for comparison tests.

Good luck finding the problem.

Regards, Earl

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Daniel-Constantin Mierla - http://www.asipto.com
http://twitter.com/#!/miconda - http://www.linkedin.com/in/miconda
Kamailio Advanced Training, San Francisco, USA - June 24-27, 2013
   * http://asipto.com/u/katu *