[jitsi-users] multiple OTR Session : how to get rid of them ?


#1

Q: how do i get rid of multiple OTR Sessions from one client ?

Same behaviour like this: https://trac.jitsi.org/ticket/1279

Problem:

My chat partner does not see, that we have 3 sessions open. My client
does see them.

So somewhere my jitsi thinks we have sessions, but don't have them and
they are not working.

How can i get rid of the two none working sessions ?

Caused was it by reinstalling jitsi on my desktop pc and overwriting the
ressource id with my old one.
At least i think that caused it.

Marius


#2

I thought it was just me. We are seeing this problem every single day here.

We've tried restarting the Jitsi clients, restarting the jabber server, manually disconnecting clients from the server...
I have not been able to find a reliable solution, or even a cause.

Jitsi throws errors about "multiple sessions" but it's just two people having a conversation, one session.

···

-----Original Message-----
From: users [mailto:users-bounces@jitsi.org] On Behalf Of Marius
Sent: Friday, June 19, 2015 8:14 AM
To: Jitsi Users
Subject: [jitsi-users] multiple OTR Session : how to get rid of them ?

Q: how do i get rid of multiple OTR Sessions from one client ?

Same behaviour like this: https://trac.jitsi.org/ticket/1279

Problem:

My chat partner does not see, that we have 3 sessions open. My client does see them.

So somewhere my jitsi thinks we have sessions, but don't have them and they are not working.

How can i get rid of the two none working sessions ?

Caused was it by reinstalling jitsi on my desktop pc and overwriting the ressource id with my old one.
At least i think that caused it.

Marius

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hello Marius, have you tried to end the private conversations? If not,
could you please give that a try?

Thanks,
George

···

On 06/19/2015 02:14 PM, Marius wrote:

Q: how do i get rid of multiple OTR Sessions from one client ?

Same behaviour like this: https://trac.jitsi.org/ticket/1279

Problem:

My chat partner does not see, that we have 3 sessions open. My client
does see them.

So somewhere my jitsi thinks we have sessions, but don't have them and
they are not working.

How can i get rid of the two none working sessions ?

Caused was it by reinstalling jitsi on my desktop pc and overwriting the
ressource id with my old one.
At least i think that caused it.

Marius

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

I have maybe now the opposite problem: Jitsi actually dropping the OTR
session too early:

It seems that Jitsi drops the OTR session keys and requests a new
session when a remote client goes offline (because it looses connection
to the remote server, maybe server has been restarted). After coming
back online the remote client sends messages still on the old session
and Jitsi complains "message was sent for another connection".

IMHO the OTR session should stay established, because none of the
clients was shut down, and both have a valid, trusted session. Real
problem with this is that people write to you but there is no
notification message and of course the message content gets lost.

BR Florian

···

Am 19.06.2015 um 15:06 schrieb Phil Tull:

I thought it was just me. We are seeing this problem every single day here.

We've tried restarting the Jitsi clients, restarting the jabber server, manually disconnecting clients from the server...
I have not been able to find a reliable solution, or even a cause.

Jitsi throws errors about "multiple sessions" but it's just two people having a conversation, one session.


#5

That was the first i tried, without success.

Marius

···

Am 19.06.2015 um 14:29 schrieb George Politis:

Hello Marius, have you tried to end the private conversations? If not,
could you please give that a try?


#6

I'm a little confused because the sessions are not persistent; so if,
for example, you restart your client, and if you and your friend you're
only using a single client to connect to the server, this shouldn't
result in multiple OTR sessions.. Is this your case or have I missed
something?

···

On 06/19/2015 02:45 PM, Marius wrote:

Am 19.06.2015 um 14:29 schrieb George Politis:

Hello Marius, have you tried to end the private conversations? If not,
could you please give that a try?

That was the first i tried, without success.


#7

Hi Marius,
make sure you have "message carbons" disabled, restart Jitsi.

···

On 6/19/15 3:45 PM, Marius wrote:

Am 19.06.2015 um 14:29 schrieb George Politis:

Hello Marius, have you tried to end the private conversations? If not,
could you please give that a try?

That was the first i tried, without success.

Marius

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Whatever that maybe in an translated client :slight_smile:

I found a Workaround: Remove the contact and add him again. gets rid of
the messages and problems involved with it.

Marius

···

Am 19.06.2015 um 14:58 schrieb Mr.Smith:

Hi Marius,
make sure you have "message carbons" disabled, restart Jitsi.


#9

Both parties had only one client running,
restarted multiply times,
and only one side had those multiply otr sessions shown ( mine actually ).

Marius

···

Am 19.06.2015 um 15:02 schrieb George Politis:

On 06/19/2015 02:45 PM, Marius wrote:

Am 19.06.2015 um 14:29 schrieb George Politis:

Hello Marius, have you tried to end the private conversations? If not,
could you please give that a try?

That was the first i tried, without success.

I'm a little confused because the sessions are not persistent; so if,
for example, you restart your client, and if you and your friend you're
only using a single client to connect to the server, this shouldn't
result in multiple OTR sessions.. Is this your case or have I missed
something?


#10

here in German "Nachrichtenkopien deaktivieren":

PGP.sig (489 Bytes)

···

On 6/19/15 4:03 PM, Marius wrote:

Am 19.06.2015 um 14:58 schrieb Mr.Smith:

Hi Marius,
make sure you have "message carbons" disabled, restart Jitsi.

Whatever that maybe in an translated client :slight_smile:

I found a Workaround: Remove the contact and add him again. gets rid of
the messages and problems involved with it.

Marius

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#11

It's already deactivated.

Marius

···

Am 19.06.2015 um 15:13 schrieb Mr.Smith:

here in German "Nachrichtenkopien deaktivieren":


#12

Info: Dein PGPKey auf dem Schl�sselserver ist defekt. Thunderbird kann
den nicht importieren.

Marius