[jitsi-users] Multiple Instances of Jitsi


#1

Hi,

Is there any way to have multiple instances of jitsi at the same time on
the same machine?

Regards
Brijesh


#2

I don't see why not, provided they listen on different port numbers, but why do
you need multiple instances?

A single instance will support multiple conferences, so what are you trying to
achieve?

Antony.

···

On Thursday 08 October 2015 at 11:59:44, Brijesh khundhawala wrote:

Is there any way to have multiple instances of jitsi at the same time on
the same machine?

--
Atheism is a non-prophet-making organisation.

                                                   Please reply to the list;
                                                         please *don't* CC me.


#3

Antony,

Thanks For the Quick reply.
Can you tell me how can we make 2 different accounts to listen to different
port?
Right now my both the accounts listen 59902 port. So whenever I try to call
from one account to another, I get Busy Out response.

Regards
Brijesh

···

On Thu, Oct 8, 2015 at 3:45 PM, Antony Stone < Antony.Stone@jitsi.open.source.it> wrote:

On Thursday 08 October 2015 at 11:59:44, Brijesh khundhawala wrote:

> Is there any way to have multiple instances of jitsi at the same time on
> the same machine?

I don't see why not, provided they listen on different port numbers, but
why do
you need multiple instances?

A single instance will support multiple conferences, so what are you
trying to
achieve?

Antony.

--
Atheism is a non-prophet-making organisation.

                                                   Please reply to the
list;
                                                         please *don't* CC
me.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Just add your second SIP account to your accountslist and your done.

All you have to remember is, that you have to select over which account
the outgoing call shall be done.

Marius

···

Am 08.10.2015 um 11:59 schrieb Brijesh khundhawala:

Hi,

Is there any way to have multiple instances of jitsi at the same time
on the same machine?


#5

Antony,

Thanks For the Quick reply.
Can you tell me how can we make 2 different accounts to listen to different
port?

Not offhand, no, because you seem to be running something rather different from
me (see below); however I'm sure someone else here can point you in the right
direction.

Right now my both the accounts listen 59902 port.

I don't believe that can be true. A second instance would be unable to bind
to the (already in-use) port, and fail to start.

So whenever I try to call from one account to another, I get Busy Out
response.

I'm running Jitsi Videobridge, Meetme, and Jigasi (installed as described at
https://jitsi.org/qi ). I have nothing listening on port 59902.

What does the output of "netstat -lptun" show you?

Antony.

···

On Thursday 08 October 2015 at 12:31:07, Brijesh khundhawala wrote:

--
Roses are red,
Bacon is too,
Poetry's hard,
Bacon.
        with thanks to Claire Davison

                                                   Please reply to the list;
                                                         please *don't* CC me.


#6

I believe the original poster is talking about the desktop Jitsi
client, not Jitsi Meet web service.

···

On Thu, 8 Oct 2015 14:20:18 +0200 Antony Stone wrote:

On Thursday 08 October 2015 at 12:31:07, Brijesh khundhawala wrote:

So whenever I try to call from one account to another, I get Busy Out
response.

I'm running Jitsi Videobridge, Meetme, and Jigasi (installed as
described at https://jitsi.org/qi ). I have nothing listening on port
59902.

--

Yasen Pramatarov
Lindeas Ltd. https://lindeas.com
'working on GNU/Linux ideas'
Professional Jitsi Meet services


#7

Hi Marius,

It seems that you suggest: multiple clients at the same time on the same machine.
That would imply that you run a multi-seat system.
In different desktop-windows (perhaps even different displays), you could startup multiple clients using different user-accounts, each having its own home-directory holding its own config-file (Listening ports…)
However, which audio/video-device will be connected to which user…
In general, multi seat is tough. Specially with pluggable devices :frowning:

hw

···

On Thu, Oct 8, 2015 at 7:31 PM, Marius <jitsi@benderirc.de<mailto:jitsi@benderirc.de>> wrote:
Am 08.10.2015 um 11:59 schrieb Brijesh khundhawala:

Hi,

Is there any way to have multiple instances of jitsi at the same time
on the same machine?

Just add your second SIP account to your accountslist and your done.

All you have to remember is, that you have to select over which account
the outgoing call shall be done.

Marius

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

______________________________________________________________________
Dit bericht kan informatie bevatten die niet voor u is bestemd. Indien u niet de geadresseerde bent of dit bericht abusievelijk aan u is toegezonden, wordt u verzocht dat aan de afzender te melden en het bericht te verwijderen. De Staat aanvaardt geen aansprakelijkheid voor schade, van welke aard ook, die verband houdt met risico's verbonden aan het electronisch verzenden van berichten.

This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. The State accepts no liability for damage of any kind resulting from the risks inherent in the electronic transmission of messages.


#8

I will explain my scenaorio.
I need to register two users to one registrar. i.e. I need to have two
users associated to one registrar. I need both of these users to interact.
But they should reside on the same machine/ip.
I want SIP user.
So for that is there any way so that I can see two different jitsi window
over a same machine. I am using windows environment for jitsi.

Thanks a lot for you help.

Regards
Brijesh


#9

Marius,

I have added two accounts. I am able to make a call from one account to
another. But As I mentioned I still see the same port number in the Contact
header. For both the accounts.

Regards
Brijesh

···

On Thu, Oct 8, 2015 at 7:31 PM, Marius <jitsi@benderirc.de> wrote:

Am 08.10.2015 um 11:59 schrieb Brijesh khundhawala:
> Hi,
>
> Is there any way to have multiple instances of jitsi at the same time
> on the same machine?
>
>

Just add your second SIP account to your accountslist and your done.

All you have to remember is, that you have to select over which account
the outgoing call shall be done.

Marius

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#10

You can run a second instance with a new configuration by setting the SC_HOME_DIR_LOCATION property. See here for details:
http://lists.jitsi.org/pipermail/dev/2013-August/018103.html

Regards,
Boris

···

On 08/10/15 09:52, Brijesh khundhawala wrote:

Marius,

I have added two accounts. I am able to make a call from one account to
another. But As I mentioned I still see the same port number in the
Contact header. For both the accounts.


#11

Apologies - my mistaken assumption :frowning:

I still don't quite see why a client application would set up a listening
port, but then I've not used the Jitsi desktop client, so I probably just
don't know what I'm talking about here :slight_smile:

I'll let someone else take over and answer the question from here :slight_smile:

Antony.

···

On Thursday 08 October 2015 at 15:26:14, Yasen Pramatarov wrote:

On Thu, 8 Oct 2015 14:20:18 +0200 Antony Stone wrote:
>On Thursday 08 October 2015 at 12:31:07, Brijesh khundhawala wrote:
>> So whenever I try to call from one account to another, I get Busy Out
>> response.
>
>I'm running Jitsi Videobridge, Meetme, and Jigasi (installed as
>described at https://jitsi.org/qi ). I have nothing listening on port
>59902.

I believe the original poster is talking about the desktop Jitsi
client, not Jitsi Meet web service.

--
There are only 10 types of people in the world:
those who understand binary notation,
and those who don't.

                                                   Please reply to the list;
                                                         please *don't* CC me.


#12

That is true.

Regards
Brijesh

···

On Thu, Oct 8, 2015 at 6:56 PM, Yasen Pramatarov <yasen@lindeas.com> wrote:

On Thu, 8 Oct 2015 14:20:18 +0200 Antony Stone wrote:

>On Thursday 08 October 2015 at 12:31:07, Brijesh khundhawala wrote:
>> So whenever I try to call from one account to another, I get Busy Out
>> response.
>
>I'm running Jitsi Videobridge, Meetme, and Jigasi (installed as
>described at https://jitsi.org/qi ). I have nothing listening on port
>59902.

I believe the original poster is talking about the desktop Jitsi
client, not Jitsi Meet web service.

--
> Yasen Pramatarov
> Lindeas Ltd. https://lindeas.com
> 'working on GNU/Linux ideas'
> Professional Jitsi Meet services

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#13

Thanks Antony. :slight_smile:
I would also like to know if any other way is possible.
My requirement is to use only one windows machine and register two soft
clients to the same registrar. And I should be able to make a call between
them. Web based solution would also work. :slight_smile:

regards
Brijesh

···

On Thu, Oct 8, 2015 at 7:05 PM, Antony Stone < Antony.Stone@jitsi.open.source.it> wrote:

On Thursday 08 October 2015 at 15:26:14, Yasen Pramatarov wrote:

> On Thu, 8 Oct 2015 14:20:18 +0200 Antony Stone wrote:
> >On Thursday 08 October 2015 at 12:31:07, Brijesh khundhawala wrote:
> >> So whenever I try to call from one account to another, I get Busy Out
> >> response.
> >
> >I'm running Jitsi Videobridge, Meetme, and Jigasi (installed as
> >described at https://jitsi.org/qi ). I have nothing listening on port
> >59902.
>
> I believe the original poster is talking about the desktop Jitsi
> client, not Jitsi Meet web service.

Apologies - my mistaken assumption :frowning:

I still don't quite see why a client application would set up a listening
port, but then I've not used the Jitsi desktop client, so I probably just
don't know what I'm talking about here :slight_smile:

I'll let someone else take over and answer the question from here :slight_smile:

Antony.

--
There are only 10 types of people in the world:
those who understand binary notation,
and those who don't.

                                                   Please reply to the
list;
                                                         please *don't* CC
me.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#14

Actually I am new to jitsi.
Can you please tell me steps in detail?
Where can I find this directory?
And do i need to run some command or just restarting the jitsi would make
the changes?

Regards
Brijesh

···

On Thu, Oct 8, 2015 at 9:36 PM, Boris Grozev <boris@jitsi.org> wrote:

On 08/10/15 09:52, Brijesh khundhawala wrote:

Marius,

I have added two accounts. I am able to make a call from one account to
another. But As I mentioned I still see the same port number in the
Contact header. For both the accounts.

You can run a second instance with a new configuration by setting the
SC_HOME_DIR_LOCATION property. See here for details:
http://lists.jitsi.org/pipermail/dev/2013-August/018103.html

Regards,
Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users