[jitsi-users] More details on SIP problems with Jitsi


#1

I'm sorry that you're having troubles!

First, I'm attaching the log to this email for reference. Now, more detail:

Both of us are using IPTel for a SIP service, he's on Windows XP I'm on
Fedora 18. Ports seem forwarded fine as I have an IPKall number
forwarded to my SIP account and I can use it with no problems.

It isn't necessary to open any incoming ports if your sip providers has a media relay, and iptel does have such a relay.

Noticed that whenever I call him and he answers (and we can't hear each
other) the SIP account immediately goes OFFLINE. Once it's online again,
the same thing happens when I try to call again.

Judging from the logs, there are some problems with UDP and/or DNS on your network. The DNS resolution does not work correctly and we need to fall back to our backup DNS resolver (where there's a bug because it throws up as well).
I also see an attempt to open an SPDIF-device for audio capturing. Is your audio configuration correct?

Does this provide anyone with any clues?

Thanks!
Anthony
<jitsi0.log.0>

Ingo

-- sent from my mobile

···

Le 31.05.2013 à 06:24, "Anthony Papillion" <papillion@gmail.com> a écrit :


#2

I'm sorry that you're having troubles!

Thanks! I really like Jitsi and want to keep using it. But I have to resolve those problems.

It isn't necessary to open any incoming ports if your sip providers has a media relay, and iptel does have such a relay.

Good. So I'm good on that part.

Noticed I call him and he answers (and we can't hear each
other) the SIP account immediately goes OFFLINE. Once it's online again,
the same thing happens when I try to call again.

Judging from the logs, there are some problems with UDP and/or DNS on your network. The DNS resolution does not work correctly and we need to fall back to our backup DNS resolver (where there's a bug because it throws up as well).

Ok. So I guess the next logical question is "how do I solve it? I'm using AT&T DNS but can change it if necessary. Alternately, how could I make the backup work if my primary DNS won't do?

I also see an attempt to open an SPDIF-device for audio capturing. Is your audio configuration correct?

It is. The SPDIF device is an incorrect setting I chose while trying to resolve the issue. Normally, I use Pulse Audio.

Thanks again, Ingo!

Anthony

···

On May 31, 2013, at 12:29 AM, Ingo Bauersachs <ingo@jitsi.org> wrote:


#3

Noticed I call him and he answers (and we can't hear each
other) the SIP account immediately goes OFFLINE. Once it's online
again,
the same thing happens when I try to call again.

Judging from the logs, there are some problems with UDP and/or DNS
on your network. The DNS resolution does not work correctly and we
need to fall back to our backup DNS resolver (where there's a bug
because it throws up as well).

Ok. So I guess the next logical question is "how do I solve it? I'm
using AT&T DNS but can change it if necessary. Alternately, how could
I make the backup work if my primary DNS won't do?

Jitsi tries to automatically use Google's public DNS (8.8.4.4 and 8.8.8.8)
as a backup if the DNS resolvers of the operating system fail to supply a
response within 3 seconds or only give invalid responses. In your case
however this fails and I'll look at this over the weekend. In the meantime,
you could try configuring your OS to use the before mentioned DNS server on
the OS by default.

I also see an attempt to open an SPDIF-device for audio capturing.
Is your audio configuration correct?

It is. The SPDIF device is an incorrect setting I chose while trying
to resolve the issue. Normally, I use Pulse Audio.

Okay then. Another thing I noticed: you seem to have an Ekiga-Account. This
doesn't work, please see the FAQ [1] why.

Thanks again, Ingo!
Anthony

Ingo

[1] https://jitsi.org/Documentation/FAQ#ekiga.net


#4

I did this a few minutes ago. Added the 8.8.8.8 server to my OS's DNS
server list. Surfing has gotten measurably faster...

So now, Jitsi won't connect to ANYTHING. Jabber, IPTel, nothing. It just
stays offline. New log as of a few minutes ago is attached. This log was
created by 1) closing Jitsi, 2) deleting the existing log, 3) opening
Jitsi. This is just ONE connection attempt to both a jabber server and
SIP server.

Hope this helps. I really want to be able to use this! lol

Anthony

jitsi0.log.0 (26.9 KB)

···

On 05/31/2013 05:34 AM, Ingo Bauersachs wrote:

Noticed I call him and he answers (and we can't hear each
other) the SIP account immediately goes OFFLINE. Once it's online
again,
the same thing happens when I try to call again.

Judging from the logs, there are some problems with UDP and/or DNS
on your network. The DNS resolution does not work correctly and we
need to fall back to our backup DNS resolver (where there's a bug
because it throws up as well).

Ok. So I guess the next logical question is "how do I solve it? I'm
using AT&T DNS but can change it if necessary. Alternately, how could
I make the backup work if my primary DNS won't do?

Jitsi tries to automatically use Google's public DNS (8.8.4.4 and 8.8.8.8)
as a backup if the DNS resolvers of the operating system fail to supply a
response within 3 seconds or only give invalid responses. In your case
however this fails and I'll look at this over the weekend. In the meantime,
you could try configuring your OS to use the before mentioned DNS server on
the OS by default.


#5

Jitsi tries to automatically use Google's public DNS (8.8.4.4 and

8.8.8.8)

as a backup if the DNS resolvers of the operating system fail to supply a
response within 3 seconds or only give invalid responses. In your case
however this fails and I'll look at this over the weekend. In the

meantime,

you could try configuring your OS to use the before mentioned DNS server

on

the OS by default.

I did this a few minutes ago. Added the 8.8.8.8 server to my OS's DNS
server list. Surfing has gotten measurably faster...

So now, Jitsi won't connect to ANYTHING. Jabber, IPTel, nothing. It just
stays offline. New log as of a few minutes ago is attached. This log was
created by 1) closing Jitsi, 2) deleting the existing log, 3) opening
Jitsi. This is just ONE connection attempt to both a jabber server and
SIP server.

Thanks for the log, this one is a bit easier to read:
- It cannot find an audio capture device, the sound system is PortAudio.
Could you try playing around with the audio configuration a bit until you
see something in the level indicator?
- You seem to have an IPv6 address. While Jitsi should work with IPv6, could
still try to launch it in IPv4 mode only? (append -4 from the command line)
- I don't know what went wrong with the DNS resolvers, but the error message
in the log now says that a class from a library is missing (DNSJAVA)...
never seen this before.

Hope this helps. I really want to be able to use this! lol

Anthony

Ingo


#6

Jitsi tries to automatically use Google's public DNS (8.8.4.4 and

8.8.8.8)

as a backup if the DNS resolvers of the operating system fail to supply a
response within 3 seconds or only give invalid responses. In your case
however this fails and I'll look at this over the weekend. In the

meantime,

you could try configuring your OS to use the before mentioned DNS server

on

the OS by default.

I did this a few minutes ago. Added the 8.8.8.8 server to my OS's DNS
server list. Surfing has gotten measurably faster...

So now, Jitsi won't connect to ANYTHING. Jabber, IPTel, nothing. It just
stays offline. New log as of a few minutes ago is attached. This log was
created by 1) closing Jitsi, 2) deleting the existing log, 3) opening
Jitsi. This is just ONE connection attempt to both a jabber server and
SIP server.

Thanks for the log, this one is a bit easier to read:
- It cannot find an audio capture device, the sound system is PortAudio.
Could you try playing around with the audio configuration a bit until you
see something in the level indicator?

Here's the weird thing: Even though I had PortAudio selected and it
looked like Jitsi wasn't finding my audio device, people could still
hear me (when I was able to make a call). However, I did go ahead and
change it back to PulseAudio just to be save.

- You seem to have an IPv6 address. While Jitsi should work with IPv6, could
still try to launch it in IPv4 mode only? (append -4 from the command line)

I did this and it seems like I can now connect to Jabber! This may have
just fixed my problems! I will play around with it a bit today and see
if it works. I'll report back to the list a bit later once I know.
Either way, THANK YOU for all your help. You've been a life saver.

- I don't know what went wrong with the DNS resolvers, but the error message
in the log now says that a class from a library is missing (DNSJAVA)...
never seen this before.

Anthony

···

On 05/31/2013 06:46 AM, Ingo Bauersachs wrote: