[jitsi-users] Logitech Webcam Pro 9000


#1

Jitsi turns on recording led on camera
but shows black rectangle (no video) in Options->Video->Devices tab
when I select "UVC Camera (046d:0809) /dev/video0" item in 'Camera:'
combobox
I use version 2.3.4771 of Jitsi on Debian 7.1 (SMP Debian 3.10.3-1
(2013-07-27) x86_64)
All other programs (ekiga, vlc, cheese) works well and shows video without
problems.

$ sudo lsusb | grep cam
Bus 001 Device 009: ID 046d:0809 Logitech, Inc. Webcam Pro 9000

$ v4l2-ctl --list-formats | grep "Pixel Format"
    Pixel Format: 'YUYV'
    Pixel Format: 'MJPG' (compressed)
    Pixel Format: 'RGB3' (emulated)
    Pixel Format: 'BGR3' (emulated)
    Pixel Format: 'YU12' (emulated)
    Pixel Format: 'YV12' (emulated)

this link:
https://java.net/jira/browse/JITSI-593
says, that both
V4L2_PIX_FMT_YUYV and V4L2_PIX_FMT_MJPEG
are supported.

I tried advice from threads
https://java.net/nonav/projects/jitsi/lists/dev/archive/2013-03/message/121
https://java.net/projects/jitsi/lists/users/archive/2011-06/message/6
to export LD_PRELOAD before starting Jitsi:
$ echo $LD_PRELOAD
/usr/lib/vlc/plugins/access/libv4l2_plugin.so:/usr/lib/x86_64-linux-gnu/libv4l2rds.so:/usr/lib/x86_64-linux-gnu/libv4l1.so:/usr/lib/x86_64-linux-gnu/libv4l2.so:/usr/lib/x86_64-linux-gnu/libv4l/plugins/libv4l-mplane.so:/usr/lib/x86_64-linux-gnu/libv4lconvert.so:/usr/lib/x86_64-linux-gnu/libv4l/v4l2convert.so:/usr/lib/x86_64-linux-gnu/libv4l/v4l1compat.so
but this doesn't help.

How to configure Java Media Framework in Jitsi to work with Logitech Webcam
Pro 9000 ?