[jitsi-users] Limiting Jitsi's number of domain names


#1

Hello,

I use a standard architecture (Prosody, Nginx, Videobridge, ConferenceFocus, Meet).

I try to optimize the number of Jitsi domain names to obtain on each project from my IT team. Let's imagine an instance called jitsi.mydomain.com. I will need :

- jitsi.mydomain.com
- auth.mydomain.com
- conference.mydomain.com
- videobridge.mydomain.com
- focus.mydomain.com
- [recorder.mydomain.com]

I can't escape to declare the two first ones because they are called from Jitsi meet, and to put the 3 last ones only in the server's hosts file, as all servers are on the same machine.

But the videobridge for example, keeps complaining it doesn't know localhost in the logs.

Does someone already made researches and tries on this problem ?

David


#2

Hello,

I use a standard architecture (Prosody, Nginx, Videobridge,
ConferenceFocus, Meet).

I try to optimize the number of Jitsi domain names to obtain on each
project from my IT team. Let's imagine an instance called
jitsi.mydomain.com. I will need :

- jitsi.mydomain.com
- auth.mydomain.com
- conference.mydomain.com
- videobridge.mydomain.com
- focus.mydomain.com
- [recorder.mydomain.com]

You don't need DNS-resolvable names for the last 4, they are only used inside XMPP.

I can't escape to declare the two first ones because they are called
from Jitsi meet, and to put the 3 last ones only in the server's hosts
file, as all servers are on the same machine.

But the videobridge for example, keeps complaining it doesn't know
localhost in the logs.

Please post the related logs.

Regards,
Boris

···

On 12/04/2017 10:40, David Mézière wrote:


#3

Thanks Boris,

I have this line :

JVB 2017-04-13 09:57:17.698 GRAVE: [17] org.jitsi.meet.ComponentMain.call().278 host-unknown, host:project-videobridge.immanens.com, port:5347
org.xmpp.component.ComponentException: host-unknown
         at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:219)
         at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)
         at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)
         at org.jitsi.meet.ComponentMain$3.call(ComponentMain.java:270)
         at org.jitsi.meet.ComponentMain$3.call(ComponentMain.java:255)
         at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
         at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
         at java.util.concurrent.FutureTask.run(FutureTask.java:266)
         at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
         at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
         at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
         at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
         at java.lang.Thread.run(Thread.java:745)

Repeated every 5 min.

In the config I have :

- JVB_HOSTNAME=project-jitsi.immanens.com
- JVB_HOST=project-videobridge.immanens.com

JVB_HOST was empty, I've put this for a try yesterday. I was having the same line in the logs, but with "unknown host localhost".

I followed my procedure, it must be the 30th Jitsi I deploy, I don't get it :slight_smile: Must the first one declared be a parent domain of the others ?

here is an extract of the hosts file :
127.0.0.1 project-jitsi.immanens.com project-jitsi
127.0.0.1 project-auth.immanens.com project-auth
127.0.0.1 project-conference.immanens.com project-conference
127.0.0.1 project-videobridge.immanens.com project-videobridge
127.0.0.1 project-focus.immanens.com project-focus

David

···

Le 12/04/2017 à 18:23, Boris Grozev a écrit :

On 12/04/2017 10:40, David Mézière wrote:

Hello,

I use a standard architecture (Prosody, Nginx, Videobridge,
ConferenceFocus, Meet).

I try to optimize the number of Jitsi domain names to obtain on each
project from my IT team. Let's imagine an instance called
jitsi.mydomain.com. I will need :

- jitsi.mydomain.com
- auth.mydomain.com
- conference.mydomain.com
- videobridge.mydomain.com
- focus.mydomain.com
- [recorder.mydomain.com]

You don't need DNS-resolvable names for the last 4, they are only used inside XMPP.

I can't escape to declare the two first ones because they are called
from Jitsi meet, and to put the 3 last ones only in the server's hosts
file, as all servers are on the same machine.

But the videobridge for example, keeps complaining it doesn't know
localhost in the logs.

Please post the related logs.

Regards,
Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Hi,

Thanks Boris,

I have this line :

JVB 2017-04-13 09:57:17.698 GRAVE: [17]
org.jitsi.meet.ComponentMain.call().278 host-unknown,
host:project-videobridge.immanens.com, port:5347
org.xmpp.component.ComponentException: host-unknown
        at

This error has nothing to do with the system and resolving hostnames.
These are virtual hosts inside prosody. The exception is in the moment
where jvb connects to prosody and says I'm connecting as component
project-videobridge.immanens.com and prosody responds, host-unknown,
which means I do not have any configuration for this virtual host.

org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:219)

        at
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)
        at
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)
        at org.jitsi.meet.ComponentMain$3.call(ComponentMain.java:270)
        at org.jitsi.meet.ComponentMain$3.call(ComponentMain.java:255)
        at
org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
        at
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
        at java.util.concurrent.FutureTask.run(FutureTask.java:266)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
        at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
        at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at java.lang.Thread.run(Thread.java:745)

Repeated every 5 min.

In the config I have :

- JVB_HOSTNAME=project-jitsi.immanens.com
- JVB_HOST=project-videobridge.immanens.com

JVB_HOST was empty, I've put this for a try yesterday. I was having the same
line in the logs, but with "unknown host localhost".

So here is a snippet from the default config:

# sets the hostname of the XMPP server (default: domain if set,
localhost otherwise)
JVB_HOST=

# sets the XMPP domain (default: none)
JVB_HOSTNAME=

So JVB_HOST is the domain name, or ip address where jvb will try to
connect to JVB_PORT (5347), while JVB_HOSTNAME is an xmpp domain name
configured inside prosody, in case of jitsi-meet and jvb this one can
be just virtual without the need to be resolvable.

Regards
damencho

···

On Thu, Apr 13, 2017 at 3:07 AM, David Mézière <d.meziere@immanens.com> wrote:

I followed my procedure, it must be the 30th Jitsi I deploy, I don't get it
:slight_smile: Must the first one declared be a parent domain of the others ?

here is an extract of the hosts file :
127.0.0.1 project-jitsi.immanens.com project-jitsi
127.0.0.1 project-auth.immanens.com project-auth
127.0.0.1 project-conference.immanens.com project-conference
127.0.0.1 project-videobridge.immanens.com project-videobridge
127.0.0.1 project-focus.immanens.com project-focus

David

Le 12/04/2017 à 18:23, Boris Grozev a écrit :

On 12/04/2017 10:40, David Mézière wrote:

Hello,

I use a standard architecture (Prosody, Nginx, Videobridge,
ConferenceFocus, Meet).

I try to optimize the number of Jitsi domain names to obtain on each
project from my IT team. Let's imagine an instance called
jitsi.mydomain.com. I will need :

- jitsi.mydomain.com
- auth.mydomain.com
- conference.mydomain.com
- videobridge.mydomain.com
- focus.mydomain.com
- [recorder.mydomain.com]

You don't need DNS-resolvable names for the last 4, they are only used
inside XMPP.

I can't escape to declare the two first ones because they are called
from Jitsi meet, and to put the 3 last ones only in the server's hosts
file, as all servers are on the same machine.

But the videobridge for example, keeps complaining it doesn't know
localhost in the logs.

Please post the related logs.

Regards,
Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Damian,

Thank you, I reviewed my prosody and videobridge config, and my logs are cleaner. I will now move forward with the other elements. I think it would be great to have a documentation somewhere on the internals of this point. Some doc that would tell which domain should be DNS-accessible, wich ones can refer only to prosody internals, etc. Like it have been done with the architecural diagram recently added, that was awaited for long.

David

···

Le 13/04/2017 à 15:32, Damian Minkov a écrit :

Hi,

On Thu, Apr 13, 2017 at 3:07 AM, David Mézière <d.meziere@immanens.com> wrote:

Thanks Boris,

I have this line :

JVB 2017-04-13 09:57:17.698 GRAVE: [17]
org.jitsi.meet.ComponentMain.call().278 host-unknown,
host:project-videobridge.immanens.com, port:5347
org.xmpp.component.ComponentException: host-unknown
         at

This error has nothing to do with the system and resolving hostnames.
These are virtual hosts inside prosody. The exception is in the moment
where jvb connects to prosody and says I'm connecting as component
project-videobridge.immanens.com and prosody responds, host-unknown,
which means I do not have any configuration for this virtual host.

org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:219)

         at
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:221)
         at
org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:201)
         at org.jitsi.meet.ComponentMain$3.call(ComponentMain.java:270)
         at org.jitsi.meet.ComponentMain$3.call(ComponentMain.java:255)
         at
org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
         at
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
         at java.util.concurrent.FutureTask.run(FutureTask.java:266)
         at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
         at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
         at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
         at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
         at java.lang.Thread.run(Thread.java:745)

Repeated every 5 min.

In the config I have :

- JVB_HOSTNAME=project-jitsi.immanens.com
- JVB_HOST=project-videobridge.immanens.com

JVB_HOST was empty, I've put this for a try yesterday. I was having the same
line in the logs, but with "unknown host localhost".

So here is a snippet from the default config:

# sets the hostname of the XMPP server (default: domain if set,
localhost otherwise)
JVB_HOST=

# sets the XMPP domain (default: none)
JVB_HOSTNAME=

So JVB_HOST is the domain name, or ip address where jvb will try to
connect to JVB_PORT (5347), while JVB_HOSTNAME is an xmpp domain name
configured inside prosody, in case of jitsi-meet and jvb this one can
be just virtual without the need to be resolvable.

Regards
damencho

I followed my procedure, it must be the 30th Jitsi I deploy, I don't get it
:slight_smile: Must the first one declared be a parent domain of the others ?

here is an extract of the hosts file :
127.0.0.1 project-jitsi.immanens.com project-jitsi
127.0.0.1 project-auth.immanens.com project-auth
127.0.0.1 project-conference.immanens.com project-conference
127.0.0.1 project-videobridge.immanens.com project-videobridge
127.0.0.1 project-focus.immanens.com project-focus

David

Le 12/04/2017 à 18:23, Boris Grozev a écrit :

On 12/04/2017 10:40, David Mézière wrote:

Hello,

I use a standard architecture (Prosody, Nginx, Videobridge,
ConferenceFocus, Meet).

I try to optimize the number of Jitsi domain names to obtain on each
project from my IT team. Let's imagine an instance called
jitsi.mydomain.com. I will need :

- jitsi.mydomain.com
- auth.mydomain.com
- conference.mydomain.com
- videobridge.mydomain.com
- focus.mydomain.com
- [recorder.mydomain.com]

You don't need DNS-resolvable names for the last 4, they are only used
inside XMPP.

I can't escape to declare the two first ones because they are called
from Jitsi meet, and to put the 3 last ones only in the server's hosts
file, as all servers are on the same machine.

But the videobridge for example, keeps complaining it doesn't know
localhost in the logs.

Please post the related logs.

Regards,
Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users