[jitsi-users] lib-jitsi-meet error


#1

Hello All,

Is this a known issue? Has anyone encountered this before?

When I try to do 'npm install' on my node, it gives me following error.

"> lib-jitsi-meet@0.0.0 postinstall
/home/skarambelkar/src/jitsi-meet/node_modules/lib-jitsi-meet

webpack -p

/home/skarambelkar/src/jitsi-meet/node_modules/lib-jitsi-meet/webpack.config.js:11
    new webpack.LoaderOptionsPlugin({
    ^

TypeError: webpack.LoaderOptionsPlugin is not a constructor
    at Object.<anonymous>
(/home/skarambelkar/src/jitsi-meet/node_modules/lib-jitsi-meet/webpack.config.js:11:5)
    at Module._compile (module.js:569:30)
    at Object.Module._extensions..js (module.js:580:10)
    at Module.load (module.js:503:32)
    at tryModuleLoad (module.js:466:12)
    at Function.Module._load (module.js:458:3)
    at Module.require (module.js:513:17)
    at require (internal/module.js:11:18)
    at module.exports
(/home/skarambelkar/src/jitsi-meet/node_modules/webpack/bin/convert-argv.js:80:13)
    at Object.<anonymous>
(/home/skarambelkar/src/jitsi-meet/node_modules/webpack/bin/webpack.js:39:40)
npm WARN eslint-plugin-mocha@2.0.0 requires a peer of eslint@^2.0.0 but
none was installed.
npm WARN babel-loader@7.0.0 requires a peer of webpack@2 but none was
installed.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! lib-jitsi-meet@0.0.0 postinstall: `webpack -p`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the lib-jitsi-meet@0.0.0 postinstall script.
npm ERR! This is probably not a problem with npm. There is likely
additional logging output above.
"

I have upgraded node and npm to latest version.

npm -v
5.0.0

node -v
v8.0.0

As I can see, it didn't pull lib-jitsi-meet files in node_modules.

skarambelkar@convene-2017:~/src/jitsi-meet/node_modules$ ls lib*
ls: cannot access lib*: No such file or directory

I don't know why its not pulling the lib sources. Can anyone help me here?

Thank you.
Sandeep Karambelkar


#2

Don't use node 8 and npm 5. Switch to node 6.11.0 and npm 3.10.10. As
part of the switch, make sure to delete nod_modules and do `npm
install` again.