[jitsi-users] Jvb error


#1

Hi,

Encountering some issues with jitsi-meet install.
Followed directions @
https://github.com/jitsi/jitsi-meet/blob/master/INSTALL.md

Issue starting jvb ends up with an error as in the pastbin below:
http://pastebin.com/Cq7A6KbP

Error " SEVERE: [1] util.UtilActivator.uncaughtException().108 An uncaught
exception occurred in thread=Thread[main,5,main] and message was:
java.net.ConnectException: Connection refused
org.xmpp.component.ComponentException: java.net.ConnectException:
Connection refused"

*Env *- Ubuntu trusty
*java *- 1.7.0_65
OpenJDK Runtime Environment (IcedTea 2.5.1) (7u65-2.5.1-4ubuntu1~0.14.04.1)
OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)

*jitsi-videobridge* - jitsi-voideobridge-linux-x64-226

I tried older versions as well, same issue

···

--
Thanks,
Sangram Rath


#2

Hi,

this is because jvb cannot connect to prosody as the password used for
component connection is not correct. The password in
/etc/prosody/prosody.cfg.lua under Component "jitsi-videobridge......"
and the password in /etc/default/jitsi-videobridge.
Recently there was a problem with jvb package which regenerates this
password in /etc/default/jitsi-videobridge on every upgrade, but this
is now fixed and should not be a problem anymore.

Regards
damencho

···

On Mon, Aug 25, 2014 at 7:04 AM, Sangram Rath <sangram.rath@gmail.com> wrote:

Hi,

Encountering some issues with jitsi-meet install.
Followed directions @
https://github.com/jitsi/jitsi-meet/blob/master/INSTALL.md

Issue starting jvb ends up with an error as in the pastbin below:
http://pastebin.com/Cq7A6KbP

Error " SEVERE: [1] util.UtilActivator.uncaughtException().108 An uncaught
exception occurred in thread=Thread[main,5,main] and message was:
java.net.ConnectException: Connection refused
org.xmpp.component.ComponentException: java.net.ConnectException: Connection
refused"

Env - Ubuntu trusty
java - 1.7.0_65
OpenJDK Runtime Environment (IcedTea 2.5.1) (7u65-2.5.1-4ubuntu1~0.14.04.1)
OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)

jitsi-videobridge - jitsi-voideobridge-linux-x64-226

I tried older versions as well, same issue

--
Thanks,
Sangram Rath

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

I think the TCP connection to prosody has failed. Have you restarted prosody after adding the "component" lines in its config? Can you make sure that it is listening on the configured port, and that the port is accessible from the jvb machine?

Regards,
Boris

···

On 25/08/14 07:04, Sangram Rath wrote:

Hi,

Encountering some issues with jitsi-meet install.
Followed directions @
https://github.com/jitsi/jitsi-meet/blob/master/INSTALL.md

Issue starting jvb ends up with an error as in the pastbin below:
http://pastebin.com/Cq7A6KbP

Error " SEVERE: [1] util.UtilActivator.uncaughtException().108 An
uncaught exception occurred in thread=Thread[main,5,main] and message
was: java.net.ConnectException: Connection refused
org.xmpp.component.ComponentException: java.net.ConnectException:
Connection refused"


#4

Thanks, I dont have a /etc/default/jitsi-videobridge folder though
and I am using jitsi-videobridge 226.

···

On Mon, Aug 25, 2014 at 11:35 AM, Damian Minkov <damencho@jitsi.org> wrote:

Hi,

this is because jvb cannot connect to prosody as the password used for
component connection is not correct. The password in
/etc/prosody/prosody.cfg.lua under Component "jitsi-videobridge......"
and the password in /etc/default/jitsi-videobridge.
Recently there was a problem with jvb package which regenerates this
password in /etc/default/jitsi-videobridge on every upgrade, but this
is now fixed and should not be a problem anymore.

Regards
damencho

On Mon, Aug 25, 2014 at 7:04 AM, Sangram Rath <sangram.rath@gmail.com> > wrote:
> Hi,
>
> Encountering some issues with jitsi-meet install.
> Followed directions @
> https://github.com/jitsi/jitsi-meet/blob/master/INSTALL.md
>
> Issue starting jvb ends up with an error as in the pastbin below:
> http://pastebin.com/Cq7A6KbP
>
> Error " SEVERE: [1] util.UtilActivator.uncaughtException().108 An
uncaught
> exception occurred in thread=Thread[main,5,main] and message was:
> java.net.ConnectException: Connection refused
> org.xmpp.component.ComponentException: java.net.ConnectException:
Connection
> refused"
>
> Env - Ubuntu trusty
> java - 1.7.0_65
> OpenJDK Runtime Environment (IcedTea 2.5.1)
(7u65-2.5.1-4ubuntu1~0.14.04.1)
> OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)
>
> jitsi-videobridge - jitsi-voideobridge-linux-x64-226
>
> I tried older versions as well, same issue
>
> --
> Thanks,
> Sangram Rath
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Thanks,
Sangram K Rath


#5

It seems to be working now, recreated the config files and did not give
error this time.

I however, have posted another query on SIP call, if someone could throw
some light, it will be much appreciated.
"Unable to make SIP call with jitsi-meet"

···

On Mon, Aug 25, 2014 at 1:28 PM, Boris Grozev <boris@jitsi.org> wrote:

On 25/08/14 07:04, Sangram Rath wrote:

Hi,

Encountering some issues with jitsi-meet install.
Followed directions @
https://github.com/jitsi/jitsi-meet/blob/master/INSTALL.md

Issue starting jvb ends up with an error as in the pastbin below:
http://pastebin.com/Cq7A6KbP

Error " SEVERE: [1] util.UtilActivator.uncaughtException().108 An
uncaught exception occurred in thread=Thread[main,5,main] and message
was: java.net.ConnectException: Connection refused
org.xmpp.component.ComponentException: java.net.ConnectException:
Connection refused"

I think the TCP connection to prosody has failed. Have you restarted
prosody after adding the "component" lines in its config? Can you make sure
that it is listening on the configured port, and that the port is
accessible from the jvb machine?

Regards,
Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Thanks,
Sangram K Rath


#6

It seems to be working now, recreated the config files and did not give
error this time.

I however, have posted another query on SIP call, if someone could
throw
some light, it will be much appreciated.
"Unable to make SIP call with jitsi-meet"

I might be missing something, but I don't see an email with that subject.

Boris

···

On August 25, 2014 11:58:38 AM EEST, Sangram Rath <sangram.rath@gmail.com> wrote:

On Mon, Aug 25, 2014 at 1:28 PM, Boris Grozev <boris@jitsi.org> wrote:

On 25/08/14 07:04, Sangram Rath wrote:

Hi,

Encountering some issues with jitsi-meet install.
Followed directions @
https://github.com/jitsi/jitsi-meet/blob/master/INSTALL.md

Issue starting jvb ends up with an error as in the pastbin below:
http://pastebin.com/Cq7A6KbP

Error " SEVERE: [1] util.UtilActivator.uncaughtException().108 An
uncaught exception occurred in thread=Thread[main,5,main] and

message

was: java.net.ConnectException: Connection refused
org.xmpp.component.ComponentException: java.net.ConnectException:
Connection refused"

I think the TCP connection to prosody has failed. Have you restarted
prosody after adding the "component" lines in its config? Can you

make sure

that it is listening on the configured port, and that the port is
accessible from the jvb machine?

Regards,
Boris

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Sent from a mobile. Please excuse my brevity.