[jitsi-users] Jitsy very slow


#1

Hello,

on a new laptop Debian7 installation I have Jitsi (1.0.1-build.3967) running
very slow: it takes seconds to start a call and I loose all incoming calls.

I saw this post on the web, but without useful answers:

http://java.net/projects/jitsi/lists/users/archive/2012-05/message/25

My Java version is:

java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.4) (6b24-1.11.4-3)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

Bye,
  Matteo


#2

I've also seen that occur on some machines but don't really have a clue
as to what the reason might be. Maybe some of our other Debian users
would have an idea?

Emil

···

On 27.09.12, 14:00, Matteo Calorio wrote:

Hello,

on a new laptop Debian7 installation I have Jitsi (1.0.1-build.3967)
running very slow: it takes seconds to start a call and I loose all
incoming calls.

I saw this post on the web, but without useful answers:

http://java.net/projects/jitsi/lists/users/archive/2012-05/message/25

My Java version is:

java version "1.6.0_24"

OpenJDK Runtime Environment (IcedTea6 1.11.4) (6b24-1.11.4-3)

OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

Bye,

Matteo

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31


#3

Matteo Calorio wrote:

Hello,

on a new laptop Debian7 installation I have Jitsi (1.0.1-build.3967)
running very slow: it takes seconds to start a call and I loose all
incoming calls.

Could you post the specs of this laptop and the account types you use regularly for calling?

I run Jitsi on Debian Wheezy/7 on a desktop and a laptop, both with 2 core cpus (intel @2GHz on laprop, AMD @3GHz on desktop) and Jitsi is quite responsive. Note that i use 32-bit OS (686-pae variant).

But different accounts have different behaviour: i use a SIP account and that connects instantly and a Google Talk account and that takes a while to connect (the other side uses Jitsi too) because of the zrtp key exchange and maybe the Jingle discovery takes a bit of time too.

What do you mean by loosing all incoming calls? Does Jitsi ring or just does not react?

Anyway, you might try out the latest nightly build:

https://download.jitsi.org/jitsi/nightly/debian/

There are lots of changes since the 3967 build, might work better (it does on my case).

···

I saw this post on the web, but without useful answers:

http://java.net/projects/jitsi/lists/users/archive/2012-05/message/25

My Java version is:

java version "1.6.0_24"

OpenJDK Runtime Environment (IcedTea6 1.11.4) (6b24-1.11.4-3)

OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

Bye,

Matteo

--
O zi buna,
Kertesz Laszlo


#4

Here are the logs. Sorry, I did a mistake with the addresses, it was not
intentional. Matteo

---- Original Messagge ----

jitsi.log.tgz (6.01 KB)

···

From: Emil Ivov <emcho@jitsi.org>
Sent: martedì 2 ottobre 2012, 16:59
To: Matteo Calorio <matteo.calorio@linux.ors-tech.it>
Cc:
Subj: Re: [jitsi-users] Re: Jitsy very slow

OK, that's not a problem I was thinking of. This one may be due
something else. Could we please have a look at the logs?

Thanks,
Emil

P.S. Btw, was your response intentionally personal?

On 02.10.12, 16:45, Matteo Calorio wrote:

The capture: http://linux.ors-tech.it/jitsi01.ogv

Disabling desktop effect doesn't solve the problem.

I changed my java version to:

java version "1.7.0_03"

OpenJDK Runtime Environment (IcedTea7 2.1.2) (7u3-2.1.2-2)

OpenJDK 64-Bit Server VM (build 22.0-b10, mixed mode)

... but still nothing...

I disabled desktop effects... and nothing changed.

I have only Kde wm.

Thanks,

Matteo

---- Original Messagge ----

From: Emil Ivov <emcho@jitsi.org>

Sent: martedì 2 ottobre 2012, 15:24

To: users@jitsi.java.net

Cc: Matteo Calorio <matteo.calorio@linux.ors-tech.it>

Subj: Re: [jitsi-users] Re: Jitsy very slow

Oh and one more thing. If the problem you have really is the same as the

one I've seen it is fairly clear when watching jitsi that there's

something wrong with the rendering.

Just to help me and others understand, do you think you might capture

your experience in a screencast and upload it somewhere?

Thanks,

Emil

On 02.10.12, 15:19, Emil Ivov wrote:

On 02.10.12, 15:11, Matteo Calorio wrote:

I changed priority to maximum allowed and to realtime scheduliong, but

nothing changes (chrt -r -p 20 21241).

Anyway, it appens also with normal priority and without other user

applications running (but the machine shoud be powerful enough).

Yeah, from what I've seen this really is a problem with the drawing, so

I still think changing window managers and JDK version would be

reasonable things to try.

Also, if your current window manager has some advanced drawing options

enabled (e.g. some effects or such) then it might be worth disabling

those too ... just for a try.

Emil

Thanks,

Matteo

---- Original Messagge ----

From: Gerald Drouillard <gerrylist@drouillard.ca>

Sent: martedì 2 ottobre 2012, 14:47

To: users@jitsi.java.net

Cc:

Subj: [jitsi-users] Re: Jitsy very slow

On 10/2/2012 3:40 AM, Matteo Calorio wrote:

No difference in the delay if I change the Audio System: it takes 10

seconds to establish a call, but then it does it.

Even changing the property you suggested to me doesn't solve the

problem.

It appears jitsi is very slow to draw windows, but maybe this is only

a consequence of something else.

We have to start Jitsi and any other softphone with the following:

C:\Windows\System32\cmd.exe /c start "hi" /realtime "C:\Program

Files\Jitsi\run.exe"

Your voip software needs realtime communication when users start to open

applications, browsers, email and anything else that wants resources

from the computer.


#5

The only problem I can see from debug is:

15:57:26.589 GRAVE:
impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectUsingSRVRecords().839
No SRV addresses found for xmpp-client.

Thanks,
  Matteo

---- Original Messagge ----

···

From: Emil Ivov <emcho@jitsi.org>
Sent: giovedì 27 settembre 2012, 15:28
To: users@jitsi.java.net
Cc: Matteo Calorio <matteo.calorio@linux.ors-tech.it>
Subj: [jitsi-users] Re: Jitsy very slow

I've also seen that occur on some machines but don't really have a clue
as to what the reason might be. Maybe some of our other Debian users
would have an idea?

Emil

On 27.09.12, 14:00, Matteo Calorio wrote:

Hello,

on a new laptop Debian7 installation I have Jitsi (1.0.1-build.3967)
running very slow: it takes seconds to start a call and I loose all
incoming calls.

I saw this post on the web, but without useful answers:

http://java.net/projects/jitsi/lists/users/archive/2012-05/message/25

My Java version is:

java version "1.6.0_24"

OpenJDK Runtime Environment (IcedTea6 1.11.4) (6b24-1.11.4-3)

OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

Bye,

Matteo


#6

Here they are:

    description: Notebook
    product: SVS1511U9ES (N/A)
    vendor: Sony Corporation
    version: C60ALQ40
    width: 64 bits
  *-core
     *-cpu
          product: Intel(R) Core(TM) i7-3612QM CPU @ 2.10GHz
          capacity: 1200MHz
          width: 64 bits
          clock: 100MHz
          capabilities: x86-64 fpu fpu_exception wp vme de pse tsc msr pae mce
cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss
ht tm pbe syscall nx rdtscp constant_tsc arch_perfmon pebs bts rep_good nopl
xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est
tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer
aes xsave avx f16c rdrand lahf_lm ida arat epb xsaveopt pln pts dtherm
tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms cpufreq
          configuration: cores=4 enabledcores=4 threads=8
     *-memory
          size: 8GiB

VGA compatible controller: NVIDIA Corporation Device 0fd3 (rev a1)
Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express
Gigabit Ethernet controller (rev 07)

I use a SIP account and an XMPP one.

I run Jitsi on this new machine with Debian 7 on it, on the old machine (it
broke, that's why I changed it) it was much more responsive, but I couldn't
see video output (only with Jitsi, even with nightly builds, with other
software I could). On the new laptop video is ok.

On incoming calls Jitsi rings, but slowly and before I answer some timeouts
happens.

The nightly build seems to solve the problem: it take almost 2 seconds to
reply since I press the answer button, but it works.

Thanks,
  Matteo

---- Original Messagge ----

···

From: Kertesz Laszlo <laszlo.kertesz@gmail.com>
Sent: giovedì 27 settembre 2012, 20:14
To: users@jitsi.java.net
Cc:
Subj: [jitsi-users] Re: Jitsy very slow

Matteo Calorio wrote:

Hello,

on a new laptop Debian7 installation I have Jitsi (1.0.1-build.3967)
running very slow: it takes seconds to start a call and I loose all
incoming calls.

Could you post the specs of this laptop and the account types you use
regularly for calling?

I run Jitsi on Debian Wheezy/7 on a desktop and a laptop, both with 2
core cpus (intel @2GHz on laprop, AMD @3GHz on desktop) and Jitsi is
quite responsive. Note that i use 32-bit OS (686-pae variant).

But different accounts have different behaviour: i use a SIP account and
that connects instantly and a Google Talk account and that takes a while
to connect (the other side uses Jitsi too) because of the zrtp key
exchange and maybe the Jingle discovery takes a bit of time too.

What do you mean by loosing all incoming calls? Does Jitsi ring or just
does not react?

Anyway, you might try out the latest nightly build:

https://download.jitsi.org/jitsi/nightly/debian/

There are lots of changes since the 3967 build, might work better (it
does on my case).

I saw this post on the web, but without useful answers:

http://java.net/projects/jitsi/lists/users/archive/2012-05/message/25

My Java version is:

java version "1.6.0_24"

OpenJDK Runtime Environment (IcedTea6 1.11.4) (6b24-1.11.4-3)

OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

Bye,

Matteo


#7

Hey Matteo,

Here are the logs.

Thanks. I was more interested in the pcap-s though. Could you please
generate a log zip from within Jitsi [0]?

It would be best if you did this right after establishing a "slow" call.

Thanks,
Emil

[0] https://jitsi.org/faq/logs

···

On 03.10.12, 10:45, Matteo Calorio wrote:

Sorry, I did a mistake with the addresses, it was not
intentional. Matteo

---- Original Messagge ----

From: Emil Ivov <emcho@jitsi.org>

Sent: martedì 2 ottobre 2012, 16:59

To: Matteo Calorio <matteo.calorio@linux.ors-tech.it>

Cc:

Subj: Re: [jitsi-users] Re: Jitsy very slow

OK, that's not a problem I was thinking of. This one may be due

something else. Could we please have a look at the logs?

Thanks,

Emil

P.S. Btw, was your response intentionally personal?

On 02.10.12, 16:45, Matteo Calorio wrote:

The capture: http://linux.ors-tech.it/jitsi01.ogv

Disabling desktop effect doesn't solve the problem.

I changed my java version to:

java version "1.7.0_03"

OpenJDK Runtime Environment (IcedTea7 2.1.2) (7u3-2.1.2-2)

OpenJDK 64-Bit Server VM (build 22.0-b10, mixed mode)

... but still nothing...

I disabled desktop effects... and nothing changed.

I have only Kde wm.

Thanks,

Matteo

---- Original Messagge ----

From: Emil Ivov <emcho@jitsi.org>

Sent: martedì 2 ottobre 2012, 15:24

To: users@jitsi.java.net

Cc: Matteo Calorio <matteo.calorio@linux.ors-tech.it>

Subj: Re: [jitsi-users] Re: Jitsy very slow

Oh and one more thing. If the problem you have really is the same as the

one I've seen it is fairly clear when watching jitsi that there's

something wrong with the rendering.

Just to help me and others understand, do you think you might capture

your experience in a screencast and upload it somewhere?

Thanks,

Emil

On 02.10.12, 15:19, Emil Ivov wrote:

On 02.10.12, 15:11, Matteo Calorio wrote:

I changed priority to maximum allowed and to realtime scheduliong, but

nothing changes (chrt -r -p 20 21241).

Anyway, it appens also with normal priority and without other user

applications running (but the machine shoud be powerful enough).

Yeah, from what I've seen this really is a problem with the drawing, so

I still think changing window managers and JDK version would be

reasonable things to try.

Also, if your current window manager has some advanced drawing options

enabled (e.g. some effects or such) then it might be worth disabling

those too ... just for a try.

Emil

Thanks,

Matteo

---- Original Messagge ----

From: Gerald Drouillard <gerrylist@drouillard.ca>

Sent: martedì 2 ottobre 2012, 14:47

To: users@jitsi.java.net

Cc:

Subj: [jitsi-users] Re: Jitsy very slow

On 10/2/2012 3:40 AM, Matteo Calorio wrote:

No difference in the delay if I change the Audio System: it takes 10

seconds to establish a call, but then it does it.

Even changing the property you suggested to me doesn't solve the

problem.

It appears jitsi is very slow to draw windows, but maybe this is only

a consequence of something else.

We have to start Jitsi and any other softphone with the following:

C:\Windows\System32\cmd.exe /c start "hi" /realtime "C:\Program

Files\Jitsi\run.exe"

Your voip software needs realtime communication when users start to open

applications, browsers, email and anything else that wants resources

from the computer.

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31


#8

Have you tried using alternative window managers?

Have you tried upgrading to J7?

Both of the above just shots in the dark but I am afraid I can't think
of anything else. The problem is certainly not related to resources, and
it's also not a generic linux problem although, as I already mentioned,
I have witnessed it on some platforms.

Emil

···

On 01.10.12, 15:43, Matteo Calorio wrote:

Here they are:

description: Notebook

product: SVS1511U9ES (N/A)

vendor: Sony Corporation

version: C60ALQ40

width: 64 bits

*-core

*-cpu

product: Intel(R) Core(TM) i7-3612QM CPU @ 2.10GHz

capacity: 1200MHz

width: 64 bits

clock: 100MHz

capabilities: x86-64 fpu fpu_exception wp vme de pse tsc msr pae mce cx8
apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2
ss ht tm pbe syscall nx rdtscp constant_tsc arch_perfmon pebs bts
rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64
monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2
x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm ida
arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid
fsgsbase smep erms cpufreq

configuration: cores=4 enabledcores=4 threads=8

*-memory

size: 8GiB

VGA compatible controller: NVIDIA Corporation Device 0fd3 (rev a1)

Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI
Express Gigabit Ethernet controller (rev 07)

I use a SIP account and an XMPP one.

I run Jitsi on this new machine with Debian 7 on it, on the old machine
(it broke, that's why I changed it) it was much more responsive, but I
couldn't see video output (only with Jitsi, even with nightly builds,
with other software I could). On the new laptop video is ok.

On incoming calls Jitsi rings, but slowly and before I answer some
timeouts happens.

The nightly build seems to solve the problem: it take almost 2 seconds
to reply since I press the answer button, but it works.

Thanks,

Matteo

---- Original Messagge ----

From: Kertesz Laszlo <laszlo.kertesz@gmail.com>

Sent: giovedì 27 settembre 2012, 20:14

To: users@jitsi.java.net

Cc:

Subj: [jitsi-users] Re: Jitsy very slow

Matteo Calorio wrote:

Hello,

on a new laptop Debian7 installation I have Jitsi (1.0.1-build.3967)

running very slow: it takes seconds to start a call and I loose all

incoming calls.

Could you post the specs of this laptop and the account types you use

regularly for calling?

I run Jitsi on Debian Wheezy/7 on a desktop and a laptop, both with 2

core cpus (intel @2GHz on laprop, AMD @3GHz on desktop) and Jitsi is

quite responsive. Note that i use 32-bit OS (686-pae variant).

But different accounts have different behaviour: i use a SIP account and

that connects instantly and a Google Talk account and that takes a while

to connect (the other side uses Jitsi too) because of the zrtp key

exchange and maybe the Jingle discovery takes a bit of time too.

What do you mean by loosing all incoming calls? Does Jitsi ring or just

does not react?

Anyway, you might try out the latest nightly build:

https://download.jitsi.org/jitsi/nightly/debian/

There are lots of changes since the 3967 build, might work better (it

does on my case).

I saw this post on the web, but without useful answers:

http://java.net/projects/jitsi/lists/users/archive/2012-05/message/25

My Java version is:

java version "1.6.0_24"

OpenJDK Runtime Environment (IcedTea6 1.11.4) (6b24-1.11.4-3)

OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

Bye,

Matteo

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31


#9

Here it is: http://linux.ors-tech.it/2012-10-03@13.06.27-logs.zip

Thanks,
  Matteo

---- Original Messagge ----

···

From: Emil Ivov <emcho@jitsi.org>
Sent: mercoledì 3 ottobre 2012, 13:02
To: Matteo Calorio <matteo.calorio@linux.ors-tech.it>
Cc: users@jitsi.java.net
Subj: [jitsi-users] Re: Jitsy very slow

Hey Matteo,

On 03.10.12, 10:45, Matteo Calorio wrote:

Here are the logs.

Thanks. I was more interested in the pcap-s though. Could you please
generate a log zip from within Jitsi [0]?

It would be best if you did this right after establishing a "slow" call.

Thanks,
Emil

[0] https://jitsi.org/faq/logs

Sorry, I did a mistake with the addresses, it was not
intentional. Matteo

---- Original Messagge ----

From: Emil Ivov <emcho@jitsi.org>

Sent: martedì 2 ottobre 2012, 16:59

To: Matteo Calorio <matteo.calorio@linux.ors-tech.it>

Cc:

Subj: Re: [jitsi-users] Re: Jitsy very slow

OK, that's not a problem I was thinking of. This one may be due

something else. Could we please have a look at the logs?

Thanks,

Emil

P.S. Btw, was your response intentionally personal?

On 02.10.12, 16:45, Matteo Calorio wrote:

The capture: http://linux.ors-tech.it/jitsi01.ogv

Disabling desktop effect doesn't solve the problem.

I changed my java version to:

java version "1.7.0_03"

OpenJDK Runtime Environment (IcedTea7 2.1.2) (7u3-2.1.2-2)

OpenJDK 64-Bit Server VM (build 22.0-b10, mixed mode)

... but still nothing...

I disabled desktop effects... and nothing changed.

I have only Kde wm.

Thanks,

Matteo

---- Original Messagge ----

From: Emil Ivov <emcho@jitsi.org>

Sent: martedì 2 ottobre 2012, 15:24

To: users@jitsi.java.net

Cc: Matteo Calorio <matteo.calorio@linux.ors-tech.it>

Subj: Re: [jitsi-users] Re: Jitsy very slow

Oh and one more thing. If the problem you have really is the same as the

one I've seen it is fairly clear when watching jitsi that there's

something wrong with the rendering.

Just to help me and others understand, do you think you might capture

your experience in a screencast and upload it somewhere?

Thanks,

Emil

On 02.10.12, 15:19, Emil Ivov wrote:

On 02.10.12, 15:11, Matteo Calorio wrote:

I changed priority to maximum allowed and to realtime scheduliong, but

nothing changes (chrt -r -p 20 21241).

Anyway, it appens also with normal priority and without other user

applications running (but the machine shoud be powerful enough).

Yeah, from what I've seen this really is a problem with the drawing, so

I still think changing window managers and JDK version would be

reasonable things to try.

Also, if your current window manager has some advanced drawing options

enabled (e.g. some effects or such) then it might be worth disabling

those too ... just for a try.

Emil

Thanks,

Matteo

---- Original Messagge ----

From: Gerald Drouillard <gerrylist@drouillard.ca>

Sent: martedì 2 ottobre 2012, 14:47

To: users@jitsi.java.net

Cc:

Subj: [jitsi-users] Re: Jitsy very slow

On 10/2/2012 3:40 AM, Matteo Calorio wrote:

No difference in the delay if I change the Audio System: it takes 10

seconds to establish a call, but then it does it.

Even changing the property you suggested to me doesn't solve the

problem.

It appears jitsi is very slow to draw windows, but maybe this is only

a consequence of something else.

We have to start Jitsi and any other softphone with the following:

C:\Windows\System32\cmd.exe /c start "hi" /realtime "C:\Program

Files\Jitsi\run.exe"

Your voip software needs realtime communication when users start to open

applications, browsers, email and anything else that wants resources

from the computer.


#10

Not yet, but the last nightly build appear to mitigate the problem.

Thanks,
  Matteo

---- Original Messagge ----

···

From: Emil Ivov <emcho@jitsi.org>
Sent: lunedì 1 ottobre 2012, 23:44
To: users@jitsi.java.net
Cc: Matteo Calorio <matteo.calorio@linux.ors-tech.it>
Subj: [jitsi-users] Re: Jitsy very slow

Have you tried using alternative window managers?

Have you tried upgrading to J7?

Both of the above just shots in the dark but I am afraid I can't think
of anything else. The problem is certainly not related to resources, and
it's also not a generic linux problem although, as I already mentioned,
I have witnessed it on some platforms.

Emil

On 01.10.12, 15:43, Matteo Calorio wrote:

Here they are:

description: Notebook

product: SVS1511U9ES (N/A)

vendor: Sony Corporation

version: C60ALQ40

width: 64 bits

*-core

*-cpu

product: Intel(R) Core(TM) i7-3612QM CPU @ 2.10GHz

capacity: 1200MHz

width: 64 bits

clock: 100MHz

capabilities: x86-64 fpu fpu_exception wp vme de pse tsc msr pae mce cx8
apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2
ss ht tm pbe syscall nx rdtscp constant_tsc arch_perfmon pebs bts
rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64
monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2
x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm ida
arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid
fsgsbase smep erms cpufreq

configuration: cores=4 enabledcores=4 threads=8

*-memory

size: 8GiB

VGA compatible controller: NVIDIA Corporation Device 0fd3 (rev a1)

Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI
Express Gigabit Ethernet controller (rev 07)

I use a SIP account and an XMPP one.

I run Jitsi on this new machine with Debian 7 on it, on the old machine
(it broke, that's why I changed it) it was much more responsive, but I
couldn't see video output (only with Jitsi, even with nightly builds,
with other software I could). On the new laptop video is ok.

On incoming calls Jitsi rings, but slowly and before I answer some
timeouts happens.

The nightly build seems to solve the problem: it take almost 2 seconds
to reply since I press the answer button, but it works.

Thanks,

Matteo

---- Original Messagge ----

From: Kertesz Laszlo <laszlo.kertesz@gmail.com>

Sent: giovedì 27 settembre 2012, 20:14

To: users@jitsi.java.net

Cc:

Subj: [jitsi-users] Re: Jitsy very slow

Matteo Calorio wrote:

Hello,

on a new laptop Debian7 installation I have Jitsi (1.0.1-build.3967)

running very slow: it takes seconds to start a call and I loose all

incoming calls.

Could you post the specs of this laptop and the account types you use

regularly for calling?

I run Jitsi on Debian Wheezy/7 on a desktop and a laptop, both with 2

core cpus (intel @2GHz on laprop, AMD @3GHz on desktop) and Jitsi is

quite responsive. Note that i use 32-bit OS (686-pae variant).

But different accounts have different behaviour: i use a SIP account and

that connects instantly and a Google Talk account and that takes a while

to connect (the other side uses Jitsi too) because of the zrtp key

exchange and maybe the Jingle discovery takes a bit of time too.

What do you mean by loosing all incoming calls? Does Jitsi ring or just

does not react?

Anyway, you might try out the latest nightly build:

https://download.jitsi.org/jitsi/nightly/debian/

There are lots of changes since the 3967 build, might work better (it

does on my case).

I saw this post on the web, but without useful answers:

http://java.net/projects/jitsi/lists/users/archive/2012-05/message/25

My Java version is:

java version "1.6.0_24"

OpenJDK Runtime Environment (IcedTea6 1.11.4) (6b24-1.11.4-3)

OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

Bye,

Matteo


#11

Matteo,

Do you notice any difference is the delay (in establishing calls and/or in answering calls) if you change the Audio System (in Tools > Options > Audio). We support PulseAudio and PortAudio on Linux.

And if you add net.java.sip.communicator.service.media.DISABLE_VIDEO_SUPPORT=true to your sip-communicator.properties (which should be in ~/.jitsi/ or ~/.sip-communicator/)? You should quit Jitsi before applying this modification.

Regards,
Lyubomir


#12

We have to start Jitsi and any other softphone with the following:
C:\Windows\System32\cmd.exe /c start "hi" /realtime "C:\Program Files\Jitsi\run.exe"

Your voip software needs realtime communication when users start to open applications, browsers, email and anything else that wants resources from the computer.

···

On 10/2/2012 3:40 AM, Matteo Calorio wrote:

No difference in the delay if I change the Audio System: it takes 10 seconds to establish a call, but then it does it.

Even changing the property you suggested to me doesn't solve the problem.

It appears jitsi is very slow to draw windows, but maybe this is only a consequence of something else.

--
Regards
--------------------------------------
Gerald Drouillard
Technology Architect
Drouillard & Associates, Inc.
http://www.Drouillard.biz


#13

No difference in the delay if I change the Audio System: it takes 10 seconds
to establish a call, but then it does it.

Even changing the property you suggested to me doesn't solve the problem.

It appears jitsi is very slow to draw windows, but maybe this is only a
consequence of something else.

Thanks,
  Matteo

---- Original Messagge ----

···

From: Lyubomir Marinov <lyubomir.marinov@jitsi.org>
Sent: martedì 2 ottobre 2012, 09:25
To: users@jitsi.java.net
Cc: Matteo Calorio <matteo.calorio@linux.ors-tech.it>
Subj: Re: [jitsi-users] Jitsy very slow

Matteo,

Do you notice any difference is the delay (in establishing calls and/or in
answering calls) if you change the Audio System (in Tools > Options > Audio).
We support PulseAudio and PortAudio on Linux.

And if you add
net.java.sip.communicator.service.media.DISABLE_VIDEO_SUPPORT=true to your
sip-communicator.properties (which should be in ~/.jitsi/ or ~/.sip-
communicator/)? You should quit Jitsi before applying this modification.

Regards,
Lyubomir


#14

I changed priority to maximum allowed and to realtime scheduliong, but nothing
changes (chrt -r -p 20 21241).

Anyway, it appens also with normal priority and without other user
applications running (but the machine shoud be powerful enough).

Thanks,
  Matteo

---- Original Messagge ----

···

From: Gerald Drouillard <gerrylist@drouillard.ca>
Sent: martedì 2 ottobre 2012, 14:47
To: users@jitsi.java.net
Cc:
Subj: [jitsi-users] Re: Jitsy very slow

On 10/2/2012 3:40 AM, Matteo Calorio wrote:

No difference in the delay if I change the Audio System: it takes 10
seconds to establish a call, but then it does it.

Even changing the property you suggested to me doesn't solve the problem.

It appears jitsi is very slow to draw windows, but maybe this is only
a consequence of something else.

We have to start Jitsi and any other softphone with the following:
C:\Windows\System32\cmd.exe /c start "hi" /realtime "C:\Program
Files\Jitsi\run.exe"

Your voip software needs realtime communication when users start to open
applications, browsers, email and anything else that wants resources
from the computer.


#15

I changed priority to maximum allowed and to realtime scheduliong, but
nothing changes (chrt -r -p 20 21241).

Anyway, it appens also with normal priority and without other user
applications running (but the machine shoud be powerful enough).

Yeah, from what I've seen this really is a problem with the drawing, so
I still think changing window managers and JDK version would be
reasonable things to try.

Also, if your current window manager has some advanced drawing options
enabled (e.g. some effects or such) then it might be worth disabling
those too ... just for a try.

Emil

···

On 02.10.12, 15:11, Matteo Calorio wrote:

Thanks,

Matteo

---- Original Messagge ----

From: Gerald Drouillard <gerrylist@drouillard.ca>

Sent: martedì 2 ottobre 2012, 14:47

To: users@jitsi.java.net

Cc:

Subj: [jitsi-users] Re: Jitsy very slow

On 10/2/2012 3:40 AM, Matteo Calorio wrote:

No difference in the delay if I change the Audio System: it takes 10

seconds to establish a call, but then it does it.

Even changing the property you suggested to me doesn't solve the problem.

It appears jitsi is very slow to draw windows, but maybe this is only

a consequence of something else.

We have to start Jitsi and any other softphone with the following:

C:\Windows\System32\cmd.exe /c start "hi" /realtime "C:\Program

Files\Jitsi\run.exe"

Your voip software needs realtime communication when users start to open

applications, browsers, email and anything else that wants resources

from the computer.

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31


#16

Oh and one more thing. If the problem you have really is the same as the
one I've seen it is fairly clear when watching jitsi that there's
something wrong with the rendering.

Just to help me and others understand, do you think you might capture
your experience in a screencast and upload it somewhere?

Thanks,
Emil

···

On 02.10.12, 15:19, Emil Ivov wrote:

On 02.10.12, 15:11, Matteo Calorio wrote:

I changed priority to maximum allowed and to realtime scheduliong, but
nothing changes (chrt -r -p 20 21241).

Anyway, it appens also with normal priority and without other user
applications running (but the machine shoud be powerful enough).

Yeah, from what I've seen this really is a problem with the drawing, so
I still think changing window managers and JDK version would be
reasonable things to try.

Also, if your current window manager has some advanced drawing options
enabled (e.g. some effects or such) then it might be worth disabling
those too ... just for a try.

Emil

Thanks,

Matteo

---- Original Messagge ----

From: Gerald Drouillard <gerrylist@drouillard.ca>

Sent: martedì 2 ottobre 2012, 14:47

To: users@jitsi.java.net

Cc:

Subj: [jitsi-users] Re: Jitsy very slow

On 10/2/2012 3:40 AM, Matteo Calorio wrote:

No difference in the delay if I change the Audio System: it takes 10

seconds to establish a call, but then it does it.

Even changing the property you suggested to me doesn't solve the problem.

It appears jitsi is very slow to draw windows, but maybe this is only

a consequence of something else.

We have to start Jitsi and any other softphone with the following:

C:\Windows\System32\cmd.exe /c start "hi" /realtime "C:\Program

Files\Jitsi\run.exe"

Your voip software needs realtime communication when users start to open

applications, browsers, email and anything else that wants resources

from the computer.

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31