[jitsi-users] Jitsimeet deb package installs but video doesn't work.


#1

Greetings:

I've installed the jitsimeet deb package on Ubuntu 14.04. The install
appeared to go well, but users cannot see each others' video. Chat
works fine and people do see their own video.

I can see that prosody is talking to JVB in prosody.log:

Aug 17 15:37:22 jitsi-videobridge.scratch.domainname.net:component info External component successfully authenticated

But something involving ICE is failing in jvb.log:

16:10:49.506 INFO: [326] org.jitsi.videobridge.IceUdpTransportManager.info() Failed to connect IceUdpTransportManager: net.java.sip.communicator.service.protocol.OperationFailedException: Could not establish connection (ICE failed)

···

*
16:10:44.481 INFO: [348] org.ice4j.ice.ConnectivityCheckClient.processTimeout() timeout for pair: 104.xxx.yyy.zzz:10021/udp/host -> 192.168.56.1:50933/udp/host (video.RTCP), failing.
16:10:44.502 INFO: [349] org.ice4j.ice.ConnectivityCheckClient.processTimeout() timeout for pair: 104.xxx.yyy.zzz:10021/udp/host -> 172.17.1.183:50934/udp/host (video.RTCP), failing.

Note the local addresses there. Looking at chrome's debug console
as a user shows warnings for "getting turn credentials failed; is
mod_turncredentials or similar installed?" and sometimes "confid does
not exist yet, postponing".

The server is not behind a NAT, but all the users (probably) are. The
errors suggest that I need turncredentials configured but the package
install didn't do that. I checked against the manual install
instructions but the related files (involving restund) don't appear to
be there.

What direction should I be looking in to get this to work?

--

Andrew


#2

Hi. I had the same experience.

You should setup and configure turn server. Also edit prosody.cfg.lua file and add turn credentials. And uncomment option “useStunTurn: true” in config.js

Hope it will help.

···

17.08.2014, 20:46, “Andrew” ajvant@gmail.com:

Greetings:

I’ve installed the jitsimeet deb package on Ubuntu 14.04. The install
appeared to go well, but users cannot see each others’ video. Chat
works fine and people do see their own video.

I can see that prosody is talking to JVB in prosody.log:

Aug 17 15:37:22 jitsi-videobridge.scratch.domainname.net:component info External component successfully authenticated

But something involving ICE is failing in jvb.log:

16:10:49.506 INFO: [326] org.jitsi.videobridge.IceUdpTransportManager.info() Failed to connect IceUdpTransportManager: net.java.sip.communicator.service.protocol.OperationFailedException: Could not establish connection (ICE failed)
*
16:10:44.481 INFO: [348] org.ice4j.ice.ConnectivityCheckClient.processTimeout() timeout for pair: 104.xxx.yyy.zzz:10021/udp/host -> 192.168.56.1:50933/udp/host (video.RTCP), failing.
16:10:44.502 INFO: [349] org.ice4j.ice.ConnectivityCheckClient.processTimeout() timeout for pair: 104.xxx.yyy.zzz:10021/udp/host -> 172.17.1.183:50934/udp/host (video.RTCP), failing.

Note the local addresses there. Looking at chrome’s debug console
as a user shows warnings for “getting turn credentials failed; is
mod_turncredentials or similar installed?” and sometimes “confid does
not exist yet, postponing”.

The server is not behind a NAT, but all the users (probably) are. The
errors suggest that I need turncredentials configured but the package
install didn’t do that. I checked against the manual install
instructions but the related files (involving restund) don’t appear to
be there.

What direction should I be looking in to get this to work?

Andrew


users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users