[jitsi-users] jitsi with modified port


#1

Hi!
I setup jitsi-meet using quick install method (https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md). The host name is dc2bsy.entrydns.org. It is a dynamic dns service. I put the server behind NAT. All required port is opened using port forwarding.
I have several problem:

When I use port 443, the client cannot open the site because of security issue. On chrome browser swowing ERR_SSL_VERSION_OR_CIPHER_MISMATCH. This is the first problem.
Then I make a little modification. Port 443 changed into 1443 on router, then forwarded to 443 on server. It seems can resolve the problem. Client can open the main page, even the created channel, but they can not access microphone or camera. Stuck on permission. I open the web console and get the error, it is about binding. Then I change the BOSH configuration in dc2bsy.entrydns.org-config.js and add port number 1443. Client can use the microphone and camera, but they can not send the voice / sound to each other, even every participants can not see anoter participant. This is the second.

I wish for suggestion to solve the problem.

Regard

Nugroho


#2

Hi,

Did you configure jvb for the nat as described here:
https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md#advanced-configuration
You will have problems if your public address is changing if that is
the case you need to implement something that on this change, changes
jvb configuration and restart jvb otherwise it will not work.

For the bosh, you need to check what is the error in prosody when
changing the port. Maybe you will need to modify some headers in the
bosh configuration, something is not matching there and it confuses
the webserver or prosody...
Looking at nginx config:
proxy_set_header X-Forwarded-For $remote_addr;
proxy_set_header Host $http_host;
If some of these mention port 443 but actually 1443 is used this can
be a problem I think, but not sure, this needs to be checked for
eventual errors in prosody.

Regards
damencho

ยทยทยท

On Wed, Nov 15, 2017 at 7:29 AM, nugroho <nugroho.redbuff@gmail.com> wrote:

Hi!
I setup jitsi-meet using quick install method
(https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md). The
host name is dc2bsy.entrydns.org. It is a dynamic dns service. I put the
server behind NAT. All required port is opened using port forwarding.
I have several problem:

When I use port 443, the client cannot open the site because of security
issue. On chrome browser swowing ERR_SSL_VERSION_OR_CIPHER_MISMATCH. This is
the first problem.
Then I make a little modification. Port 443 changed into 1443 on router,
then forwarded to 443 on server. It seems can resolve the problem. Client
can open the main page, even the created channel, but they can not access
microphone or camera. Stuck on permission. I open the web console and get
the error, it is about binding. Then I change the BOSH configuration in
dc2bsy.entrydns.org-config.js and add port number 1443. Client can use the
microphone and camera, but they can not send the voice / sound to each
other, even every participants can not see anoter participant. This is the
second.

I wish for suggestion to solve the problem.

Regard

Nugroho

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users