[jitsi-users] jitsi videobridge issues


#1

Hi,

some issues with jitsi-videobridge-linux-x86-454:

1. the setup guide is wrong for ejabberd:

    module: ejabberd_service
    hosts:
      "jitsi-videobridge.<EJABBERDOMAIN>":
        password: "EJABBERPWD"

   without "jitsi-videobridge." its not working.

Someone promised in 2013 to fix the guide, but he did not.

2. between two Jitsi client both linux in a lan :

- no encryption is enabled! Encryption works perfect with those two
calling them directly
- no video is enabled :

it's called a videobridge, why is video not enabled by default ?

- starting the bridge with --apis=rest cmdline option added and some
free ports in the properties file, the videobridge is no longer found by
the client :facepalm:

3. the entire conference looks exactly like any normal conference call,
except encrpytion is not working.

4. the ZRTP black overlay windows, which apear when you click the red
lock symbol, apear, but they are empty.

5. read and understand 1. before proceeding :

if the subdomain is not used in the ejabberd config, jitsi client goes
into some sort of endless "i won't work" mode,
if the bridge is started. It somehow fucks up the complete UI loop. The
only option to end the program was to use KILL -9.

6. the 64bit version does go nuts, if no memory is available, but it's
configured. In other words, if you do not set a max memory variable in
the script, it uses 3 GB ram. It those 3 GB are not available, the
logoutput goes mad at startup.

if it's a MAXramusage variable, don't use it as minimum ram allocation :wink:

7. the 64bit version complained about a missing FFMPEG component ??? the
32bit version does not complain... very strange.

(but would explain why video isn't working the way it was expected )

Questions in the next mail.

best regards,
Marius


#2

Hi,

some issues with jitsi-videobridge-linux-x86-454:

1. the setup guide is wrong for ejabberd:

   module: ejabberd_service
   hosts:
     "jitsi-videobridge.<EJABBERDOMAIN>":
       password: "EJABBERPWD"

  without "jitsi-videobridge." its not working.

Someone promised in 2013 to fix the guide, but he did not.

2. between two Jitsi client both linux in a lan :

- no encryption is enabled! Encryption works perfect with those two
calling them directly
- no video is enabled :

it's called a videobridge, why is video not enabled by default ?

- starting the bridge with --apis=rest cmdline option added and some
free ports in the properties file, the videobridge is no longer found
by
the client :facepalm:

Yes, if you disable the XMPP API, it won't work. Try --apis=rest,xmpp

Regards,
Boris

···

On May 30, 2015 1:23:03 AM EEST, Marius <jitsi@benderirc.de> wrote:

3. the entire conference looks exactly like any normal conference call,
except encrpytion is not working.

4. the ZRTP black overlay windows, which apear when you click the red
lock symbol, apear, but they are empty.

5. read and understand 1. before proceeding :

if the subdomain is not used in the ejabberd config, jitsi client goes
into some sort of endless "i won't work" mode,
if the bridge is started. It somehow fucks up the complete UI loop. The
only option to end the program was to use KILL -9.

6. the 64bit version does go nuts, if no memory is available, but it's
configured. In other words, if you do not set a max memory variable in
the script, it uses 3 GB ram. It those 3 GB are not available, the
logoutput goes mad at startup.

if it's a MAXramusage variable, don't use it as minimum ram allocation
:wink:

7. the 64bit version complained about a missing FFMPEG component ???
the
32bit version does not complain... very strange.

(but would explain why video isn't working the way it was expected )

Questions in the next mail.

best regards,
Marius

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Sent from a mobile. Please excuse my brevity.


#3

Hi,

some issues with jitsi-videobridge-linux-x86-454:

1. the setup guide is wrong for ejabberd:

     module: ejabberd_service
     hosts:
       "jitsi-videobridge.<EJABBERDOMAIN>":
         password: "EJABBERPWD"

    without "jitsi-videobridge." its not working.

Someone promised in 2013 to fix the guide, but he did not.

Could you be more specific? Which guide, how should it be fixed?

The guide here[1] does contain "jitsi-videobridge.", so I don't understand what the issue is.

2. between two Jitsi client both linux in a lan :

- no encryption is enabled! Encryption works perfect with those two
calling them directly

The Jitsi client does not support encryption for videobridge conferences at this time.

- no video is enabled :

it's called a videobridge, why is video not enabled by default ?

I believe an option to create a conference/videobridge with video enabled is something we agreed we'd like to have, so contributions are welcome.

- starting the bridge with --apis=rest cmdline option added and some
free ports in the properties file, the videobridge is no longer found by
the client :facepalm:

3. the entire conference looks exactly like any normal conference call,
except encrpytion is not working.

4. the ZRTP black overlay windows, which apear when you click the red
lock symbol, apear, but they are empty.

The Jitsi client does not support encryption for videobridge conferences at this time.

Regards,
Boris

[1] https://jitsi.org/Projects/JitsiVideobridgeWithEjabberd

···

On 30/05/15 01:23, Marius wrote:


#4

It's back.

If the bridge can't do something usefull without xmpp, i consider this
as a logic bug, which whould be fixed.

Is there something it can do without xmpp, or are there more apis to
enable, cause i just found the REST one.

Marius

···

Am 31.05.2015 um 06:28 schrieb Boris Grozev:

it's called a videobridge, why is video not enabled by default ?

- starting the bridge with --apis=rest cmdline option added and some
free ports in the properties file, the videobridge is no longer found
by
the client :facepalm:
Yes, if you disable the XMPP API, it won't work. Try --apis=rest,xmpp


#5

I'm 100% sure, last week i saw the webpage page without the jisi..
subdomain. ATM, just forget about it.

Marius

···

Am 01.06.2015 um 10:41 schrieb Boris Grozev:

On 30/05/15 01:23, Marius wrote:

Hi,

some issues with jitsi-videobridge-linux-x86-454:

1. the setup guide is wrong for ejabberd:

     module: ejabberd_service
     hosts:
       "jitsi-videobridge.<EJABBERDOMAIN>":
         password: "EJABBERPWD"

    without "jitsi-videobridge." its not working.

Someone promised in 2013 to fix the guide, but he did not.

Could you be more specific? Which guide, how should it be fixed?

The guide here[1] does contain "jitsi-videobridge.", so I don't
understand what the issue is.


#6

I don't get it. What do you consider a bug? Videobridge supports two different independent interfaces ("rest" and "xmpp"), and you can configure which ones to enable via the --apis argument. If you need XMPP, enable it.

Boris

···

On May 31, 2015 12:47:59 PM EEST, Marius <jitsi@benderirc.de> wrote:

Am 31.05.2015 um 06:28 schrieb Boris Grozev:

it's called a videobridge, why is video not enabled by default ?

- starting the bridge with --apis=rest cmdline option added and some
free ports in the properties file, the videobridge is no longer found
by
the client :facepalm:
Yes, if you disable the XMPP API, it won't work. Try --apis=rest,xmpp

It's back.

If the bridge can't do something usefull without xmpp, i consider this
as a logic bug, which whould be fixed.

Is there something it can do without xmpp, or are there more apis to
enable, cause i just found the REST one.

--
Sent from a mobile. Please excuse my brevity.


#7

Maybe there is another page somewhere that I am not aware of, but this one always had it:
https://jitsi.org/Projects/JitsiVideobridgeWithEjabberd?action=diff

Boris

···

On 01/06/15 14:35, Marius wrote:

Am 01.06.2015 um 10:41 schrieb Boris Grozev:

On 30/05/15 01:23, Marius wrote:

Hi,

some issues with jitsi-videobridge-linux-x86-454:

1. the setup guide is wrong for ejabberd:

      module: ejabberd_service
      hosts:
        "jitsi-videobridge.<EJABBERDOMAIN>":
          password: "EJABBERPWD"

     without "jitsi-videobridge." its not working.

Someone promised in 2013 to fix the guide, but he did not.

Could you be more specific? Which guide, how should it be fixed?

The guide here[1] does contain "jitsi-videobridge.", so I don't
understand what the issue is.

I'm 100% sure, last week i saw the webpage page without the jisi..
subdomain. ATM, just forget about it.


#8

Hi Boris,

I checked this webpage :
https://github.com/jitsi/jitsi-videobridge/blob/master/doc/rest-videobridge.md

"To enable the REST API you have to start Jitsi video bridge with
parameter --apis=rest."

No word about xmpp getting disabled that way, not even mentioned.*

*It's unexpected to be disabled by enabling somthing additional.

As far as i get it, xmpp is needed to use the bridge by the client, so
why disabling it at all ? Does not make sense

I believe, the default should stay enabled until it gets disabled on
purpose.

best regards,
Marius

···

Am 31.05.2015 um 17:02 schrieb Boris Grozev:

It's back.

If the bridge can't do something usefull without xmpp, i consider this
as a logic bug, which whould be fixed.

Is there something it can do without xmpp, or are there more apis to
enable, cause i just found the REST one.
I don't get it. What do you consider a bug? Videobridge supports two different independent interfaces ("rest" and "xmpp"), and you can configure which ones to enable via the --apis argument. If you need XMPP, enable it.


#9

Hello,

It's back.

If the bridge can't do something usefull without xmpp, i consider this
as a logic bug, which whould be fixed.

Is there something it can do without xmpp, or are there more apis to
enable, cause i just found the REST one.

I don't get it. What do you consider a bug? Videobridge supports two different independent interfaces ("rest" and "xmpp"), and you can configure which ones to enable via the --apis argument. If you need XMPP, enable it.

Hi Boris,

I checked this webpage :
https://github.com/jitsi/jitsi-videobridge/blob/master/doc/rest-videobridge.md

"To enable the REST API you have to start Jitsi video bridge with
parameter --apis=rest."

No word about xmpp getting disabled that way, not even mentioned.

It's unexpected to be disabled by enabling somthing additional.

Look at it this way: if you set no values for "apis" JVB starts with XMPP
support only.

If you do, the bridge only starts the APIs that you requested.

As far as i get it, xmpp is needed to use the bridge by the client, so why
disabling it at all ? Does not make sense

This is not correct. Jitsi Videobridge can work with either API. There are
applications that only use it with REST.

I believe, the default should stay enabled until it gets disabled on
purpose.

The APIs parameter specifies the APIs that you want turned on. Everything
else is turned off. If you don't specify that parameter a value of "xmpp"
is assumed by default.

Hope this clarifies things.

Emil

···

On Sunday, May 31, 2015, Marius <jitsi@benderirc.de> wrote:

Am 31.05.2015 um 17:02 schrieb Boris Grozev:

--
sent from my mobile


#10

Clarified the doc.

Boris

···

On 31/05/15 18:25, Marius wrote:

Am 31.05.2015 um 17:02 schrieb Boris Grozev:

It's back.

If the bridge can't do something usefull without xmpp, i consider this
as a logic bug, which whould be fixed.

Is there something it can do without xmpp, or are there more apis to
enable, cause i just found the REST one.
I don't get it. What do you consider a bug? Videobridge supports two different independent interfaces ("rest" and "xmpp"), and you can configure which ones to enable via the --apis argument. If you need XMPP, enable it.

Hi Boris,

I checked this webpage :
https://github.com/jitsi/jitsi-videobridge/blob/master/doc/rest-videobridge.md

"To enable the REST API you have to start Jitsi video bridge with
parameter --apis=rest."