[jitsi-users] Jitsi video bridge changes


#1

Hi There

Since 6 months more or less, I have been testing the performance of Jitsi Meet and tracking its changes and features without major problems. Even I've been using it with my colleagues substituting services as Skype or Hangout. Recently since the jicofo feature start I'm not able anymore to keep running the jitsi meet in my server.

I've been following the guidelines several times from scratch, and even I tried installing the .deb package as well without success. The problem is that apparently Jitsi Meet is working but is no able to create session (Room). Let me add a couple of examples that probably can help you in order to give you an idea.

After running the video bridge, I always have this error:

13:00:33.138 INFO: [10] org.jitsi.videobridge.osgi.OSGiBundleActivator.info() org.jitsi.impl.neomedia.transform.srtp.SRTPCryptoContext.checkReplay=false
13:00:33.143 INFO: [10] org.jitsi.videobridge.osgi.OSGiBundleActivator.info() net.java.sip.communicator.SC_HOME_DIR_NAME=.sip-communicator
13:00:33.148 INFO: [10] org.jitsi.videobridge.osgi.OSGiBundleActivator.info() net.java.sip.communicator.SC_HOME_DIR_LOCATION=/home/******
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.

After running Jicofo I always get this that as far as I understand is running properly:

  Network Address Manager Service ...[REGISTERED]
13:03:28.677 INFO: [10] impl.netaddr.NetworkConfigurationWatcher.checkNetworkInterfaces().387 Currently Active eth0:[/192.168.10.132]
13:03:28.715 FINA: [10] plugin.reconnectplugin.ReconnectPluginActivator.start().238 Found 0 already installed providers.
13:03:42.878 INFO: [11] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() HAVE Discovered items for: raspachini.no-ip.org
13:03:42.886 INFO: [11] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() <item jid="jitsi-videobridge.raspachini.no-ip.org"/>
13:03:42.891 INFO: [11] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() <item jid="focus.raspachini.no-ip.org"/>
13:03:42.896 INFO: [11] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() <item jid="conference.raspachini.no-ip.org"/>
13:03:42.902 INFO: [11] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() <item jid="auth.raspachini.no-ip.org"/>
13:03:43.086 INFO: [11] org.jitsi.jicofo.JitsiMeetServices.init().179 Discovered videobridge: jitsi-videobridge.raspachini.no-ip.org
13:03:43.093 ADVERTENCIA: [11] org.jitsi.jicofo.BridgeSelector.addJvbAddress().125 No pub-sub node mapped for jitsi-videobridge.raspachini.no-ip.org statistics will not be tracked fro this instance.
13:03:43.392 INFO: [11] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.info() XMPP provider Jabber:focus@auth.raspachini.no-ip.org/focus3203345159850@127.0.0.1 connected (JID: focus@auth.raspachini.no-ip.org/focus3203345159850)

Now, herein my config.js:

var config = {
     hosts: {
         domain: 'raspachini.no-ip.org',
         //anonymousdomain: 'guest.example.com',
         muc: 'conference.raspachini.no-ip.org', // FIXME: use XEP-0030
         bridge: 'jitsi-videobridge.raspachini.no-ip.org', // FIXME: use XEP-0030
         //jirecon: 'jirecon.jitsi-meet.example.com',
         //call_control: 'callcontrol.jitsi-meet.example.com',
         //focus: 'focus.raspachini.no-ip.org' - defaults to 'focus.jitsi-meet.example.com'
     },
// getroomnode: function (path) { return 'someprefixpossiblybasedonpath'; },
     useStunTurn: true, // use XEP-0215 to fetch STUN and TURN server
     useIPv6: true, // ipv6 support. use at your own risk
     useNicks: false,
     bosh: '//raspachini.no-ip.org/http-bind', // FIXME: use xep-0156 for that
     clientNode: 'http://jitsi.org/jitsimeet', // The name of client node advertised in XEP-0115 'c' stanza
     //focusUserJid: 'focus@auth.jitsi-meet.example.com', // The real JID of focus participant - can be overridden here
     //defaultSipNumber: '', // Default SIP number
     desktopSharing: 'ext', // Desktop sharing method. Can be set to 'ext', 'webrtc' or false to disable.
     chromeExtensionId: 'diibjkoicjeejcmhdnailmkgecihlobk', // Id of desktop streamer Chrome extension
     desktopSharingSources: ['screen', 'window'],
     minChromeExtVersion: '0.1', // Required version of Chrome extension
     openSctp: true, // Toggle to enable/disable SCTP channels
// disableStats: false,
// disableAudioLevels: false,
     channelLastN: -1, // The default value of the channel attribute last-n.
     adaptiveLastN: false,
     adaptiveSimulcast: false,
     useRtcpMux: true,
     useBundle: true,
     enableRecording: false,
     enableWelcomePage: false,
     enableSimulcast: false,
     enableFirefoxSupport: true, //firefox support is still experimental and
     // will work when simulcast is *disabled* and rtcpMux & bundle are *enabled*.
     logStats: false, // Enable logging of PeerConnection stats via the focus
     /*noticeMessage: 'Service update is scheduled for 16th March 2015. '

···

+
     'During that time service will not be available. ' +
     'Apologise for inconvenience.'*/
};

When I access to the Jitmeet in order to create a video conference, (please look image attached), seems that is working but when I try to invite somebody else, appears and hold that message (Your conference is currently being created...) so that means that the bridge for whatever reason is not doing it job.

If somebody can give me a light I will be very grateful.

Thank you in advance.

Best regards,