[jitsi-users] Jitsi spawning Conhost Window at startup


#1

Dear Developers,

Recently, I received a request to test Jitsi on our corporate systems/network to possibly make it available to all.
Systems are all Windows 7 64-bit.

During testing, I come across the following issue.
When Jitisi is started at the desktop, it opens a command-prompt window as pictured below:

[cid:image004.jpg@01D38B9D.8519C020]

It looks like Java is opening/starting a Conhost-process in the background during startup (terminal in/output??).
This is very annoying to our users.
This happens with both the X86 and the X64-version.
Can this somehow be cancelled and/or blocked?

With kind regards,

[Beschrijving: Beschrijving: http://www.antoniusziekenhuis.nl/emailsig/sazlogo200x71.gif]
Maarten Maanen, van
ICT - St. Antonius Ziekenhuis


#2

Is this running on some kind of Terminal Sever/VDi? I have never seen this before.
Jitsi does spawn itself to check if the main process is still alive and asks for a restart if it crashed. There should be cmdline parameter to circumvent/bypass that, but I‘d need to look in the source code (run.c if you want to search yourself on Github).

Ingo

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

···

On 12 Jan 2018, at 18:06, Maanen, Maarten van (I&I Beheer) <m.van.maanen1@antoniusziekenhuis.nl> wrote:

Dear Developers,

Recently, I received a request to test Jitsi on our corporate systems/network to possibly make it available to all.
Systems are all Windows 7 64-bit.

During testing, I come across the following issue.
When Jitisi is started at the desktop, it opens a command-prompt window as pictured below:

<image004.jpg>

It looks like Java is opening/starting a Conhost-process in the background during startup (terminal in/output??).
This is very annoying to our users.
This happens with both the X86 and the X64-version.
Can this somehow be cancelled and/or blocked?

With kind regards,

<image003.gif>
Maarten Maanen, van
ICT - St. Antonius Ziekenhuis

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hello Ingo,

Thank you very much for the response.

Yes, I am trying to run Jitsi on your Citrix-bases VDI-environment.
Actually, I have virtualized the Jitsi application with VMWare Thinapp.
When I start the Thinapped-application, I can see multiple instances running, one of which is the conhost session.

This behavior does indeed NOT happen on a normal locally installed desktop.
However, since our users should be able to login at any location in our environment, a local installed version of Jitsi is not an option.

If you could find out the commandline parameter to disable the terminal/conhost option that would be most helpful.

I must admit than run.c does ring a bell for me. I’m pretty good at virtualizing, but not at programming unfortunately.

With kind regards,

[Beschrijving: Beschrijving: http://www.antoniusziekenhuis.nl/emailsig/sazlogo200x71.gif]
Maarten Maanen, van
ICT - St. Antonius Ziekenhuis

···

Van: users [mailto:users-bounces@jitsi.org] Namens Ingo Bauersachs
Verzonden: maandag 15 januari 2018 13:08
Aan: Jitsi Users
Onderwerp: Re: [jitsi-users] Jitsi spawning Conhost Window at startup

Is this running on some kind of Terminal Sever/VDi? I have never seen this before.
Jitsi does spawn itself to check if the main process is still alive and asks for a restart if it crashed. There should be cmdline parameter to circumvent/bypass that, but I‘d need to look in the source code (run.c if you want to search yourself on Github).

Ingo
Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

On 12 Jan 2018, at 18:06, Maanen, Maarten van (I&I Beheer) <m.van.maanen1@antoniusziekenhuis.nl<mailto:m.van.maanen1@antoniusziekenhuis.nl>> wrote:
Dear Developers,

Recently, I received a request to test Jitsi on our corporate systems/network to possibly make it available to all.
Systems are all Windows 7 64-bit.

During testing, I come across the following issue.
When Jitisi is started at the desktop, it opens a command-prompt window as pictured below:

<image004.jpg>

It looks like Java is opening/starting a Conhost-process in the background during startup (terminal in/output??).
This is very annoying to our users.
This happens with both the X86 and the X64-version.
Can this somehow be cancelled and/or blocked?

With kind regards,

<image003.gif>
Maarten Maanen, van
ICT - St. Antonius Ziekenhuis

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Yes, I am trying to run Jitsi on your Citrix-bases VDI-environment.

Actually, I have virtualized the Jitsi application with VMWare Thinapp.

When I start the Thinapped-application, I can see multiple instances running,
one of which is the conhost session.

This behavior does indeed NOT happen on a normal locally installed desktop.

However, since our users should be able to login at any location in our
environment, a local installed version of Jitsi is not an option.

Not sure why the conhost pops up there. Before doing any further investigation about it: do all the other functions you require from Jitsi work at all? If you want to do phone calls for example, I somewhat doubt that this will work due to the additional latency.

If you could find out the commandline parameter to disable the
terminal/conhost option that would be most helpful.

I must admit than run.c does ring a bell for me. I’m pretty good at
virtualizing, but not at programming unfortunately.

Actually, I was mistaken. There is currently no parameter, the decision whether to launch the crash handler or the actual application is based on the presence of a parent process. It would not be hard to add something though.

With kind regards,
Maarten Maanen, van

Ingo


#5

Hi Ingo,

Thanks again for your response.
Sorry to here there are not command line options.

As for functionality, we are only using the chat-function and that works fine. Even when we close the conhost windows it will also work.
But of course, users find the command window very disturbing.

Regards,

Met vriendelijke groet,

Maarten Maanen, van
ICT - St. Antonius Ziekenhuis

-----Oorspronkelijk bericht-----

···

Van: users [mailto:users-bounces@jitsi.org] Namens Ingo Bauersachs
Verzonden: woensdag 17 januari 2018 02:18
Aan: 'Jitsi Users'
Onderwerp: Re: [jitsi-users] Jitsi spawning Conhost Window at startup

Yes, I am trying to run Jitsi on your Citrix-bases VDI-environment.

Actually, I have virtualized the Jitsi application with VMWare Thinapp.

When I start the Thinapped-application, I can see multiple instances
running, one of which is the conhost session.

This behavior does indeed NOT happen on a normal locally installed desktop.

However, since our users should be able to login at any location in
our environment, a local installed version of Jitsi is not an option.

Not sure why the conhost pops up there. Before doing any further investigation about it: do all the other functions you require from Jitsi work at all? If you want to do phone calls for example, I somewhat doubt that this will work due to the additional latency.

If you could find out the commandline parameter to disable the
terminal/conhost option that would be most helpful.

I must admit than run.c does ring a bell for me. I’m pretty good at
virtualizing, but not at programming unfortunately.

Actually, I was mistaken. There is currently no parameter, the decision whether to launch the crash handler or the actual application is based on the presence of a parent process. It would not be hard to add something though.

With kind regards,
Maarten Maanen, van

Ingo

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users