[jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.


#1

Hi !

It's all in the title.

On some not well defined situations, Jitsi cannot connect and ask my SIP
passwords again.

(maybe when laptop resuming from sleep, VPN is down/restarting or when
the internet connection is bad (packet losses))

The weird thing is that when I press "Cancel" to get rid of the login
dialogs, the saved password have already been cleared.

Pretty annoying, I need to change all my passwords each time it's
occuring because they are unique and I never use them so I never
remember them (if not the SIP password itself, the web platform password
where I can retrieve the SIP password...)

Beside this Jitsi is great :slight_smile:

Thanks in advance !

Luc

PS: Actually using Jitsi 2.8.5426 on Debian 8


#2

Hi,

I have been waiting for them to fix that for at least two years.. I don't
believe they will ever fix it. As far as I can tell sometimes the keep
alive negotiating doesn't go as expected (it's UDP for God sake) and
instead of retrying it clears the password. Try using the maximum value
allowed (3600) that improved things a bit.

Good luck,

Flávio Pereira
Assistente Técnico

Universidade de Coimbra • Administração
Divisão de Infra-estruturas de Tecnologias de Informação e Comunicação
Rua Arco da Traição | 3000-056 • Coimbra • Portugal
Tel: +351 239 242 870 | Tlm. 965 913 049
E-mail: flavio@uc.pt

www.uc.pt <http://www.uc.pt/ciuc>

[image: logos UC & Património Mundial]

Este e-mail pretende ser amigo do ambiente. Pondere antes de o imprimir! A
Universidade de Coimbra dá preferência a produtos e serviços com menor
impacto ambiental. This e-mail is environment friendly. Please think twice
before printing it! The University of Coimbra prefers products and services
with reduced environmental impact

···

On Tue, Nov 3, 2015 at 2:51 AM, Luc Deschenaux < luc.deschenaux.mta@sunrise.ch> wrote:

Hi !

It's all in the title.

On some not well defined situations, Jitsi cannot connect and ask my SIP
passwords again.

(maybe when laptop resuming from sleep, VPN is down/restarting or when
the internet connection is bad (packet losses))

The weird thing is that when I press "Cancel" to get rid of the login
dialogs, the saved password have already been cleared.

Pretty annoying, I need to change all my passwords each time it's
occuring because they are unique and I never use them so I never
remember them (if not the SIP password itself, the web platform password
where I can retrieve the SIP password...)

Beside this Jitsi is great :slight_smile:

Thanks in advance !

Luc

PS: Actually using Jitsi 2.8.5426 on Debian 8

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hi,

The password is cleared only after two consecutive authorization
challenges, which are considered as wrong password, there is no standard
way to detect wrong password. I have seen this problem with asterisk and
havn't seen why it perform this way.
Increasing the keep-alive checks interval actually removes the keep-alive
and with some standart nats, like linux one, if you do not send a packet
for 30 secs you can miss calls as it will destroy your mapping.
If you make a dump in such a situation and see why this happen you are more
than welcome to comment and maybe offer a patch that we will accept. Any
contributions are welcome.

Here the password is cleared:
https://github.com/jitsi/jitsi/blob/4b124d7b8a79739686aac64450b2ba390217087e/src/net/java/sip/communicator/impl/protocol/sip/security/SipSecurityManager.java#L264

Regards
damencho

···

On Mon, Nov 16, 2015 at 4:59 PM, Flávio Pereira <flavio@uc.pt> wrote:

Hi,

I have been waiting for them to fix that for at least two years.. I don't
believe they will ever fix it. As far as I can tell sometimes the keep
alive negotiating doesn't go as expected (it's UDP for God sake) and
instead of retrying it clears the password. Try using the maximum value
allowed (3600) that improved things a bit.

Good luck,

Flávio Pereira
Assistente Técnico

Universidade de Coimbra • Administração
Divisão de Infra-estruturas de Tecnologias de Informação e Comunicação
Rua Arco da Traição | 3000-056 • Coimbra • Portugal
Tel: +351 239 242 870 | Tlm. 965 913 049
E-mail: flavio@uc.pt

www.uc.pt <http://www.uc.pt/ciuc>

[image: logos UC & Património Mundial]

Este e-mail pretende ser amigo do ambiente. Pondere antes de o imprimir! A
Universidade de Coimbra dá preferência a produtos e serviços com menor
impacto ambiental. This e-mail is environment friendly. Please think twice
before printing it! The University of Coimbra prefers products and services
with reduced environmental impact

On Tue, Nov 3, 2015 at 2:51 AM, Luc Deschenaux < > luc.deschenaux.mta@sunrise.ch> wrote:

Hi !

It's all in the title.

On some not well defined situations, Jitsi cannot connect and ask my SIP
passwords again.

(maybe when laptop resuming from sleep, VPN is down/restarting or when
the internet connection is bad (packet losses))

The weird thing is that when I press "Cancel" to get rid of the login
dialogs, the saved password have already been cleared.

Pretty annoying, I need to change all my passwords each time it's
occuring because they are unique and I never use them so I never
remember them (if not the SIP password itself, the web platform password
where I can retrieve the SIP password...)

Beside this Jitsi is great :slight_smile:

Thanks in advance !

Luc

PS: Actually using Jitsi 2.8.5426 on Debian 8

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Respectfully, you are wrong.
The credentials get cleared every few hours for our users. I have some people with laptops that automatically sleep / hibernate.
When they wake up, there is a period of time when Jitsi is awake but the full network stack isn’t up yet. Once the network comes up, a firewall agent needs to wake up to allow them access to the network. Before it is ready, Jitsi jumps in and thinks it should immediately connect, and it can’t.
Then Jitsi wrongly decides their password is wrong (it isn’t) and clears all their settings.

Those users have all uninstalled Jitsi because of this. We spent countless hours on this and gave up.

···

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: Saturday, December 05, 2015 9:36 AM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Hi,

The password is cleared only after two consecutive authorization challenges, which are considered as wrong password, there is no standard way to detect wrong password. I have seen this problem with asterisk and havn't seen why it perform this way.
Increasing the keep-alive checks interval actually removes the keep-alive and with some standart nats, like linux one, if you do not send a packet for 30 secs you can miss calls as it will destroy your mapping.
If you make a dump in such a situation and see why this happen you are more than welcome to comment and maybe offer a patch that we will accept. Any contributions are welcome.

Here the password is cleared:
https://github.com/jitsi/jitsi/blob/4b124d7b8a79739686aac64450b2ba390217087e/src/net/java/sip/communicator/impl/protocol/sip/security/SipSecurityManager.java#L264

Regards
damencho

On Mon, Nov 16, 2015 at 4:59 PM, Flávio Pereira <flavio@uc.pt<mailto:flavio@uc.pt>> wrote:
Hi,
I have been waiting for them to fix that for at least two years.. I don't believe they will ever fix it. As far as I can tell sometimes the keep alive negotiating doesn't go as expected (it's UDP for God sake) and instead of retrying it clears the password. Try using the maximum value allowed (3600) that improved things a bit.
Good luck,

Flávio Pereira
Assistente Técnico

Universidade de Coimbra • Administração
Divisão de Infra-estruturas de Tecnologias de Informação e Comunicação
Rua Arco da Traição | 3000-056 • Coimbra • Portugal
Tel: +351 239 242 870<tel:%2B351%20239%20242%20870> | Tlm. 965 913 049
E-mail: flavio@uc.pt<mailto:flavio@uc.pt>

www.uc.pt <http://www.uc.pt>

[logos UC & Património Mundial]

Este e-mail pretende ser amigo do ambiente. Pondere antes de o imprimir! A Universidade de Coimbra dá preferência a produtos e serviços com menor impacto ambiental. This e-mail is environment friendly. Please think twice before printing it! The University of Coimbra prefers products and services with reduced environmental impact

On Tue, Nov 3, 2015 at 2:51 AM, Luc Deschenaux <luc.deschenaux.mta@sunrise.ch<mailto:luc.deschenaux.mta@sunrise.ch>> wrote:
Hi !

It's all in the title.

On some not well defined situations, Jitsi cannot connect and ask my SIP
passwords again.

(maybe when laptop resuming from sleep, VPN is down/restarting or when
the internet connection is bad (packet losses))

The weird thing is that when I press "Cancel" to get rid of the login
dialogs, the saved password have already been cleared.

Pretty annoying, I need to change all my passwords each time it's
occuring because they are unique and I never use them so I never
remember them (if not the SIP password itself, the web platform password
where I can retrieve the SIP password...)

Beside this Jitsi is great :slight_smile:

Thanks in advance !

Luc

PS: Actually using Jitsi 2.8.5426 on Debian 8

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

I forgot to add my thoughts for a possible solution.
Jitsi should NEVER decide for itself if my password is wrong. It should keep trying to reconnect every 30 seconds until it succeeds, or I tell it to stop.
My son’s password hasn’t changed in years, yet Jitsi says it is wrong at least twice a day.

Don’t take it on yourself to second guess the network. That’s not Jitsi’s job.

···

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: Saturday, December 05, 2015 9:36 AM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Hi,

The password is cleared only after two consecutive authorization challenges, which are considered as wrong password, there is no standard way to detect wrong password. I have seen this problem with asterisk and havn't seen why it perform this way.
Increasing the keep-alive checks interval actually removes the keep-alive and with some standart nats, like linux one, if you do not send a packet for 30 secs you can miss calls as it will destroy your mapping.
If you make a dump in such a situation and see why this happen you are more than welcome to comment and maybe offer a patch that we will accept. Any contributions are welcome.

Here the password is cleared:
https://github.com/jitsi/jitsi/blob/4b124d7b8a79739686aac64450b2ba390217087e/src/net/java/sip/communicator/impl/protocol/sip/security/SipSecurityManager.java#L264

Regards
damencho

On Mon, Nov 16, 2015 at 4:59 PM, Flávio Pereira <flavio@uc.pt<mailto:flavio@uc.pt>> wrote:
Hi,
I have been waiting for them to fix that for at least two years.. I don't believe they will ever fix it. As far as I can tell sometimes the keep alive negotiating doesn't go as expected (it's UDP for God sake) and instead of retrying it clears the password. Try using the maximum value allowed (3600) that improved things a bit.
Good luck,

Flávio Pereira
Assistente Técnico

Universidade de Coimbra • Administração
Divisão de Infra-estruturas de Tecnologias de Informação e Comunicação
Rua Arco da Traição | 3000-056 • Coimbra • Portugal
Tel: +351 239 242 870<tel:%2B351%20239%20242%20870> | Tlm. 965 913 049
E-mail: flavio@uc.pt<mailto:flavio@uc.pt>

www.uc.pt <http://www.uc.pt>

[logos UC & Património Mundial]

Este e-mail pretende ser amigo do ambiente. Pondere antes de o imprimir! A Universidade de Coimbra dá preferência a produtos e serviços com menor impacto ambiental. This e-mail is environment friendly. Please think twice before printing it! The University of Coimbra prefers products and services with reduced environmental impact

On Tue, Nov 3, 2015 at 2:51 AM, Luc Deschenaux <luc.deschenaux.mta@sunrise.ch<mailto:luc.deschenaux.mta@sunrise.ch>> wrote:
Hi !

It's all in the title.

On some not well defined situations, Jitsi cannot connect and ask my SIP
passwords again.

(maybe when laptop resuming from sleep, VPN is down/restarting or when
the internet connection is bad (packet losses))

The weird thing is that when I press "Cancel" to get rid of the login
dialogs, the saved password have already been cleared.

Pretty annoying, I need to change all my passwords each time it's
occuring because they are unique and I never use them so I never
remember them (if not the SIP password itself, the web platform password
where I can retrieve the SIP password...)

Beside this Jitsi is great :slight_smile:

Thanks in advance !

Luc

PS: Actually using Jitsi 2.8.5426 on Debian 8

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

Hi,

When this happens check the pcap in the logs, what packets had been
exchanged are there any consecutive authorization challenges comming from
the server. This is an issue I have seen very rarely, but maybe it is more
common when vpn connection is in the picture. This needs more observation
and debugging. Does anything changes if you use TCP for your sip connection?
Then what is your proposal to detect wrong passwords?

Regards
damencho

···

On Sat, Dec 5, 2015 at 9:59 AM, Phil Tull <phil@aquilatech.com> wrote:

I forgot to add my thoughts for a possible solution.

Jitsi should NEVER decide for itself if my password is wrong. It should
keep trying to reconnect every 30 seconds until it succeeds, or I tell it
to stop.

My son’s password hasn’t changed in years, yet Jitsi says it is wrong at
least twice a day.

Don’t take it on yourself to second guess the network. That’s not Jitsi’s
job.

*From:* users [mailto:users-bounces@jitsi.org] *On Behalf Of *Damian
Minkov
*Sent:* Saturday, December 05, 2015 9:36 AM
*To:* Jitsi Users <users@jitsi.org>
*Subject:* Re: [jitsi-users] Jitsi sip communicator: SIP passwords
cleared after unsuccessful connection attempt.

Hi,

The password is cleared only after two consecutive authorization
challenges, which are considered as wrong password, there is no standard
way to detect wrong password. I have seen this problem with asterisk and
havn't seen why it perform this way.

Increasing the keep-alive checks interval actually removes the keep-alive
and with some standart nats, like linux one, if you do not send a packet
for 30 secs you can miss calls as it will destroy your mapping.

If you make a dump in such a situation and see why this happen you are
more than welcome to comment and maybe offer a patch that we will accept.
Any contributions are welcome.

Here the password is cleared:

https://github.com/jitsi/jitsi/blob/4b124d7b8a79739686aac64450b2ba390217087e/src/net/java/sip/communicator/impl/protocol/sip/security/SipSecurityManager.java#L264

Regards

damencho

On Mon, Nov 16, 2015 at 4:59 PM, Flávio Pereira <flavio@uc.pt> wrote:

Hi,

I have been waiting for them to fix that for at least two years.. I don't
believe they will ever fix it. As far as I can tell sometimes the keep
alive negotiating doesn't go as expected (it's UDP for God sake) and
instead of retrying it clears the password. Try using the maximum value
allowed (3600) that improved things a bit.

Good luck,

Flávio Pereira
Assistente Técnico

Universidade de Coimbra • Administração
Divisão de Infra-estruturas de Tecnologias de Informação e Comunicação
Rua Arco da Traição | 3000-056 • Coimbra • Portugal
Tel: +351 239 242 870 | Tlm. 965 913 049
E-mail: flavio@uc.pt

www.uc.pt

[image: logos UC & Património Mundial]

Este e-mail pretende ser amigo do ambiente. Pondere antes de o imprimir! A
Universidade de Coimbra dá preferência a produtos e serviços com menor
impacto ambiental. This e-mail is environment friendly. Please think twice
before printing it! The University of Coimbra prefers products and services
with reduced environmental impact

On Tue, Nov 3, 2015 at 2:51 AM, Luc Deschenaux < > luc.deschenaux.mta@sunrise.ch> wrote:

Hi !

It's all in the title.

On some not well defined situations, Jitsi cannot connect and ask my SIP
passwords again.

(maybe when laptop resuming from sleep, VPN is down/restarting or when
the internet connection is bad (packet losses))

The weird thing is that when I press "Cancel" to get rid of the login
dialogs, the saved password have already been cleared.

Pretty annoying, I need to change all my passwords each time it's
occuring because they are unique and I never use them so I never
remember them (if not the SIP password itself, the web platform password
where I can retrieve the SIP password...)

Beside this Jitsi is great :slight_smile:

Thanks in advance !

Luc

PS: Actually using Jitsi 2.8.5426 on Debian 8

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

When this happens, the laptops are not even getting to the server. The firewall authentication agent hasn’t even logged on yet.
At least I think that’s what happening.

In 30 seconds or so, the agent connects to the firewall and traffic starts to flow to the network.
But by then, Jitsi has wrongly decided the password is wrong and deletes the account credentials.

Result = frustrated users.

···

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: Saturday, December 05, 2015 2:54 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Hi,

When this happens check the pcap in the logs, what packets had been exchanged are there any consecutive authorization challenges comming from the server. This is an issue I have seen very rarely, but maybe it is more common when vpn connection is in the picture. This needs more observation and debugging. Does anything changes if you use TCP for your sip connection?
Then what is your proposal to detect wrong passwords?

Regards
damencho

On Sat, Dec 5, 2015 at 9:59 AM, Phil Tull <phil@aquilatech.com<mailto:phil@aquilatech.com>> wrote:
I forgot to add my thoughts for a possible solution.
Jitsi should NEVER decide for itself if my password is wrong. It should keep trying to reconnect every 30 seconds until it succeeds, or I tell it to stop.
My son’s password hasn’t changed in years, yet Jitsi says it is wrong at least twice a day.

Don’t take it on yourself to second guess the network. That’s not Jitsi’s job.

From: users [mailto:users-bounces@jitsi.org<mailto:users-bounces@jitsi.org>] On Behalf Of Damian Minkov
Sent: Saturday, December 05, 2015 9:36 AM
To: Jitsi Users <users@jitsi.org<mailto:users@jitsi.org>>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Hi,

The password is cleared only after two consecutive authorization challenges, which are considered as wrong password, there is no standard way to detect wrong password. I have seen this problem with asterisk and havn't seen why it perform this way.
Increasing the keep-alive checks interval actually removes the keep-alive and with some standart nats, like linux one, if you do not send a packet for 30 secs you can miss calls as it will destroy your mapping.
If you make a dump in such a situation and see why this happen you are more than welcome to comment and maybe offer a patch that we will accept. Any contributions are welcome.

Here the password is cleared:
https://github.com/jitsi/jitsi/blob/4b124d7b8a79739686aac64450b2ba390217087e/src/net/java/sip/communicator/impl/protocol/sip/security/SipSecurityManager.java#L264

Regards
damencho

On Mon, Nov 16, 2015 at 4:59 PM, Flávio Pereira <flavio@uc.pt<mailto:flavio@uc.pt>> wrote:
Hi,
I have been waiting for them to fix that for at least two years.. I don't believe they will ever fix it. As far as I can tell sometimes the keep alive negotiating doesn't go as expected (it's UDP for God sake) and instead of retrying it clears the password. Try using the maximum value allowed (3600) that improved things a bit.
Good luck,

Flávio Pereira
Assistente Técnico

Universidade de Coimbra • Administração
Divisão de Infra-estruturas de Tecnologias de Informação e Comunicação
Rua Arco da Traição | 3000-056 • Coimbra • Portugal
Tel: +351 239 242 870<tel:%2B351%20239%20242%20870> | Tlm. 965 913 049
E-mail: flavio@uc.pt<mailto:flavio@uc.pt>

www.uc.pt <http://www.uc.pt>
[logos UC & Património Mundial]

Este e-mail pretende ser amigo do ambiente. Pondere antes de o imprimir! A Universidade de Coimbra dá preferência a produtos e serviços com menor impacto ambiental. This e-mail is environment friendly. Please think twice before printing it! The University of Coimbra prefers products and services with reduced environmental impact

On Tue, Nov 3, 2015 at 2:51 AM, Luc Deschenaux <luc.deschenaux.mta@sunrise.ch<mailto:luc.deschenaux.mta@sunrise.ch>> wrote:
Hi !

It's all in the title.

On some not well defined situations, Jitsi cannot connect and ask my SIP
passwords again.

(maybe when laptop resuming from sleep, VPN is down/restarting or when
the internet connection is bad (packet losses))

The weird thing is that when I press "Cancel" to get rid of the login
dialogs, the saved password have already been cleared.

Pretty annoying, I need to change all my passwords each time it's
occuring because they are unique and I never use them so I never
remember them (if not the SIP password itself, the web platform password
where I can retrieve the SIP password...)

Beside this Jitsi is great :slight_smile:

Thanks in advance !

Luc

PS: Actually using Jitsi 2.8.5426 on Debian 8

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

And if the password is really wrong? If we continue trying to register it will likely just block your account or IP.

We had the same problem with Asterisk at work, but I haven't seen it in a year now. Version 11.11 or so seems to have fixed it.

My analysis was that Asterisk wrongly responded with a 40x error despite a correct response to its challenge. I guess Jitsi's keep-alive and the re-register mixed up an internal state in Asterisk.

The network problem with the delay coming up isn't a problem with us either, my machine sometimes takes a few minutes after standby due to the Intel nic stuff that does VLANs. No password prompt either.

But despite all this, I agree that we shouldn't delete the password, but present the dialog with the pw still there. It's up to the user then to enter a new one if necessary.

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

···

Le 05.12.2015 à 17:02, Phil Tull <phil@aquilatech.com> a écrit :

I forgot to add my thoughts for a possible solution.
Jitsi should NEVER decide for itself if my password is wrong. It should keep trying to reconnect every 30 seconds until it succeeds, or I tell it to stop.
My son’s password hasn’t changed in years, yet Jitsi says it is wrong at least twice a day.

Don’t take it on yourself to second guess the network. That’s not Jitsi’s job.

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: Saturday, December 05, 2015 9:36 AM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Hi,

The password is cleared only after two consecutive authorization challenges, which are considered as wrong password, there is no standard way to detect wrong password. I have seen this problem with asterisk and havn't seen why it perform this way.
Increasing the keep-alive checks interval actually removes the keep-alive and with some standart nats, like linux one, if you do not send a packet for 30 secs you can miss calls as it will destroy your mapping.
If you make a dump in such a situation and see why this happen you are more than welcome to comment and maybe offer a patch that we will accept. Any contributions are welcome.

Here the password is cleared:
https://github.com/jitsi/jitsi/blob/4b124d7b8a79739686aac64450b2ba390217087e/src/net/java/sip/communicator/impl/protocol/sip/security/SipSecurityManager.java#L264

Regards
damencho

On Mon, Nov 16, 2015 at 4:59 PM, Flávio Pereira <flavio@uc.pt> wrote:
Hi,

I have been waiting for them to fix that for at least two years.. I don't believe they will ever fix it. As far as I can tell sometimes the keep alive negotiating doesn't go as expected (it's UDP for God sake) and instead of retrying it clears the password. Try using the maximum value allowed (3600) that improved things a bit.

Good luck,

Flávio Pereira
Assistente Técnico

Universidade de Coimbra • Administração
Divisão de Infra-estruturas de Tecnologias de Informação e Comunicação
Rua Arco da Traição | 3000-056 • Coimbra • Portugal
Tel: +351 239 242 870 | Tlm. 965 913 049
E-mail: flavio@uc.pt

www.uc.pt

Este e-mail pretende ser amigo do ambiente. Pondere antes de o imprimir! A Universidade de Coimbra dá preferência a produtos e serviços com menor impacto ambiental. This e-mail is environment friendly. Please think twice before printing it! The University of Coimbra prefers products and services with reduced environmental impact

On Tue, Nov 3, 2015 at 2:51 AM, Luc Deschenaux <luc.deschenaux.mta@sunrise.ch> wrote:
Hi !

It's all in the title.

On some not well defined situations, Jitsi cannot connect and ask my SIP
passwords again.

(maybe when laptop resuming from sleep, VPN is down/restarting or when
the internet connection is bad (packet losses))

The weird thing is that when I press "Cancel" to get rid of the login
dialogs, the saved password have already been cleared.

Pretty annoying, I need to change all my passwords each time it's
occuring because they are unique and I never use them so I never
remember them (if not the SIP password itself, the web platform password
where I can retrieve the SIP password...)

Beside this Jitsi is great :slight_smile:

Thanks in advance !

Luc

PS: Actually using Jitsi 2.8.5426 on Debian 8

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#9

Hey there,

Just saw this and wanted to jump in so that there is no confusion.

This behavior was initially implemented so that Jitsi would delete the
password if, and only if, the server said it's not the right one. That
intention is still valid.

What seems to be wrong in your case is that, for some reason, Jitsi
confuses a network problem with an authentication error with the server. I
am not sure at what point this crept in but it is clearly a bug and should
be fixed. I think it's not a SIP only issue actually so it's probably in
the way we handle these events in the UI.

What we will not do is to have Jitsi endlessly retry in silence in the
presence of authentication errors. This is just as wrong and will cause
even more confusion as in case of a password that is actually wrong, users
will wait for their application to connect for ages without having any
feedback (as Ingo pointed out).

I do agree that deleting the stored password may be optimized though and
ideally we could prompt the user to re-authenticate while still preserving
the current password as a default. I can see this being useful in a few
scenarios (that are all marginal).

This isn't a 5 minute hack though and I am not aware of someone who would
take this task.

Emil

I forgot to add my thoughts for a possible solution.

Jitsi should NEVER decide for itself if my password is wrong. It should
keep trying to reconnect every 30 seconds until it succeeds, or I tell it
to stop.

My son’s password hasn’t changed in years, yet Jitsi says it is wrong at

···

On Sun, Dec 6, 2015 at 2:59 AM, Phil Tull <phil@aquilatech.com> wrote:

least twice a day.

Don’t take it on yourself to second guess the network. That’s not Jitsi’s
job.

*From:* users [mailto:users-bounces@jitsi.org] *On Behalf Of *Damian
Minkov
*Sent:* Saturday, December 05, 2015 9:36 AM
*To:* Jitsi Users <users@jitsi.org>
*Subject:* Re: [jitsi-users] Jitsi sip communicator: SIP passwords
cleared after unsuccessful connection attempt.

Hi,

The password is cleared only after two consecutive authorization
challenges, which are considered as wrong password, there is no standard
way to detect wrong password. I have seen this problem with asterisk and
havn't seen why it perform this way.

Increasing the keep-alive checks interval actually removes the keep-alive
and with some standart nats, like linux one, if you do not send a packet
for 30 secs you can miss calls as it will destroy your mapping.

If you make a dump in such a situation and see why this happen you are
more than welcome to comment and maybe offer a patch that we will accept.
Any contributions are welcome.

Here the password is cleared:

https://github.com/jitsi/jitsi/blob/4b124d7b8a79739686aac64450b2ba390217087e/src/net/java/sip/communicator/impl/protocol/sip/security/SipSecurityManager.java#L264

Regards

damencho

On Mon, Nov 16, 2015 at 4:59 PM, Flávio Pereira <flavio@uc.pt> wrote:

Hi,

I have been waiting for them to fix that for at least two years.. I don't
believe they will ever fix it. As far as I can tell sometimes the keep
alive negotiating doesn't go as expected (it's UDP for God sake) and
instead of retrying it clears the password. Try using the maximum value
allowed (3600) that improved things a bit.

Good luck,

Flávio Pereira
Assistente Técnico

Universidade de Coimbra • Administração
Divisão de Infra-estruturas de Tecnologias de Informação e Comunicação
Rua Arco da Traição | 3000-056 • Coimbra • Portugal
Tel: +351 239 242 870 | Tlm. 965 913 049
E-mail: flavio@uc.pt

www.uc.pt

[image: logos UC & Património Mundial]

Este e-mail pretende ser amigo do ambiente. Pondere antes de o imprimir! A
Universidade de Coimbra dá preferência a produtos e serviços com menor
impacto ambiental. This e-mail is environment friendly. Please think twice
before printing it! The University of Coimbra prefers products and services
with reduced environmental impact

On Tue, Nov 3, 2015 at 2:51 AM, Luc Deschenaux < > luc.deschenaux.mta@sunrise.ch> wrote:

Hi !

It's all in the title.

On some not well defined situations, Jitsi cannot connect and ask my SIP
passwords again.

(maybe when laptop resuming from sleep, VPN is down/restarting or when
the internet connection is bad (packet losses))

The weird thing is that when I press "Cancel" to get rid of the login
dialogs, the saved password have already been cleared.

Pretty annoying, I need to change all my passwords each time it's
occuring because they are unique and I never use them so I never
remember them (if not the SIP password itself, the web platform password
where I can retrieve the SIP password...)

Beside this Jitsi is great :slight_smile:

Thanks in advance !

Luc

PS: Actually using Jitsi 2.8.5426 on Debian 8

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
https://jitsi.org


#10

If it’s really wrong then it’s my fault for putting in the wrong password. I’ll fix it.
It’s my server, my domain, and my password.

Jitsi is the only application that does this or has this issue.
All other software just retries and reconnects when the network is back up.
This is NOT complicated.

···

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Saturday, December 05, 2015 2:57 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

And if the password is really wrong? If we continue trying to register it will likely just block your account or IP.

We had the same problem with Asterisk at work, but I haven't seen it in a year now. Version 11.11 or so seems to have fixed it.

My analysis was that Asterisk wrongly responded with a 40x error despite a correct response to its challenge. I guess Jitsi's keep-alive and the re-register mixed up an internal state in Asterisk.

The network problem with the delay coming up isn't a problem with us either, my machine sometimes takes a few minutes after standby due to the Intel nic stuff that does VLANs. No password prompt either.

But despite all this, I agree that we shouldn't delete the password, but present the dialog with the pw still there. It's up to the user then to enter a new one if necessary.
Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 05.12.2015 à 17:02, Phil Tull <phil@aquilatech.com<mailto:phil@aquilatech.com>> a écrit :
I forgot to add my thoughts for a possible solution.
Jitsi should NEVER decide for itself if my password is wrong. It should keep trying to reconnect every 30 seconds until it succeeds, or I tell it to stop.
My son’s password hasn’t changed in years, yet Jitsi says it is wrong at least twice a day.

Don’t take it on yourself to second guess the network. That’s not Jitsi’s job.

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: Saturday, December 05, 2015 9:36 AM
To: Jitsi Users <users@jitsi.org<mailto:users@jitsi.org>>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Hi,

The password is cleared only after two consecutive authorization challenges, which are considered as wrong password, there is no standard way to detect wrong password. I have seen this problem with asterisk and havn't seen why it perform this way.
Increasing the keep-alive checks interval actually removes the keep-alive and with some standart nats, like linux one, if you do not send a packet for 30 secs you can miss calls as it will destroy your mapping.
If you make a dump in such a situation and see why this happen you are more than welcome to comment and maybe offer a patch that we will accept. Any contributions are welcome.

Here the password is cleared:
https://github.com/jitsi/jitsi/blob/4b124d7b8a79739686aac64450b2ba390217087e/src/net/java/sip/communicator/impl/protocol/sip/security/SipSecurityManager.java#L264

Regards
damencho

On Mon, Nov 16, 2015 at 4:59 PM, Flávio Pereira <flavio@uc.pt<mailto:flavio@uc.pt>> wrote:
Hi,
I have been waiting for them to fix that for at least two years.. I don't believe they will ever fix it. As far as I can tell sometimes the keep alive negotiating doesn't go as expected (it's UDP for God sake) and instead of retrying it clears the password. Try using the maximum value allowed (3600) that improved things a bit.
Good luck,

Flávio Pereira
Assistente Técnico

Universidade de Coimbra • Administração
Divisão de Infra-estruturas de Tecnologias de Informação e Comunicação
Rua Arco da Traição | 3000-056 • Coimbra • Portugal
Tel: +351 239 242 870<tel:%2B351%20239%20242%20870> | Tlm. 965 913 049
E-mail: flavio@uc.pt<mailto:flavio@uc.pt>

www.uc.pt <http://www.uc.pt>

[logos UC & Património Mundial]

Este e-mail pretende ser amigo do ambiente. Pondere antes de o imprimir! A Universidade de Coimbra dá preferência a produtos e serviços com menor impacto ambiental. This e-mail is environment friendly. Please think twice before printing it! The University of Coimbra prefers products and services with reduced environmental impact

On Tue, Nov 3, 2015 at 2:51 AM, Luc Deschenaux <luc.deschenaux.mta@sunrise.ch<mailto:luc.deschenaux.mta@sunrise.ch>> wrote:
Hi !

It's all in the title.

On some not well defined situations, Jitsi cannot connect and ask my SIP
passwords again.

(maybe when laptop resuming from sleep, VPN is down/restarting or when
the internet connection is bad (packet losses))

The weird thing is that when I press "Cancel" to get rid of the login
dialogs, the saved password have already been cleared.

Pretty annoying, I need to change all my passwords each time it's
occuring because they are unique and I never use them so I never
remember them (if not the SIP password itself, the web platform password
where I can retrieve the SIP password...)

Beside this Jitsi is great :slight_smile:

Thanks in advance !

Luc

PS: Actually using Jitsi 2.8.5426 on Debian 8

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#11

Then open a pull request on GitHub. Jitsi is open source after all.

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

···

Le 05.12.2015 à 21:33, Phil Tull <phil@aquilatech.com> a écrit :

If it’s really wrong then it’s my fault for putting in the wrong password. I’ll fix it.
It’s my server, my domain, and my password.

Jitsi is the only application that does this or has this issue.
All other software just retries and reconnects when the network is back up.
This is NOT complicated.

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Saturday, December 05, 2015 2:57 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

And if the password is really wrong? If we continue trying to register it will likely just block your account or IP.

We had the same problem with Asterisk at work, but I haven't seen it in a year now. Version 11.11 or so seems to have fixed it.

My analysis was that Asterisk wrongly responded with a 40x error despite a correct response to its challenge. I guess Jitsi's keep-alive and the re-register mixed up an internal state in Asterisk.

The network problem with the delay coming up isn't a problem with us either, my machine sometimes takes a few minutes after standby due to the Intel nic stuff that does VLANs. No password prompt either.

But despite all this, I agree that we shouldn't delete the password, but present the dialog with the pw still there. It's up to the user then to enter a new one if necessary.

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 05.12.2015 à 17:02, Phil Tull <phil@aquilatech.com> a écrit :

I forgot to add my thoughts for a possible solution.
Jitsi should NEVER decide for itself if my password is wrong. It should keep trying to reconnect every 30 seconds until it succeeds, or I tell it to stop.
My son’s password hasn’t changed in years, yet Jitsi says it is wrong at least twice a day.

Don’t take it on yourself to second guess the network. That’s not Jitsi’s job.

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: Saturday, December 05, 2015 9:36 AM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Hi,

The password is cleared only after two consecutive authorization challenges, which are considered as wrong password, there is no standard way to detect wrong password. I have seen this problem with asterisk and havn't seen why it perform this way.
Increasing the keep-alive checks interval actually removes the keep-alive and with some standart nats, like linux one, if you do not send a packet for 30 secs you can miss calls as it will destroy your mapping.
If you make a dump in such a situation and see why this happen you are more than welcome to comment and maybe offer a patch that we will accept. Any contributions are welcome.

Here the password is cleared:
https://github.com/jitsi/jitsi/blob/4b124d7b8a79739686aac64450b2ba390217087e/src/net/java/sip/communicator/impl/protocol/sip/security/SipSecurityManager.java#L264

Regards
damencho

On Mon, Nov 16, 2015 at 4:59 PM, Flávio Pereira <flavio@uc.pt> wrote:
Hi,

I have been waiting for them to fix that for at least two years.. I don't believe they will ever fix it. As far as I can tell sometimes the keep alive negotiating doesn't go as expected (it's UDP for God sake) and instead of retrying it clears the password. Try using the maximum value allowed (3600) that improved things a bit.

Good luck,

Flávio Pereira
Assistente Técnico

Universidade de Coimbra • Administração
Divisão de Infra-estruturas de Tecnologias de Informação e Comunicação
Rua Arco da Traição | 3000-056 • Coimbra • Portugal
Tel: +351 239 242 870 | Tlm. 965 913 049
E-mail: flavio@uc.pt

www.uc.pt

Este e-mail pretende ser amigo do ambiente. Pondere antes de o imprimir! A Universidade de Coimbra dá preferência a produtos e serviços com menor impacto ambiental. This e-mail is environment friendly. Please think twice before printing it! The University of Coimbra prefers products and services with reduced environmental impact

On Tue, Nov 3, 2015 at 2:51 AM, Luc Deschenaux <luc.deschenaux.mta@sunrise.ch> wrote:
Hi !

It's all in the title.

On some not well defined situations, Jitsi cannot connect and ask my SIP
passwords again.

(maybe when laptop resuming from sleep, VPN is down/restarting or when
the internet connection is bad (packet losses))

The weird thing is that when I press "Cancel" to get rid of the login
dialogs, the saved password have already been cleared.

Pretty annoying, I need to change all my passwords each time it's
occuring because they are unique and I never use them so I never
remember them (if not the SIP password itself, the web platform password
where I can retrieve the SIP password...)

Beside this Jitsi is great :slight_smile:

Thanks in advance !

Luc

PS: Actually using Jitsi 2.8.5426 on Debian 8

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#12

Hi Emil, just to add, while I use SIP and XMPP, the users who are having this problem were only interested in XMPP.

···

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Emil Ivov
Sent: Tuesday, December 08, 2015 3:59 AM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Hey there,

Just saw this and wanted to jump in so that there is no confusion.

This behavior was initially implemented so that Jitsi would delete the password if, and only if, the server said it's not the right one. That intention is still valid.

What seems to be wrong in your case is that, for some reason, Jitsi confuses a network problem with an authentication error with the server. I am not sure at what point this crept in but it is clearly a bug and should be fixed. I think it's not a SIP only issue actually so it's probably in the way we handle these events in the UI.

What we will not do is to have Jitsi endlessly retry in silence in the presence of authentication errors. This is just as wrong and will cause even more confusion as in case of a password that is actually wrong, users will wait for their application to connect for ages without having any feedback (as Ingo pointed out).

I do agree that deleting the stored password may be optimized though and ideally we could prompt the user to re-authenticate while still preserving the current password as a default. I can see this being useful in a few scenarios (that are all marginal).

This isn't a 5 minute hack though and I am not aware of someone who would take this task.

Emil

On Sun, Dec 6, 2015 at 2:59 AM, Phil Tull <phil@aquilatech.com<mailto:phil@aquilatech.com>> wrote:
I forgot to add my thoughts for a possible solution.
Jitsi should NEVER decide for itself if my password is wrong. It should keep trying to reconnect every 30 seconds until it succeeds, or I tell it to stop.
My son’s password hasn’t changed in years, yet Jitsi says it is wrong at least twice a day.

Don’t take it on yourself to second guess the network. That’s not Jitsi’s job.

From: users [mailto:users-bounces@jitsi.org<mailto:users-bounces@jitsi.org>] On Behalf Of Damian Minkov
Sent: Saturday, December 05, 2015 9:36 AM
To: Jitsi Users <users@jitsi.org<mailto:users@jitsi.org>>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Hi,

The password is cleared only after two consecutive authorization challenges, which are considered as wrong password, there is no standard way to detect wrong password. I have seen this problem with asterisk and havn't seen why it perform this way.
Increasing the keep-alive checks interval actually removes the keep-alive and with some standart nats, like linux one, if you do not send a packet for 30 secs you can miss calls as it will destroy your mapping.
If you make a dump in such a situation and see why this happen you are more than welcome to comment and maybe offer a patch that we will accept. Any contributions are welcome.

Here the password is cleared:
https://github.com/jitsi/jitsi/blob/4b124d7b8a79739686aac64450b2ba390217087e/src/net/java/sip/communicator/impl/protocol/sip/security/SipSecurityManager.java#L264

Regards
damencho

On Mon, Nov 16, 2015 at 4:59 PM, Flávio Pereira <flavio@uc.pt<mailto:flavio@uc.pt>> wrote:
Hi,
I have been waiting for them to fix that for at least two years.. I don't believe they will ever fix it. As far as I can tell sometimes the keep alive negotiating doesn't go as expected (it's UDP for God sake) and instead of retrying it clears the password. Try using the maximum value allowed (3600) that improved things a bit.
Good luck,

Flávio Pereira
Assistente Técnico

Universidade de Coimbra • Administração
Divisão de Infra-estruturas de Tecnologias de Informação e Comunicação
Rua Arco da Traição | 3000-056 • Coimbra • Portugal
Tel: +351 239 242 870<tel:%2B351%20239%20242%20870> | Tlm. 965 913 049
E-mail: flavio@uc.pt<mailto:flavio@uc.pt>

www.uc.pt <http://www.uc.pt>
[logos UC & Património Mundial]

Este e-mail pretende ser amigo do ambiente. Pondere antes de o imprimir! A Universidade de Coimbra dá preferência a produtos e serviços com menor impacto ambiental. This e-mail is environment friendly. Please think twice before printing it! The University of Coimbra prefers products and services with reduced environmental impact

On Tue, Nov 3, 2015 at 2:51 AM, Luc Deschenaux <luc.deschenaux.mta@sunrise.ch<mailto:luc.deschenaux.mta@sunrise.ch>> wrote:
Hi !

It's all in the title.

On some not well defined situations, Jitsi cannot connect and ask my SIP
passwords again.

(maybe when laptop resuming from sleep, VPN is down/restarting or when
the internet connection is bad (packet losses))

The weird thing is that when I press "Cancel" to get rid of the login
dialogs, the saved password have already been cleared.

Pretty annoying, I need to change all my passwords each time it's
occuring because they are unique and I never use them so I never
remember them (if not the SIP password itself, the web platform password
where I can retrieve the SIP password...)

Beside this Jitsi is great :slight_smile:

Thanks in advance !

Luc

PS: Actually using Jitsi 2.8.5426 on Debian 8

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
https://jitsi.org


#13

Is there a doc that describes compiling the program under Windows?
I’m a C developer and I use Visual Studio.

So you build in Eclipse I am assuming?

···

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Saturday, December 05, 2015 3:59 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Then open a pull request on GitHub. Jitsi is open source after all.
Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 05.12.2015 à 21:33, Phil Tull <phil@aquilatech.com<mailto:phil@aquilatech.com>> a écrit :
If it’s really wrong then it’s my fault for putting in the wrong password. I’ll fix it.
It’s my server, my domain, and my password.

Jitsi is the only application that does this or has this issue.
All other software just retries and reconnects when the network is back up.
This is NOT complicated.

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Saturday, December 05, 2015 2:57 PM
To: Jitsi Users <users@jitsi.org<mailto:users@jitsi.org>>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

And if the password is really wrong? If we continue trying to register it will likely just block your account or IP.

We had the same problem with Asterisk at work, but I haven't seen it in a year now. Version 11.11 or so seems to have fixed it.

My analysis was that Asterisk wrongly responded with a 40x error despite a correct response to its challenge. I guess Jitsi's keep-alive and the re-register mixed up an internal state in Asterisk.

The network problem with the delay coming up isn't a problem with us either, my machine sometimes takes a few minutes after standby due to the Intel nic stuff that does VLANs. No password prompt either.

But despite all this, I agree that we shouldn't delete the password, but present the dialog with the pw still there. It's up to the user then to enter a new one if necessary.
Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 05.12.2015 à 17:02, Phil Tull <phil@aquilatech.com<mailto:phil@aquilatech.com>> a écrit :
I forgot to add my thoughts for a possible solution.
Jitsi should NEVER decide for itself if my password is wrong. It should keep trying to reconnect every 30 seconds until it succeeds, or I tell it to stop.
My son’s password hasn’t changed in years, yet Jitsi says it is wrong at least twice a day.

Don’t take it on yourself to second guess the network. That’s not Jitsi’s job.

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: Saturday, December 05, 2015 9:36 AM
To: Jitsi Users <users@jitsi.org<mailto:users@jitsi.org>>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Hi,

The password is cleared only after two consecutive authorization challenges, which are considered as wrong password, there is no standard way to detect wrong password. I have seen this problem with asterisk and havn't seen why it perform this way.
Increasing the keep-alive checks interval actually removes the keep-alive and with some standart nats, like linux one, if you do not send a packet for 30 secs you can miss calls as it will destroy your mapping.
If you make a dump in such a situation and see why this happen you are more than welcome to comment and maybe offer a patch that we will accept. Any contributions are welcome.

Here the password is cleared:
https://github.com/jitsi/jitsi/blob/4b124d7b8a79739686aac64450b2ba390217087e/src/net/java/sip/communicator/impl/protocol/sip/security/SipSecurityManager.java#L264

Regards
damencho

On Mon, Nov 16, 2015 at 4:59 PM, Flávio Pereira <flavio@uc.pt<mailto:flavio@uc.pt>> wrote:
Hi,
I have been waiting for them to fix that for at least two years.. I don't believe they will ever fix it. As far as I can tell sometimes the keep alive negotiating doesn't go as expected (it's UDP for God sake) and instead of retrying it clears the password. Try using the maximum value allowed (3600) that improved things a bit.
Good luck,

Flávio Pereira
Assistente Técnico

Universidade de Coimbra • Administração
Divisão de Infra-estruturas de Tecnologias de Informação e Comunicação
Rua Arco da Traição | 3000-056 • Coimbra • Portugal
Tel: +351 239 242 870<tel:%2B351%20239%20242%20870> | Tlm. 965 913 049
E-mail: flavio@uc.pt<mailto:flavio@uc.pt>

www.uc.pt <http://www.uc.pt>

[logos UC & Património Mundial]

Este e-mail pretende ser amigo do ambiente. Pondere antes de o imprimir! A Universidade de Coimbra dá preferência a produtos e serviços com menor impacto ambiental. This e-mail is environment friendly. Please think twice before printing it! The University of Coimbra prefers products and services with reduced environmental impact

On Tue, Nov 3, 2015 at 2:51 AM, Luc Deschenaux <luc.deschenaux.mta@sunrise.ch<mailto:luc.deschenaux.mta@sunrise.ch>> wrote:
Hi !

It's all in the title.

On some not well defined situations, Jitsi cannot connect and ask my SIP
passwords again.

(maybe when laptop resuming from sleep, VPN is down/restarting or when
the internet connection is bad (packet losses))

The weird thing is that when I press "Cancel" to get rid of the login
dialogs, the saved password have already been cleared.

Pretty annoying, I need to change all my passwords each time it's
occuring because they are unique and I never use them so I never
remember them (if not the SIP password itself, the web platform password
where I can retrieve the SIP password...)

Beside this Jitsi is great :slight_smile:

Thanks in advance !

Luc

PS: Actually using Jitsi 2.8.5426 on Debian 8

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#14

Yes, there's a detailed doc in the dev-section on our homepage.

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

···

Le 06.12.2015 à 01:06, Phil Tull <phil@aquilatech.com> a écrit :

Is there a doc that describes compiling the program under Windows?
I’m a C developer and I use Visual Studio.

So you build in Eclipse I am assuming?

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Saturday, December 05, 2015 3:59 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Then open a pull request on GitHub. Jitsi is open source after all.

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 05.12.2015 à 21:33, Phil Tull <phil@aquilatech.com> a écrit :

If it’s really wrong then it’s my fault for putting in the wrong password. I’ll fix it.
It’s my server, my domain, and my password.

Jitsi is the only application that does this or has this issue.
All other software just retries and reconnects when the network is back up.
This is NOT complicated.

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Saturday, December 05, 2015 2:57 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

And if the password is really wrong? If we continue trying to register it will likely just block your account or IP.

We had the same problem with Asterisk at work, but I haven't seen it in a year now. Version 11.11 or so seems to have fixed it.

My analysis was that Asterisk wrongly responded with a 40x error despite a correct response to its challenge. I guess Jitsi's keep-alive and the re-register mixed up an internal state in Asterisk.

The network problem with the delay coming up isn't a problem with us either, my machine sometimes takes a few minutes after standby due to the Intel nic stuff that does VLANs. No password prompt either.

But despite all this, I agree that we shouldn't delete the password, but present the dialog with the pw still there. It's up to the user then to enter a new one if necessary.

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 05.12.2015 à 17:02, Phil Tull <phil@aquilatech.com> a écrit :

I forgot to add my thoughts for a possible solution.
Jitsi should NEVER decide for itself if my password is wrong. It should keep trying to reconnect every 30 seconds until it succeeds, or I tell it to stop.
My son’s password hasn’t changed in years, yet Jitsi says it is wrong at least twice a day.

Don’t take it on yourself to second guess the network. That’s not Jitsi’s job.

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: Saturday, December 05, 2015 9:36 AM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Hi,

The password is cleared only after two consecutive authorization challenges, which are considered as wrong password, there is no standard way to detect wrong password. I have seen this problem with asterisk and havn't seen why it perform this way.
Increasing the keep-alive checks interval actually removes the keep-alive and with some standart nats, like linux one, if you do not send a packet for 30 secs you can miss calls as it will destroy your mapping.
If you make a dump in such a situation and see why this happen you are more than welcome to comment and maybe offer a patch that we will accept. Any contributions are welcome.

Here the password is cleared:
https://github.com/jitsi/jitsi/blob/4b124d7b8a79739686aac64450b2ba390217087e/src/net/java/sip/communicator/impl/protocol/sip/security/SipSecurityManager.java#L264

Regards
damencho

On Mon, Nov 16, 2015 at 4:59 PM, Flávio Pereira <flavio@uc.pt> wrote:
Hi,

I have been waiting for them to fix that for at least two years.. I don't believe they will ever fix it. As far as I can tell sometimes the keep alive negotiating doesn't go as expected (it's UDP for God sake) and instead of retrying it clears the password. Try using the maximum value allowed (3600) that improved things a bit.

Good luck,

Flávio Pereira
Assistente Técnico

Universidade de Coimbra • Administração
Divisão de Infra-estruturas de Tecnologias de Informação e Comunicação
Rua Arco da Traição | 3000-056 • Coimbra • Portugal
Tel: +351 239 242 870 | Tlm. 965 913 049
E-mail: flavio@uc.pt

www.uc.pt

Este e-mail pretende ser amigo do ambiente. Pondere antes de o imprimir! A Universidade de Coimbra dá preferência a produtos e serviços com menor impacto ambiental. This e-mail is environment friendly. Please think twice before printing it! The University of Coimbra prefers products and services with reduced environmental impact

On Tue, Nov 3, 2015 at 2:51 AM, Luc Deschenaux <luc.deschenaux.mta@sunrise.ch> wrote:
Hi !

It's all in the title.

On some not well defined situations, Jitsi cannot connect and ask my SIP
passwords again.

(maybe when laptop resuming from sleep, VPN is down/restarting or when
the internet connection is bad (packet losses))

The weird thing is that when I press "Cancel" to get rid of the login
dialogs, the saved password have already been cleared.

Pretty annoying, I need to change all my passwords each time it's
occuring because they are unique and I never use them so I never
remember them (if not the SIP password itself, the web platform password
where I can retrieve the SIP password...)

Beside this Jitsi is great :slight_smile:

Thanks in advance !

Luc

PS: Actually using Jitsi 2.8.5426 on Debian 8

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#15

Been at this for 12 hours now.

The best I’ve been able to get is this error on make.
warning: [options] bootstrap class path not set in conjunction with -source 1.7
Followed by
BUILD FAILED
C:\Projects\Eclipse\jitsi\build.xml:301: Error running javac.exe compiler

I have JDK 1.8 64 bit current version.
Any hints on how to compile?

···

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Saturday, December 05, 2015 3:59 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Then open a pull request on GitHub. Jitsi is open source after all.
Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 05.12.2015 à 21:33, Phil Tull <phil@aquilatech.com<mailto:phil@aquilatech.com>> a écrit :
If it’s really wrong then it’s my fault for putting in the wrong password. I’ll fix it.
It’s my server, my domain, and my password.

Jitsi is the only application that does this or has this issue.
All other software just retries and reconnects when the network is back up.
This is NOT complicated.

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Saturday, December 05, 2015 2:57 PM
To: Jitsi Users <users@jitsi.org<mailto:users@jitsi.org>>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

And if the password is really wrong? If we continue trying to register it will likely just block your account or IP.

We had the same problem with Asterisk at work, but I haven't seen it in a year now. Version 11.11 or so seems to have fixed it.

My analysis was that Asterisk wrongly responded with a 40x error despite a correct response to its challenge. I guess Jitsi's keep-alive and the re-register mixed up an internal state in Asterisk.

The network problem with the delay coming up isn't a problem with us either, my machine sometimes takes a few minutes after standby due to the Intel nic stuff that does VLANs. No password prompt either.

But despite all this, I agree that we shouldn't delete the password, but present the dialog with the pw still there. It's up to the user then to enter a new one if necessary.
Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 05.12.2015 à 17:02, Phil Tull <phil@aquilatech.com<mailto:phil@aquilatech.com>> a écrit :
I forgot to add my thoughts for a possible solution.
Jitsi should NEVER decide for itself if my password is wrong. It should keep trying to reconnect every 30 seconds until it succeeds, or I tell it to stop.
My son’s password hasn’t changed in years, yet Jitsi says it is wrong at least twice a day.

Don’t take it on yourself to second guess the network. That’s not Jitsi’s job.

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: Saturday, December 05, 2015 9:36 AM
To: Jitsi Users <users@jitsi.org<mailto:users@jitsi.org>>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Hi,

The password is cleared only after two consecutive authorization challenges, which are considered as wrong password, there is no standard way to detect wrong password. I have seen this problem with asterisk and havn't seen why it perform this way.
Increasing the keep-alive checks interval actually removes the keep-alive and with some standart nats, like linux one, if you do not send a packet for 30 secs you can miss calls as it will destroy your mapping.
If you make a dump in such a situation and see why this happen you are more than welcome to comment and maybe offer a patch that we will accept. Any contributions are welcome.

Here the password is cleared:
https://github.com/jitsi/jitsi/blob/4b124d7b8a79739686aac64450b2ba390217087e/src/net/java/sip/communicator/impl/protocol/sip/security/SipSecurityManager.java#L264

Regards
damencho

On Mon, Nov 16, 2015 at 4:59 PM, Flávio Pereira <flavio@uc.pt<mailto:flavio@uc.pt>> wrote:
Hi,
I have been waiting for them to fix that for at least two years.. I don't believe they will ever fix it. As far as I can tell sometimes the keep alive negotiating doesn't go as expected (it's UDP for God sake) and instead of retrying it clears the password. Try using the maximum value allowed (3600) that improved things a bit.
Good luck,

Flávio Pereira
Assistente Técnico

Universidade de Coimbra • Administração
Divisão de Infra-estruturas de Tecnologias de Informação e Comunicação
Rua Arco da Traição | 3000-056 • Coimbra • Portugal
Tel: +351 239 242 870<tel:%2B351%20239%20242%20870> | Tlm. 965 913 049
E-mail: flavio@uc.pt<mailto:flavio@uc.pt>

www.uc.pt <http://www.uc.pt>

[logos UC & Património Mundial]

Este e-mail pretende ser amigo do ambiente. Pondere antes de o imprimir! A Universidade de Coimbra dá preferência a produtos e serviços com menor impacto ambiental. This e-mail is environment friendly. Please think twice before printing it! The University of Coimbra prefers products and services with reduced environmental impact

On Tue, Nov 3, 2015 at 2:51 AM, Luc Deschenaux <luc.deschenaux.mta@sunrise.ch<mailto:luc.deschenaux.mta@sunrise.ch>> wrote:
Hi !

It's all in the title.

On some not well defined situations, Jitsi cannot connect and ask my SIP
passwords again.

(maybe when laptop resuming from sleep, VPN is down/restarting or when
the internet connection is bad (packet losses))

The weird thing is that when I press "Cancel" to get rid of the login
dialogs, the saved password have already been cleared.

Pretty annoying, I need to change all my passwords each time it's
occuring because they are unique and I never use them so I never
remember them (if not the SIP password itself, the web platform password
where I can retrieve the SIP password...)

Beside this Jitsi is great :slight_smile:

Thanks in advance !

Luc

PS: Actually using Jitsi 2.8.5426 on Debian 8

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#16

Is that from within Eclipse or from a normal cmd-prompt?

The 1.7 warning is harmless.

Anyway, you probably need to add the jdk\bin directory to your PATH env-variable. Setting JDK_HOME wouldn't hurt either. Remember to restart cmd/Eclipse after changes to env-variables.

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

···

Le 07.12.2015 à 00:54, Phil Tull <phil@aquilatech.com> a écrit :

Been at this for 12 hours now.

The best I’ve been able to get is this error on make.
warning: [options] bootstrap class path not set in conjunction with -source 1.7
Followed by
BUILD FAILED
C:\Projects\Eclipse\jitsi\build.xml:301: Error running javac.exe compiler

I have JDK 1.8 64 bit current version.
Any hints on how to compile?

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Saturday, December 05, 2015 3:59 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Then open a pull request on GitHub. Jitsi is open source after all.

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 05.12.2015 à 21:33, Phil Tull <phil@aquilatech.com> a écrit :

If it’s really wrong then it’s my fault for putting in the wrong password. I’ll fix it.
It’s my server, my domain, and my password.

Jitsi is the only application that does this or has this issue.
All other software just retries and reconnects when the network is back up.
This is NOT complicated.

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Saturday, December 05, 2015 2:57 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

And if the password is really wrong? If we continue trying to register it will likely just block your account or IP.

We had the same problem with Asterisk at work, but I haven't seen it in a year now. Version 11.11 or so seems to have fixed it.

My analysis was that Asterisk wrongly responded with a 40x error despite a correct response to its challenge. I guess Jitsi's keep-alive and the re-register mixed up an internal state in Asterisk.

The network problem with the delay coming up isn't a problem with us either, my machine sometimes takes a few minutes after standby due to the Intel nic stuff that does VLANs. No password prompt either.

But despite all this, I agree that we shouldn't delete the password, but present the dialog with the pw still there. It's up to the user then to enter a new one if necessary.

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 05.12.2015 à 17:02, Phil Tull <phil@aquilatech.com> a écrit :

I forgot to add my thoughts for a possible solution.
Jitsi should NEVER decide for itself if my password is wrong. It should keep trying to reconnect every 30 seconds until it succeeds, or I tell it to stop.
My son’s password hasn’t changed in years, yet Jitsi says it is wrong at least twice a day.

Don’t take it on yourself to second guess the network. That’s not Jitsi’s job.

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: Saturday, December 05, 2015 9:36 AM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Hi,

The password is cleared only after two consecutive authorization challenges, which are considered as wrong password, there is no standard way to detect wrong password. I have seen this problem with asterisk and havn't seen why it perform this way.
Increasing the keep-alive checks interval actually removes the keep-alive and with some standart nats, like linux one, if you do not send a packet for 30 secs you can miss calls as it will destroy your mapping.
If you make a dump in such a situation and see why this happen you are more than welcome to comment and maybe offer a patch that we will accept. Any contributions are welcome.

Here the password is cleared:
https://github.com/jitsi/jitsi/blob/4b124d7b8a79739686aac64450b2ba390217087e/src/net/java/sip/communicator/impl/protocol/sip/security/SipSecurityManager.java#L264

Regards
damencho

On Mon, Nov 16, 2015 at 4:59 PM, Flávio Pereira <flavio@uc.pt> wrote:
Hi,

I have been waiting for them to fix that for at least two years.. I don't believe they will ever fix it. As far as I can tell sometimes the keep alive negotiating doesn't go as expected (it's UDP for God sake) and instead of retrying it clears the password. Try using the maximum value allowed (3600) that improved things a bit.

Good luck,

Flávio Pereira
Assistente Técnico

Universidade de Coimbra • Administração
Divisão de Infra-estruturas de Tecnologias de Informação e Comunicação
Rua Arco da Traição | 3000-056 • Coimbra • Portugal
Tel: +351 239 242 870 | Tlm. 965 913 049
E-mail: flavio@uc.pt

www.uc.pt

Este e-mail pretende ser amigo do ambiente. Pondere antes de o imprimir! A Universidade de Coimbra dá preferência a produtos e serviços com menor impacto ambiental. This e-mail is environment friendly. Please think twice before printing it! The University of Coimbra prefers products and services with reduced environmental impact

On Tue, Nov 3, 2015 at 2:51 AM, Luc Deschenaux <luc.deschenaux.mta@sunrise.ch> wrote:
Hi !

It's all in the title.

On some not well defined situations, Jitsi cannot connect and ask my SIP
passwords again.

(maybe when laptop resuming from sleep, VPN is down/restarting or when
the internet connection is bad (packet losses))

The weird thing is that when I press "Cancel" to get rid of the login
dialogs, the saved password have already been cleared.

Pretty annoying, I need to change all my passwords each time it's
occuring because they are unique and I never use them so I never
remember them (if not the SIP password itself, the web platform password
where I can retrieve the SIP password...)

Beside this Jitsi is great :slight_smile:

Thanks in advance !

Luc

PS: Actually using Jitsi 2.8.5426 on Debian 8

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#17

OK, I have compiled now, I think.
Next I click on Run -> Debug and get this in the console.
But nothing seems to happen.

How do I get the application to startup and test?

Buildfile: C:\Projects\Eclipse\jitsi\build.xml
clean-bundle-repositories:
init:
-pre-version:
version:
    [javac] Compiling 3 source files to C:\Projects\Eclipse\jitsi\classes
    [javac] warning: [options] bootstrap class path not set in conjunction with -source 1.7
    [javac] 1 warning
     [echo] Jitsi version 2.9.0.build.by.SVN
-pre-googlecontacts-none:
     [copy] Copying 1 file to C:\Projects\Eclipse\jitsi\src\net\java\sip\communicator\impl\googlecontacts
-pre-googlecontacts:
compile:
    [javac] Compiling 2 source files to C:\Projects\Eclipse\jitsi\classes
    [javac] warning: [options] bootstrap class path not set in conjunction with -source 1.7
    [javac] 1 warning
resource:
native2ascii:
bundle-sc-launcher:
load-properties:
bundle-util:
      [jar] Building jar: C:\Projects\Eclipse\jitsi\sc-bundles\util.jar
bundle-service-dns:
bundle-impl-dns:
bundle-dns-config:
bundle-splash-screen:
bundle-configuration:
bundle-configuration-slick:
bundle-history:
bundle-history-slick:
bundle-messagehistory:
bundle-msghistory-slick:
bundle-callhistory:
bundle-callhistory-slick:
bundle-popupmessagehandler-slick:
bundle-netaddr-dynamically:
bundle-netaddr-statically:
bundle-netaddr:
bundle-netaddr-slick:
bundle-slickless:
bundle-slick-runner:
bundle-sip:
      [jar] Building jar: C:\Projects\Eclipse\jitsi\sc-bundles\protocol-sip.jar
      [jar] gov/nist/core/CommonLogger.class already added, skipping
      [jar] gov/nist/core/CommonLoggerLog4j.class already added, skipping
      [jar] gov/nist/core/Debug.class already added, skipping
      [jar] gov/nist/core/DuplicateNameValueList.class already added, skipping
      [jar] gov/nist/core/GenericObject.class already added, skipping
      [jar] gov/nist/core/GenericObjectList.class already added, skipping
      [jar] gov/nist/core/Host.class already added, skipping
      [jar] gov/nist/core/HostNameParser.class already added, skipping
      [jar] gov/nist/core/HostPort.class already added, skipping
      [jar] gov/nist/core/InternalErrorHandler.class already added, skipping
      [jar] gov/nist/core/LexerCore.class already added, skipping
      [jar] gov/nist/core/LogLevels.class already added, skipping
      [jar] gov/nist/core/LogWriter.class already added, skipping
      [jar] gov/nist/core/Match.class already added, skipping
      [jar] gov/nist/core/MultiMap.class already added, skipping
      [jar] gov/nist/core/MultiValueMap.class already added, skipping
      [jar] gov/nist/core/MultiValueMapImpl.class already added, skipping
      [jar] gov/nist/core/NameValue.class already added, skipping
      [jar] gov/nist/core/NameValueList.class already added, skipping
      [jar] gov/nist/core/PackageNames.class already added, skipping
      [jar] gov/nist/core/ParserCore.class already added, skipping
      [jar] gov/nist/core/Separators.class already added, skipping
      [jar] gov/nist/core/ServerLogger.class already added, skipping
      [jar] gov/nist/core/StackLogger.class already added, skipping
      [jar] gov/nist/core/StringTokenizer.class already added, skipping
      [jar] gov/nist/core/ThreadAuditor$ThreadHandle.class already added, skipping
      [jar] gov/nist/core/ThreadAuditor.class already added, skipping
      [jar] gov/nist/core/Token.class already added, skipping
      [jar] gov/nist/core/net/AddressResolver.class already added, skipping
      [jar] gov/nist/core/net/DefaultNetworkLayer.class already added, skipping
      [jar] gov/nist/core/net/NetworkLayer.class already added, skipping
      [jar] gov/nist/core/net/SslNetworkLayer.class already added, skipping
      [jar] gov/nist/javax/sdp/parser/Lexer.class already added, skipping
bundle-sip-slick:
bundle-fileaccess:
bundle-fileaccess-slick:
bundle-neomedia:
bundle-ldap:
bundle-googlecontacts-service:
bundle-httputil:
bundle-browserlauncher:
bundle-googlecontacts:
      [jar] Building jar: C:\Projects\Eclipse\jitsi\sc-bundles\googlecontacts.jar
bundle-hid-service:
bundle-hid:
bundle-resource-manager:
bundle-resources-skinpack:
bundle-resources-defaultpack:
bundle-protocol:
bundle-protocol-media:
bundle-icq:
bundle-icq-slick:
bundle-mock:
bundle-smacklib:
bundle-jmdnslib:
bundle-jabber:
bundle-jabber-slick:
bundle-commons-lang:
bundle-swing-ui:
bundle-ui-service:
bundle-jnalib:
bundle-phonenumbers:
bundle-slf4j:
bundle-irc-api:
bundle-irc:
bundle-irc-commands:
bundle-plugin-ircaccregwizz:
bundle-yahoo:
bundle-yahoo-slick:
bundle-contactlist:
meta-contactlist:
meta-contactlist-slick:
bundle-plugin-icqaccregwizz:
bundle-plugin-jabberaccregwizz:
bundle-plugin-sipaccregwizz:
bundle-plugin-yahooaccregwizz:
bundle-plugin-aimaccregwizz:
bundle-commons-codec:
bundle-plugin-spellcheck:
bundle-version-impl:
      [jar] Building jar: C:\Projects\Eclipse\jitsi\sc-bundles\version-impl.jar
bundle-shutdown-timeout:
bundle-windows-clean-shutdown:
bundle-growlnotification:
bundle-swingnotification:
bundle-galagonotification:
bundle-sparkle:
bundle-plugin-branding:
bundle-sysactivitynotifications-dynamically:
bundle-sysactivitynotifications-statically:
bundle-sysactivitynotifications:
bundle-osdependent:
bundle-systray-service:
bundle-pluginmanager:
bundle-skinmanager:
bundle-notification-service:
bundle-notification-handlers:
bundle-notification-wiring:
bundle-notification-config:
bundle-contacteventhandler:
bundle-plugin-blf:
bundle-plugin-contactinfo:
bundle-plugin-chatalerter:
bundle-keybindings:
bundle-plugin-keybindingChooser:
bundle-plugin-globalproxyconfig:
bundle-jfontchooserlib:
bundle-update:
bundle-plugin-update:
bundle-plugin-simpleaccreg:
bundle-plugin-generalconfig:
bundle-plugin-googletalkaccregwizz:
bundle-argdelegation-service:
bundle-argdelegation:
bundle-zrtp4j:
bundle-sdes4j:
bundle-json:
bundle-filehistory:
bundle-metahistory:
bundle-metahistory-slick:
bundle-plugin-facebookaccregwizz:
bundle-plugin-ippiaccregwizz:
bundle-bouncycastle:
bundle-plugin-otr:
bundle-plugin-iptelaccregwizz:
bundle-contactsource:
bundle-plugin-reconnect:
bundle-plugin-securityconfig:
bundle-plugin-advancedconfig:
bundle-credentialsstorage:
bundle-credentialsstorage-slick:
bundle-plugin-nimbuzzavatar:
bundle-custom-avatar:
bundle-replacement:
bundle-youtube:
bundle-dailymotion:
bundle-smiley:
bundle-vimeo:
bundle-vbox7:
bundle-metacafe:
bundle-flickr:
bundle-hulu:
bundle-twitpic:
bundle-directimage:
bundle-bliptv:
bundle-viddler:
bundle-plugin-chatconfig:
bundle-certificate:
bundle-packetlogging:
bundle-plugin-loggingutils:
bundle-provdisc:
bundle-provdisc-dhcp:
bundle-provdisc-mdns:
bundle-provisioning:
bundle-addrbook:
bundle-plugin-ldap:
bundle-thunderbird:
bundle-plugin-contactsourceconfig:
bundle-plugin-certconfig:
bundle-globalshortcut:
bundle-plugin-msofficecomm:
bundle-libjitsi:
bundle-customcontactactions:
bundle-phonenumbercontactsource:
bundle-demuxcontactsource:
bundle-muc:
bundle-desktoputil:
bundle-globaldisplaydetails:
bundle-usersearch:
bundle-plugin-propertieseditor:
bundle-plugin-accountinfo:
bundle-plugin-connectioninfo:
bundle-guava:
bundle-hsql:
bundles:
package:
make:
deploy-os-specific-bundles:
make-and-deploy:
BUILD SUCCESSFUL
Total time: 6 seconds

···

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Sunday, December 06, 2015 5:39 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Is that from within Eclipse or from a normal cmd-prompt?

The 1.7 warning is harmless.

Anyway, you probably need to add the jdk\bin directory to your PATH env-variable. Setting JDK_HOME wouldn't hurt either. Remember to restart cmd/Eclipse after changes to env-variables.
Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 07.12.2015 à 00:54, Phil Tull <phil@aquilatech.com<mailto:phil@aquilatech.com>> a écrit :
Been at this for 12 hours now.

The best I’ve been able to get is this error on make.
warning: [options] bootstrap class path not set in conjunction with -source 1.7
Followed by
BUILD FAILED
C:\Projects\Eclipse\jitsi\build.xml:301: Error running javac.exe compiler

I have JDK 1.8 64 bit current version.
Any hints on how to compile?

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Saturday, December 05, 2015 3:59 PM
To: Jitsi Users <users@jitsi.org<mailto:users@jitsi.org>>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Then open a pull request on GitHub. Jitsi is open source after all.
Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 05.12.2015 à 21:33, Phil Tull <phil@aquilatech.com<mailto:phil@aquilatech.com>> a écrit :
If it’s really wrong then it’s my fault for putting in the wrong password. I’ll fix it.
It’s my server, my domain, and my password.

Jitsi is the only application that does this or has this issue.
All other software just retries and reconnects when the network is back up.
This is NOT complicated.

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Saturday, December 05, 2015 2:57 PM
To: Jitsi Users <users@jitsi.org<mailto:users@jitsi.org>>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

And if the password is really wrong? If we continue trying to register it will likely just block your account or IP.

We had the same problem with Asterisk at work, but I haven't seen it in a year now. Version 11.11 or so seems to have fixed it.

My analysis was that Asterisk wrongly responded with a 40x error despite a correct response to its challenge. I guess Jitsi's keep-alive and the re-register mixed up an internal state in Asterisk.

The network problem with the delay coming up isn't a problem with us either, my machine sometimes takes a few minutes after standby due to the Intel nic stuff that does VLANs. No password prompt either.

But despite all this, I agree that we shouldn't delete the password, but present the dialog with the pw still there. It's up to the user then to enter a new one if necessary.
Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 05.12.2015 à 17:02, Phil Tull <phil@aquilatech.com<mailto:phil@aquilatech.com>> a écrit :
I forgot to add my thoughts for a possible solution.
Jitsi should NEVER decide for itself if my password is wrong. It should keep trying to reconnect every 30 seconds until it succeeds, or I tell it to stop.
My son’s password hasn’t changed in years, yet Jitsi says it is wrong at least twice a day.

Don’t take it on yourself to second guess the network. That’s not Jitsi’s job.

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: Saturday, December 05, 2015 9:36 AM
To: Jitsi Users <users@jitsi.org<mailto:users@jitsi.org>>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Hi,

The password is cleared only after two consecutive authorization challenges, which are considered as wrong password, there is no standard way to detect wrong password. I have seen this problem with asterisk and havn't seen why it perform this way.
Increasing the keep-alive checks interval actually removes the keep-alive and with some standart nats, like linux one, if you do not send a packet for 30 secs you can miss calls as it will destroy your mapping.
If you make a dump in such a situation and see why this happen you are more than welcome to comment and maybe offer a patch that we will accept. Any contributions are welcome.

Here the password is cleared:
https://github.com/jitsi/jitsi/blob/4b124d7b8a79739686aac64450b2ba390217087e/src/net/java/sip/communicator/impl/protocol/sip/security/SipSecurityManager.java#L264

Regards
damencho

On Mon, Nov 16, 2015 at 4:59 PM, Flávio Pereira <flavio@uc.pt<mailto:flavio@uc.pt>> wrote:
Hi,
I have been waiting for them to fix that for at least two years.. I don't believe they will ever fix it. As far as I can tell sometimes the keep alive negotiating doesn't go as expected (it's UDP for God sake) and instead of retrying it clears the password. Try using the maximum value allowed (3600) that improved things a bit.
Good luck,

Flávio Pereira
Assistente Técnico

Universidade de Coimbra • Administração
Divisão de Infra-estruturas de Tecnologias de Informação e Comunicação
Rua Arco da Traição | 3000-056 • Coimbra • Portugal
Tel: +351 239 242 870<tel:%2B351%20239%20242%20870> | Tlm. 965 913 049
E-mail: flavio@uc.pt<mailto:flavio@uc.pt>

www.uc.pt <http://www.uc.pt>

[logos UC & Património Mundial]

Este e-mail pretende ser amigo do ambiente. Pondere antes de o imprimir! A Universidade de Coimbra dá preferência a produtos e serviços com menor impacto ambiental. This e-mail is environment friendly. Please think twice before printing it! The University of Coimbra prefers products and services with reduced environmental impact

On Tue, Nov 3, 2015 at 2:51 AM, Luc Deschenaux <luc.deschenaux.mta@sunrise.ch<mailto:luc.deschenaux.mta@sunrise.ch>> wrote:
Hi !

It's all in the title.

On some not well defined situations, Jitsi cannot connect and ask my SIP
passwords again.

(maybe when laptop resuming from sleep, VPN is down/restarting or when
the internet connection is bad (packet losses))

The weird thing is that when I press "Cancel" to get rid of the login
dialogs, the saved password have already been cleared.

Pretty annoying, I need to change all my passwords each time it's
occuring because they are unique and I never use them so I never
remember them (if not the SIP password itself, the web platform password
where I can retrieve the SIP password...)

Beside this Jitsi is great :slight_smile:

Thanks in advance !

Luc

PS: Actually using Jitsi 2.8.5426 on Debian 8

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#18

You debugged the ant build. Read the doc again, it explains how to create a run configuration.

Freundliche Grüsse,
Ingo Bauersachs

-- Sent from my tablet

···

On 06.12.2015, at 23:59, Phil Tull <phil@aquilatech.com> wrote:

OK, I have compiled now, I think.
Next I click on Run -> Debug and get this in the console.
But nothing seems to happen.

How do I get the application to startup and test?

Buildfile: C:\Projects\Eclipse\jitsi\build.xml
clean-bundle-repositories:
init:
-pre-version:
version:
    [javac] Compiling 3 source files to C:\Projects\Eclipse\jitsi\classes
    [javac] warning: [options] bootstrap class path not set in conjunction with -source 1.7
    [javac] 1 warning
     [echo] Jitsi version 2.9.0.build.by.SVN
-pre-googlecontacts-none:
     [copy] Copying 1 file to C:\Projects\Eclipse\jitsi\src\net\java\sip\communicator\impl\googlecontacts
-pre-googlecontacts:
compile:
    [javac] Compiling 2 source files to C:\Projects\Eclipse\jitsi\classes
    [javac] warning: [options] bootstrap class path not set in conjunction with -source 1.7
    [javac] 1 warning
resource:
native2ascii:
bundle-sc-launcher:
load-properties:
bundle-util:
      [jar] Building jar: C:\Projects\Eclipse\jitsi\sc-bundles\util.jar
bundle-service-dns:
bundle-impl-dns:
bundle-dns-config:
bundle-splash-screen:
bundle-configuration:
bundle-configuration-slick:
bundle-history:
bundle-history-slick:
bundle-messagehistory:
bundle-msghistory-slick:
bundle-callhistory:
bundle-callhistory-slick:
bundle-popupmessagehandler-slick:
bundle-netaddr-dynamically:
bundle-netaddr-statically:
bundle-netaddr:
bundle-netaddr-slick:
bundle-slickless:
bundle-slick-runner:
bundle-sip:
      [jar] Building jar: C:\Projects\Eclipse\jitsi\sc-bundles\protocol-sip.jar
      [jar] gov/nist/core/CommonLogger.class already added, skipping
      [jar] gov/nist/core/CommonLoggerLog4j.class already added, skipping
      [jar] gov/nist/core/Debug.class already added, skipping
      [jar] gov/nist/core/DuplicateNameValueList.class already added, skipping
      [jar] gov/nist/core/GenericObject.class already added, skipping
      [jar] gov/nist/core/GenericObjectList.class already added, skipping
      [jar] gov/nist/core/Host.class already added, skipping
      [jar] gov/nist/core/HostNameParser.class already added, skipping
      [jar] gov/nist/core/HostPort.class already added, skipping
      [jar] gov/nist/core/InternalErrorHandler.class already added, skipping
      [jar] gov/nist/core/LexerCore.class already added, skipping
      [jar] gov/nist/core/LogLevels.class already added, skipping
      [jar] gov/nist/core/LogWriter.class already added, skipping
      [jar] gov/nist/core/Match.class already added, skipping
      [jar] gov/nist/core/MultiMap.class already added, skipping
      [jar] gov/nist/core/MultiValueMap.class already added, skipping
      [jar] gov/nist/core/MultiValueMapImpl.class already added, skipping
      [jar] gov/nist/core/NameValue.class already added, skipping
      [jar] gov/nist/core/NameValueList.class already added, skipping
      [jar] gov/nist/core/PackageNames.class already added, skipping
      [jar] gov/nist/core/ParserCore.class already added, skipping
      [jar] gov/nist/core/Separators.class already added, skipping
      [jar] gov/nist/core/ServerLogger.class already added, skipping
      [jar] gov/nist/core/StackLogger.class already added, skipping
      [jar] gov/nist/core/StringTokenizer.class already added, skipping
      [jar] gov/nist/core/ThreadAuditor$ThreadHandle.class already added, skipping
      [jar] gov/nist/core/ThreadAuditor.class already added, skipping
      [jar] gov/nist/core/Token.class already added, skipping
      [jar] gov/nist/core/net/AddressResolver.class already added, skipping
      [jar] gov/nist/core/net/DefaultNetworkLayer.class already added, skipping
      [jar] gov/nist/core/net/NetworkLayer.class already added, skipping
      [jar] gov/nist/core/net/SslNetworkLayer.class already added, skipping
      [jar] gov/nist/javax/sdp/parser/Lexer.class already added, skipping
bundle-sip-slick:
bundle-fileaccess:
bundle-fileaccess-slick:
bundle-neomedia:
bundle-ldap:
bundle-googlecontacts-service:
bundle-httputil:
bundle-browserlauncher:
bundle-googlecontacts:
      [jar] Building jar: C:\Projects\Eclipse\jitsi\sc-bundles\googlecontacts.jar
bundle-hid-service:
bundle-hid:
bundle-resource-manager:
bundle-resources-skinpack:
bundle-resources-defaultpack:
bundle-protocol:
bundle-protocol-media:
bundle-icq:
bundle-icq-slick:
bundle-mock:
bundle-smacklib:
bundle-jmdnslib:
bundle-jabber:
bundle-jabber-slick:
bundle-commons-lang:
bundle-swing-ui:
bundle-ui-service:
bundle-jnalib:
bundle-phonenumbers:
bundle-slf4j:
bundle-irc-api:
bundle-irc:
bundle-irc-commands:
bundle-plugin-ircaccregwizz:
bundle-yahoo:
bundle-yahoo-slick:
bundle-contactlist:
meta-contactlist:
meta-contactlist-slick:
bundle-plugin-icqaccregwizz:
bundle-plugin-jabberaccregwizz:
bundle-plugin-sipaccregwizz:
bundle-plugin-yahooaccregwizz:
bundle-plugin-aimaccregwizz:
bundle-commons-codec:
bundle-plugin-spellcheck:
bundle-version-impl:
      [jar] Building jar: C:\Projects\Eclipse\jitsi\sc-bundles\version-impl.jar
bundle-shutdown-timeout:
bundle-windows-clean-shutdown:
bundle-growlnotification:
bundle-swingnotification:
bundle-galagonotification:
bundle-sparkle:
bundle-plugin-branding:
bundle-sysactivitynotifications-dynamically:
bundle-sysactivitynotifications-statically:
bundle-sysactivitynotifications:
bundle-osdependent:
bundle-systray-service:
bundle-pluginmanager:
bundle-skinmanager:
bundle-notification-service:
bundle-notification-handlers:
bundle-notification-wiring:
bundle-notification-config:
bundle-contacteventhandler:
bundle-plugin-blf:
bundle-plugin-contactinfo:
bundle-plugin-chatalerter:
bundle-keybindings:
bundle-plugin-keybindingChooser:
bundle-plugin-globalproxyconfig:
bundle-jfontchooserlib:
bundle-update:
bundle-plugin-update:
bundle-plugin-simpleaccreg:
bundle-plugin-generalconfig:
bundle-plugin-googletalkaccregwizz:
bundle-argdelegation-service:
bundle-argdelegation:
bundle-zrtp4j:
bundle-sdes4j:
bundle-json:
bundle-filehistory:
bundle-metahistory:
bundle-metahistory-slick:
bundle-plugin-facebookaccregwizz:
bundle-plugin-ippiaccregwizz:
bundle-bouncycastle:
bundle-plugin-otr:
bundle-plugin-iptelaccregwizz:
bundle-contactsource:
bundle-plugin-reconnect:
bundle-plugin-securityconfig:
bundle-plugin-advancedconfig:
bundle-credentialsstorage:
bundle-credentialsstorage-slick:
bundle-plugin-nimbuzzavatar:
bundle-custom-avatar:
bundle-replacement:
bundle-youtube:
bundle-dailymotion:
bundle-smiley:
bundle-vimeo:
bundle-vbox7:
bundle-metacafe:
bundle-flickr:
bundle-hulu:
bundle-twitpic:
bundle-directimage:
bundle-bliptv:
bundle-viddler:
bundle-plugin-chatconfig:
bundle-certificate:
bundle-packetlogging:
bundle-plugin-loggingutils:
bundle-provdisc:
bundle-provdisc-dhcp:
bundle-provdisc-mdns:
bundle-provisioning:
bundle-addrbook:
bundle-plugin-ldap:
bundle-thunderbird:
bundle-plugin-contactsourceconfig:
bundle-plugin-certconfig:
bundle-globalshortcut:
bundle-plugin-msofficecomm:
bundle-libjitsi:
bundle-customcontactactions:
bundle-phonenumbercontactsource:
bundle-demuxcontactsource:
bundle-muc:
bundle-desktoputil:
bundle-globaldisplaydetails:
bundle-usersearch:
bundle-plugin-propertieseditor:
bundle-plugin-accountinfo:
bundle-plugin-connectioninfo:
bundle-guava:
bundle-hsql:
bundles:
package:
make:
deploy-os-specific-bundles:
make-and-deploy:
BUILD SUCCESSFUL
Total time: 6 seconds

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Sunday, December 06, 2015 5:39 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Is that from within Eclipse or from a normal cmd-prompt?

The 1.7 warning is harmless.

Anyway, you probably need to add the jdk\bin directory to your PATH env-variable. Setting JDK_HOME wouldn't hurt either. Remember to restart cmd/Eclipse after changes to env-variables.

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 07.12.2015 à 00:54, Phil Tull <phil@aquilatech.com> a écrit :

Been at this for 12 hours now.

The best I’ve been able to get is this error on make.
warning: [options] bootstrap class path not set in conjunction with -source 1.7
Followed by
BUILD FAILED
C:\Projects\Eclipse\jitsi\build.xml:301: Error running javac.exe compiler

I have JDK 1.8 64 bit current version.
Any hints on how to compile?

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Saturday, December 05, 2015 3:59 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Then open a pull request on GitHub. Jitsi is open source after all.

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 05.12.2015 à 21:33, Phil Tull <phil@aquilatech.com> a écrit :

If it’s really wrong then it’s my fault for putting in the wrong password. I’ll fix it.
It’s my server, my domain, and my password.

Jitsi is the only application that does this or has this issue.
All other software just retries and reconnects when the network is back up.
This is NOT complicated.

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Saturday, December 05, 2015 2:57 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

And if the password is really wrong? If we continue trying to register it will likely just block your account or IP.

We had the same problem with Asterisk at work, but I haven't seen it in a year now. Version 11.11 or so seems to have fixed it.

My analysis was that Asterisk wrongly responded with a 40x error despite a correct response to its challenge. I guess Jitsi's keep-alive and the re-register mixed up an internal state in Asterisk.

The network problem with the delay coming up isn't a problem with us either, my machine sometimes takes a few minutes after standby due to the Intel nic stuff that does VLANs. No password prompt either.

But despite all this, I agree that we shouldn't delete the password, but present the dialog with the pw still there. It's up to the user then to enter a new one if necessary.

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 05.12.2015 à 17:02, Phil Tull <phil@aquilatech.com> a écrit :

I forgot to add my thoughts for a possible solution.
Jitsi should NEVER decide for itself if my password is wrong. It should keep trying to reconnect every 30 seconds until it succeeds, or I tell it to stop.
My son’s password hasn’t changed in years, yet Jitsi says it is wrong at least twice a day.

Don’t take it on yourself to second guess the network. That’s not Jitsi’s job.

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: Saturday, December 05, 2015 9:36 AM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Hi,

The password is cleared only after two consecutive authorization challenges, which are considered as wrong password, there is no standard way to detect wrong password. I have seen this problem with asterisk and havn't seen why it perform this way.
Increasing the keep-alive checks interval actually removes the keep-alive and with some standart nats, like linux one, if you do not send a packet for 30 secs you can miss calls as it will destroy your mapping.
If you make a dump in such a situation and see why this happen you are more than welcome to comment and maybe offer a patch that we will accept. Any contributions are welcome.

Here the password is cleared:
https://github.com/jitsi/jitsi/blob/4b124d7b8a79739686aac64450b2ba390217087e/src/net/java/sip/communicator/impl/protocol/sip/security/SipSecurityManager.java#L264

Regards
damencho

On Mon, Nov 16, 2015 at 4:59 PM, Flávio Pereira <flavio@uc.pt> wrote:
Hi,

I have been waiting for them to fix that for at least two years.. I don't believe they will ever fix it. As far as I can tell sometimes the keep alive negotiating doesn't go as expected (it's UDP for God sake) and instead of retrying it clears the password. Try using the maximum value allowed (3600) that improved things a bit.

Good luck,

Flávio Pereira
Assistente Técnico

Universidade de Coimbra • Administração
Divisão de Infra-estruturas de Tecnologias de Informação e Comunicação
Rua Arco da Traição | 3000-056 • Coimbra • Portugal
Tel: +351 239 242 870 | Tlm. 965 913 049
E-mail: flavio@uc.pt

www.uc.pt

Este e-mail pretende ser amigo do ambiente. Pondere antes de o imprimir! A Universidade de Coimbra dá preferência a produtos e serviços com menor impacto ambiental. This e-mail is environment friendly. Please think twice before printing it! The University of Coimbra prefers products and services with reduced environmental impact

On Tue, Nov 3, 2015 at 2:51 AM, Luc Deschenaux <luc.deschenaux.mta@sunrise.ch> wrote:
Hi !

It's all in the title.

On some not well defined situations, Jitsi cannot connect and ask my SIP
passwords again.

(maybe when laptop resuming from sleep, VPN is down/restarting or when
the internet connection is bad (packet losses))

The weird thing is that when I press "Cancel" to get rid of the login
dialogs, the saved password have already been cleared.

Pretty annoying, I need to change all my passwords each time it's
occuring because they are unique and I never use them so I never
remember them (if not the SIP password itself, the web platform password
where I can retrieve the SIP password...)

Beside this Jitsi is great :slight_smile:

Thanks in advance !

Luc

PS: Actually using Jitsi 2.8.5426 on Debian 8

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#19

I don’t know which document you are referring to.
I have this: https://jitsi.org/Documentation/ConfigureEclipseNew

The last paragraph says to run the Ant target make-and-deploy, which I did.
Then “run” or “debug” with Eclipse, which I did.

I followed this page to the letter.

···

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Monday, December 07, 2015 1:55 AM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

You debugged the ant build. Read the doc again, it explains how to create a run configuration.
Freundliche Grüsse,
Ingo Bauersachs

-- Sent from my tablet

On 06.12.2015, at 23:59, Phil Tull <phil@aquilatech.com<mailto:phil@aquilatech.com>> wrote:
OK, I have compiled now, I think.
Next I click on Run -> Debug and get this in the console.
But nothing seems to happen.

How do I get the application to startup and test?

Buildfile: C:\Projects\Eclipse\jitsi\build.xml
clean-bundle-repositories:
init:
-pre-version:
version:
    [javac] Compiling 3 source files to C:\Projects\Eclipse\jitsi\classes
    [javac] warning: [options] bootstrap class path not set in conjunction with -source 1.7
    [javac] 1 warning
     [echo] Jitsi version 2.9.0.build.by.SVN
-pre-googlecontacts-none:
     [copy] Copying 1 file to C:\Projects\Eclipse\jitsi\src\net\java\sip\communicator\impl\googlecontacts
-pre-googlecontacts:
compile:
    [javac] Compiling 2 source files to C:\Projects\Eclipse\jitsi\classes
    [javac] warning: [options] bootstrap class path not set in conjunction with -source 1.7
    [javac] 1 warning
resource:
native2ascii:
bundle-sc-launcher:
load-properties:
bundle-util:
      [jar] Building jar: C:\Projects\Eclipse\jitsi\sc-bundles\util.jar
bundle-service-dns:
bundle-impl-dns:
bundle-dns-config:
bundle-splash-screen:
bundle-configuration:
bundle-configuration-slick:
bundle-history:
bundle-history-slick:
bundle-messagehistory:
bundle-msghistory-slick:
bundle-callhistory:
bundle-callhistory-slick:
bundle-popupmessagehandler-slick:
bundle-netaddr-dynamically:
bundle-netaddr-statically:
bundle-netaddr:
bundle-netaddr-slick:
bundle-slickless:
bundle-slick-runner:
bundle-sip:
      [jar] Building jar: C:\Projects\Eclipse\jitsi\sc-bundles\protocol-sip.jar
      [jar] gov/nist/core/CommonLogger.class already added, skipping
      [jar] gov/nist/core/CommonLoggerLog4j.class already added, skipping
      [jar] gov/nist/core/Debug.class already added, skipping
      [jar] gov/nist/core/DuplicateNameValueList.class already added, skipping
      [jar] gov/nist/core/GenericObject.class already added, skipping
      [jar] gov/nist/core/GenericObjectList.class already added, skipping
      [jar] gov/nist/core/Host.class already added, skipping
      [jar] gov/nist/core/HostNameParser.class already added, skipping
      [jar] gov/nist/core/HostPort.class already added, skipping
      [jar] gov/nist/core/InternalErrorHandler.class already added, skipping
      [jar] gov/nist/core/LexerCore.class already added, skipping
      [jar] gov/nist/core/LogLevels.class already added, skipping
      [jar] gov/nist/core/LogWriter.class already added, skipping
      [jar] gov/nist/core/Match.class already added, skipping
      [jar] gov/nist/core/MultiMap.class already added, skipping
      [jar] gov/nist/core/MultiValueMap.class already added, skipping
      [jar] gov/nist/core/MultiValueMapImpl.class already added, skipping
      [jar] gov/nist/core/NameValue.class already added, skipping
      [jar] gov/nist/core/NameValueList.class already added, skipping
      [jar] gov/nist/core/PackageNames.class already added, skipping
      [jar] gov/nist/core/ParserCore.class already added, skipping
      [jar] gov/nist/core/Separators.class already added, skipping
      [jar] gov/nist/core/ServerLogger.class already added, skipping
      [jar] gov/nist/core/StackLogger.class already added, skipping
      [jar] gov/nist/core/StringTokenizer.class already added, skipping
      [jar] gov/nist/core/ThreadAuditor$ThreadHandle.class already added, skipping
      [jar] gov/nist/core/ThreadAuditor.class already added, skipping
      [jar] gov/nist/core/Token.class already added, skipping
      [jar] gov/nist/core/net/AddressResolver.class already added, skipping
      [jar] gov/nist/core/net/DefaultNetworkLayer.class already added, skipping
      [jar] gov/nist/core/net/NetworkLayer.class already added, skipping
      [jar] gov/nist/core/net/SslNetworkLayer.class already added, skipping
      [jar] gov/nist/javax/sdp/parser/Lexer.class already added, skipping
bundle-sip-slick:
bundle-fileaccess:
bundle-fileaccess-slick:
bundle-neomedia:
bundle-ldap:
bundle-googlecontacts-service:
bundle-httputil:
bundle-browserlauncher:
bundle-googlecontacts:
      [jar] Building jar: C:\Projects\Eclipse\jitsi\sc-bundles\googlecontacts.jar
bundle-hid-service:
bundle-hid:
bundle-resource-manager:
bundle-resources-skinpack:
bundle-resources-defaultpack:
bundle-protocol:
bundle-protocol-media:
bundle-icq:
bundle-icq-slick:
bundle-mock:
bundle-smacklib:
bundle-jmdnslib:
bundle-jabber:
bundle-jabber-slick:
bundle-commons-lang:
bundle-swing-ui:
bundle-ui-service:
bundle-jnalib:
bundle-phonenumbers:
bundle-slf4j:
bundle-irc-api:
bundle-irc:
bundle-irc-commands:
bundle-plugin-ircaccregwizz:
bundle-yahoo:
bundle-yahoo-slick:
bundle-contactlist:
meta-contactlist:
meta-contactlist-slick:
bundle-plugin-icqaccregwizz:
bundle-plugin-jabberaccregwizz:
bundle-plugin-sipaccregwizz:
bundle-plugin-yahooaccregwizz:
bundle-plugin-aimaccregwizz:
bundle-commons-codec:
bundle-plugin-spellcheck:
bundle-version-impl:
      [jar] Building jar: C:\Projects\Eclipse\jitsi\sc-bundles\version-impl.jar
bundle-shutdown-timeout:
bundle-windows-clean-shutdown:
bundle-growlnotification:
bundle-swingnotification:
bundle-galagonotification:
bundle-sparkle:
bundle-plugin-branding:
bundle-sysactivitynotifications-dynamically:
bundle-sysactivitynotifications-statically:
bundle-sysactivitynotifications:
bundle-osdependent:
bundle-systray-service:
bundle-pluginmanager:
bundle-skinmanager:
bundle-notification-service:
bundle-notification-handlers:
bundle-notification-wiring:
bundle-notification-config:
bundle-contacteventhandler:
bundle-plugin-blf:
bundle-plugin-contactinfo:
bundle-plugin-chatalerter:
bundle-keybindings:
bundle-plugin-keybindingChooser:
bundle-plugin-globalproxyconfig:
bundle-jfontchooserlib:
bundle-update:
bundle-plugin-update:
bundle-plugin-simpleaccreg:
bundle-plugin-generalconfig:
bundle-plugin-googletalkaccregwizz:
bundle-argdelegation-service:
bundle-argdelegation:
bundle-zrtp4j:
bundle-sdes4j:
bundle-json:
bundle-filehistory:
bundle-metahistory:
bundle-metahistory-slick:
bundle-plugin-facebookaccregwizz:
bundle-plugin-ippiaccregwizz:
bundle-bouncycastle:
bundle-plugin-otr:
bundle-plugin-iptelaccregwizz:
bundle-contactsource:
bundle-plugin-reconnect:
bundle-plugin-securityconfig:
bundle-plugin-advancedconfig:
bundle-credentialsstorage:
bundle-credentialsstorage-slick:
bundle-plugin-nimbuzzavatar:
bundle-custom-avatar:
bundle-replacement:
bundle-youtube:
bundle-dailymotion:
bundle-smiley:
bundle-vimeo:
bundle-vbox7:
bundle-metacafe:
bundle-flickr:
bundle-hulu:
bundle-twitpic:
bundle-directimage:
bundle-bliptv:
bundle-viddler:
bundle-plugin-chatconfig:
bundle-certificate:
bundle-packetlogging:
bundle-plugin-loggingutils:
bundle-provdisc:
bundle-provdisc-dhcp:
bundle-provdisc-mdns:
bundle-provisioning:
bundle-addrbook:
bundle-plugin-ldap:
bundle-thunderbird:
bundle-plugin-contactsourceconfig:
bundle-plugin-certconfig:
bundle-globalshortcut:
bundle-plugin-msofficecomm:
bundle-libjitsi:
bundle-customcontactactions:
bundle-phonenumbercontactsource:
bundle-demuxcontactsource:
bundle-muc:
bundle-desktoputil:
bundle-globaldisplaydetails:
bundle-usersearch:
bundle-plugin-propertieseditor:
bundle-plugin-accountinfo:
bundle-plugin-connectioninfo:
bundle-guava:
bundle-hsql:
bundles:
package:
make:
deploy-os-specific-bundles:
make-and-deploy:
BUILD SUCCESSFUL
Total time: 6 seconds

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Sunday, December 06, 2015 5:39 PM
To: Jitsi Users <users@jitsi.org<mailto:users@jitsi.org>>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Is that from within Eclipse or from a normal cmd-prompt?

The 1.7 warning is harmless.

Anyway, you probably need to add the jdk\bin directory to your PATH env-variable. Setting JDK_HOME wouldn't hurt either. Remember to restart cmd/Eclipse after changes to env-variables.
Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 07.12.2015 à 00:54, Phil Tull <phil@aquilatech.com<mailto:phil@aquilatech.com>> a écrit :
Been at this for 12 hours now.

The best I’ve been able to get is this error on make.
warning: [options] bootstrap class path not set in conjunction with -source 1.7
Followed by
BUILD FAILED
C:\Projects\Eclipse\jitsi\build.xml:301: Error running javac.exe compiler

I have JDK 1.8 64 bit current version.
Any hints on how to compile?

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Saturday, December 05, 2015 3:59 PM
To: Jitsi Users <users@jitsi.org<mailto:users@jitsi.org>>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Then open a pull request on GitHub. Jitsi is open source after all.
Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 05.12.2015 à 21:33, Phil Tull <phil@aquilatech.com<mailto:phil@aquilatech.com>> a écrit :
If it’s really wrong then it’s my fault for putting in the wrong password. I’ll fix it.
It’s my server, my domain, and my password.

Jitsi is the only application that does this or has this issue.
All other software just retries and reconnects when the network is back up.
This is NOT complicated.

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Saturday, December 05, 2015 2:57 PM
To: Jitsi Users <users@jitsi.org<mailto:users@jitsi.org>>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

And if the password is really wrong? If we continue trying to register it will likely just block your account or IP.

We had the same problem with Asterisk at work, but I haven't seen it in a year now. Version 11.11 or so seems to have fixed it.

My analysis was that Asterisk wrongly responded with a 40x error despite a correct response to its challenge. I guess Jitsi's keep-alive and the re-register mixed up an internal state in Asterisk.

The network problem with the delay coming up isn't a problem with us either, my machine sometimes takes a few minutes after standby due to the Intel nic stuff that does VLANs. No password prompt either.

But despite all this, I agree that we shouldn't delete the password, but present the dialog with the pw still there. It's up to the user then to enter a new one if necessary.
Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 05.12.2015 à 17:02, Phil Tull <phil@aquilatech.com<mailto:phil@aquilatech.com>> a écrit :
I forgot to add my thoughts for a possible solution.
Jitsi should NEVER decide for itself if my password is wrong. It should keep trying to reconnect every 30 seconds until it succeeds, or I tell it to stop.
My son’s password hasn’t changed in years, yet Jitsi says it is wrong at least twice a day.

Don’t take it on yourself to second guess the network. That’s not Jitsi’s job.

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: Saturday, December 05, 2015 9:36 AM
To: Jitsi Users <users@jitsi.org<mailto:users@jitsi.org>>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Hi,

The password is cleared only after two consecutive authorization challenges, which are considered as wrong password, there is no standard way to detect wrong password. I have seen this problem with asterisk and havn't seen why it perform this way.
Increasing the keep-alive checks interval actually removes the keep-alive and with some standart nats, like linux one, if you do not send a packet for 30 secs you can miss calls as it will destroy your mapping.
If you make a dump in such a situation and see why this happen you are more than welcome to comment and maybe offer a patch that we will accept. Any contributions are welcome.

Here the password is cleared:
https://github.com/jitsi/jitsi/blob/4b124d7b8a79739686aac64450b2ba390217087e/src/net/java/sip/communicator/impl/protocol/sip/security/SipSecurityManager.java#L264

Regards
damencho

On Mon, Nov 16, 2015 at 4:59 PM, Flávio Pereira <flavio@uc.pt<mailto:flavio@uc.pt>> wrote:
Hi,
I have been waiting for them to fix that for at least two years.. I don't believe they will ever fix it. As far as I can tell sometimes the keep alive negotiating doesn't go as expected (it's UDP for God sake) and instead of retrying it clears the password. Try using the maximum value allowed (3600) that improved things a bit.
Good luck,

Flávio Pereira
Assistente Técnico

Universidade de Coimbra • Administração
Divisão de Infra-estruturas de Tecnologias de Informação e Comunicação
Rua Arco da Traição | 3000-056 • Coimbra • Portugal
Tel: +351 239 242 870<tel:%2B351%20239%20242%20870> | Tlm. 965 913 049
E-mail: flavio@uc.pt<mailto:flavio@uc.pt>

www.uc.pt <http://www.uc.pt>

[logos UC & Património Mundial]

Este e-mail pretende ser amigo do ambiente. Pondere antes de o imprimir! A Universidade de Coimbra dá preferência a produtos e serviços com menor impacto ambiental. This e-mail is environment friendly. Please think twice before printing it! The University of Coimbra prefers products and services with reduced environmental impact

On Tue, Nov 3, 2015 at 2:51 AM, Luc Deschenaux <luc.deschenaux.mta@sunrise.ch<mailto:luc.deschenaux.mta@sunrise.ch>> wrote:
Hi !

It's all in the title.

On some not well defined situations, Jitsi cannot connect and ask my SIP
passwords again.

(maybe when laptop resuming from sleep, VPN is down/restarting or when
the internet connection is bad (packet losses))

The weird thing is that when I press "Cancel" to get rid of the login
dialogs, the saved password have already been cleared.

Pretty annoying, I need to change all my passwords each time it's
occuring because they are unique and I never use them so I never
remember them (if not the SIP password itself, the web platform password
where I can retrieve the SIP password...)

Beside this Jitsi is great :slight_smile:

Thanks in advance !

Luc

PS: Actually using Jitsi 2.8.5426 on Debian 8

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org<mailto:users@jitsi.org>
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#20

The section titled 'CONFIGURE RUN AND DEBUG THROUGH ECLIPSE' (sorry for shouting, it's copy/paste)

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

···

Le 07.12.2015 à 17:06, Phil Tull <phil@aquilatech.com> a écrit :

I don’t know which document you are referring to.
I have this: https://jitsi.org/Documentation/ConfigureEclipseNew

The last paragraph says to run the Ant target make-and-deploy, which I did.
Then “run” or “debug” with Eclipse, which I did.

I followed this page to the letter.

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Monday, December 07, 2015 1:55 AM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

You debugged the ant build. Read the doc again, it explains how to create a run configuration.

Freundliche Grüsse,
Ingo Bauersachs

-- Sent from my tablet

On 06.12.2015, at 23:59, Phil Tull <phil@aquilatech.com> wrote:

OK, I have compiled now, I think.
Next I click on Run -> Debug and get this in the console.
But nothing seems to happen.

How do I get the application to startup and test?

Buildfile: C:\Projects\Eclipse\jitsi\build.xml
clean-bundle-repositories:
init:
-pre-version:
version:
    [javac] Compiling 3 source files to C:\Projects\Eclipse\jitsi\classes
    [javac] warning: [options] bootstrap class path not set in conjunction with -source 1.7
    [javac] 1 warning
     [echo] Jitsi version 2.9.0.build.by.SVN
-pre-googlecontacts-none:
     [copy] Copying 1 file to C:\Projects\Eclipse\jitsi\src\net\java\sip\communicator\impl\googlecontacts
-pre-googlecontacts:
compile:
    [javac] Compiling 2 source files to C:\Projects\Eclipse\jitsi\classes
    [javac] warning: [options] bootstrap class path not set in conjunction with -source 1.7
    [javac] 1 warning
resource:
native2ascii:
bundle-sc-launcher:
load-properties:
bundle-util:
      [jar] Building jar: C:\Projects\Eclipse\jitsi\sc-bundles\util.jar
bundle-service-dns:
bundle-impl-dns:
bundle-dns-config:
bundle-splash-screen:
bundle-configuration:
bundle-configuration-slick:
bundle-history:
bundle-history-slick:
bundle-messagehistory:
bundle-msghistory-slick:
bundle-callhistory:
bundle-callhistory-slick:
bundle-popupmessagehandler-slick:
bundle-netaddr-dynamically:
bundle-netaddr-statically:
bundle-netaddr:
bundle-netaddr-slick:
bundle-slickless:
bundle-slick-runner:
bundle-sip:
      [jar] Building jar: C:\Projects\Eclipse\jitsi\sc-bundles\protocol-sip.jar
      [jar] gov/nist/core/CommonLogger.class already added, skipping
      [jar] gov/nist/core/CommonLoggerLog4j.class already added, skipping
      [jar] gov/nist/core/Debug.class already added, skipping
      [jar] gov/nist/core/DuplicateNameValueList.class already added, skipping
      [jar] gov/nist/core/GenericObject.class already added, skipping
      [jar] gov/nist/core/GenericObjectList.class already added, skipping
      [jar] gov/nist/core/Host.class already added, skipping
      [jar] gov/nist/core/HostNameParser.class already added, skipping
      [jar] gov/nist/core/HostPort.class already added, skipping
      [jar] gov/nist/core/InternalErrorHandler.class already added, skipping
      [jar] gov/nist/core/LexerCore.class already added, skipping
      [jar] gov/nist/core/LogLevels.class already added, skipping
      [jar] gov/nist/core/LogWriter.class already added, skipping
      [jar] gov/nist/core/Match.class already added, skipping
      [jar] gov/nist/core/MultiMap.class already added, skipping
      [jar] gov/nist/core/MultiValueMap.class already added, skipping
      [jar] gov/nist/core/MultiValueMapImpl.class already added, skipping
      [jar] gov/nist/core/NameValue.class already added, skipping
      [jar] gov/nist/core/NameValueList.class already added, skipping
      [jar] gov/nist/core/PackageNames.class already added, skipping
      [jar] gov/nist/core/ParserCore.class already added, skipping
      [jar] gov/nist/core/Separators.class already added, skipping
      [jar] gov/nist/core/ServerLogger.class already added, skipping
      [jar] gov/nist/core/StackLogger.class already added, skipping
      [jar] gov/nist/core/StringTokenizer.class already added, skipping
      [jar] gov/nist/core/ThreadAuditor$ThreadHandle.class already added, skipping
      [jar] gov/nist/core/ThreadAuditor.class already added, skipping
      [jar] gov/nist/core/Token.class already added, skipping
      [jar] gov/nist/core/net/AddressResolver.class already added, skipping
      [jar] gov/nist/core/net/DefaultNetworkLayer.class already added, skipping
      [jar] gov/nist/core/net/NetworkLayer.class already added, skipping
      [jar] gov/nist/core/net/SslNetworkLayer.class already added, skipping
      [jar] gov/nist/javax/sdp/parser/Lexer.class already added, skipping
bundle-sip-slick:
bundle-fileaccess:
bundle-fileaccess-slick:
bundle-neomedia:
bundle-ldap:
bundle-googlecontacts-service:
bundle-httputil:
bundle-browserlauncher:
bundle-googlecontacts:
      [jar] Building jar: C:\Projects\Eclipse\jitsi\sc-bundles\googlecontacts.jar
bundle-hid-service:
bundle-hid:
bundle-resource-manager:
bundle-resources-skinpack:
bundle-resources-defaultpack:
bundle-protocol:
bundle-protocol-media:
bundle-icq:
bundle-icq-slick:
bundle-mock:
bundle-smacklib:
bundle-jmdnslib:
bundle-jabber:
bundle-jabber-slick:
bundle-commons-lang:
bundle-swing-ui:
bundle-ui-service:
bundle-jnalib:
bundle-phonenumbers:
bundle-slf4j:
bundle-irc-api:
bundle-irc:
bundle-irc-commands:
bundle-plugin-ircaccregwizz:
bundle-yahoo:
bundle-yahoo-slick:
bundle-contactlist:
meta-contactlist:
meta-contactlist-slick:
bundle-plugin-icqaccregwizz:
bundle-plugin-jabberaccregwizz:
bundle-plugin-sipaccregwizz:
bundle-plugin-yahooaccregwizz:
bundle-plugin-aimaccregwizz:
bundle-commons-codec:
bundle-plugin-spellcheck:
bundle-version-impl:
      [jar] Building jar: C:\Projects\Eclipse\jitsi\sc-bundles\version-impl.jar
bundle-shutdown-timeout:
bundle-windows-clean-shutdown:
bundle-growlnotification:
bundle-swingnotification:
bundle-galagonotification:
bundle-sparkle:
bundle-plugin-branding:
bundle-sysactivitynotifications-dynamically:
bundle-sysactivitynotifications-statically:
bundle-sysactivitynotifications:
bundle-osdependent:
bundle-systray-service:
bundle-pluginmanager:
bundle-skinmanager:
bundle-notification-service:
bundle-notification-handlers:
bundle-notification-wiring:
bundle-notification-config:
bundle-contacteventhandler:
bundle-plugin-blf:
bundle-plugin-contactinfo:
bundle-plugin-chatalerter:
bundle-keybindings:
bundle-plugin-keybindingChooser:
bundle-plugin-globalproxyconfig:
bundle-jfontchooserlib:
bundle-update:
bundle-plugin-update:
bundle-plugin-simpleaccreg:
bundle-plugin-generalconfig:
bundle-plugin-googletalkaccregwizz:
bundle-argdelegation-service:
bundle-argdelegation:
bundle-zrtp4j:
bundle-sdes4j:
bundle-json:
bundle-filehistory:
bundle-metahistory:
bundle-metahistory-slick:
bundle-plugin-facebookaccregwizz:
bundle-plugin-ippiaccregwizz:
bundle-bouncycastle:
bundle-plugin-otr:
bundle-plugin-iptelaccregwizz:
bundle-contactsource:
bundle-plugin-reconnect:
bundle-plugin-securityconfig:
bundle-plugin-advancedconfig:
bundle-credentialsstorage:
bundle-credentialsstorage-slick:
bundle-plugin-nimbuzzavatar:
bundle-custom-avatar:
bundle-replacement:
bundle-youtube:
bundle-dailymotion:
bundle-smiley:
bundle-vimeo:
bundle-vbox7:
bundle-metacafe:
bundle-flickr:
bundle-hulu:
bundle-twitpic:
bundle-directimage:
bundle-bliptv:
bundle-viddler:
bundle-plugin-chatconfig:
bundle-certificate:
bundle-packetlogging:
bundle-plugin-loggingutils:
bundle-provdisc:
bundle-provdisc-dhcp:
bundle-provdisc-mdns:
bundle-provisioning:
bundle-addrbook:
bundle-plugin-ldap:
bundle-thunderbird:
bundle-plugin-contactsourceconfig:
bundle-plugin-certconfig:
bundle-globalshortcut:
bundle-plugin-msofficecomm:
bundle-libjitsi:
bundle-customcontactactions:
bundle-phonenumbercontactsource:
bundle-demuxcontactsource:
bundle-muc:
bundle-desktoputil:
bundle-globaldisplaydetails:
bundle-usersearch:
bundle-plugin-propertieseditor:
bundle-plugin-accountinfo:
bundle-plugin-connectioninfo:
bundle-guava:
bundle-hsql:
bundles:
package:
make:
deploy-os-specific-bundles:
make-and-deploy:
BUILD SUCCESSFUL
Total time: 6 seconds

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Sunday, December 06, 2015 5:39 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Is that from within Eclipse or from a normal cmd-prompt?

The 1.7 warning is harmless.

Anyway, you probably need to add the jdk\bin directory to your PATH env-variable. Setting JDK_HOME wouldn't hurt either. Remember to restart cmd/Eclipse after changes to env-variables.

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 07.12.2015 à 00:54, Phil Tull <phil@aquilatech.com> a écrit :

Been at this for 12 hours now.

The best I’ve been able to get is this error on make.
warning: [options] bootstrap class path not set in conjunction with -source 1.7
Followed by
BUILD FAILED
C:\Projects\Eclipse\jitsi\build.xml:301: Error running javac.exe compiler

I have JDK 1.8 64 bit current version.
Any hints on how to compile?

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Saturday, December 05, 2015 3:59 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Then open a pull request on GitHub. Jitsi is open source after all.

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 05.12.2015 à 21:33, Phil Tull <phil@aquilatech.com> a écrit :

If it’s really wrong then it’s my fault for putting in the wrong password. I’ll fix it.
It’s my server, my domain, and my password.

Jitsi is the only application that does this or has this issue.
All other software just retries and reconnects when the network is back up.
This is NOT complicated.

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Ingo Bauersachs
Sent: Saturday, December 05, 2015 2:57 PM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

And if the password is really wrong? If we continue trying to register it will likely just block your account or IP.

We had the same problem with Asterisk at work, but I haven't seen it in a year now. Version 11.11 or so seems to have fixed it.

My analysis was that Asterisk wrongly responded with a 40x error despite a correct response to its challenge. I guess Jitsi's keep-alive and the re-register mixed up an internal state in Asterisk.

The network problem with the delay coming up isn't a problem with us either, my machine sometimes takes a few minutes after standby due to the Intel nic stuff that does VLANs. No password prompt either.

But despite all this, I agree that we shouldn't delete the password, but present the dialog with the pw still there. It's up to the user then to enter a new one if necessary.

Freundliche Grüsse,
Ingo Bauersachs

-- sent from my mobile

Le 05.12.2015 à 17:02, Phil Tull <phil@aquilatech.com> a écrit :

I forgot to add my thoughts for a possible solution.
Jitsi should NEVER decide for itself if my password is wrong. It should keep trying to reconnect every 30 seconds until it succeeds, or I tell it to stop.
My son’s password hasn’t changed in years, yet Jitsi says it is wrong at least twice a day.

Don’t take it on yourself to second guess the network. That’s not Jitsi’s job.

From: users [mailto:users-bounces@jitsi.org] On Behalf Of Damian Minkov
Sent: Saturday, December 05, 2015 9:36 AM
To: Jitsi Users <users@jitsi.org>
Subject: Re: [jitsi-users] Jitsi sip communicator: SIP passwords cleared after unsuccessful connection attempt.

Hi,

The password is cleared only after two consecutive authorization challenges, which are considered as wrong password, there is no standard way to detect wrong password. I have seen this problem with asterisk and havn't seen why it perform this way.
Increasing the keep-alive checks interval actually removes the keep-alive and with some standart nats, like linux one, if you do not send a packet for 30 secs you can miss calls as it will destroy your mapping.
If you make a dump in such a situation and see why this happen you are more than welcome to comment and maybe offer a patch that we will accept. Any contributions are welcome.

Here the password is cleared:
https://github.com/jitsi/jitsi/blob/4b124d7b8a79739686aac64450b2ba390217087e/src/net/java/sip/communicator/impl/protocol/sip/security/SipSecurityManager.java#L264

Regards
damencho

On Mon, Nov 16, 2015 at 4:59 PM, Flávio Pereira <flavio@uc.pt> wrote:
Hi,

I have been waiting for them to fix that for at least two years.. I don't believe they will ever fix it. As far as I can tell sometimes the keep alive negotiating doesn't go as expected (it's UDP for God sake) and instead of retrying it clears the password. Try using the maximum value allowed (3600) that improved things a bit.

Good luck,

Flávio Pereira
Assistente Técnico

Universidade de Coimbra • Administração
Divisão de Infra-estruturas de Tecnologias de Informação e Comunicação
Rua Arco da Traição | 3000-056 • Coimbra • Portugal
Tel: +351 239 242 870 | Tlm. 965 913 049
E-mail: flavio@uc.pt

www.uc.pt

Este e-mail pretende ser amigo do ambiente. Pondere antes de o imprimir! A Universidade de Coimbra dá preferência a produtos e serviços com menor impacto ambiental. This e-mail is environment friendly. Please think twice before printing it! The University of Coimbra prefers products and services with reduced environmental impact

On Tue, Nov 3, 2015 at 2:51 AM, Luc Deschenaux <luc.deschenaux.mta@sunrise.ch> wrote:
Hi !

It's all in the title.

On some not well defined situations, Jitsi cannot connect and ask my SIP
passwords again.

(maybe when laptop resuming from sleep, VPN is down/restarting or when
the internet connection is bad (packet losses))

The weird thing is that when I press "Cancel" to get rid of the login
dialogs, the saved password have already been cleared.

Pretty annoying, I need to change all my passwords each time it's
occuring because they are unique and I never use them so I never
remember them (if not the SIP password itself, the web platform password
where I can retrieve the SIP password...)

Beside this Jitsi is great :slight_smile:

Thanks in advance !

Luc

PS: Actually using Jitsi 2.8.5426 on Debian 8

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users