[jitsi-users] Jitsi showing contacts twice


#1

I've had this issue before but not recently, until tonight when it re-occured.

I added one of my Jitsi accounts (my own domain but hosted on gmail)
as a contact in Gibberbot earlier and now the Gibberbot contact
(gmail.com) is showing twice in Jitsi (both showing the contact as
online) but it may just be a co-incidence as another of my contacts in
Jitsi, not added to Gibberbot, is also showing twice and both as
offline. I can't say when exactly this started either, so it may have
been some time after I added the contact in Gibberbot.

I've tried closing Jitsi and restarting it but it still shows those
two contacts twice each.

I'm using 2.3.4656.9728 on Win7 x64.


#2

Hi Derek,

Just to be sure that these are really problematic contacts, could you please confirm that this isn't a contact which exists in two different rosters (for two different accounts)? I have such contacts and we don't automatically merge them in jitsi, but when you open a chat and you click at the protocol icon (on the left of the write area) you'll normally see a different account in the send via.

Other than that do you experience a strange behavior when clicking on those contacts or when trying to call them?

Thanks!
Yana

···

On Jun 10, 2013, at 2:18 AM, Derek Moss <dmts@stoptheviolence.co.uk> wrote:

I've had this issue before but not recently, until tonight when it re-occured.

I added one of my Jitsi accounts (my own domain but hosted on gmail)
as a contact in Gibberbot earlier and now the Gibberbot contact
(gmail.com) is showing twice in Jitsi (both showing the contact as
online) but it may just be a co-incidence as another of my contacts in
Jitsi, not added to Gibberbot, is also showing twice and both as
offline. I can't say when exactly this started either, so it may have
been some time after I added the contact in Gibberbot.

I've tried closing Jitsi and restarting it but it still shows those
two contacts twice each.

I'm using 2.3.4656.9728 on Win7 x64.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hey Derek,

Sending e-mails is certainly not part of the XMPP specification. The jit.si addresses DO NOT currently handle e-mail (there is an MX record but it just forwards to /dev/null). We may try to handle this in the future but we are not there yet.

And yes, you are right, this is not a Jitsi issue. It only concerns the Gibberbot and jit.si services.

Cheers,
Emil

···

On 10.06.13, 02:18, Derek Moss wrote:

I've had this issue before but not recently, until tonight when it re-occured.

I added one of my Jitsi accounts (my own domain but hosted on gmail)
as a contact in Gibberbot earlier and now the Gibberbot contact
(gmail.com) is showing twice in Jitsi (both showing the contact as
online) but it may just be a co-incidence as another of my contacts in
Jitsi, not added to Gibberbot, is also showing twice and both as
offline. I can't say when exactly this started either, so it may have
been some time after I added the contact in Gibberbot.

I've tried closing Jitsi and restarting it but it still shows those
two contacts twice each.

I'm using 2.3.4656.9728 on Win7 x64.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
.

--
https://jitsi.org


#4

I cold booted either last night or this morning and I have the
duplicate contacts showing again now.

···

On 12 June 2013 17:32, Emil Ivov <emcho@jitsi.org> wrote:

Hey Derek,

Sending e-mails is certainly not part of the XMPP specification. The jit.si
addresses DO NOT currently handle e-mail (there is an MX record but it just
forwards to /dev/null). We may try to handle this in the future but we are
not there yet.

And yes, you are right, this is not a Jitsi issue. It only concerns the
Gibberbot and jit.si services.

Cheers,
Emil

On 10.06.13, 02:18, Derek Moss wrote:

I've had this issue before but not recently, until tonight when it
re-occured.

I added one of my Jitsi accounts (my own domain but hosted on gmail)
as a contact in Gibberbot earlier and now the Gibberbot contact
(gmail.com) is showing twice in Jitsi (both showing the contact as
online) but it may just be a co-incidence as another of my contacts in
Jitsi, not added to Gibberbot, is also showing twice and both as
offline. I can't say when exactly this started either, so it may have
been some time after I added the contact in Gibberbot.

I've tried closing Jitsi and restarting it but it still shows those
two contacts twice each.

I'm using 2.3.4656.9728 on Win7 x64.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
.

--
https://jitsi.org


#5

Still showing the duplicates after updating to 4684.

···

On 13 June 2013 13:26, Derek Moss <dmts@stoptheviolence.co.uk> wrote:

I cold booted either last night or this morning and I have the
duplicate contacts showing again now.

On 12 June 2013 17:32, Emil Ivov <emcho@jitsi.org> wrote:

Hey Derek,

Sending e-mails is certainly not part of the XMPP specification. The jit.si
addresses DO NOT currently handle e-mail (there is an MX record but it just
forwards to /dev/null). We may try to handle this in the future but we are
not there yet.

And yes, you are right, this is not a Jitsi issue. It only concerns the
Gibberbot and jit.si services.

Cheers,
Emil

On 10.06.13, 02:18, Derek Moss wrote:

I've had this issue before but not recently, until tonight when it
re-occured.

I added one of my Jitsi accounts (my own domain but hosted on gmail)
as a contact in Gibberbot earlier and now the Gibberbot contact
(gmail.com) is showing twice in Jitsi (both showing the contact as
online) but it may just be a co-incidence as another of my contacts in
Jitsi, not added to Gibberbot, is also showing twice and both as
offline. I can't say when exactly this started either, so it may have
been some time after I added the contact in Gibberbot.

I've tried closing Jitsi and restarting it but it still shows those
two contacts twice each.

I'm using 2.3.4656.9728 on Win7 x64.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users
.

--
https://jitsi.org