[jitsi-users] Jitsi - Openfire - STUN settings


#1

Hello everyone,
i'm struggling trying to use jitsi as a client for my openfire installation
in place of the spark client.
Our interest is to use the videobridge and the audio video feature that
jitsi integrates.
Unfortunately I still cannot do a proper STUN configuration in order to
permit two clients placed on different networks to properly establish a rtp
communication.
On the ICE tab configuration settings i did insert only the stun server i
want to use (stun.l.google.com). The server works fine (tested with winstun
on order to see if it translates properly my public ip) but once i try to
establish a phone call the ip released on the call are the private ip
instead of the public one.
Does anyone have an idea on how to proceed?

Thanks in advance
Regards
Giorgio


#2

STUN alone is not sufficient for NAT traversal. You also need a relaying
mechanism for fallback. With Openfire you can use their Jingle Nodes plugin.

Make sure however that you run Jitsi with its default configuration. (You
may want to delete the conifg folder if you've experimented eith the
settings)

Emil

--sent from my mobile

···

On 22 Oct 2013 12:29, "Giorgio Catena" <thechain1974@gmail.com> wrote:

Hello everyone,
i'm struggling trying to use jitsi as a client for my openfire
installation in place of the spark client.
Our interest is to use the videobridge and the audio video feature that
jitsi integrates.
Unfortunately I still cannot do a proper STUN configuration in order to
permit two clients placed on different networks to properly establish a rtp
communication.
On the ICE tab configuration settings i did insert only the stun server i
want to use (stun.l.google.com). The server works fine (tested with
winstun on order to see if it translates properly my public ip) but once i
try to establish a phone call the ip released on the call are the private
ip instead of the public one.
Does anyone have an idea on how to proceed?

Thanks in advance
Regards
Giorgio

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hi, the jinglenodes plugin simply does not work. I've already tried it
with no success. A webrtc test client using google stun server works
fine... could you tell me what fields had to be set up? If i leave all
the default settings enabled it says ice error...

···

Il 22/ott/2013 12:37 "Emil Ivov" <emcho@jitsi.org> ha scritto:

STUN alone is not sufficient for NAT traversal. You also need a relaying
mechanism for fallback. With Openfire you can use their Jingle Nodes plugin.

Make sure however that you run Jitsi with its default configuration. (You
may want to delete the conifg folder if you've experimented eith the
settings)

Emil

--sent from my mobile
On 22 Oct 2013 12:29, "Giorgio Catena" <thechain1974@gmail.com> wrote:

Hello everyone,
i'm struggling trying to use jitsi as a client for my openfire
installation in place of the spark client.
Our interest is to use the videobridge and the audio video feature that
jitsi integrates.
Unfortunately I still cannot do a proper STUN configuration in order to
permit two clients placed on different networks to properly establish a rtp
communication.
On the ICE tab configuration settings i did insert only the stun server i
want to use (stun.l.google.com). The server works fine (tested with
winstun on order to see if it translates properly my public ip) but once i
try to establish a phone call the ip released on the call are the private
ip instead of the public one.
Does anyone have an idea on how to proceed?

Thanks in advance
Regards
Giorgio

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#4

Can you establish a connection using two Jitsi instances with *default*
configuration and jit.si accounts?

--sent from my mobile

···

On 22 Oct 2013 12:56, "Giorgio Catena" <thechain1974@gmail.com> wrote:

Hi, the jinglenodes plugin simply does not work. I've already tried it
with no success. A webrtc test client using google stun server works
fine... could you tell me what fields had to be set up? If i leave all
the default settings enabled it says ice error...
Il 22/ott/2013 12:37 "Emil Ivov" <emcho@jitsi.org> ha scritto:

STUN alone is not sufficient for NAT traversal. You also need a relaying
mechanism for fallback. With Openfire you can use their Jingle Nodes plugin.

Make sure however that you run Jitsi with its default configuration. (You
may want to delete the conifg folder if you've experimented eith the
settings)

Emil

--sent from my mobile
On 22 Oct 2013 12:29, "Giorgio Catena" <thechain1974@gmail.com> wrote:

Hello everyone,
i'm struggling trying to use jitsi as a client for my openfire
installation in place of the spark client.
Our interest is to use the videobridge and the audio video feature that
jitsi integrates.
Unfortunately I still cannot do a proper STUN configuration in order to
permit two clients placed on different networks to properly establish a rtp
communication.
On the ICE tab configuration settings i did insert only the stun server
i want to use (stun.l.google.com). The server works fine (tested with
winstun on order to see if it translates properly my public ip) but once i
try to establish a phone call the ip released on the call are the private
ip instead of the public one.
Does anyone have an idea on how to proceed?

Thanks in advance
Regards
Giorgio

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

I do have to create the account. In case it would work what should it mean?
Due to the fact i have to use my OF server i'm going to test all with it.
Could you provide me the setting I should use with OF- STUN and so on?
Maybe i'm doing something wrong.

Regards

···

2013/10/22 Emil Ivov <emcho@jitsi.org>

Can you establish a connection using two Jitsi instances with *default*
configuration and jit.si accounts?

--sent from my mobile
On 22 Oct 2013 12:56, "Giorgio Catena" <thechain1974@gmail.com> wrote:

Hi, the jinglenodes plugin simply does not work. I've already tried it
with no success. A webrtc test client using google stun server works
fine... could you tell me what fields had to be set up? If i leave all
the default settings enabled it says ice error...
Il 22/ott/2013 12:37 "Emil Ivov" <emcho@jitsi.org> ha scritto:

STUN alone is not sufficient for NAT traversal. You also need a relaying
mechanism for fallback. With Openfire you can use their Jingle Nodes plugin.

Make sure however that you run Jitsi with its default configuration.
(You may want to delete the conifg folder if you've experimented eith the
settings)

Emil

--sent from my mobile
On 22 Oct 2013 12:29, "Giorgio Catena" <thechain1974@gmail.com> wrote:

Hello everyone,
i'm struggling trying to use jitsi as a client for my openfire
installation in place of the spark client.
Our interest is to use the videobridge and the audio video feature that
jitsi integrates.
Unfortunately I still cannot do a proper STUN configuration in order to
permit two clients placed on different networks to properly establish a rtp
communication.
On the ICE tab configuration settings i did insert only the stun server
i want to use (stun.l.google.com). The server works fine (tested with
winstun on order to see if it translates properly my public ip) but once i
try to establish a phone call the ip released on the call are the private
ip instead of the public one.
Does anyone have an idea on how to proceed?

Thanks in advance
Regards
Giorgio

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

It would mean that you are doing something wrong and it would help us help
you. Creating an accout will take you all of ten seconds.

If you don't want to do this then fine, I just thought you were asking for
help.

--sent from my mobile

···

On 22 Oct 2013 13:18, "Giorgio Catena" <thechain1974@gmail.com> wrote:

I do have to create the account. In case it would work what should it
mean? Due to the fact i have to use my OF server i'm going to test all with
it.
Could you provide me the setting I should use with OF- STUN and so on?
Maybe i'm doing something wrong.

Regards

2013/10/22 Emil Ivov <emcho@jitsi.org>

Can you establish a connection using two Jitsi instances with *default*
configuration and jit.si accounts?

--sent from my mobile
On 22 Oct 2013 12:56, "Giorgio Catena" <thechain1974@gmail.com> wrote:

Hi, the jinglenodes plugin simply does not work. I've already tried it
with no success. A webrtc test client using google stun server works
fine... could you tell me what fields had to be set up? If i leave all
the default settings enabled it says ice error...
Il 22/ott/2013 12:37 "Emil Ivov" <emcho@jitsi.org> ha scritto:

STUN alone is not sufficient for NAT traversal. You also need a
relaying mechanism for fallback. With Openfire you can use their Jingle
Nodes plugin.

Make sure however that you run Jitsi with its default configuration.
(You may want to delete the conifg folder if you've experimented eith the
settings)

Emil

--sent from my mobile
On 22 Oct 2013 12:29, "Giorgio Catena" <thechain1974@gmail.com> wrote:

Hello everyone,
i'm struggling trying to use jitsi as a client for my openfire
installation in place of the spark client.
Our interest is to use the videobridge and the audio video feature
that jitsi integrates.
Unfortunately I still cannot do a proper STUN configuration in order
to permit two clients placed on different networks to properly establish a
rtp communication.
On the ICE tab configuration settings i did insert only the stun
server i want to use (stun.l.google.com). The server works fine
(tested with winstun on order to see if it translates properly my public
ip) but once i try to establish a phone call the ip released on the call
are the private ip instead of the public one.
Does anyone have an idea on how to proceed?

Thanks in advance
Regards
Giorgio

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

No problem i'll do it now.. :slight_smile:

···

Il 22/ott/2013 13:23 "Emil Ivov" <emcho@jitsi.org> ha scritto:

It would mean that you are doing something wrong and it would help us help
you. Creating an accout will take you all of ten seconds.

If you don't want to do this then fine, I just thought you were asking
for help.

--sent from my mobile
On 22 Oct 2013 13:18, "Giorgio Catena" <thechain1974@gmail.com> wrote:

I do have to create the account. In case it would work what should it
mean? Due to the fact i have to use my OF server i'm going to test all with
it.
Could you provide me the setting I should use with OF- STUN and so on?
Maybe i'm doing something wrong.

Regards

2013/10/22 Emil Ivov <emcho@jitsi.org>

Can you establish a connection using two Jitsi instances with *default*
configuration and jit.si accounts?

--sent from my mobile
On 22 Oct 2013 12:56, "Giorgio Catena" <thechain1974@gmail.com> wrote:

Hi, the jinglenodes plugin simply does not work. I've already tried
it with no success. A webrtc test client using google stun server works
fine... could you tell me what fields had to be set up? If i leave all
the default settings enabled it says ice error...
Il 22/ott/2013 12:37 "Emil Ivov" <emcho@jitsi.org> ha scritto:

STUN alone is not sufficient for NAT traversal. You also need a
relaying mechanism for fallback. With Openfire you can use their Jingle
Nodes plugin.

Make sure however that you run Jitsi with its default configuration.
(You may want to delete the conifg folder if you've experimented eith the
settings)

Emil

--sent from my mobile
On 22 Oct 2013 12:29, "Giorgio Catena" <thechain1974@gmail.com> wrote:

Hello everyone,
i'm struggling trying to use jitsi as a client for my openfire
installation in place of the spark client.
Our interest is to use the videobridge and the audio video feature
that jitsi integrates.
Unfortunately I still cannot do a proper STUN configuration in order
to permit two clients placed on different networks to properly establish a
rtp communication.
On the ICE tab configuration settings i did insert only the stun
server i want to use (stun.l.google.com). The server works fine
(tested with winstun on order to see if it translates properly my public
ip) but once i try to establish a phone call the ip released on the call
are the private ip instead of the public one.
Does anyone have an idea on how to proceed?

Thanks in advance
Regards
Giorgio

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Well to be sincere i do have a problem trying to open jit.si connection
from our inside lan. The security dept did not accept to open it....
What makes me mad is that jinglenodes seems so simple to use that i cannt
understand why it does not work. I'm also trying to setup a dedicated linux
box, with xmpp-jinglenodes recompiled from the git source. It binds to xmpp
server but after that simply goes in timeout. What i cannt understand if
why in the same config of the jitsi client (only stun written in the conf)
the webrtc test client works (can do rtp call using xmpp signaling) and
jitsi fails.

···

2013/10/22 Giorgio Catena <thechain1974@gmail.com>

No problem i'll do it now.. :slight_smile:
Il 22/ott/2013 13:23 "Emil Ivov" <emcho@jitsi.org> ha scritto:

It would mean that you are doing something wrong and it would help us help

you. Creating an accout will take you all of ten seconds.

If you don't want to do this then fine, I just thought you were asking
for help.

--sent from my mobile
On 22 Oct 2013 13:18, "Giorgio Catena" <thechain1974@gmail.com> wrote:

I do have to create the account. In case it would work what should it
mean? Due to the fact i have to use my OF server i'm going to test all with
it.
Could you provide me the setting I should use with OF- STUN and so on?
Maybe i'm doing something wrong.

Regards

2013/10/22 Emil Ivov <emcho@jitsi.org>

Can you establish a connection using two Jitsi instances with *default*
configuration and jit.si accounts?

--sent from my mobile
On 22 Oct 2013 12:56, "Giorgio Catena" <thechain1974@gmail.com> wrote:

Hi, the jinglenodes plugin simply does not work. I've already tried
it with no success. A webrtc test client using google stun server works
fine... could you tell me what fields had to be set up? If i leave all
the default settings enabled it says ice error...
Il 22/ott/2013 12:37 "Emil Ivov" <emcho@jitsi.org> ha scritto:

STUN alone is not sufficient for NAT traversal. You also need a
relaying mechanism for fallback. With Openfire you can use their Jingle
Nodes plugin.

Make sure however that you run Jitsi with its default configuration.
(You may want to delete the conifg folder if you've experimented eith the
settings)

Emil

--sent from my mobile
On 22 Oct 2013 12:29, "Giorgio Catena" <thechain1974@gmail.com> >>>>>> wrote:

Hello everyone,
i'm struggling trying to use jitsi as a client for my openfire
installation in place of the spark client.
Our interest is to use the videobridge and the audio video feature
that jitsi integrates.
Unfortunately I still cannot do a proper STUN configuration in order
to permit two clients placed on different networks to properly establish a
rtp communication.
On the ICE tab configuration settings i did insert only the stun
server i want to use (stun.l.google.com). The server works fine
(tested with winstun on order to see if it translates properly my public
ip) but once i try to establish a phone call the ip released on the call
are the private ip instead of the public one.
Does anyone have an idea on how to proceed?

Thanks in advance
Regards
Giorgio

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#9

I did cross check also using a turn server (
https://code.google.com/p/rfc5766-turn-server/) but with unfortunatly i
obtained the same results. Is there any way to have an example of a wrking
config with a stun/turn server? The options on the client seems to be all
ok, the check made by winstun and similar software are ok but the
communication between two jitsi clients simply does not work.

Thanks in advance.

···

2013/10/22 Giorgio Catena <thechain1974@gmail.com>

Well to be sincere i do have a problem trying to open jit.si connection
from our inside lan. The security dept did not accept to open it....
What makes me mad is that jinglenodes seems so simple to use that i cannt
understand why it does not work. I'm also trying to setup a dedicated linux
box, with xmpp-jinglenodes recompiled from the git source. It binds to xmpp
server but after that simply goes in timeout. What i cannt understand if
why in the same config of the jitsi client (only stun written in the conf)
the webrtc test client works (can do rtp call using xmpp signaling) and
jitsi fails.

2013/10/22 Giorgio Catena <thechain1974@gmail.com>

No problem i'll do it now.. :slight_smile:
Il 22/ott/2013 13:23 "Emil Ivov" <emcho@jitsi.org> ha scritto:

It would mean that you are doing something wrong and it would help us

help you. Creating an accout will take you all of ten seconds.

If you don't want to do this then fine, I just thought you were asking
for help.

--sent from my mobile
On 22 Oct 2013 13:18, "Giorgio Catena" <thechain1974@gmail.com> wrote:

I do have to create the account. In case it would work what should it
mean? Due to the fact i have to use my OF server i'm going to test all with
it.
Could you provide me the setting I should use with OF- STUN and so on?
Maybe i'm doing something wrong.

Regards

2013/10/22 Emil Ivov <emcho@jitsi.org>

Can you establish a connection using two Jitsi instances with
*default* configuration and jit.si accounts?

--sent from my mobile
On 22 Oct 2013 12:56, "Giorgio Catena" <thechain1974@gmail.com> wrote:

Hi, the jinglenodes plugin simply does not work. I've already tried
it with no success. A webrtc test client using google stun server works
fine... could you tell me what fields had to be set up? If i leave all
the default settings enabled it says ice error...
Il 22/ott/2013 12:37 "Emil Ivov" <emcho@jitsi.org> ha scritto:

STUN alone is not sufficient for NAT traversal. You also need a
relaying mechanism for fallback. With Openfire you can use their Jingle
Nodes plugin.

Make sure however that you run Jitsi with its default configuration.
(You may want to delete the conifg folder if you've experimented eith the
settings)

Emil

--sent from my mobile
On 22 Oct 2013 12:29, "Giorgio Catena" <thechain1974@gmail.com> >>>>>>> wrote:

Hello everyone,
i'm struggling trying to use jitsi as a client for my openfire
installation in place of the spark client.
Our interest is to use the videobridge and the audio video feature
that jitsi integrates.
Unfortunately I still cannot do a proper STUN configuration in
order to permit two clients placed on different networks to properly
establish a rtp communication.
On the ICE tab configuration settings i did insert only the stun
server i want to use (stun.l.google.com). The server works fine
(tested with winstun on order to see if it translates properly my public
ip) but once i try to establish a phone call the ip released on the call
are the private ip instead of the public one.
Does anyone have an idea on how to proceed?

Thanks in advance
Regards
Giorgio

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#10

Hey Giorgio,

Well to be sincere i do have a problem trying to open jit.si connection from
our inside lan. The security dept did not accept to open it....

That's unfortunate. However, if outbound tcp connections are forbidden
by your network, then that could also explain your problems. Obviously
I am speculating. I don't know anything about your network or your
testbed, so it is quite hard to provide meaningful help.

What makes me mad is that jinglenodes seems so simple to use that i cannt
understand why it does not work.

You can try. First you need to find out whether Jitsi allocates Jingle
Nodes addresses, then you can check whether it attempts to run ICE
checks through it.

I'm also trying to setup a dedicated linux
box, with xmpp-jinglenodes recompiled from the git source. It binds to xmpp
server but after that simply goes in timeout.

The openfire plugin generally works quite nice. If it isn't working
for you, I'd be more inclined to look at the network rather than try
and recompile jingle nodes.

What i cannt understand if why
in the same config of the jitsi client (only stun written in the conf) the
webrtc test client works (can do rtp call using xmpp signaling) and jitsi
fails.

There could be many reasons. Are you connecting the exact same two
hosts using the same STUN server? Can we see the logs?

Emil

···

On Tue, Oct 22, 2013 at 1:35 PM, Giorgio Catena <thechain1974@gmail.com> wrote:

2013/10/22 Giorgio Catena <thechain1974@gmail.com>

No problem i'll do it now.. :slight_smile:

Il 22/ott/2013 13:23 "Emil Ivov" <emcho@jitsi.org> ha scritto:

It would mean that you are doing something wrong and it would help us
help you. Creating an accout will take you all of ten seconds.

If you don't want to do this then fine, I just thought you were asking
for help.

--sent from my mobile

On 22 Oct 2013 13:18, "Giorgio Catena" <thechain1974@gmail.com> wrote:

I do have to create the account. In case it would work what should it
mean? Due to the fact i have to use my OF server i'm going to test all with
it.
Could you provide me the setting I should use with OF- STUN and so on?
Maybe i'm doing something wrong.

Regards

2013/10/22 Emil Ivov <emcho@jitsi.org>

Can you establish a connection using two Jitsi instances with *default*
configuration and jit.si accounts?

--sent from my mobile

On 22 Oct 2013 12:56, "Giorgio Catena" <thechain1974@gmail.com> wrote:

Hi, the jinglenodes plugin simply does not work. I've already tried
it with no success. A webrtc test client using google stun server works
fine... could you tell me what fields had to be set up? If i leave all the
default settings enabled it says ice error...

Il 22/ott/2013 12:37 "Emil Ivov" <emcho@jitsi.org> ha scritto:

STUN alone is not sufficient for NAT traversal. You also need a
relaying mechanism for fallback. With Openfire you can use their Jingle
Nodes plugin.

Make sure however that you run Jitsi with its default configuration.
(You may want to delete the conifg folder if you've experimented eith the
settings)

Emil

--sent from my mobile

On 22 Oct 2013 12:29, "Giorgio Catena" <thechain1974@gmail.com> >>>>>>> wrote:

Hello everyone,
i'm struggling trying to use jitsi as a client for my openfire
installation in place of the spark client.
Our interest is to use the videobridge and the audio video feature
that jitsi integrates.
Unfortunately I still cannot do a proper STUN configuration in order
to permit two clients placed on different networks to properly establish a
rtp communication.
On the ICE tab configuration settings i did insert only the stun
server i want to use (stun.l.google.com). The server works fine (tested with
winstun on order to see if it translates properly my public ip) but once i
try to establish a phone call the ip released on the call are the private ip
instead of the public one.
Does anyone have an idea on how to proceed?

Thanks in advance
Regards
Giorgio

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31


#11

I did cross check also using a turn server
(https://code.google.com/p/rfc5766-turn-server/) but with unfortunatly i
obtained the same results. Is there any way to have an example of a wrking
config with a stun/turn server?

Sure, but you said you can't access it from your network.

Emil

···

On Tue, Oct 22, 2013 at 5:40 PM, Giorgio Catena <thechain1974@gmail.com> wrote:

The options on the client seems to be all
ok, the check made by winstun and similar software are ok but the
communication between two jitsi clients simply does not work.

Thanks in advance.

2013/10/22 Giorgio Catena <thechain1974@gmail.com>

Well to be sincere i do have a problem trying to open jit.si connection
from our inside lan. The security dept did not accept to open it....
What makes me mad is that jinglenodes seems so simple to use that i cannt
understand why it does not work. I'm also trying to setup a dedicated linux
box, with xmpp-jinglenodes recompiled from the git source. It binds to xmpp
server but after that simply goes in timeout. What i cannt understand if why
in the same config of the jitsi client (only stun written in the conf) the
webrtc test client works (can do rtp call using xmpp signaling) and jitsi
fails.

2013/10/22 Giorgio Catena <thechain1974@gmail.com>

No problem i'll do it now.. :slight_smile:

Il 22/ott/2013 13:23 "Emil Ivov" <emcho@jitsi.org> ha scritto:

It would mean that you are doing something wrong and it would help us
help you. Creating an accout will take you all of ten seconds.

If you don't want to do this then fine, I just thought you were asking
for help.

--sent from my mobile

On 22 Oct 2013 13:18, "Giorgio Catena" <thechain1974@gmail.com> wrote:

I do have to create the account. In case it would work what should it
mean? Due to the fact i have to use my OF server i'm going to test all with
it.
Could you provide me the setting I should use with OF- STUN and so on?
Maybe i'm doing something wrong.

Regards

2013/10/22 Emil Ivov <emcho@jitsi.org>

Can you establish a connection using two Jitsi instances with
*default* configuration and jit.si accounts?

--sent from my mobile

On 22 Oct 2013 12:56, "Giorgio Catena" <thechain1974@gmail.com> wrote:

Hi, the jinglenodes plugin simply does not work. I've already tried
it with no success. A webrtc test client using google stun server works
fine... could you tell me what fields had to be set up? If i leave all the
default settings enabled it says ice error...

Il 22/ott/2013 12:37 "Emil Ivov" <emcho@jitsi.org> ha scritto:

STUN alone is not sufficient for NAT traversal. You also need a
relaying mechanism for fallback. With Openfire you can use their Jingle
Nodes plugin.

Make sure however that you run Jitsi with its default configuration.
(You may want to delete the conifg folder if you've experimented eith the
settings)

Emil

--sent from my mobile

On 22 Oct 2013 12:29, "Giorgio Catena" <thechain1974@gmail.com> >>>>>>>> wrote:

Hello everyone,
i'm struggling trying to use jitsi as a client for my openfire
installation in place of the spark client.
Our interest is to use the videobridge and the audio video feature
that jitsi integrates.
Unfortunately I still cannot do a proper STUN configuration in
order to permit two clients placed on different networks to properly
establish a rtp communication.
On the ICE tab configuration settings i did insert only the stun
server i want to use (stun.l.google.com). The server works fine (tested with
winstun on order to see if it translates properly my public ip) but once i
try to establish a phone call the ip released on the call are the private ip
instead of the public one.
Does anyone have an idea on how to proceed?

Thanks in advance
Regards
Giorgio

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31


#12

Hi emil tomorrow i'll provide logs with jinglenodes setup and stun. The
idea to recompile jinglenodes was given from thiago the main jinglenodes
developer. I can also try to provide some more details regarding our
network specs.
Thanks again

···

Il 22/ott/2013 17:53 "Emil Ivov" <emcho@jitsi.org> ha scritto:

Hey Giorgio,

On Tue, Oct 22, 2013 at 1:35 PM, Giorgio Catena <thechain1974@gmail.com> > wrote:
> Well to be sincere i do have a problem trying to open jit.si connection
from
> our inside lan. The security dept did not accept to open it....

That's unfortunate. However, if outbound tcp connections are forbidden
by your network, then that could also explain your problems. Obviously
I am speculating. I don't know anything about your network or your
testbed, so it is quite hard to provide meaningful help.

> What makes me mad is that jinglenodes seems so simple to use that i cannt
> understand why it does not work.

You can try. First you need to find out whether Jitsi allocates Jingle
Nodes addresses, then you can check whether it attempts to run ICE
checks through it.

> I'm also trying to setup a dedicated linux
> box, with xmpp-jinglenodes recompiled from the git source. It binds to
xmpp
> server but after that simply goes in timeout.

The openfire plugin generally works quite nice. If it isn't working
for you, I'd be more inclined to look at the network rather than try
and recompile jingle nodes.

> What i cannt understand if why
> in the same config of the jitsi client (only stun written in the conf)
the
> webrtc test client works (can do rtp call using xmpp signaling) and jitsi
> fails.

There could be many reasons. Are you connecting the exact same two
hosts using the same STUN server? Can we see the logs?

Emil
>
>
>
>
> 2013/10/22 Giorgio Catena <thechain1974@gmail.com>
>>
>> No problem i'll do it now.. :slight_smile:
>>
>> Il 22/ott/2013 13:23 "Emil Ivov" <emcho@jitsi.org> ha scritto:
>>
>>> It would mean that you are doing something wrong and it would help us
>>> help you. Creating an accout will take you all of ten seconds.
>>>
>>> If you don't want to do this then fine, I just thought you were asking
>>> for help.
>>>
>>> --sent from my mobile
>>>
>>> On 22 Oct 2013 13:18, "Giorgio Catena" <thechain1974@gmail.com> wrote:
>>>>
>>>> I do have to create the account. In case it would work what should it
>>>> mean? Due to the fact i have to use my OF server i'm going to test
all with
>>>> it.
>>>> Could you provide me the setting I should use with OF- STUN and so on?
>>>> Maybe i'm doing something wrong.
>>>>
>>>> Regards
>>>>
>>>>
>>>> 2013/10/22 Emil Ivov <emcho@jitsi.org>
>>>>>
>>>>> Can you establish a connection using two Jitsi instances with
*default*
>>>>> configuration and jit.si accounts?
>>>>>
>>>>> --sent from my mobile
>>>>>
>>>>> On 22 Oct 2013 12:56, "Giorgio Catena" <thechain1974@gmail.com> > wrote:
>>>>>>
>>>>>> Hi, the jinglenodes plugin simply does not work. I've already
tried
>>>>>> it with no success. A webrtc test client using google stun server
works
>>>>>> fine... could you tell me what fields had to be set up? If i
leave all the
>>>>>> default settings enabled it says ice error...
>>>>>>
>>>>>> Il 22/ott/2013 12:37 "Emil Ivov" <emcho@jitsi.org> ha scritto:
>>>>>>>
>>>>>>> STUN alone is not sufficient for NAT traversal. You also need a
>>>>>>> relaying mechanism for fallback. With Openfire you can use their
Jingle
>>>>>>> Nodes plugin.
>>>>>>>
>>>>>>> Make sure however that you run Jitsi with its default
configuration.
>>>>>>> (You may want to delete the conifg folder if you've experimented
eith the
>>>>>>> settings)
>>>>>>>
>>>>>>> Emil
>>>>>>>
>>>>>>> --sent from my mobile
>>>>>>>
>>>>>>> On 22 Oct 2013 12:29, "Giorgio Catena" <thechain1974@gmail.com> > >>>>>>> wrote:
>>>>>>>>
>>>>>>>> Hello everyone,
>>>>>>>> i'm struggling trying to use jitsi as a client for my openfire
>>>>>>>> installation in place of the spark client.
>>>>>>>> Our interest is to use the videobridge and the audio video feature
>>>>>>>> that jitsi integrates.
>>>>>>>> Unfortunately I still cannot do a proper STUN configuration in
order
>>>>>>>> to permit two clients placed on different networks to properly
establish a
>>>>>>>> rtp communication.
>>>>>>>> On the ICE tab configuration settings i did insert only the stun
>>>>>>>> server i want to use (stun.l.google.com). The server works fine
(tested with
>>>>>>>> winstun on order to see if it translates properly my public ip)
but once i
>>>>>>>> try to establish a phone call the ip released on the call are the
private ip
>>>>>>>> instead of the public one.
>>>>>>>> Does anyone have an idea on how to proceed?
>>>>>>>>
>>>>>>>> Thanks in advance
>>>>>>>> Regards
>>>>>>>> Giorgio
>>>>>>>>
>>>>>>>> _______________________________________________
>>>>>>>> users mailing list
>>>>>>>> users@jitsi.org
>>>>>>>> Unsubscribe instructions and other list options:
>>>>>>>> http://lists.jitsi.org/mailman/listinfo/users
>>>>>>>
>>>>>>>
>>>>>>> _______________________________________________
>>>>>>> users mailing list
>>>>>>> users@jitsi.org
>>>>>>> Unsubscribe instructions and other list options:
>>>>>>> http://lists.jitsi.org/mailman/listinfo/users
>>>>>>
>>>>>>
>>>>>> _______________________________________________
>>>>>> users mailing list
>>>>>> users@jitsi.org
>>>>>> Unsubscribe instructions and other list options:
>>>>>> http://lists.jitsi.org/mailman/listinfo/users
>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> users mailing list
>>>>> users@jitsi.org
>>>>> Unsubscribe instructions and other list options:
>>>>> http://lists.jitsi.org/mailman/listinfo/users
>>>>
>>>>
>>>>
>>>> _______________________________________________
>>>> users mailing list
>>>> users@jitsi.org
>>>> Unsubscribe instructions and other list options:
>>>> http://lists.jitsi.org/mailman/listinfo/users
>>>
>>>
>>> _______________________________________________
>>> users mailing list
>>> users@jitsi.org
>>> Unsubscribe instructions and other list options:
>>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#13

Hi,
as requested I'm going to describe the configuration we are using and that
is giving us problems trying to use jitsi to do a call from our lan to an
external client (that in our tests is using a wi-fi umts modem) and - or
viceversa.
The XMPP - Openfire server is a windows box with 2 nics both with public ip
address as requested from jinglenodes and stun to work. The machine is
reachable on the same pubblic addresses from the inside LAN.
There is only a firewall protecting the machine from the public access no
NAT is in place.
Trying to use Spark or Jitsi with the STUN option enabled (inserting the
primary ip, port 3478) the client cannot instantiate the connection.
Trying to use Jitsi with jinglenodes (enabled the jinglenodes module, don't
know if it works, it says public ip cannot be verified, I saw on the code
that to verify it it should point to a stun server that is not answering,
maybe that this is the cause) the clients cannot connect each other, the
call is made but once the other client answer no audio or video are sent.
Trying to use spark with webrtc plugin (xmpp signaling on the openfire
server + WEBRTC for RTP communication) the clients start the A/V session
properly. What I noticed is that the WEBRTC plugin made by Dele Oljiade has
hardcoded in the jar the reference to the stun.l.google.com STUN server
(port 19302). At this point I decided to do is to exclude the XMPP server
from the relay role and-or jinglenodes role trying to use the Google's
public available STUN.
For this reason, I tried to place on the jitsi conf (keeping obviously the
same testing configuration) the reference to the IP of Google's STUN server.
Before doing that i did cross chek the correct behaviour of the google's
stun server on both client using winstun and the result are ok, the public
addresses are correctly translated as expected.
I inserted that STUN address on the jitsi configuration of both Jitsi
client disabling all the options (included autodiscovery and jinglenodes),
trying to do the call nothing happens (same behaviour noticed with
jinglenodes enablad). If I look at the connection properties during the
call I see that even if stun server is in the configuration the ip of the
parties involved in the call are the private ip not the public. It seems
that i think stun settings are for some reason not saved and - or used but
I cannot understand why.

Do you want me to provide the log with both jinglenodes and stun attempts?

Regards.

···

2013/10/22 Giorgio Catena <thechain1974@gmail.com>

Hi emil tomorrow i'll provide logs with jinglenodes setup and stun. The
idea to recompile jinglenodes was given from thiago the main jinglenodes
developer. I can also try to provide some more details regarding our
network specs.
Thanks again
Il 22/ott/2013 17:53 "Emil Ivov" <emcho@jitsi.org> ha scritto:

Hey Giorgio,

On Tue, Oct 22, 2013 at 1:35 PM, Giorgio Catena <thechain1974@gmail.com> >> wrote:
> Well to be sincere i do have a problem trying to open jit.siconnection from
> our inside lan. The security dept did not accept to open it....

That's unfortunate. However, if outbound tcp connections are forbidden
by your network, then that could also explain your problems. Obviously
I am speculating. I don't know anything about your network or your
testbed, so it is quite hard to provide meaningful help.

> What makes me mad is that jinglenodes seems so simple to use that i
cannt
> understand why it does not work.

You can try. First you need to find out whether Jitsi allocates Jingle
Nodes addresses, then you can check whether it attempts to run ICE
checks through it.

> I'm also trying to setup a dedicated linux
> box, with xmpp-jinglenodes recompiled from the git source. It binds to
xmpp
> server but after that simply goes in timeout.

The openfire plugin generally works quite nice. If it isn't working
for you, I'd be more inclined to look at the network rather than try
and recompile jingle nodes.

> What i cannt understand if why
> in the same config of the jitsi client (only stun written in the conf)
the
> webrtc test client works (can do rtp call using xmpp signaling) and
jitsi
> fails.

There could be many reasons. Are you connecting the exact same two
hosts using the same STUN server? Can we see the logs?

Emil
>
>
>
>
> 2013/10/22 Giorgio Catena <thechain1974@gmail.com>
>>
>> No problem i'll do it now.. :slight_smile:
>>
>> Il 22/ott/2013 13:23 "Emil Ivov" <emcho@jitsi.org> ha scritto:
>>
>>> It would mean that you are doing something wrong and it would help us
>>> help you. Creating an accout will take you all of ten seconds.
>>>
>>> If you don't want to do this then fine, I just thought you were
asking
>>> for help.
>>>
>>> --sent from my mobile
>>>
>>> On 22 Oct 2013 13:18, "Giorgio Catena" <thechain1974@gmail.com> >> wrote:
>>>>
>>>> I do have to create the account. In case it would work what should it
>>>> mean? Due to the fact i have to use my OF server i'm going to test
all with
>>>> it.
>>>> Could you provide me the setting I should use with OF- STUN and so
on?
>>>> Maybe i'm doing something wrong.
>>>>
>>>> Regards
>>>>
>>>>
>>>> 2013/10/22 Emil Ivov <emcho@jitsi.org>
>>>>>
>>>>> Can you establish a connection using two Jitsi instances with
*default*
>>>>> configuration and jit.si accounts?
>>>>>
>>>>> --sent from my mobile
>>>>>
>>>>> On 22 Oct 2013 12:56, "Giorgio Catena" <thechain1974@gmail.com> >> wrote:
>>>>>>
>>>>>> Hi, the jinglenodes plugin simply does not work. I've already
tried
>>>>>> it with no success. A webrtc test client using google stun server
works
>>>>>> fine... could you tell me what fields had to be set up? If i
leave all the
>>>>>> default settings enabled it says ice error...
>>>>>>
>>>>>> Il 22/ott/2013 12:37 "Emil Ivov" <emcho@jitsi.org> ha scritto:
>>>>>>>
>>>>>>> STUN alone is not sufficient for NAT traversal. You also need a
>>>>>>> relaying mechanism for fallback. With Openfire you can use their
Jingle
>>>>>>> Nodes plugin.
>>>>>>>
>>>>>>> Make sure however that you run Jitsi with its default
configuration.
>>>>>>> (You may want to delete the conifg folder if you've experimented
eith the
>>>>>>> settings)
>>>>>>>
>>>>>>> Emil
>>>>>>>
>>>>>>> --sent from my mobile
>>>>>>>
>>>>>>> On 22 Oct 2013 12:29, "Giorgio Catena" <thechain1974@gmail.com> >> >>>>>>> wrote:
>>>>>>>>
>>>>>>>> Hello everyone,
>>>>>>>> i'm struggling trying to use jitsi as a client for my openfire
>>>>>>>> installation in place of the spark client.
>>>>>>>> Our interest is to use the videobridge and the audio video
feature
>>>>>>>> that jitsi integrates.
>>>>>>>> Unfortunately I still cannot do a proper STUN configuration in
order
>>>>>>>> to permit two clients placed on different networks to properly
establish a
>>>>>>>> rtp communication.
>>>>>>>> On the ICE tab configuration settings i did insert only the stun
>>>>>>>> server i want to use (stun.l.google.com). The server works fine
(tested with
>>>>>>>> winstun on order to see if it translates properly my public ip)
but once i
>>>>>>>> try to establish a phone call the ip released on the call are
the private ip
>>>>>>>> instead of the public one.
>>>>>>>> Does anyone have an idea on how to proceed?
>>>>>>>>
>>>>>>>> Thanks in advance
>>>>>>>> Regards
>>>>>>>> Giorgio
>>>>>>>>
>>>>>>>> _______________________________________________
>>>>>>>> users mailing list
>>>>>>>> users@jitsi.org
>>>>>>>> Unsubscribe instructions and other list options:
>>>>>>>> http://lists.jitsi.org/mailman/listinfo/users
>>>>>>>
>>>>>>>
>>>>>>> _______________________________________________
>>>>>>> users mailing list
>>>>>>> users@jitsi.org
>>>>>>> Unsubscribe instructions and other list options:
>>>>>>> http://lists.jitsi.org/mailman/listinfo/users
>>>>>>
>>>>>>
>>>>>> _______________________________________________
>>>>>> users mailing list
>>>>>> users@jitsi.org
>>>>>> Unsubscribe instructions and other list options:
>>>>>> http://lists.jitsi.org/mailman/listinfo/users
>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> users mailing list
>>>>> users@jitsi.org
>>>>> Unsubscribe instructions and other list options:
>>>>> http://lists.jitsi.org/mailman/listinfo/users
>>>>
>>>>
>>>>
>>>> _______________________________________________
>>>> users mailing list
>>>> users@jitsi.org
>>>> Unsubscribe instructions and other list options:
>>>> http://lists.jitsi.org/mailman/listinfo/users
>>>
>>>
>>> _______________________________________________
>>> users mailing list
>>> users@jitsi.org
>>> Unsubscribe instructions and other list options:
>>> http://lists.jitsi.org/mailman/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/users

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#14

Hey Giorgio,

Hi,
as requested I'm going to describe the configuration we are using and
that is giving us problems trying to use jitsi to do a call from our lan
to an external client (that in our tests is using a wi-fi umts modem)
and - or viceversa.
The XMPP - Openfire server is a windows box with 2 nics both with public
ip address as requested from jinglenodes and stun to work. The machine
is reachable on the same pubblic addresses from the inside LAN.
There is only a firewall protecting the machine from the public access
no NAT is in place.

You mean there's a firewall in front of Openfire? Could it be blocking incoming UDP sessions? You might want to check that out.

Trying to use Spark or Jitsi with the STUN option enabled (inserting the
primary ip, port 3478) the client cannot instantiate the connection.
Trying to use Jitsi with jinglenodes (enabled the jinglenodes module,
don't know if it works, it says public ip cannot be verified, I saw on
the code that to verify it it should point to a stun server that is not
answering, maybe that this is the cause) the clients cannot connect each
other, the call is made but once the other client answer no audio or
video are sent.
Trying to use spark with webrtc plugin (xmpp signaling on the openfire
server + WEBRTC for RTP communication) the clients start the A/V session
properly. What I noticed is that the WEBRTC plugin made by Dele Oljiade
has hardcoded in the jar the reference to the stun.l.google.com
<http://stun.l.google.com> STUN server (port 19302).

Jitsi also comes with a preconfigured STUN server (stun.jitsi.net). Maybe it is also blocked?

At this point I
decided to do is to exclude the XMPP server from the relay role and-or
jinglenodes role trying to use the Google's public available STUN.
For this reason, I tried to place on the jitsi conf (keeping obviously
the same testing configuration) the reference to the IP of Google's STUN
server.
Before doing that i did cross chek the correct behaviour of the google's
stun server on both client using winstun and the result are ok, the
public addresses are correctly translated as expected.
I inserted that STUN address on the jitsi configuration of both Jitsi
client disabling all the options (included autodiscovery and
jinglenodes), trying to do the call nothing happens (same behaviour
noticed with jinglenodes enablad).

Have you checked if Jitsi's STUN Binding Requests reach the server and whether they get answered?

If I look at the connection
properties during the call I see that even if stun server is in the
configuration the ip of the parties involved in the call are the private
ip not the public. It seems that i think stun settings are for some
reason not saved and - or used but I cannot understand why.

Or maybe the STUN queries are not succeeding.

Do you want me to provide the log with both jinglenodes and stun attempts?

That would help although I can't promise at what point people would be able to look through them. You may want to check out the questions above too.

Emil

···

On 23.10.13, 09:12, Giorgio Catena wrote:

Regards.

2013/10/22 Giorgio Catena <thechain1974@gmail.com
<mailto:thechain1974@gmail.com>>

    Hi emil tomorrow i'll provide logs with jinglenodes setup and stun.
    The idea to recompile jinglenodes was given from thiago the main
    jinglenodes developer. I can also try to provide some more details
    regarding our network specs.
    Thanks again

    Il 22/ott/2013 17:53 "Emil Ivov" <emcho@jitsi.org > <mailto:emcho@jitsi.org>> ha scritto:

        Hey Giorgio,

        On Tue, Oct 22, 2013 at 1:35 PM, Giorgio Catena > <thechain1974@gmail.com <mailto:thechain1974@gmail.com>> wrote:
         > Well to be sincere i do have a problem trying to open jit.si
        <http://jit.si> connection from
         > our inside lan. The security dept did not accept to open it....

        That's unfortunate. However, if outbound tcp connections are
        forbidden
        by your network, then that could also explain your problems.
        Obviously
        I am speculating. I don't know anything about your network or your
        testbed, so it is quite hard to provide meaningful help.

         > What makes me mad is that jinglenodes seems so simple to use
        that i cannt
         > understand why it does not work.

        You can try. First you need to find out whether Jitsi allocates
        Jingle
        Nodes addresses, then you can check whether it attempts to run ICE
        checks through it.

         > I'm also trying to setup a dedicated linux
         > box, with xmpp-jinglenodes recompiled from the git source. It
        binds to xmpp
         > server but after that simply goes in timeout.

        The openfire plugin generally works quite nice. If it isn't working
        for you, I'd be more inclined to look at the network rather than try
        and recompile jingle nodes.

         > What i cannt understand if why
         > in the same config of the jitsi client (only stun written in
        the conf) the
         > webrtc test client works (can do rtp call using xmpp
        signaling) and jitsi
         > fails.

        There could be many reasons. Are you connecting the exact same two
        hosts using the same STUN server? Can we see the logs?

        Emil
         >
         > 2013/10/22 Giorgio Catena <thechain1974@gmail.com
        <mailto:thechain1974@gmail.com>>
         >>
         >> No problem i'll do it now.. :slight_smile:
         >>
         >> Il 22/ott/2013 13:23 "Emil Ivov" <emcho@jitsi.org > <mailto:emcho@jitsi.org>> ha scritto:
         >>
         >>> It would mean that you are doing something wrong and it
        would help us
         >>> help you. Creating an accout will take you all of ten seconds.
         >>>
         >>> If you don't want to do this then fine, I just thought you
        were asking
         >>> for help.
         >>>
         >>> --sent from my mobile
         >>>
         >>> On 22 Oct 2013 13:18, "Giorgio Catena" > <thechain1974@gmail.com <mailto:thechain1974@gmail.com>> wrote:
         >>>>
         >>>> I do have to create the account. In case it would work
        what should it
         >>>> mean? Due to the fact i have to use my OF server i'm going
        to test all with
         >>>> it.
         >>>> Could you provide me the setting I should use with OF-
        STUN and so on?
         >>>> Maybe i'm doing something wrong.
         >>>>
         >>>> Regards
         >>>>
         >>>> 2013/10/22 Emil Ivov <emcho@jitsi.org
        <mailto:emcho@jitsi.org>>
         >>>>>
         >>>>> Can you establish a connection using two Jitsi instances
        with *default*
         >>>>> configuration and jit.si <http://jit.si> accounts?
         >>>>>
         >>>>> --sent from my mobile
         >>>>>
         >>>>> On 22 Oct 2013 12:56, "Giorgio Catena" > <thechain1974@gmail.com <mailto:thechain1974@gmail.com>> wrote:
         >>>>>>
         >>>>>> Hi, the jinglenodes plugin simply does not work. I've
        already tried
         >>>>>> it with no success. A webrtc test client using google
        stun server works
         >>>>>> fine... could you tell me what fields had to be set up?
          If i leave all the
         >>>>>> default settings enabled it says ice error...
         >>>>>>
         >>>>>> Il 22/ott/2013 12:37 "Emil Ivov" <emcho@jitsi.org > <mailto:emcho@jitsi.org>> ha scritto:
         >>>>>>>
         >>>>>>> STUN alone is not sufficient for NAT traversal. You
        also need a
         >>>>>>> relaying mechanism for fallback. With Openfire you can
        use their Jingle
         >>>>>>> Nodes plugin.
         >>>>>>>
         >>>>>>> Make sure however that you run Jitsi with its default
        configuration.
         >>>>>>> (You may want to delete the conifg folder if you've
        experimented eith the
         >>>>>>> settings)
         >>>>>>>
         >>>>>>> Emil
         >>>>>>>
         >>>>>>> --sent from my mobile
         >>>>>>>
         >>>>>>> On 22 Oct 2013 12:29, "Giorgio Catena" > <thechain1974@gmail.com <mailto:thechain1974@gmail.com>> > >>>>>>> wrote:
         >>>>>>>>
         >>>>>>>> Hello everyone,
         >>>>>>>> i'm struggling trying to use jitsi as a client for my
        openfire
         >>>>>>>> installation in place of the spark client.
         >>>>>>>> Our interest is to use the videobridge and the audio
        video feature
         >>>>>>>> that jitsi integrates.
         >>>>>>>> Unfortunately I still cannot do a proper STUN
        configuration in order
         >>>>>>>> to permit two clients placed on different networks to
        properly establish a
         >>>>>>>> rtp communication.
         >>>>>>>> On the ICE tab configuration settings i did insert
        only the stun
         >>>>>>>> server i want to use (stun.l.google.com
        <http://stun.l.google.com>). The server works fine (tested with
         >>>>>>>> winstun on order to see if it translates properly my
        public ip) but once i
         >>>>>>>> try to establish a phone call the ip released on the
        call are the private ip
         >>>>>>>> instead of the public one.
         >>>>>>>> Does anyone have an idea on how to proceed?
         >>>>>>>>
         >>>>>>>> Thanks in advance
         >>>>>>>> Regards
         >>>>>>>> Giorgio
         >>>>>>>>
         >>>>>>>> _______________________________________________
         >>>>>>>> users mailing list
         >>>>>>>> users@jitsi.org <mailto:users@jitsi.org>
         >>>>>>>> Unsubscribe instructions and other list options:
         >>>>>>>> http://lists.jitsi.org/mailman/listinfo/users
         >>>>>>>
         >>>>>>> _______________________________________________
         >>>>>>> users mailing list
         >>>>>>> users@jitsi.org <mailto:users@jitsi.org>
         >>>>>>> Unsubscribe instructions and other list options:
         >>>>>>> http://lists.jitsi.org/mailman/listinfo/users
         >>>>>>
         >>>>>> _______________________________________________
         >>>>>> users mailing list
         >>>>>> users@jitsi.org <mailto:users@jitsi.org>
         >>>>>> Unsubscribe instructions and other list options:
         >>>>>> http://lists.jitsi.org/mailman/listinfo/users
         >>>>>
         >>>>> _______________________________________________
         >>>>> users mailing list
         >>>>> users@jitsi.org <mailto:users@jitsi.org>
         >>>>> Unsubscribe instructions and other list options:
         >>>>> http://lists.jitsi.org/mailman/listinfo/users
         >>>>
         >>>> _______________________________________________
         >>>> users mailing list
         >>>> users@jitsi.org <mailto:users@jitsi.org>
         >>>> Unsubscribe instructions and other list options:
         >>>> http://lists.jitsi.org/mailman/listinfo/users
         >>>
         >>> _______________________________________________
         >>> users mailing list
         >>> users@jitsi.org <mailto:users@jitsi.org>
         >>> Unsubscribe instructions and other list options:
         >>> http://lists.jitsi.org/mailman/listinfo/users
         >
         > _______________________________________________
         > users mailing list
         > users@jitsi.org <mailto:users@jitsi.org>
         > Unsubscribe instructions and other list options:
         > http://lists.jitsi.org/mailman/listinfo/users

        --
        Emil Ivov, Ph.D. 67000 Strasbourg,
        Project Lead France
        Jitsi
        emcho@jitsi.org <mailto:emcho@jitsi.org>
          PHONE: +33.1.77.62.43.30 <tel:%2B33.1.77.62.43.30>
        https://jitsi.org FAX: +33.1.77.62.47.31
        <tel:%2B33.1.77.62.47.31>

        _______________________________________________
        users mailing list
        users@jitsi.org <mailto:users@jitsi.org>
        Unsubscribe instructions and other list options:
        http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
https://jitsi.org


#15

(CC-ing dev. Let's keep this on the list so that others could benefit the same issues occur elsewhere).

ok emil i'll do other checks.

Cool, don't hesitate if you have questions there.

The udp are correctly opened afaik.

Well, you'd best have a look through Wireshark. That could very well explain the behaviour you describe.

Ok
which port does the jitsi stun work?

Jitsi uses ports 5000 to 6000 for media. STUN checks are sent on the media ports. Wireshark recognizes them as such so you should be able to filter them out pretty easily.

I'd provide logs asap. Do you
know anyone I could ask to crosscheck jinglenodes?

Well, the easiest would have been to connect to our jit.si server and then compare Jitsi behaviour between that and your Openfire installation.

Also, after starting Jitsi and connecting to your accounts you should see something like this in your logs:

11:17:09.962 INFO: [139] impl.protocol.jabber.JingleNodesServiceDiscovery.run().128 Jingle Nodes discovery terminated!
11:17:09.963 INFO: [139] impl.protocol.jabber.JingleNodesServiceDiscovery.run().129 Found 1 Jingle Nodes relay for account: emcho@jit.si in 989 ms.

If you don't see this then your Jingle Nodes Plugin is not properly connected to Openfire. If you do, but things still don't work, then the relay is properly initialized but Jitsi is unable to verify connectivity when establishing a call (which would be the case if your firewall is blocking stuff).

Hope this helps,
Emil

···

On 23.10.13, 15:12, Giorgio Catena wrote:

Il 23/ott/2013 14:58 "Emil Ivov" <emcho@jitsi.org > <mailto:emcho@jitsi.org>> ha scritto:

    Hey Giorgio,

    On 23.10.13, 09:12, Giorgio Catena wrote:

        Hi,
        as requested I'm going to describe the configuration we are
        using and
        that is giving us problems trying to use jitsi to do a call from
        our lan
        to an external client (that in our tests is using a wi-fi umts
        modem)
        and - or viceversa.
        The XMPP - Openfire server is a windows box with 2 nics both
        with public
        ip address as requested from jinglenodes and stun to work. The
        machine
        is reachable on the same pubblic addresses from the inside LAN.
        There is only a firewall protecting the machine from the public
        access
        no NAT is in place.

    You mean there's a firewall in front of Openfire? Could it be
    blocking incoming UDP sessions? You might want to check that out.

        Trying to use Spark or Jitsi with the STUN option enabled
        (inserting the
        primary ip, port 3478) the client cannot instantiate the connection.
        Trying to use Jitsi with jinglenodes (enabled the jinglenodes
        module,
        don't know if it works, it says public ip cannot be verified, I
        saw on
        the code that to verify it it should point to a stun server that
        is not
        answering, maybe that this is the cause) the clients cannot
        connect each
        other, the call is made but once the other client answer no audio or
        video are sent.
        Trying to use spark with webrtc plugin (xmpp signaling on the
        openfire
        server + WEBRTC for RTP communication) the clients start the A/V
        session
        properly. What I noticed is that the WEBRTC plugin made by Dele
        Oljiade
        has hardcoded in the jar the reference to the stun.l.google.com
        <http://stun.l.google.com>
        <http://stun.l.google.com> STUN server (port 19302).

    Jitsi also comes with a preconfigured STUN server (stun.jitsi.net
    <http://stun.jitsi.net>). Maybe it is also blocked?

        At this point I
        decided to do is to exclude the XMPP server from the relay role
        and-or
        jinglenodes role trying to use the Google's public available STUN.
        For this reason, I tried to place on the jitsi conf (keeping
        obviously
        the same testing configuration) the reference to the IP of
        Google's STUN
        server.
        Before doing that i did cross chek the correct behaviour of the
        google's
        stun server on both client using winstun and the result are ok, the
        public addresses are correctly translated as expected.
        I inserted that STUN address on the jitsi configuration of both
        Jitsi
        client disabling all the options (included autodiscovery and
        jinglenodes), trying to do the call nothing happens (same behaviour
        noticed with jinglenodes enablad).

    Have you checked if Jitsi's STUN Binding Requests reach the server
    and whether they get answered?

        If I look at the connection
        properties during the call I see that even if stun server is in the
        configuration the ip of the parties involved in the call are the
        private
        ip not the public. It seems that i think stun settings are for some
        reason not saved and - or used but I cannot understand why.

    Or maybe the STUN queries are not succeeding.

        Do you want me to provide the log with both jinglenodes and stun
        attempts?

    That would help although I can't promise at what point people would
    be able to look through them. You may want to check out the
    questions above too.

    Emil

        Regards.

        2013/10/22 Giorgio Catena <thechain1974@gmail.com
        <mailto:thechain1974@gmail.com>
        <mailto:thechain1974@gmail.com <mailto:thechain1974@gmail.com>__>>

             Hi emil tomorrow i'll provide logs with jinglenodes setup
        and stun.
             The idea to recompile jinglenodes was given from thiago the
        main
             jinglenodes developer. I can also try to provide some more
        details
             regarding our network specs.
             Thanks again

             Il 22/ott/2013 17:53 "Emil Ivov" <emcho@jitsi.org > <mailto:emcho@jitsi.org> > <mailto:emcho@jitsi.org <mailto:emcho@jitsi.org>>> ha scritto:

                 Hey Giorgio,

                 On Tue, Oct 22, 2013 at 1:35 PM, Giorgio Catena > <thechain1974@gmail.com <mailto:thechain1974@gmail.com> > <mailto:thechain1974@gmail.com > <mailto:thechain1974@gmail.com>__>> wrote:
                  > Well to be sincere i do have a problem trying to
        open jit.si <http://jit.si>
                 <http://jit.si> connection from
                  > our inside lan. The security dept did not accept to
        open it....

                 That's unfortunate. However, if outbound tcp
        connections are
                 forbidden
                 by your network, then that could also explain your
        problems.
                 Obviously
                 I am speculating. I don't know anything about your
        network or your
                 testbed, so it is quite hard to provide meaningful help.

                  > What makes me mad is that jinglenodes seems so
        simple to use
                 that i cannt
                  > understand why it does not work.

                 You can try. First you need to find out whether Jitsi
        allocates
                 Jingle
                 Nodes addresses, then you can check whether it attempts
        to run ICE
                 checks through it.

                  > I'm also trying to setup a dedicated linux
                  > box, with xmpp-jinglenodes recompiled from the git
        source. It
                 binds to xmpp
                  > server but after that simply goes in timeout.

                 The openfire plugin generally works quite nice. If it
        isn't working
                 for you, I'd be more inclined to look at the network
        rather than try
                 and recompile jingle nodes.

                  > What i cannt understand if why
                  > in the same config of the jitsi client (only stun
        written in
                 the conf) the
                  > webrtc test client works (can do rtp call using xmpp
                 signaling) and jitsi
                  > fails.

                 There could be many reasons. Are you connecting the
        exact same two
                 hosts using the same STUN server? Can we see the logs?

                 Emil
                  >
                  > 2013/10/22 Giorgio Catena <thechain1974@gmail.com
        <mailto:thechain1974@gmail.com>
                 <mailto:thechain1974@gmail.com
        <mailto:thechain1974@gmail.com>__>>
                  >>
                  >> No problem i'll do it now.. :slight_smile:
                  >>
                  >> Il 22/ott/2013 13:23 "Emil Ivov" <emcho@jitsi.org
        <mailto:emcho@jitsi.org>
                 <mailto:emcho@jitsi.org <mailto:emcho@jitsi.org>>> ha
        scritto:
                  >>
                  >>> It would mean that you are doing something wrong
        and it
                 would help us
                  >>> help you. Creating an accout will take you all of
        ten seconds.
                  >>>
                  >>> If you don't want to do this then fine, I just
        thought you
                 were asking
                  >>> for help.
                  >>>
                  >>> --sent from my mobile
                  >>>
                  >>> On 22 Oct 2013 13:18, "Giorgio Catena" > <thechain1974@gmail.com <mailto:thechain1974@gmail.com> > <mailto:thechain1974@gmail.com > <mailto:thechain1974@gmail.com>__>> wrote:
                  >>>>
                  >>>> I do have to create the account. In case it would
        work
                 what should it
                  >>>> mean? Due to the fact i have to use my OF server
        i'm going
                 to test all with
                  >>>> it.
                  >>>> Could you provide me the setting I should use
        with OF-
                 STUN and so on?
                  >>>> Maybe i'm doing something wrong.
                  >>>>
                  >>>> Regards
                  >>>>
                  >>>> 2013/10/22 Emil Ivov <emcho@jitsi.org
        <mailto:emcho@jitsi.org>
                 <mailto:emcho@jitsi.org <mailto:emcho@jitsi.org>>>
                  >>>>>
                  >>>>> Can you establish a connection using two Jitsi
        instances
                 with *default*
                  >>>>> configuration and jit.si <http://jit.si>
        <http://jit.si> accounts?
                  >>>>>
                  >>>>> --sent from my mobile
                  >>>>>
                  >>>>> On 22 Oct 2013 12:56, "Giorgio Catena" > <thechain1974@gmail.com <mailto:thechain1974@gmail.com> > <mailto:thechain1974@gmail.com > <mailto:thechain1974@gmail.com>__>> wrote:
                  >>>>>>
                  >>>>>> Hi, the jinglenodes plugin simply does not
        work. I've
                 already tried
                  >>>>>> it with no success. A webrtc test client using
        google
                 stun server works
                  >>>>>> fine... could you tell me what fields had to
        be set up?
                   If i leave all the
                  >>>>>> default settings enabled it says ice error...
                  >>>>>>
                  >>>>>> Il 22/ott/2013 12:37 "Emil Ivov"
        <emcho@jitsi.org <mailto:emcho@jitsi.org>
                 <mailto:emcho@jitsi.org <mailto:emcho@jitsi.org>>> ha
        scritto:
                  >>>>>>>
                  >>>>>>> STUN alone is not sufficient for NAT
        traversal. You
                 also need a
                  >>>>>>> relaying mechanism for fallback. With Openfire
        you can
                 use their Jingle
                  >>>>>>> Nodes plugin.
                  >>>>>>>
                  >>>>>>> Make sure however that you run Jitsi with its
        default
                 configuration.
                  >>>>>>> (You may want to delete the conifg folder if
        you've
                 experimented eith the
                  >>>>>>> settings)
                  >>>>>>>
                  >>>>>>> Emil
                  >>>>>>>
                  >>>>>>> --sent from my mobile
                  >>>>>>>
                  >>>>>>> On 22 Oct 2013 12:29, "Giorgio Catena" > <thechain1974@gmail.com <mailto:thechain1974@gmail.com> > <mailto:thechain1974@gmail.com <mailto:thechain1974@gmail.com>__>> > >>>>>>> wrote:
                  >>>>>>>>
                  >>>>>>>> Hello everyone,
                  >>>>>>>> i'm struggling trying to use jitsi as a
        client for my
                 openfire
                  >>>>>>>> installation in place of the spark client.
                  >>>>>>>> Our interest is to use the videobridge and
        the audio
                 video feature
                  >>>>>>>> that jitsi integrates.
                  >>>>>>>> Unfortunately I still cannot do a proper STUN
                 configuration in order
                  >>>>>>>> to permit two clients placed on different
        networks to
                 properly establish a
                  >>>>>>>> rtp communication.
                  >>>>>>>> On the ICE tab configuration settings i did
        insert
                 only the stun
                  >>>>>>>> server i want to use (stun.l.google.com
        <http://stun.l.google.com>
                 <http://stun.l.google.com>). The server works fine
        (tested with
                  >>>>>>>> winstun on order to see if it translates
        properly my
                 public ip) but once i
                  >>>>>>>> try to establish a phone call the ip released
        on the
                 call are the private ip
                  >>>>>>>> instead of the public one.
                  >>>>>>>> Does anyone have an idea on how to proceed?
                  >>>>>>>>
                  >>>>>>>> Thanks in advance
                  >>>>>>>> Regards
                  >>>>>>>> Giorgio
                  >>>>>>>>
                  >>>>>>>> _________________________________________________
                  >>>>>>>> users mailing list
                  >>>>>>>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>>>>>> Unsubscribe instructions and other list options:
                  >>>>>>>>
        http://lists.jitsi.org/__mailman/listinfo/users
        <http://lists.jitsi.org/mailman/listinfo/users>
                  >>>>>>>
                  >>>>>>> _________________________________________________
                  >>>>>>> users mailing list
                  >>>>>>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>>>>> Unsubscribe instructions and other list options:
                  >>>>>>>
        http://lists.jitsi.org/__mailman/listinfo/users
        <http://lists.jitsi.org/mailman/listinfo/users>
                  >>>>>>
                  >>>>>> _________________________________________________
                  >>>>>> users mailing list
                  >>>>>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>>>> Unsubscribe instructions and other list options:
                  >>>>>> http://lists.jitsi.org/__mailman/listinfo/users
        <http://lists.jitsi.org/mailman/listinfo/users>
                  >>>>>
                  >>>>> _________________________________________________
                  >>>>> users mailing list
                  >>>>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>>> Unsubscribe instructions and other list options:
                  >>>>> http://lists.jitsi.org/__mailman/listinfo/users
        <http://lists.jitsi.org/mailman/listinfo/users>
                  >>>>
                  >>>> _________________________________________________
                  >>>> users mailing list
                  >>>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>> Unsubscribe instructions and other list options:
                  >>>> http://lists.jitsi.org/__mailman/listinfo/users
        <http://lists.jitsi.org/mailman/listinfo/users>
                  >>>
                  >>> _________________________________________________
                  >>> users mailing list
                  >>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>> Unsubscribe instructions and other list options:
                  >>> http://lists.jitsi.org/__mailman/listinfo/users
        <http://lists.jitsi.org/mailman/listinfo/users>
                  >
                  > _________________________________________________
                  > users mailing list
                  > users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  > Unsubscribe instructions and other list options:
                  > http://lists.jitsi.org/__mailman/listinfo/users
        <http://lists.jitsi.org/mailman/listinfo/users>

                 --
                 Emil Ivov, Ph.D. 67000 Strasbourg,
                 Project Lead France
                 Jitsi
        emcho@jitsi.org <mailto:emcho@jitsi.org> <mailto:emcho@jitsi.org
        <mailto:emcho@jitsi.org>>
                   PHONE: +33.1.77.62.43.30 <tel:%2B33.1.77.62.43.30>
        <tel:%2B33.1.77.62.43.30>
        https://jitsi.org FAX: +33.1.77.62.47.31
        <tel:%2B33.1.77.62.47.31>
                 <tel:%2B33.1.77.62.47.31>

                 _________________________________________________
                 users mailing list
        users@jitsi.org <mailto:users@jitsi.org> <mailto:users@jitsi.org
        <mailto:users@jitsi.org>>
                 Unsubscribe instructions and other list options:
        http://lists.jitsi.org/__mailman/listinfo/users
        <http://lists.jitsi.org/mailman/listinfo/users>

        _________________________________________________
        users mailing list
        users@jitsi.org <mailto:users@jitsi.org>
        Unsubscribe instructions and other list options:
        http://lists.jitsi.org/__mailman/listinfo/users
        <http://lists.jitsi.org/mailman/listinfo/users>

    --
    https://jitsi.org

--
https://jitsi.org


#16

Hi,

I presume you are talking of STUN over XMPP and not SIP.

If I recall correctly, Jitsi was to get SIP STUN implemented in September.
Has that timeline been pushed forward again?

Cheers

···

On Wed, Oct 23, 2013 at 2:30 PM, Emil Ivov <emcho@jitsi.org> wrote:

(CC-ing dev. Let's keep this on the list so that others could benefit the
same issues occur elsewhere).

On 23.10.13, 15:12, Giorgio Catena wrote:

ok emil i'll do other checks.

Cool, don't hesitate if you have questions there.

The udp are correctly opened afaik.

Well, you'd best have a look through Wireshark. That could very well
explain the behaviour you describe.

Ok

which port does the jitsi stun work?

Jitsi uses ports 5000 to 6000 for media. STUN checks are sent on the media
ports. Wireshark recognizes them as such so you should be able to filter
them out pretty easily.

I'd provide logs asap. Do you

know anyone I could ask to crosscheck jinglenodes?

Well, the easiest would have been to connect to our jit.si server and
then compare Jitsi behaviour between that and your Openfire installation.

Also, after starting Jitsi and connecting to your accounts you should see
something like this in your logs:

11:17:09.962 INFO: [139] impl.protocol.jabber.**
JingleNodesServiceDiscovery.**run().128 Jingle Nodes discovery terminated!
11:17:09.963 INFO: [139] impl.protocol.jabber.**
JingleNodesServiceDiscovery.**run().129 Found 1 Jingle Nodes relay for
account: emcho@jit.si in 989 ms.

If you don't see this then your Jingle Nodes Plugin is not properly
connected to Openfire. If you do, but things still don't work, then the
relay is properly initialized but Jitsi is unable to verify connectivity
when establishing a call (which would be the case if your firewall is
blocking stuff).

Hope this helps,
Emil

Il 23/ott/2013 14:58 "Emil Ivov" <emcho@jitsi.org >> <mailto:emcho@jitsi.org>> ha scritto:

    Hey Giorgio,

    On 23.10.13, 09:12, Giorgio Catena wrote:

        Hi,
        as requested I'm going to describe the configuration we are
        using and
        that is giving us problems trying to use jitsi to do a call from
        our lan
        to an external client (that in our tests is using a wi-fi umts
        modem)
        and - or viceversa.
        The XMPP - Openfire server is a windows box with 2 nics both
        with public
        ip address as requested from jinglenodes and stun to work. The
        machine
        is reachable on the same pubblic addresses from the inside LAN.
        There is only a firewall protecting the machine from the public
        access
        no NAT is in place.

    You mean there's a firewall in front of Openfire? Could it be
    blocking incoming UDP sessions? You might want to check that out.

        Trying to use Spark or Jitsi with the STUN option enabled
        (inserting the
        primary ip, port 3478) the client cannot instantiate the
connection.
        Trying to use Jitsi with jinglenodes (enabled the jinglenodes
        module,
        don't know if it works, it says public ip cannot be verified, I
        saw on
        the code that to verify it it should point to a stun server that
        is not
        answering, maybe that this is the cause) the clients cannot
        connect each
        other, the call is made but once the other client answer no audio
or
        video are sent.
        Trying to use spark with webrtc plugin (xmpp signaling on the
        openfire
        server + WEBRTC for RTP communication) the clients start the A/V
        session
        properly. What I noticed is that the WEBRTC plugin made by Dele
        Oljiade
        has hardcoded in the jar the reference to the stun.l.google.com
        <http://stun.l.google.com>
        <http://stun.l.google.com> STUN server (port 19302).

    Jitsi also comes with a preconfigured STUN server (stun.jitsi.net
    <http://stun.jitsi.net>). Maybe it is also blocked?

        At this point I
        decided to do is to exclude the XMPP server from the relay role
        and-or
        jinglenodes role trying to use the Google's public available STUN.
        For this reason, I tried to place on the jitsi conf (keeping
        obviously
        the same testing configuration) the reference to the IP of
        Google's STUN
        server.
        Before doing that i did cross chek the correct behaviour of the
        google's
        stun server on both client using winstun and the result are ok,
the
        public addresses are correctly translated as expected.
        I inserted that STUN address on the jitsi configuration of both
        Jitsi
        client disabling all the options (included autodiscovery and
        jinglenodes), trying to do the call nothing happens (same
behaviour
        noticed with jinglenodes enablad).

    Have you checked if Jitsi's STUN Binding Requests reach the server
    and whether they get answered?

        If I look at the connection
        properties during the call I see that even if stun server is in
the
        configuration the ip of the parties involved in the call are the
        private
        ip not the public. It seems that i think stun settings are for
some
        reason not saved and - or used but I cannot understand why.

    Or maybe the STUN queries are not succeeding.

        Do you want me to provide the log with both jinglenodes and stun
        attempts?

    That would help although I can't promise at what point people would
    be able to look through them. You may want to check out the
    questions above too.

    Emil

        Regards.

        2013/10/22 Giorgio Catena <thechain1974@gmail.com
        <mailto:thechain1974@gmail.com**>
        <mailto:thechain1974@gmail.com <mailto:thechain1974@gmail.com**
>__>>

             Hi emil tomorrow i'll provide logs with jinglenodes setup
        and stun.
             The idea to recompile jinglenodes was given from thiago the
        main
             jinglenodes developer. I can also try to provide some more
        details
             regarding our network specs.
             Thanks again

             Il 22/ott/2013 17:53 "Emil Ivov" <emcho@jitsi.org
        <mailto:emcho@jitsi.org>
             <mailto:emcho@jitsi.org <mailto:emcho@jitsi.org>>> ha
scritto:

                 Hey Giorgio,

                 On Tue, Oct 22, 2013 at 1:35 PM, Giorgio Catena >> <thechain1974@gmail.com <mailto:thechain1974@gmail.com** >> > >> <mailto:thechain1974@gmail.com >> <mailto:thechain1974@gmail.com**>__>> wrote:
                  > Well to be sincere i do have a problem trying to
        open jit.si <http://jit.si>
                 <http://jit.si> connection from
                  > our inside lan. The security dept did not accept to
        open it....

                 That's unfortunate. However, if outbound tcp
        connections are
                 forbidden
                 by your network, then that could also explain your
        problems.
                 Obviously
                 I am speculating. I don't know anything about your
        network or your
                 testbed, so it is quite hard to provide meaningful help.

                  > What makes me mad is that jinglenodes seems so
        simple to use
                 that i cannt
                  > understand why it does not work.

                 You can try. First you need to find out whether Jitsi
        allocates
                 Jingle
                 Nodes addresses, then you can check whether it attempts
        to run ICE
                 checks through it.

                  > I'm also trying to setup a dedicated linux
                  > box, with xmpp-jinglenodes recompiled from the git
        source. It
                 binds to xmpp
                  > server but after that simply goes in timeout.

                 The openfire plugin generally works quite nice. If it
        isn't working
                 for you, I'd be more inclined to look at the network
        rather than try
                 and recompile jingle nodes.

                  > What i cannt understand if why
                  > in the same config of the jitsi client (only stun
        written in
                 the conf) the
                  > webrtc test client works (can do rtp call using xmpp
                 signaling) and jitsi
                  > fails.

                 There could be many reasons. Are you connecting the
        exact same two
                 hosts using the same STUN server? Can we see the logs?

                 Emil
                  >
                  >
                  >
                  >
                  > 2013/10/22 Giorgio Catena <thechain1974@gmail.com
        <mailto:thechain1974@gmail.com**>
                 <mailto:thechain1974@gmail.com
        <mailto:thechain1974@gmail.com**>__>>
                  >>
                  >> No problem i'll do it now.. :slight_smile:
                  >>
                  >> Il 22/ott/2013 13:23 "Emil Ivov" <emcho@jitsi.org
        <mailto:emcho@jitsi.org>
                 <mailto:emcho@jitsi.org <mailto:emcho@jitsi.org>>> ha
        scritto:
                  >>
                  >>> It would mean that you are doing something wrong
        and it
                 would help us
                  >>> help you. Creating an accout will take you all of
        ten seconds.
                  >>>
                  >>> If you don't want to do this then fine, I just
        thought you
                 were asking
                  >>> for help.
                  >>>
                  >>> --sent from my mobile
                  >>>
                  >>> On 22 Oct 2013 13:18, "Giorgio Catena" >> <thechain1974@gmail.com <mailto:thechain1974@gmail.com** >> > >> <mailto:thechain1974@gmail.com >> <mailto:thechain1974@gmail.com**>__>> wrote:
                  >>>>
                  >>>> I do have to create the account. In case it would
        work
                 what should it
                  >>>> mean? Due to the fact i have to use my OF server
        i'm going
                 to test all with
                  >>>> it.
                  >>>> Could you provide me the setting I should use
        with OF-
                 STUN and so on?
                  >>>> Maybe i'm doing something wrong.
                  >>>>
                  >>>> Regards
                  >>>>
                  >>>>
                  >>>> 2013/10/22 Emil Ivov <emcho@jitsi.org
        <mailto:emcho@jitsi.org>
                 <mailto:emcho@jitsi.org <mailto:emcho@jitsi.org>>>
                  >>>>>
                  >>>>> Can you establish a connection using two Jitsi
        instances
                 with *default*
                  >>>>> configuration and jit.si <http://jit.si>
        <http://jit.si> accounts?
                  >>>>>
                  >>>>> --sent from my mobile
                  >>>>>
                  >>>>> On 22 Oct 2013 12:56, "Giorgio Catena" >> <thechain1974@gmail.com <mailto:thechain1974@gmail.com** >> > >> <mailto:thechain1974@gmail.com >> <mailto:thechain1974@gmail.com**>__>> wrote:
                  >>>>>>
                  >>>>>> Hi, the jinglenodes plugin simply does not
        work. I've
                 already tried
                  >>>>>> it with no success. A webrtc test client using
        google
                 stun server works
                  >>>>>> fine... could you tell me what fields had to
        be set up?
                   If i leave all the
                  >>>>>> default settings enabled it says ice error...
                  >>>>>>
                  >>>>>> Il 22/ott/2013 12:37 "Emil Ivov"
        <emcho@jitsi.org <mailto:emcho@jitsi.org>
                 <mailto:emcho@jitsi.org <mailto:emcho@jitsi.org>>> ha
        scritto:
                  >>>>>>>
                  >>>>>>> STUN alone is not sufficient for NAT
        traversal. You
                 also need a
                  >>>>>>> relaying mechanism for fallback. With Openfire
        you can
                 use their Jingle
                  >>>>>>> Nodes plugin.
                  >>>>>>>
                  >>>>>>> Make sure however that you run Jitsi with its
        default
                 configuration.
                  >>>>>>> (You may want to delete the conifg folder if
        you've
                 experimented eith the
                  >>>>>>> settings)
                  >>>>>>>
                  >>>>>>> Emil
                  >>>>>>>
                  >>>>>>> --sent from my mobile
                  >>>>>>>
                  >>>>>>> On 22 Oct 2013 12:29, "Giorgio Catena"
                 <thechain1974@gmail.com <mailto:thechain1974@gmail.com**
>
        <mailto:thechain1974@gmail.com <mailto:thechain1974@gmail.com**
>__>>
                  >>>>>>> wrote:
                  >>>>>>>>
                  >>>>>>>> Hello everyone,
                  >>>>>>>> i'm struggling trying to use jitsi as a
        client for my
                 openfire
                  >>>>>>>> installation in place of the spark client.
                  >>>>>>>> Our interest is to use the videobridge and
        the audio
                 video feature
                  >>>>>>>> that jitsi integrates.
                  >>>>>>>> Unfortunately I still cannot do a proper STUN
                 configuration in order
                  >>>>>>>> to permit two clients placed on different
        networks to
                 properly establish a
                  >>>>>>>> rtp communication.
                  >>>>>>>> On the ICE tab configuration settings i did
        insert
                 only the stun
                  >>>>>>>> server i want to use (stun.l.google.com
        <http://stun.l.google.com>
                 <http://stun.l.google.com>). The server works fine
        (tested with
                  >>>>>>>> winstun on order to see if it translates
        properly my
                 public ip) but once i
                  >>>>>>>> try to establish a phone call the ip released
        on the
                 call are the private ip
                  >>>>>>>> instead of the public one.
                  >>>>>>>> Does anyone have an idea on how to proceed?
                  >>>>>>>>
                  >>>>>>>> Thanks in advance
                  >>>>>>>> Regards
                  >>>>>>>> Giorgio
                  >>>>>>>>
                  >>>>>>>> ______________________________**
___________________
                  >>>>>>>> users mailing list
                  >>>>>>>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>>>>>> Unsubscribe instructions and other list
options:
                  >>>>>>>>
        http://lists.jitsi.org/__**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >>>>>>>
                  >>>>>>>
                  >>>>>>> ______________________________**
___________________
                  >>>>>>> users mailing list
                  >>>>>>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>>>>> Unsubscribe instructions and other list options:
                  >>>>>>>
        http://lists.jitsi.org/
mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >>>>>>
                  >>>>>>
                  >>>>>> ______________________________**
___________________
                  >>>>>> users mailing list
                  >>>>>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>>>> Unsubscribe instructions and other list options:
                  >>>>>> http://lists.jitsi.org/

mailman/listinfo/users <http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >>>>>
                  >>>>>
                  >>>>> ______________________________**
___________________
                  >>>>> users mailing list
                  >>>>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>>> Unsubscribe instructions and other list options:
                  >>>>> http://lists.jitsi.org/
**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >>>>
                  >>>>
                  >>>>
                  >>>> ______________________________**
___________________
                  >>>> users mailing list
                  >>>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>> Unsubscribe instructions and other list options:
                  >>>> http://lists.jitsi.org/
**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >>>
                  >>>
                  >>> ______________________________**___________________
                  >>> users mailing list
                  >>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>> Unsubscribe instructions and other list options:
                  >>> http://lists.jitsi.org/
**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >
                  >
                  >
                  > ______________________________**___________________
                  > users mailing list
                  > users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  > Unsubscribe instructions and other list options:
                  > http://lists.jitsi.org/
**mailman/listinfo/users<http://lists.jitsi.org/__mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>

                 --
                 Emil Ivov, Ph.D. 67000 Strasbourg,
                 Project Lead France
                 Jitsi
        emcho@jitsi.org <mailto:emcho@jitsi.org> <mailto:emcho@jitsi.org
        <mailto:emcho@jitsi.org>>
                   PHONE: +33.1.77.62.43.30 <tel:%2B33.1.77.62.43.30>
        <tel:%2B33.1.77.62.43.30>
        https://jitsi.org FAX: +33.1.77.62.47.31
        <tel:%2B33.1.77.62.47.31>
                 <tel:%2B33.1.77.62.47.31>

                 ______________________________**___________________
                 users mailing list
        users@jitsi.org <mailto:users@jitsi.org> <mailto:users@jitsi.org
        <mailto:users@jitsi.org>>
                 Unsubscribe instructions and other list options:
        http://lists.jitsi.org/__**mailman/listinfo/users<http://lists.jitsi.org/__mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>

        ______________________________**___________________
        users mailing list
        users@jitsi.org <mailto:users@jitsi.org>
        Unsubscribe instructions and other list options:
        http://lists.jitsi.org/__**mailman/listinfo/users<http://lists.jitsi.org/__mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>

    --
    https://jitsi.org

--
https://jitsi.org

______________________________**_________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/**mailman/listinfo/dev<http://lists.jitsi.org/mailman/listinfo/dev>


#17

Please send messages to the list and don't mail me privately.

--sent from my mobile

···

---------- Forwarded message ----------
From: "Emil Ivov" <emcho@jitsi.org>
Date: 26 Oct 2013 01:49
Subject: Re: [jitsi-users] Jitsi - Openfire - STUN settings
To: "Giorgio Catena" <thechain1974@gmail.com>
Cc:

Why do you turn off any options? Just leave the defaults

Also, have you tried to inspect traffic with wireshark?

--sent from my mobile
On 25 Oct 2013 11:35, "Giorgio Catena" <thechain1974@gmail.com> wrote:

Hi ,
I was able to do some other cross checks and i looked at the logs.
The test configuration is this:

- Test Laptop placed outside the network and browsing by a wifi ikey
- Openfire XMPP Server placed on our idc network and set up with a public
ip , on the firewall range 3000-5000 UDP opened to any in both directions
as specified.
- Client inside the LAN that connecto to the xmpp using the same public
address of the test laptop.
On both the clients in the ICE tab i turned off all the options leaving
on only the one that enables jinglenodes writing in the list the ip of the
server (that has the jinglenodes module enabled) and enabling it to the
relay.
As already said the server do not present the green thick doing the check
with the jinglenodes module, so my perception is that jinglenodes does not
work or that there is something broken somewhere.
I do attach the logs of the caller and of the receiver in this situation.
AFAIS the attempt con contact jingle made by the external node is failed
maybe due to the module not working properly or to something that do no
permit the pc to contact the jinglenodes server.
Maybe something on the network connection is no ok but the network admin
says nothing is blocked on the specified ports for the jinglenodes module.

If anyone could help.....
thanks

2013/10/23 Giorgio Catena <thechain1974@gmail.com>

Ok Emil i'll do the tests asap i can. Thanks for the help given until
now.
Il 23/ott/2013 15:30 "Emil Ivov" <emcho@jitsi.org> ha scritto:

(CC-ing dev. Let's keep this on the list so that others could benefit

the same issues occur elsewhere).

On 23.10.13, 15:12, Giorgio Catena wrote:

ok emil i'll do other checks.

Cool, don't hesitate if you have questions there.

The udp are correctly opened afaik.

Well, you'd best have a look through Wireshark. That could very well
explain the behaviour you describe.

Ok

which port does the jitsi stun work?

Jitsi uses ports 5000 to 6000 for media. STUN checks are sent on the
media ports. Wireshark recognizes them as such so you should be able to
filter them out pretty easily.

I'd provide logs asap. Do you

know anyone I could ask to crosscheck jinglenodes?

Well, the easiest would have been to connect to our jit.si server and
then compare Jitsi behaviour between that and your Openfire installation.

Also, after starting Jitsi and connecting to your accounts you should
see something like this in your logs:

11:17:09.962 INFO: [139] impl.protocol.jabber.**
JingleNodesServiceDiscovery.**run().128 Jingle Nodes discovery
terminated!
11:17:09.963 INFO: [139] impl.protocol.jabber.**
JingleNodesServiceDiscovery.**run().129 Found 1 Jingle Nodes relay for
account: emcho@jit.si in 989 ms.

If you don't see this then your Jingle Nodes Plugin is not properly
connected to Openfire. If you do, but things still don't work, then the
relay is properly initialized but Jitsi is unable to verify connectivity
when establishing a call (which would be the case if your firewall is
blocking stuff).

Hope this helps,
Emil

Il 23/ott/2013 14:58 "Emil Ivov" <emcho@jitsi.org >>>>> <mailto:emcho@jitsi.org>> ha scritto:

    Hey Giorgio,

    On 23.10.13, 09:12, Giorgio Catena wrote:

        Hi,
        as requested I'm going to describe the configuration we are
        using and
        that is giving us problems trying to use jitsi to do a call
from
        our lan
        to an external client (that in our tests is using a wi-fi umts
        modem)
        and - or viceversa.
        The XMPP - Openfire server is a windows box with 2 nics both
        with public
        ip address as requested from jinglenodes and stun to work. The
        machine
        is reachable on the same pubblic addresses from the inside LAN.
        There is only a firewall protecting the machine from the public
        access
        no NAT is in place.

    You mean there's a firewall in front of Openfire? Could it be
    blocking incoming UDP sessions? You might want to check that out.

        Trying to use Spark or Jitsi with the STUN option enabled
        (inserting the
        primary ip, port 3478) the client cannot instantiate the
connection.
        Trying to use Jitsi with jinglenodes (enabled the jinglenodes
        module,
        don't know if it works, it says public ip cannot be verified, I
        saw on
        the code that to verify it it should point to a stun server
that
        is not
        answering, maybe that this is the cause) the clients cannot
        connect each
        other, the call is made but once the other client answer no
audio or
        video are sent.
        Trying to use spark with webrtc plugin (xmpp signaling on the
        openfire
        server + WEBRTC for RTP communication) the clients start the
A/V
        session
        properly. What I noticed is that the WEBRTC plugin made by Dele
        Oljiade
        has hardcoded in the jar the reference to the
stun.l.google.com
        <http://stun.l.google.com>
        <http://stun.l.google.com> STUN server (port 19302).

    Jitsi also comes with a preconfigured STUN server (stun.jitsi.net
    <http://stun.jitsi.net>). Maybe it is also blocked?

        At this point I
        decided to do is to exclude the XMPP server from the relay role
        and-or
        jinglenodes role trying to use the Google's public available
STUN.
        For this reason, I tried to place on the jitsi conf (keeping
        obviously
        the same testing configuration) the reference to the IP of
        Google's STUN
        server.
        Before doing that i did cross chek the correct behaviour of the
        google's
        stun server on both client using winstun and the result are
ok, the
        public addresses are correctly translated as expected.
        I inserted that STUN address on the jitsi configuration of both
        Jitsi
        client disabling all the options (included autodiscovery and
        jinglenodes), trying to do the call nothing happens (same
behaviour
        noticed with jinglenodes enablad).

    Have you checked if Jitsi's STUN Binding Requests reach the server
    and whether they get answered?

        If I look at the connection
        properties during the call I see that even if stun server is
in the
        configuration the ip of the parties involved in the call are
the
        private
        ip not the public. It seems that i think stun settings are for
some
        reason not saved and - or used but I cannot understand why.

    Or maybe the STUN queries are not succeeding.

        Do you want me to provide the log with both jinglenodes and
stun
        attempts?

    That would help although I can't promise at what point people would
    be able to look through them. You may want to check out the
    questions above too.

    Emil

        Regards.

        2013/10/22 Giorgio Catena <thechain1974@gmail.com
        <mailto:thechain1974@gmail.com**>
        <mailto:thechain1974@gmail.com <mailto:thechain1974@gmail.com*
*>__>>

             Hi emil tomorrow i'll provide logs with jinglenodes setup
        and stun.
             The idea to recompile jinglenodes was given from thiago
the
        main
             jinglenodes developer. I can also try to provide some
more
        details
             regarding our network specs.
             Thanks again

             Il 22/ott/2013 17:53 "Emil Ivov" <emcho@jitsi.org
        <mailto:emcho@jitsi.org>
             <mailto:emcho@jitsi.org <mailto:emcho@jitsi.org>>> ha
scritto:

                 Hey Giorgio,

                 On Tue, Oct 22, 2013 at 1:35 PM, Giorgio Catena >>>>> <thechain1974@gmail.com <mailto: >>>>> thechain1974@gmail.com**> >>>>> <mailto:thechain1974@gmail.com >>>>> <mailto:thechain1974@gmail.com**>__>> wrote:
                  > Well to be sincere i do have a problem trying to
        open jit.si <http://jit.si>
                 <http://jit.si> connection from
                  > our inside lan. The security dept did not accept to
        open it....

                 That's unfortunate. However, if outbound tcp
        connections are
                 forbidden
                 by your network, then that could also explain your
        problems.
                 Obviously
                 I am speculating. I don't know anything about your
        network or your
                 testbed, so it is quite hard to provide meaningful
help.

                  > What makes me mad is that jinglenodes seems so
        simple to use
                 that i cannt
                  > understand why it does not work.

                 You can try. First you need to find out whether Jitsi
        allocates
                 Jingle
                 Nodes addresses, then you can check whether it
attempts
        to run ICE
                 checks through it.

                  > I'm also trying to setup a dedicated linux
                  > box, with xmpp-jinglenodes recompiled from the git
        source. It
                 binds to xmpp
                  > server but after that simply goes in timeout.

                 The openfire plugin generally works quite nice. If it
        isn't working
                 for you, I'd be more inclined to look at the network
        rather than try
                 and recompile jingle nodes.

                  > What i cannt understand if why
                  > in the same config of the jitsi client (only stun
        written in
                 the conf) the
                  > webrtc test client works (can do rtp call using
xmpp
                 signaling) and jitsi
                  > fails.

                 There could be many reasons. Are you connecting the
        exact same two
                 hosts using the same STUN server? Can we see the logs?

                 Emil
                  >
                  >
                  >
                  >
                  > 2013/10/22 Giorgio Catena <thechain1974@gmail.com
        <mailto:thechain1974@gmail.com**>
                 <mailto:thechain1974@gmail.com
        <mailto:thechain1974@gmail.com**>__>>
                  >>
                  >> No problem i'll do it now.. :slight_smile:
                  >>
                  >> Il 22/ott/2013 13:23 "Emil Ivov" <emcho@jitsi.org
        <mailto:emcho@jitsi.org>
                 <mailto:emcho@jitsi.org <mailto:emcho@jitsi.org>>> ha
        scritto:
                  >>
                  >>> It would mean that you are doing something wrong
        and it
                 would help us
                  >>> help you. Creating an accout will take you all of
        ten seconds.
                  >>>
                  >>> If you don't want to do this then fine, I just
        thought you
                 were asking
                  >>> for help.
                  >>>
                  >>> --sent from my mobile
                  >>>
                  >>> On 22 Oct 2013 13:18, "Giorgio Catena" >>>>> <thechain1974@gmail.com <mailto: >>>>> thechain1974@gmail.com**> >>>>> <mailto:thechain1974@gmail.com >>>>> <mailto:thechain1974@gmail.com**>__>> wrote:
                  >>>>
                  >>>> I do have to create the account. In case it
would
        work
                 what should it
                  >>>> mean? Due to the fact i have to use my OF server
        i'm going
                 to test all with
                  >>>> it.
                  >>>> Could you provide me the setting I should use
        with OF-
                 STUN and so on?
                  >>>> Maybe i'm doing something wrong.
                  >>>>
                  >>>> Regards
                  >>>>
                  >>>>
                  >>>> 2013/10/22 Emil Ivov <emcho@jitsi.org
        <mailto:emcho@jitsi.org>
                 <mailto:emcho@jitsi.org <mailto:emcho@jitsi.org>>>
                  >>>>>
                  >>>>> Can you establish a connection using two Jitsi
        instances
                 with *default*
                  >>>>> configuration and jit.si <http://jit.si>
        <http://jit.si> accounts?
                  >>>>>
                  >>>>> --sent from my mobile
                  >>>>>
                  >>>>> On 22 Oct 2013 12:56, "Giorgio Catena" >>>>> <thechain1974@gmail.com <mailto: >>>>> thechain1974@gmail.com**> >>>>> <mailto:thechain1974@gmail.com >>>>> <mailto:thechain1974@gmail.com**>__>> wrote:
                  >>>>>>
                  >>>>>> Hi, the jinglenodes plugin simply does not
        work. I've
                 already tried
                  >>>>>> it with no success. A webrtc test client
using
        google
                 stun server works
                  >>>>>> fine... could you tell me what fields had to
        be set up?
                   If i leave all the
                  >>>>>> default settings enabled it says ice error...
                  >>>>>>
                  >>>>>> Il 22/ott/2013 12:37 "Emil Ivov"
        <emcho@jitsi.org <mailto:emcho@jitsi.org>
                 <mailto:emcho@jitsi.org <mailto:emcho@jitsi.org>>> ha
        scritto:
                  >>>>>>>
                  >>>>>>> STUN alone is not sufficient for NAT
        traversal. You
                 also need a
                  >>>>>>> relaying mechanism for fallback. With
Openfire
        you can
                 use their Jingle
                  >>>>>>> Nodes plugin.
                  >>>>>>>
                  >>>>>>> Make sure however that you run Jitsi with its
        default
                 configuration.
                  >>>>>>> (You may want to delete the conifg folder if
        you've
                 experimented eith the
                  >>>>>>> settings)
                  >>>>>>>
                  >>>>>>> Emil
                  >>>>>>>
                  >>>>>>> --sent from my mobile
                  >>>>>>>
                  >>>>>>> On 22 Oct 2013 12:29, "Giorgio Catena"
                 <thechain1974@gmail.com <mailto:
thechain1974@gmail.com**>
        <mailto:thechain1974@gmail.com <mailto:thechain1974@gmail.com*
*>__>>
                  >>>>>>> wrote:
                  >>>>>>>>
                  >>>>>>>> Hello everyone,
                  >>>>>>>> i'm struggling trying to use jitsi as a
        client for my
                 openfire
                  >>>>>>>> installation in place of the spark client.
                  >>>>>>>> Our interest is to use the videobridge and
        the audio
                 video feature
                  >>>>>>>> that jitsi integrates.
                  >>>>>>>> Unfortunately I still cannot do a proper
STUN
                 configuration in order
                  >>>>>>>> to permit two clients placed on different
        networks to
                 properly establish a
                  >>>>>>>> rtp communication.
                  >>>>>>>> On the ICE tab configuration settings i did
        insert
                 only the stun
                  >>>>>>>> server i want to use (stun.l.google.com
        <http://stun.l.google.com>
                 <http://stun.l.google.com>). The server works fine
        (tested with
                  >>>>>>>> winstun on order to see if it translates
        properly my
                 public ip) but once i
                  >>>>>>>> try to establish a phone call the ip
released
        on the
                 call are the private ip
                  >>>>>>>> instead of the public one.
                  >>>>>>>> Does anyone have an idea on how to proceed?
                  >>>>>>>>
                  >>>>>>>> Thanks in advance
                  >>>>>>>> Regards
                  >>>>>>>> Giorgio
                  >>>>>>>>
                  >>>>>>>> ______________________________**
___________________
                  >>>>>>>> users mailing list
                  >>>>>>>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>>>>>> Unsubscribe instructions and other list
options:
                  >>>>>>>>
        http://lists.jitsi.org/__mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >>>>>>>
                  >>>>>>>
                  >>>>>>> ______________________________**
___________________
                  >>>>>>> users mailing list
                  >>>>>>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>>>>> Unsubscribe instructions and other list
options:
                  >>>>>>>
        http://lists.jitsi.org/
mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >>>>>>
                  >>>>>>
                  >>>>>> ______________________________**
___________________
                  >>>>>> users mailing list
                  >>>>>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>>>> Unsubscribe instructions and other list
options:
                  >>>>>> http://lists.jitsi.org/

mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >>>>>
                  >>>>>
                  >>>>> ______________________________**
___________________
                  >>>>> users mailing list
                  >>>>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>>> Unsubscribe instructions and other list
options:
                  >>>>> http://lists.jitsi.org/

mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >>>>
                  >>>>
                  >>>>
                  >>>> ______________________________**
___________________
                  >>>> users mailing list
                  >>>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>> Unsubscribe instructions and other list options:
                  >>>> http://lists.jitsi.org/
**
mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >>>
                  >>>
                  >>> ______________________________**
___________________
                  >>> users mailing list
                  >>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>> Unsubscribe instructions and other list options:
                  >>> http://lists.jitsi.org/
**
mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >
                  >
                  >
                  > ______________________________**
___________________
                  > users mailing list
                  > users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  > Unsubscribe instructions and other list options:
                  > http://lists.jitsi.org/
**mailman/listinfo/users<http://lists.jitsi.org/__mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>

                 --
                 Emil Ivov, Ph.D. 67000
Strasbourg,
                 Project Lead France
                 Jitsi
        emcho@jitsi.org <mailto:emcho@jitsi.org> <mailto:
emcho@jitsi.org
        <mailto:emcho@jitsi.org>>
                   PHONE: +33.1.77.62.43.30 <tel:%2B33.1.77.62.43.30>
        <tel:%2B33.1.77.62.43.30>
        https://jitsi.org FAX: +33.1.77.62.47.31
        <tel:%2B33.1.77.62.47.31>
                 <tel:%2B33.1.77.62.47.31>

                 ______________________________**___________________
                 users mailing list
        users@jitsi.org <mailto:users@jitsi.org> <mailto:
users@jitsi.org
        <mailto:users@jitsi.org>>
                 Unsubscribe instructions and other list options:
        http://lists.jitsi.org/__**mailman/listinfo/users<http://lists.jitsi.org/__mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>

        ______________________________**___________________
        users mailing list
        users@jitsi.org <mailto:users@jitsi.org>
        Unsubscribe instructions and other list options:
        http://lists.jitsi.org/__**mailman/listinfo/users<http://lists.jitsi.org/__mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>

    --
    https://jitsi.org

--
https://jitsi.org


#18

(adding the dev list in CC so that everyone can follow)

Thanks for your feedback Giorgio!

Very glad to know that things are now working for you!

···

On Tue, Oct 29, 2013 at 6:14 PM, Giorgio Catena <thechain1974@gmail.com>wrote:

Hi everyone,
At the end we found probably what the problem was... And it seems that now
the connections from clients behin different private lan works fine using
ice plus openfire jinglenodes plugin... there were problems on udp
publications... thanks again everyone for the help.
Giorgio
Il 29/ott/2013 08:51 "Giorgio Catena" <thechain1974@gmail.com> ha scritto:

Hi,

Thanks for the answer. I beg your pardon it was not my intento to be
unpolite in any or to ask you a "free" help support.
I'll try to do what you suggest, the doubts I tried to expone probably
not in the correct way are due to a research made on the net where it was
described that not all the option had to be turned on.
I thought that by mailing list (sorry again if I write you privately it
was not my intent) I could have clarifications on this.
Thanks again for the help by now. I'll send you, in case i will be
enabled to access to jit.si, the results of the tests.

regards

2013/10/29 Emil Ivov <emcho@jitsi.org>

Giorgio,

I have repeatedly asked you not to mail me privately (unless you are
interested in commercial support in which case I can send you a quotation).

Please, if you are interested in getting help, write to the mailing
list. Ignoring my repeated requests to do so is extremely impolite, so
please don't be surprised if you find the rest of my mail a bit coarse.

Also, please try to take into account the fact that people (including
myself) are trying to help you on their free time, so you might want to pay
attention to what they say and make the process as painless as possible for
them rather than simply choosing pay attention to random parts of their
answers and ignore others.

For example: I have repeatedly asked you to simply run Jitsi with its
*default* configuration. Clearly, you do not understand the meaning of the
various NAT traversal options and the way the corresponding mechanisms
work. That's perfectly OK, you are not expected to. However in that case,
please stop changing the configuration for no good reason. In order to
revert to the Jitsi defaults, you simply need to delete your existing
accounts and create them again.

If you feel you might have modified things outside the account
configuration then please quit the application, delete your entire Jitsi
profile directory and then start again. Here's where you can find it:

https://jitsi.org/Documentation/FAQ#jitsi-home
(simply rename the entire directory)

Finally, it would be extremely useful, for you, to simply get your
network administrators to allow you access to jit.si in order to
experiment with a working server installation. Given your random
modifications of the Jitsi configuration, I am inclined to think that you
may also be disregarding important factors in the Openfire configuration.

To sum it up. If you can't try a default Jitsi installation with a
jit.si account, then I won't be able to provide any further help. I
have no time to waste fighting with your network administration policies so
you'd need to make sure that this is fixed.

Emil

On Tue, Oct 29, 2013 at 8:08 AM, Giorgio Catena <thechain1974@gmail.com>wrote:

Hi Emil,
as far aas I can say, the first thing I do really need now is the
correct setup in two cases:

Jitsi + Jinglenodes / Openfire -> which are the fields on the ICE tab
to enable?
Jitsi + STUN/TURN / Openfire -> which are the fields on the ICE tab to
enable?

Once I knoww that on the client side the set up is correct I can try to
debug what's going wrong with my XMPP Server . This was the main reason of
the post. I'm not sure on how to set up the to configurations.

Regards

Giorgio

2013/10/28 Emil Ivov <emcho@jitsi.org>

Hey Giorgio,

You seem to be insisting on private communication. Would this mean
that you would be interested purchasing a support package from us?

Also, please use the default settings as already advised.

You seem to have disabled ICE, which basically means that you have
disabled NAT traversal. There is no way things can work that way so you
have simply been wasting time.

--sent from my mobile
On 28 Oct 2013 14:05, "Giorgio Catena" <thechain1974@gmail.com> wrote:

Hi,
this is the client config on both sides as reading around this shoudl
be correct:

[image: Immagine in linea 4]

I attach the pcap obtained using wireshark. What is strange is that i
cannot see any attempt to contact the jitsi servers, it simply try to
contact by udp directly the private ip of the other side (behind nat).
I simply does not understand what's going wrong.

regards

2013/10/28 Giorgio Catena <thechain1974@gmail.com>

Hi Emil,
leaving all the options on it returns an ICE error, thicking out the
first option the behaviour does not change.
I'll try so set up a wireshark session during my attempts.

Regards

2013/10/26 Emil Ivov <emcho@jitsi.org>

Why do you turn off any options? Just leave the defaults

Also, have you tried to inspect traffic with wireshark?

--sent from my mobile
On 25 Oct 2013 11:35, "Giorgio Catena" <thechain1974@gmail.com> >>>>>>>> wrote:

Hi ,
I was able to do some other cross checks and i looked at the logs.
The test configuration is this:

- Test Laptop placed outside the network and browsing by a wifi
ikey
- Openfire XMPP Server placed on our idc network and set up with a
public ip , on the firewall range 3000-5000 UDP opened to any in both
directions as specified.
- Client inside the LAN that connecto to the xmpp using the same
public address of the test laptop.
On both the clients in the ICE tab i turned off all the options
leaving on only the one that enables jinglenodes writing in the list the ip
of the server (that has the jinglenodes module enabled) and enabling it to
the relay.
As already said the server do not present the green thick doing
the check with the jinglenodes module, so my perception is that jinglenodes
does not work or that there is something broken somewhere.
I do attach the logs of the caller and of the receiver in this
situation.
AFAIS the attempt con contact jingle made by the external node is
failed maybe due to the module not working properly or to something that do
no permit the pc to contact the jinglenodes server.
Maybe something on the network connection is no ok but the network
admin says nothing is blocked on the specified ports for the jinglenodes
module.

If anyone could help.....
thanks

2013/10/23 Giorgio Catena <thechain1974@gmail.com>

Ok Emil i'll do the tests asap i can. Thanks for the help given
until now.
Il 23/ott/2013 15:30 "Emil Ivov" <emcho@jitsi.org> ha scritto:

(CC-ing dev. Let's keep this on the list so that others could

benefit the same issues occur elsewhere).

On 23.10.13, 15:12, Giorgio Catena wrote:

ok emil i'll do other checks.

Cool, don't hesitate if you have questions there.

The udp are correctly opened afaik.

Well, you'd best have a look through Wireshark. That could very
well explain the behaviour you describe.

Ok

which port does the jitsi stun work?

Jitsi uses ports 5000 to 6000 for media. STUN checks are sent on
the media ports. Wireshark recognizes them as such so you should be able to
filter them out pretty easily.

I'd provide logs asap. Do you

know anyone I could ask to crosscheck jinglenodes?

Well, the easiest would have been to connect to our jit.siserver and then compare Jitsi behaviour between that and your Openfire
installation.

Also, after starting Jitsi and connecting to your accounts you
should see something like this in your logs:

11:17:09.962 INFO: [139] impl.protocol.jabber.**
JingleNodesServiceDiscovery.**run().128 Jingle Nodes discovery
terminated!
11:17:09.963 INFO: [139] impl.protocol.jabber.**
JingleNodesServiceDiscovery.**run().129 Found 1 Jingle Nodes
relay for account: emcho@jit.si in 989 ms.

If you don't see this then your Jingle Nodes Plugin is not
properly connected to Openfire. If you do, but things still don't work,
then the relay is properly initialized but Jitsi is unable to verify
connectivity when establishing a call (which would be the case if your
firewall is blocking stuff).

Hope this helps,
Emil

Il 23/ott/2013 14:58 "Emil Ivov" <emcho@jitsi.org >>>>>>>>>>>> <mailto:emcho@jitsi.org>> ha scritto:

    Hey Giorgio,

    On 23.10.13, 09:12, Giorgio Catena wrote:

        Hi,
        as requested I'm going to describe the configuration we
are
        using and
        that is giving us problems trying to use jitsi to do a
call from
        our lan
        to an external client (that in our tests is using a
wi-fi umts
        modem)
        and - or viceversa.
        The XMPP - Openfire server is a windows box with 2 nics
both
        with public
        ip address as requested from jinglenodes and stun to
work. The
        machine
        is reachable on the same pubblic addresses from the
inside LAN.
        There is only a firewall protecting the machine from
the public
        access
        no NAT is in place.

    You mean there's a firewall in front of Openfire? Could it
be
    blocking incoming UDP sessions? You might want to check
that out.

        Trying to use Spark or Jitsi with the STUN option
enabled
        (inserting the
        primary ip, port 3478) the client cannot instantiate
the connection.
        Trying to use Jitsi with jinglenodes (enabled the
jinglenodes
        module,
        don't know if it works, it says public ip cannot be
verified, I
        saw on
        the code that to verify it it should point to a stun
server that
        is not
        answering, maybe that this is the cause) the clients
cannot
        connect each
        other, the call is made but once the other client
answer no audio or
        video are sent.
        Trying to use spark with webrtc plugin (xmpp signaling
on the
        openfire
        server + WEBRTC for RTP communication) the clients
start the A/V
        session
        properly. What I noticed is that the WEBRTC plugin made
by Dele
        Oljiade
        has hardcoded in the jar the reference to the
stun.l.google.com
        <http://stun.l.google.com>
        <http://stun.l.google.com> STUN server (port 19302).

    Jitsi also comes with a preconfigured STUN server (
stun.jitsi.net
    <http://stun.jitsi.net>). Maybe it is also blocked?

        At this point I
        decided to do is to exclude the XMPP server from the
relay role
        and-or
        jinglenodes role trying to use the Google's public
available STUN.
        For this reason, I tried to place on the jitsi conf
(keeping
        obviously
        the same testing configuration) the reference to the IP
of
        Google's STUN
        server.
        Before doing that i did cross chek the correct
behaviour of the
        google's
        stun server on both client using winstun and the result
are ok, the
        public addresses are correctly translated as expected.
        I inserted that STUN address on the jitsi configuration
of both
        Jitsi
        client disabling all the options (included
autodiscovery and
        jinglenodes), trying to do the call nothing happens
(same behaviour
        noticed with jinglenodes enablad).

    Have you checked if Jitsi's STUN Binding Requests reach the
server
    and whether they get answered?

        If I look at the connection
        properties during the call I see that even if stun
server is in the
        configuration the ip of the parties involved in the
call are the
        private
        ip not the public. It seems that i think stun settings
are for some
        reason not saved and - or used but I cannot understand
why.

    Or maybe the STUN queries are not succeeding.

        Do you want me to provide the log with both jinglenodes
and stun
        attempts?

    That would help although I can't promise at what point
people would
    be able to look through them. You may want to check out the
    questions above too.

    Emil

        Regards.

        2013/10/22 Giorgio Catena <thechain1974@gmail.com
        <mailto:thechain1974@gmail.com**>
        <mailto:thechain1974@gmail.com <mailto:
thechain1974@gmail.com**>__>>

             Hi emil tomorrow i'll provide logs with
jinglenodes setup
        and stun.
             The idea to recompile jinglenodes was given from
thiago the
        main
             jinglenodes developer. I can also try to provide
some more
        details
             regarding our network specs.
             Thanks again

             Il 22/ott/2013 17:53 "Emil Ivov" <emcho@jitsi.org >>>>>>>>>>>> <mailto:emcho@jitsi.org> >>>>>>>>>>>> <mailto:emcho@jitsi.org <mailto:emcho@jitsi.org>>> >>>>>>>>>>>> ha scritto:

                 Hey Giorgio,

                 On Tue, Oct 22, 2013 at 1:35 PM, Giorgio Catena >>>>>>>>>>>> <thechain1974@gmail.com <mailto: >>>>>>>>>>>> thechain1974@gmail.com**> >>>>>>>>>>>> <mailto:thechain1974@gmail.com >>>>>>>>>>>> <mailto:thechain1974@gmail.com**>__>> wrote:
                  > Well to be sincere i do have a problem
trying to
        open jit.si <http://jit.si>
                 <http://jit.si> connection from
                  > our inside lan. The security dept did not
accept to
        open it....

                 That's unfortunate. However, if outbound tcp
        connections are
                 forbidden
                 by your network, then that could also explain
your
        problems.
                 Obviously
                 I am speculating. I don't know anything about
your
        network or your
                 testbed, so it is quite hard to provide
meaningful help.

                  > What makes me mad is that jinglenodes seems
so
        simple to use
                 that i cannt
                  > understand why it does not work.

                 You can try. First you need to find out
whether Jitsi
        allocates
                 Jingle
                 Nodes addresses, then you can check whether it
attempts
        to run ICE
                 checks through it.

                  > I'm also trying to setup a dedicated linux
                  > box, with xmpp-jinglenodes recompiled from
the git
        source. It
                 binds to xmpp
                  > server but after that simply goes in
timeout.

                 The openfire plugin generally works quite
nice. If it
        isn't working
                 for you, I'd be more inclined to look at the
network
        rather than try
                 and recompile jingle nodes.

                  > What i cannt understand if why
                  > in the same config of the jitsi client
(only stun
        written in
                 the conf) the
                  > webrtc test client works (can do rtp call
using xmpp
                 signaling) and jitsi
                  > fails.

                 There could be many reasons. Are you
connecting the
        exact same two
                 hosts using the same STUN server? Can we see
the logs?

                 Emil
                  >
                  >
                  >
                  >
                  > 2013/10/22 Giorgio Catena <
thechain1974@gmail.com
        <mailto:thechain1974@gmail.com**>
                 <mailto:thechain1974@gmail.com
        <mailto:thechain1974@gmail.com**>__>>
                  >>
                  >> No problem i'll do it now.. :slight_smile:
                  >>
                  >> Il 22/ott/2013 13:23 "Emil Ivov" <
emcho@jitsi.org
        <mailto:emcho@jitsi.org>
                 <mailto:emcho@jitsi.org <mailto:
emcho@jitsi.org>>> ha
        scritto:
                  >>
                  >>> It would mean that you are doing
something wrong
        and it
                 would help us
                  >>> help you. Creating an accout will take
you all of
        ten seconds.
                  >>>
                  >>> If you don't want to do this then fine,
I just
        thought you
                 were asking
                  >>> for help.
                  >>>
                  >>> --sent from my mobile
                  >>>
                  >>> On 22 Oct 2013 13:18, "Giorgio Catena" >>>>>>>>>>>> <thechain1974@gmail.com <mailto: >>>>>>>>>>>> thechain1974@gmail.com**> >>>>>>>>>>>> <mailto:thechain1974@gmail.com >>>>>>>>>>>> <mailto:thechain1974@gmail.com**>__>> wrote:
                  >>>>
                  >>>> I do have to create the account. In case
it would
        work
                 what should it
                  >>>> mean? Due to the fact i have to use my
OF server
        i'm going
                 to test all with
                  >>>> it.
                  >>>> Could you provide me the setting I
should use
        with OF-
                 STUN and so on?
                  >>>> Maybe i'm doing something wrong.
                  >>>>
                  >>>> Regards
                  >>>>
                  >>>>
                  >>>> 2013/10/22 Emil Ivov <emcho@jitsi.org
        <mailto:emcho@jitsi.org>
                 <mailto:emcho@jitsi.org <mailto:
emcho@jitsi.org>>>
                  >>>>>
                  >>>>> Can you establish a connection using
two Jitsi
        instances
                 with *default*
                  >>>>> configuration and jit.si <http://jit.si
>
        <http://jit.si> accounts?
                  >>>>>
                  >>>>> --sent from my mobile
                  >>>>>
                  >>>>> On 22 Oct 2013 12:56, "Giorgio Catena" >>>>>>>>>>>> <thechain1974@gmail.com <mailto: >>>>>>>>>>>> thechain1974@gmail.com**> >>>>>>>>>>>> <mailto:thechain1974@gmail.com >>>>>>>>>>>> <mailto:thechain1974@gmail.com**>__>> wrote:
                  >>>>>>
                  >>>>>> Hi, the jinglenodes plugin simply
does not
        work. I've
                 already tried
                  >>>>>> it with no success. A webrtc test
client using
        google
                 stun server works
                  >>>>>> fine... could you tell me what fields
had to
        be set up?
                   If i leave all the
                  >>>>>> default settings enabled it says ice
error...
                  >>>>>>
                  >>>>>> Il 22/ott/2013 12:37 "Emil Ivov"
        <emcho@jitsi.org <mailto:emcho@jitsi.org>
                 <mailto:emcho@jitsi.org <mailto:
emcho@jitsi.org>>> ha
        scritto:
                  >>>>>>>
                  >>>>>>> STUN alone is not sufficient for NAT
        traversal. You
                 also need a
                  >>>>>>> relaying mechanism for fallback. With
Openfire
        you can
                 use their Jingle
                  >>>>>>> Nodes plugin.
                  >>>>>>>
                  >>>>>>> Make sure however that you run Jitsi
with its
        default
                 configuration.
                  >>>>>>> (You may want to delete the conifg
folder if
        you've
                 experimented eith the
                  >>>>>>> settings)
                  >>>>>>>
                  >>>>>>> Emil
                  >>>>>>>
                  >>>>>>> --sent from my mobile
                  >>>>>>>
                  >>>>>>> On 22 Oct 2013 12:29, "Giorgio Catena"
                 <thechain1974@gmail.com <mailto:
thechain1974@gmail.com**>
        <mailto:thechain1974@gmail.com <mailto:
thechain1974@gmail.com**>__>>
                  >>>>>>> wrote:
                  >>>>>>>>
                  >>>>>>>> Hello everyone,
                  >>>>>>>> i'm struggling trying to use jitsi
as a
        client for my
                 openfire
                  >>>>>>>> installation in place of the spark
client.
                  >>>>>>>> Our interest is to use the
videobridge and
        the audio
                 video feature
                  >>>>>>>> that jitsi integrates.
                  >>>>>>>> Unfortunately I still cannot do a
proper STUN
                 configuration in order
                  >>>>>>>> to permit two clients placed on
different
        networks to
                 properly establish a
                  >>>>>>>> rtp communication.
                  >>>>>>>> On the ICE tab configuration
settings i did
        insert
                 only the stun
                  >>>>>>>> server i want to use (
stun.l.google.com
        <http://stun.l.google.com>
                 <http://stun.l.google.com>). The server works
fine
        (tested with
                  >>>>>>>> winstun on order to see if it
translates
        properly my
                 public ip) but once i
                  >>>>>>>> try to establish a phone call the ip
released
        on the
                 call are the private ip
                  >>>>>>>> instead of the public one.
                  >>>>>>>> Does anyone have an idea on how to
proceed?
                  >>>>>>>>
                  >>>>>>>> Thanks in advance
                  >>>>>>>> Regards
                  >>>>>>>> Giorgio
                  >>>>>>>>
                  >>>>>>>> ______________________________**
___________________
                  >>>>>>>> users mailing list
                  >>>>>>>> users@jitsi.org <mailto:
users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>>>>>> Unsubscribe instructions and other
list options:
                  >>>>>>>>
        http://lists.jitsi.org/__mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >>>>>>>
                  >>>>>>>
                  >>>>>>> ______________________________**
___________________
                  >>>>>>> users mailing list
                  >>>>>>> users@jitsi.org <mailto:
users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>>>>> Unsubscribe instructions and other
list options:
                  >>>>>>>
        http://lists.jitsi.org/
mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >>>>>>
                  >>>>>>
                  >>>>>> ______________________________**
___________________
                  >>>>>> users mailing list
                  >>>>>> users@jitsi.org <mailto:
users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>>>> Unsubscribe instructions and other
list options:
                  >>>>>> http://lists.jitsi.org/

mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >>>>>
                  >>>>>
                  >>>>> ______________________________**
___________________
                  >>>>> users mailing list
                  >>>>> users@jitsi.org <mailto:users@jitsi.org
>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>>> Unsubscribe instructions and other list
options:
                  >>>>> http://lists.jitsi.org/

mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >>>>
                  >>>>
                  >>>>
                  >>>> ______________________________**
___________________
                  >>>> users mailing list
                  >>>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>> Unsubscribe instructions and other list
options:
                  >>>> http://lists.jitsi.org/
**
mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >>>
                  >>>
                  >>> ______________________________**
___________________
                  >>> users mailing list
                  >>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>> Unsubscribe instructions and other list
options:
                  >>> http://lists.jitsi.org/
**
mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >
                  >
                  >
                  > ______________________________**
___________________
                  > users mailing list
                  > users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  > Unsubscribe instructions and other list
options:
                  > http://lists.jitsi.org/
**
mailman/listinfo/users<http://lists.jitsi.org/__mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>

                 --
                 Emil Ivov, Ph.D. 67000
Strasbourg,
                 Project Lead France
                 Jitsi
        emcho@jitsi.org <mailto:emcho@jitsi.org> <mailto:
emcho@jitsi.org
        <mailto:emcho@jitsi.org>>
                   PHONE: +33.1.77.62.43.30<tel:%2B33.1.77.62.43.30>
        <tel:%2B33.1.77.62.43.30>
        https://jitsi.org FAX:
+33.1.77.62.47.31
        <tel:%2B33.1.77.62.47.31>
                 <tel:%2B33.1.77.62.47.31>

                 ______________________________**
___________________
                 users mailing list
        users@jitsi.org <mailto:users@jitsi.org> <mailto:
users@jitsi.org
        <mailto:users@jitsi.org>>
                 Unsubscribe instructions and other list
options:
        http://lists.jitsi.org/__**mailman/listinfo/users<http://lists.jitsi.org/__mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>

        ______________________________**___________________
        users mailing list
        users@jitsi.org <mailto:users@jitsi.org>
        Unsubscribe instructions and other list options:
        http://lists.jitsi.org/__**mailman/listinfo/users<http://lists.jitsi.org/__mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>

    --
    https://jitsi.org

--
https://jitsi.org

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31

--
Emil Ivov, Ph.D. 67000 Strasbourg,
Project Lead France
Jitsi
emcho@jitsi.org PHONE: +33.1.77.62.43.30
https://jitsi.org FAX: +33.1.77.62.47.31


#19

Yes it has. (For ICE. There were never plans for STUN only support).

Also, this thread is for XMPP

--sent from my mobile

···

On 25 Oct 2013 21:59, "Privus 007" <privus007@gmail.com> wrote:

Hi,

I presume you are talking of STUN over XMPP and not SIP.

If I recall correctly, Jitsi was to get SIP STUN implemented in September.
Has that timeline been pushed forward again?

Cheers

On Wed, Oct 23, 2013 at 2:30 PM, Emil Ivov <emcho@jitsi.org> wrote:

(CC-ing dev. Let's keep this on the list so that others could benefit the
same issues occur elsewhere).

On 23.10.13, 15:12, Giorgio Catena wrote:

ok emil i'll do other checks.

Cool, don't hesitate if you have questions there.

The udp are correctly opened afaik.

Well, you'd best have a look through Wireshark. That could very well
explain the behaviour you describe.

Ok

which port does the jitsi stun work?

Jitsi uses ports 5000 to 6000 for media. STUN checks are sent on the
media ports. Wireshark recognizes them as such so you should be able to
filter them out pretty easily.

I'd provide logs asap. Do you

know anyone I could ask to crosscheck jinglenodes?

Well, the easiest would have been to connect to our jit.si server and
then compare Jitsi behaviour between that and your Openfire installation.

Also, after starting Jitsi and connecting to your accounts you should see
something like this in your logs:

11:17:09.962 INFO: [139] impl.protocol.jabber.**
JingleNodesServiceDiscovery.**run().128 Jingle Nodes discovery
terminated!
11:17:09.963 INFO: [139] impl.protocol.jabber.**
JingleNodesServiceDiscovery.**run().129 Found 1 Jingle Nodes relay for
account: emcho@jit.si in 989 ms.

If you don't see this then your Jingle Nodes Plugin is not properly
connected to Openfire. If you do, but things still don't work, then the
relay is properly initialized but Jitsi is unable to verify connectivity
when establishing a call (which would be the case if your firewall is
blocking stuff).

Hope this helps,
Emil

Il 23/ott/2013 14:58 "Emil Ivov" <emcho@jitsi.org >>> <mailto:emcho@jitsi.org>> ha scritto:

    Hey Giorgio,

    On 23.10.13, 09:12, Giorgio Catena wrote:

        Hi,
        as requested I'm going to describe the configuration we are
        using and
        that is giving us problems trying to use jitsi to do a call from
        our lan
        to an external client (that in our tests is using a wi-fi umts
        modem)
        and - or viceversa.
        The XMPP - Openfire server is a windows box with 2 nics both
        with public
        ip address as requested from jinglenodes and stun to work. The
        machine
        is reachable on the same pubblic addresses from the inside LAN.
        There is only a firewall protecting the machine from the public
        access
        no NAT is in place.

    You mean there's a firewall in front of Openfire? Could it be
    blocking incoming UDP sessions? You might want to check that out.

        Trying to use Spark or Jitsi with the STUN option enabled
        (inserting the
        primary ip, port 3478) the client cannot instantiate the
connection.
        Trying to use Jitsi with jinglenodes (enabled the jinglenodes
        module,
        don't know if it works, it says public ip cannot be verified, I
        saw on
        the code that to verify it it should point to a stun server that
        is not
        answering, maybe that this is the cause) the clients cannot
        connect each
        other, the call is made but once the other client answer no
audio or
        video are sent.
        Trying to use spark with webrtc plugin (xmpp signaling on the
        openfire
        server + WEBRTC for RTP communication) the clients start the A/V
        session
        properly. What I noticed is that the WEBRTC plugin made by Dele
        Oljiade
        has hardcoded in the jar the reference to the stun.l.google.com
        <http://stun.l.google.com>
        <http://stun.l.google.com> STUN server (port 19302).

    Jitsi also comes with a preconfigured STUN server (stun.jitsi.net
    <http://stun.jitsi.net>). Maybe it is also blocked?

        At this point I
        decided to do is to exclude the XMPP server from the relay role
        and-or
        jinglenodes role trying to use the Google's public available
STUN.
        For this reason, I tried to place on the jitsi conf (keeping
        obviously
        the same testing configuration) the reference to the IP of
        Google's STUN
        server.
        Before doing that i did cross chek the correct behaviour of the
        google's
        stun server on both client using winstun and the result are ok,
the
        public addresses are correctly translated as expected.
        I inserted that STUN address on the jitsi configuration of both
        Jitsi
        client disabling all the options (included autodiscovery and
        jinglenodes), trying to do the call nothing happens (same
behaviour
        noticed with jinglenodes enablad).

    Have you checked if Jitsi's STUN Binding Requests reach the server
    and whether they get answered?

        If I look at the connection
        properties during the call I see that even if stun server is in
the
        configuration the ip of the parties involved in the call are the
        private
        ip not the public. It seems that i think stun settings are for
some
        reason not saved and - or used but I cannot understand why.

    Or maybe the STUN queries are not succeeding.

        Do you want me to provide the log with both jinglenodes and stun
        attempts?

    That would help although I can't promise at what point people would
    be able to look through them. You may want to check out the
    questions above too.

    Emil

        Regards.

        2013/10/22 Giorgio Catena <thechain1974@gmail.com
        <mailto:thechain1974@gmail.com**>
        <mailto:thechain1974@gmail.com <mailto:thechain1974@gmail.com**
>__>>

             Hi emil tomorrow i'll provide logs with jinglenodes setup
        and stun.
             The idea to recompile jinglenodes was given from thiago the
        main
             jinglenodes developer. I can also try to provide some more
        details
             regarding our network specs.
             Thanks again

             Il 22/ott/2013 17:53 "Emil Ivov" <emcho@jitsi.org
        <mailto:emcho@jitsi.org>
             <mailto:emcho@jitsi.org <mailto:emcho@jitsi.org>>> ha
scritto:

                 Hey Giorgio,

                 On Tue, Oct 22, 2013 at 1:35 PM, Giorgio Catena >>> <thechain1974@gmail.com <mailto:thechain1974@gmail.com* >>> *> >>> <mailto:thechain1974@gmail.com >>> <mailto:thechain1974@gmail.com**>__>> wrote:
                  > Well to be sincere i do have a problem trying to
        open jit.si <http://jit.si>
                 <http://jit.si> connection from
                  > our inside lan. The security dept did not accept to
        open it....

                 That's unfortunate. However, if outbound tcp
        connections are
                 forbidden
                 by your network, then that could also explain your
        problems.
                 Obviously
                 I am speculating. I don't know anything about your
        network or your
                 testbed, so it is quite hard to provide meaningful help.

                  > What makes me mad is that jinglenodes seems so
        simple to use
                 that i cannt
                  > understand why it does not work.

                 You can try. First you need to find out whether Jitsi
        allocates
                 Jingle
                 Nodes addresses, then you can check whether it attempts
        to run ICE
                 checks through it.

                  > I'm also trying to setup a dedicated linux
                  > box, with xmpp-jinglenodes recompiled from the git
        source. It
                 binds to xmpp
                  > server but after that simply goes in timeout.

                 The openfire plugin generally works quite nice. If it
        isn't working
                 for you, I'd be more inclined to look at the network
        rather than try
                 and recompile jingle nodes.

                  > What i cannt understand if why
                  > in the same config of the jitsi client (only stun
        written in
                 the conf) the
                  > webrtc test client works (can do rtp call using xmpp
                 signaling) and jitsi
                  > fails.

                 There could be many reasons. Are you connecting the
        exact same two
                 hosts using the same STUN server? Can we see the logs?

                 Emil
                  >
                  >
                  >
                  >
                  > 2013/10/22 Giorgio Catena <thechain1974@gmail.com
        <mailto:thechain1974@gmail.com**>
                 <mailto:thechain1974@gmail.com
        <mailto:thechain1974@gmail.com**>__>>
                  >>
                  >> No problem i'll do it now.. :slight_smile:
                  >>
                  >> Il 22/ott/2013 13:23 "Emil Ivov" <emcho@jitsi.org
        <mailto:emcho@jitsi.org>
                 <mailto:emcho@jitsi.org <mailto:emcho@jitsi.org>>> ha
        scritto:
                  >>
                  >>> It would mean that you are doing something wrong
        and it
                 would help us
                  >>> help you. Creating an accout will take you all of
        ten seconds.
                  >>>
                  >>> If you don't want to do this then fine, I just
        thought you
                 were asking
                  >>> for help.
                  >>>
                  >>> --sent from my mobile
                  >>>
                  >>> On 22 Oct 2013 13:18, "Giorgio Catena" >>> <thechain1974@gmail.com <mailto:thechain1974@gmail.com* >>> *> >>> <mailto:thechain1974@gmail.com >>> <mailto:thechain1974@gmail.com**>__>> wrote:
                  >>>>
                  >>>> I do have to create the account. In case it would
        work
                 what should it
                  >>>> mean? Due to the fact i have to use my OF server
        i'm going
                 to test all with
                  >>>> it.
                  >>>> Could you provide me the setting I should use
        with OF-
                 STUN and so on?
                  >>>> Maybe i'm doing something wrong.
                  >>>>
                  >>>> Regards
                  >>>>
                  >>>>
                  >>>> 2013/10/22 Emil Ivov <emcho@jitsi.org
        <mailto:emcho@jitsi.org>
                 <mailto:emcho@jitsi.org <mailto:emcho@jitsi.org>>>
                  >>>>>
                  >>>>> Can you establish a connection using two Jitsi
        instances
                 with *default*
                  >>>>> configuration and jit.si <http://jit.si>
        <http://jit.si> accounts?
                  >>>>>
                  >>>>> --sent from my mobile
                  >>>>>
                  >>>>> On 22 Oct 2013 12:56, "Giorgio Catena" >>> <thechain1974@gmail.com <mailto:thechain1974@gmail.com* >>> *> >>> <mailto:thechain1974@gmail.com >>> <mailto:thechain1974@gmail.com**>__>> wrote:
                  >>>>>>
                  >>>>>> Hi, the jinglenodes plugin simply does not
        work. I've
                 already tried
                  >>>>>> it with no success. A webrtc test client using
        google
                 stun server works
                  >>>>>> fine... could you tell me what fields had to
        be set up?
                   If i leave all the
                  >>>>>> default settings enabled it says ice error...
                  >>>>>>
                  >>>>>> Il 22/ott/2013 12:37 "Emil Ivov"
        <emcho@jitsi.org <mailto:emcho@jitsi.org>
                 <mailto:emcho@jitsi.org <mailto:emcho@jitsi.org>>> ha
        scritto:
                  >>>>>>>
                  >>>>>>> STUN alone is not sufficient for NAT
        traversal. You
                 also need a
                  >>>>>>> relaying mechanism for fallback. With Openfire
        you can
                 use their Jingle
                  >>>>>>> Nodes plugin.
                  >>>>>>>
                  >>>>>>> Make sure however that you run Jitsi with its
        default
                 configuration.
                  >>>>>>> (You may want to delete the conifg folder if
        you've
                 experimented eith the
                  >>>>>>> settings)
                  >>>>>>>
                  >>>>>>> Emil
                  >>>>>>>
                  >>>>>>> --sent from my mobile
                  >>>>>>>
                  >>>>>>> On 22 Oct 2013 12:29, "Giorgio Catena"
                 <thechain1974@gmail.com <mailto:thechain1974@gmail.com*
*>
        <mailto:thechain1974@gmail.com <mailto:thechain1974@gmail.com**
>__>>
                  >>>>>>> wrote:
                  >>>>>>>>
                  >>>>>>>> Hello everyone,
                  >>>>>>>> i'm struggling trying to use jitsi as a
        client for my
                 openfire
                  >>>>>>>> installation in place of the spark client.
                  >>>>>>>> Our interest is to use the videobridge and
        the audio
                 video feature
                  >>>>>>>> that jitsi integrates.
                  >>>>>>>> Unfortunately I still cannot do a proper STUN
                 configuration in order
                  >>>>>>>> to permit two clients placed on different
        networks to
                 properly establish a
                  >>>>>>>> rtp communication.
                  >>>>>>>> On the ICE tab configuration settings i did
        insert
                 only the stun
                  >>>>>>>> server i want to use (stun.l.google.com
        <http://stun.l.google.com>
                 <http://stun.l.google.com>). The server works fine
        (tested with
                  >>>>>>>> winstun on order to see if it translates
        properly my
                 public ip) but once i
                  >>>>>>>> try to establish a phone call the ip released
        on the
                 call are the private ip
                  >>>>>>>> instead of the public one.
                  >>>>>>>> Does anyone have an idea on how to proceed?
                  >>>>>>>>
                  >>>>>>>> Thanks in advance
                  >>>>>>>> Regards
                  >>>>>>>> Giorgio
                  >>>>>>>>
                  >>>>>>>> ______________________________**
___________________
                  >>>>>>>> users mailing list
                  >>>>>>>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>>>>>> Unsubscribe instructions and other list
options:
                  >>>>>>>>
        http://lists.jitsi.org/__mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >>>>>>>
                  >>>>>>>
                  >>>>>>> ______________________________**
___________________
                  >>>>>>> users mailing list
                  >>>>>>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>>>>> Unsubscribe instructions and other list
options:
                  >>>>>>>
        http://lists.jitsi.org/
mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >>>>>>
                  >>>>>>
                  >>>>>> ______________________________**
___________________
                  >>>>>> users mailing list
                  >>>>>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>>>> Unsubscribe instructions and other list options:
                  >>>>>> http://lists.jitsi.org/

mailman/listinfo/users <http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >>>>>
                  >>>>>
                  >>>>> ______________________________**
___________________
                  >>>>> users mailing list
                  >>>>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>>> Unsubscribe instructions and other list options:
                  >>>>> http://lists.jitsi.org/

mailman/listinfo/users <http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >>>>
                  >>>>
                  >>>>
                  >>>> ______________________________**
___________________
                  >>>> users mailing list
                  >>>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>>> Unsubscribe instructions and other list options:
                  >>>> http://lists.jitsi.org/
**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >>>
                  >>>
                  >>> ______________________________**
___________________
                  >>> users mailing list
                  >>> users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  >>> Unsubscribe instructions and other list options:
                  >>> http://lists.jitsi.org/
**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>
                  >
                  >
                  >
                  > ______________________________**___________________
                  > users mailing list
                  > users@jitsi.org <mailto:users@jitsi.org>
        <mailto:users@jitsi.org <mailto:users@jitsi.org>>
                  > Unsubscribe instructions and other list options:
                  > http://lists.jitsi.org/
**mailman/listinfo/users<http://lists.jitsi.org/__mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>

                 --
                 Emil Ivov, Ph.D. 67000 Strasbourg,
                 Project Lead France
                 Jitsi
        emcho@jitsi.org <mailto:emcho@jitsi.org> <mailto:emcho@jitsi.org
        <mailto:emcho@jitsi.org>>
                   PHONE: +33.1.77.62.43.30 <tel:%2B33.1.77.62.43.30>
        <tel:%2B33.1.77.62.43.30>
        https://jitsi.org FAX: +33.1.77.62.47.31
        <tel:%2B33.1.77.62.47.31>
                 <tel:%2B33.1.77.62.47.31>

                 ______________________________**___________________
                 users mailing list
        users@jitsi.org <mailto:users@jitsi.org> <mailto:users@jitsi.org
        <mailto:users@jitsi.org>>
                 Unsubscribe instructions and other list options:
        http://lists.jitsi.org/__**mailman/listinfo/users<http://lists.jitsi.org/__mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>

        ______________________________**___________________
        users mailing list
        users@jitsi.org <mailto:users@jitsi.org>
        Unsubscribe instructions and other list options:
        http://lists.jitsi.org/__**mailman/listinfo/users<http://lists.jitsi.org/__mailman/listinfo/users>
        <http://lists.jitsi.org/**mailman/listinfo/users<http://lists.jitsi.org/mailman/listinfo/users>
>

    --
    https://jitsi.org

--
https://jitsi.org

______________________________**_________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/**mailman/listinfo/dev<http://lists.jitsi.org/mailman/listinfo/dev>

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev