[jitsi-users] Jitsi on Mac fails to register with FreeVoipDeal


#1

Just dump traffic on right interface to console: tcpdump -i ethX -v -s0 net ip.of.destination.server

···

Sven Hazejager <sven@hazejager.nl> wrote:

Doesanyonehaveanysuggestions?HowdoIdebugaSIPconnection(attempt)inJitsi?On16April2015at09:21,SvenHazejagersven@hazejager.nlwrote:All,IamnewtoJitsi,havingusedTelephoneonmyMacforoutgoingSIPcallsbefore.IamtryingtogetittoworkwithFreeVoipDeal,aVoipBusterclone.Ithasactuallyworkedoncebutnowitwontregisteranymoreatall.IhavereinstalledJitsi,recreatedmyaccount,rebootedmyMac,nochange.ThereisnoproblemwithmyaccountasTelephoneandmyhardphonesworkfine.WhenItrytogoonlinewiththeSIPaccount,theiconstartsspinninguntilitstops,itnevergoesonlineandIgetnofeedbackwhatsoever.HowdoIdiagnosethisissue?Mydetails:Jitsi2.8.5426OSXYosemite10.10.3javaversion1.7.0_75Java(TM)SERuntimeEnvironment(build1.7.0_75-b13)JavaHotSpot(TM)64-BitServerVM(build24.75-b04,mixedmode)ThanksSven


#2

Spot on, thanks! Mac Firewall was blocking all connections. Fixed, and
Jitsi works like a charm now.

···

On 22 April 2015 at 21:21, mirkobrankovic <mirkobrankovic@yahoo.com> wrote:

Just dump traffic on right interface to console: tcpdump -i ethX -v -s0
net ip.of.destination.server


#3

Heh, I came late to the thead and jumped to answer after I saw your first
two messages asking for help.
Glad to hear you've now solved the issue.

Idea to Emil and the rest of devs: perhaps you could make Jitsi "ping" the
jisti home page and if it cannot be reached alert the user that the system
firewall might be blocking it (Windows Firewall also likes to block Java
apps by default, we now see that Apple's apparently does too?)

FC

···

On Sat, Apr 25, 2015 at 4:33 PM, Sven Hazejager <sven@hazejager.nl> wrote:

Spot on, thanks! Mac Firewall was blocking all connections. Fixed, and
Jitsi works like a charm now.


#4

I missed your original requests (sorry about that) but am glad that
you figured it out!

Cheers!

···

On Sat, Apr 25, 2015 at 10:33 PM, Sven Hazejager <sven@hazejager.nl> wrote:

On 22 April 2015 at 21:21, mirkobrankovic <mirkobrankovic@yahoo.com> wrote:

Just dump traffic on right interface to console: tcpdump -i ethX -v -s0
net ip.of.destination.server

Spot on, thanks! Mac Firewall was blocking all connections. Fixed, and Jitsi
works like a charm now.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

--
https://jitsi.org


#5

Idea to Emil and the rest of devs: perhaps you could make Jitsi "ping" the
jisti home page and if it cannot be reached alert the user that the system
firewall might be blocking it (Windows Firewall also likes to block Java
apps by default, we now see that Apple's apparently does too?)

The default firewall configuration will allow outbound connections and there doesn't need to be an exception for Jitsi inbound, so this doesn't really help. But a troubleshooting plugin under help might be an idea. Could you please log a feature-request on GitHub?

FC

Ingo