[jitsi-users] Jitsi on Linux : Problem webcam drivers and micro


#1

Hello everyone,

I use the wonderful Jitsi since 3 months on Windows 7 x64 and videoconferencing worksvery good.

But on Linux Mint (Cinnamon) 17.1 64 bits (I'm new on this OS), video calls have never worked despite many updates. Jitsi does not recognize my webcam and my microphone while It Works with software like "Cheeze" or "VLC".
Do you have an idea whose causing the issue and how to solve it ?
Current version : Jitsi 2.5.5359

Thank you so much !
Victo Rise Up.


#2

Hi,

try using v4l2convert and see is it working for you.
http://lists.jitsi.org/pipermail/dev/2013-October/018404.html

Regards
damencho

···

On Sun, Dec 7, 2014 at 8:20 PM, Victorin SABAT <victorin@sabat.fr> wrote:

Hello everyone,

I use the wonderful Jitsi since 3 months on Windows 7 x64 and
videoconferencing worksvery good.

But on Linux Mint (Cinnamon) 17.1 64 bits (I'm new on this OS), video calls
have never worked despite many updates. Jitsi does not recognize my webcam
and my microphone while It Works with software like "Cheeze" or "VLC".
Do you have an idea whose causing the issue and how to solve it ?
Current version : Jitsi 2.5.5359

Thank you so much !
Victo Rise Up.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

I typed this command in the console : "LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so jitsi"

and here are the first lines that followed:
"ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
OpenJDK 64-Bit Server VM warning: You have loaded library /usr/share/jitsi/lib/native/libsysactivitynotifications.so which might have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
20:47:33.679 GRAVE: [13] impl.sysactivity.SystemActivityNotificationsServiceImpl.getCurrentRunningManager().636 Error creating manager
java.lang.UnsatisfiedLinkError: /usr/share/jitsi/lib/native/libunix-java.so: /usr/share/jitsi/lib/native/libunix-java.so: mauvaise classe ELF : ELFCLASS32 (Possible cause: architecture word width mismatch)"

Then,Jitsi was launched but no video and audio device :/.


#4

Are you running i386?

···

On Wed, Dec 10, 2014 at 9:56 PM, Victorin SABAT <victorin@sabat.fr> wrote:

I typed this command in the console :
"LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so jitsi"

and here are the first lines that followed:
"ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so' from
LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so' from
LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so' from
LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so' from
LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so' from
LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
OpenJDK 64-Bit Server VM warning: You have loaded library
/usr/share/jitsi/lib/native/libsysactivitynotifications.so which might have
disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c
<libfile>', or link it with '-z noexecstack'.
20:47:33.679 GRAVE: [13]
impl.sysactivity.SystemActivityNotificationsServiceImpl.getCurrentRunningManager().636
Error creating manager
java.lang.UnsatisfiedLinkError: /usr/share/jitsi/lib/native/libunix-java.so:
/usr/share/jitsi/lib/native/libunix-java.so: mauvaise classe ELF :
ELFCLASS32 (Possible cause: architecture word width mismatch)"

Then,Jitsi was launched but no video and audio device :/.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Hi Victorin,

You're currently using a 64 bits JVM and then try to load a 32 bits
v4l2convert.so library. You should find the 64 bits library at a similar
location as you use below. You probably only need to change the
'i386-linux-gnu' part into its 64 bits counterpart.
You did use LD_PRELOAD correctly as it was loading that library. Now you
just need to refer to the correct library file.

Danny

···

On 10-12-14 20:56, Victorin SABAT wrote:

I typed this command in the console :
"LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so jitsi"

and here are the first lines that followed:
"ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so'
from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32):
ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so'
from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32):
ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so'
from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32):
ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so'
from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32):
ignored.
ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so'
from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32):
ignored.
OpenJDK 64-Bit Server VM warning: You have loaded library
/usr/share/jitsi/lib/native/libsysactivitynotifications.so which might
have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c
<libfile>', or link it with '-z noexecstack'.
20:47:33.679 GRAVE: [13]
impl.sysactivity.SystemActivityNotificationsServiceImpl.getCurrentRunningManager().636
Error creating manager
java.lang.UnsatisfiedLinkError:
/usr/share/jitsi/lib/native/libunix-java.so:
/usr/share/jitsi/lib/native/libunix-java.so: mauvaise classe ELF :
ELFCLASS32 (Possible cause: architecture word width mismatch)"

Then,Jitsi was launched but no video and audio device :/.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users