[jitsi-users] Jitsi on Android - doesn't use phone's mobile data connection


#1

When I am using mobile data only, Jitsi seems to think that there is no
connection to the internet, and declares the account status as Offline.

When I enable the WiFi though, Jitsi detects that there is now an internet
connection and declares the account status as online.

Is use of mobile data intentionally disabled? Or is it a bug?

- Sandeep


#2

Hi,

When I am using mobile data only, Jitsi seems to think that there is no
connection to the internet, and declares the account status as Offline.

When I enable the WiFi though, Jitsi detects that there is now an internet
connection and declares the account status as online.

Is use of mobile data intentionally disabled? Or is it a bug?

I cannot reproduce this issue. Jitsi stays connected all day even with
WiFi disabled.

What versions of Android and Jitsi are you using?

When saying "enable the WiFi", do you mean just enabling the interface,
or does this include associating with a WiFi network?

Then, please send logs produced when starting Jitsi (with WiFi
disabled), enabling WiFi, disabling WiFi again.

Cheers,
Nik

···

--
* mirabilos is handling my post-1990 smartphone *
<mirabilos> Aaah, it vibrates! Wherefore art thou, demonic device??

PGP-Fingerprint: 3C9D 54A4 7575 C026 FB17 FD26 B79A 3C16 A0C4 F296


#3

Bump. Does anyone else have this problem? Can any of the developers please
tell me if this is intentional or not?

Thank you.

- Sandeep

···

On Fri, Feb 7, 2014 at 11:00 PM, Sandeep <sandy.8925@gmail.com> wrote:

When I am using mobile data only, Jitsi seems to think that there is no
connection to the internet, and declares the account status as Offline.

When I enable the WiFi though, Jitsi detects that there is now an internet
connection and declares the account status as online.

Is use of mobile data intentionally disabled? Or is it a bug?

- Sandeep


#4

Hi,

Bump. Does anyone else have this problem? Can any of the developers please
tell me if this is intentional or not?

Thank you.

- Sandeep

It works fine for me too. In the logs there is debug output from reconnect
plugin. It needs to have "active" interface before reconnect. I suppose
your mobile data connection might not be recognized as active properly, but
it's just a guess. Can you send the logs a while after mobile data is
activated (with send logs option)?

Regards,
Pawel

···

On Wed, Feb 12, 2014 at 3:19 AM, Sandeep <sandy.8925@gmail.com> wrote:


#5

Bump. Does anyone else have this problem? Can any of the developers please
tell me if this is intentional or not?

Thank you.

- Sandeep

···

On Tue, Feb 11, 2014 at 6:19 PM, Sandeep <sandy.8925@gmail.com> wrote:

Bump. Does anyone else have this problem? Can any of the developers please
tell me if this is intentional or not?

Thank you.

- Sandeep

On Fri, Feb 7, 2014 at 11:00 PM, Sandeep <sandy.8925@gmail.com> wrote:

When I am using mobile data only, Jitsi seems to think that there is no
connection to the internet, and declares the account status as Offline.

When I enable the WiFi though, Jitsi detects that there is now an
internet connection and declares the account status as online.

Is use of mobile data intentionally disabled? Or is it a bug?

- Sandeep


#6

Ok, it looks like that's not a problem anymore, atleast in the latest
build. It just takes longer to change status to online than it does on a
wifi connection (expected since my data connection is slow).

- Sandeep

···

On Tue, Mar 4, 2014 at 11:28 PM, Sandeep <sandy.8925@gmail.com> wrote:

Bump. Does anyone else have this problem? Can any of the developers please
tell me if this is intentional or not?

Thank you.

- Sandeep

On Tue, Feb 11, 2014 at 6:19 PM, Sandeep <sandy.8925@gmail.com> wrote:

Bump. Does anyone else have this problem? Can any of the developers
please tell me if this is intentional or not?

Thank you.

- Sandeep

On Fri, Feb 7, 2014 at 11:00 PM, Sandeep <sandy.8925@gmail.com> wrote:

When I am using mobile data only, Jitsi seems to think that there is no
connection to the internet, and declares the account status as Offline.

When I enable the WiFi though, Jitsi detects that there is now an
internet connection and declares the account status as online.

Is use of mobile data intentionally disabled? Or is it a bug?

- Sandeep