[jitsi-users] Jitsi not starting up on Ubuntu 18.04 8Java 10)


#1

Hi!

I recently updated my system from Ubuntu 17.04 to 18.04. Since that time
Jitsi desktop won't start anymore. It hangs during the splash screen. If
I run it from the terminal I see a lot repetitive exceptions by the
apache felix framework.
Output from invoking 'jitsi':
<https://www.dropbox.com/s/fejv8ctkztxcpf7/jitsi_startup.log?dl=0>
Output from invoking 'jitsi -d':
<https://www.dropbox.com/s/vi4ypryob9pmtay/jitsi-d_startup.log?dl=0>

user@host:~$ jitsi --version
Jitsi 2.10.5550
user@host:~$ java --version
openjdk 10.0.1 2018-04-17
OpenJDK Runtime Environment (build 10.0.1+10-Ubuntu-3ubuntu1)
OpenJDK 64-Bit Server VM (build 10.0.1+10-Ubuntu-3ubuntu1, mixed mode)
user@host:~$ uname -a
Linux host 4.15.0-20-generic #21-Ubuntu SMP Tue Apr 24 06:16:15 UTC 2018
x86_64 x86_64 x86_64 GNU/Linux
user@host:~$

Can anybody help? If you need any additional information, I'm happy to
provide them.

Thanks in advance!
Simon


#2

I recently updated my system from Ubuntu 17.04 to 18.04. Since that time
Jitsi desktop won't start anymore. It hangs during the splash screen. If
I run it from the terminal I see a lot repetitive exceptions by the
apache felix framework. Output from invoking 'jitsi':
<https://www.dropbox.com/s/fejv8ctkztxcpf7/jitsi_startup.log?dl=0>
Output from invoking 'jitsi -d':
<https://www.dropbox.com/s/vi4ypryob9pmtay/jitsi-d_startup.log?dl=0>

user@host:~$ jitsi --version
Jitsi 2.10.5550
user@host:~$ java --version
openjdk 10.0.1 2018-04-17
OpenJDK Runtime Environment (build 10.0.1+10-Ubuntu-3ubuntu1)
OpenJDK 64-Bit Server VM (build 10.0.1+10-Ubuntu-3ubuntu1, mixed mode)
user@host:~$ uname -a
Linux host 4.15.0-20-generic #21-Ubuntu SMP Tue Apr 24 06:16:15 UTC 2018
x86_64 x86_64 x86_64 GNU/Linux
user@host:~$

Can anybody help? If you need any additional information, I'm happy to
provide them.

I don't think there's a solution atm. We use Apache Felix as the framework for Jitsi and event their newest release (5.6.10, included in Jitsi) isn't compatible with Java 10 yet. The package version (5.0) provided in Debian/Ubuntu isn't even compatible with Java 9.

I'll see if I can compile something from source again, but this will take time. As an alternative, you can try installing Java 8 (openjdk-8-jre) in addition to the default and run Jitsi with it.

Thanks in advance!
Simon

Ingo


#3

Hi Ingo,

ยทยทยท

Am 13.05.2018 um 11:31 schrieb Ingo Bauersachs:

I'll see if I can compile something from source again, but this will take time. As an alternative, you can try installing Java 8 (openjdk-8-jre) in addition to the default and run Jitsi with it.

Thanks for your help. I now edidted the jitsi shell script to call the
jre 8 directly, there's probably a more elegant way to do this:
javabin="/usr/lib/jvm/java-8-openjdk-amd64/bin/java"

Simon