[jitsi-users] Jitsi meet


#1

Hello,

I Installed Jitsi meet following this https://github.com/jitsi/jitsi-meet/blob/master/INSTALL.md

when I try to test it by going to http://mydomain.com I have this message:
Welcome to nginx!

If you see this page, the nginx web server is successfully installed and working. Further configuration is required.
For online documentation and support please refer to nginx.org .
Commercial support is available at nginx.com .
Thank you for using nginx.

Can you tell me if I am missing something here ?


#2

You most likely don't have the virtual host configuration in nginx.

Search for it in /etc/nginx/sites-enabled/ -- there should be a symlink to
a file in /etc/nginx/sites/available/ with a name like your domain name.
Maybe you are missing the symlink and/or the file.

If the file is there, re-create the symlink and reload nginx.

If it is not there, look for an example here

https://github.com/turint/jitsi-meet/blob/master/debian/usr/share/doc/jitsi-meet/jitsi-meet.example

Place it in sites-available, link it from sites-enabled, edit it (replace
the domain with your own and edit the paths for ssl and for the web root to
match yours, if they differ from the ones in the example) and reload nginx

···

On Fri, Sep 12, 2014 at 12:22 PM, MELLAH Khadija <kmellah@jouve.fr> wrote:

I Installed Jitsi meet following this
https://github.com/jitsi/jitsi-meet/blob/master/INSTALL.md
when I try to test it by going to http://mydomain.com
<http://jitsi.example.com/> I have this message:

--
Yasen Pramatarov
sysadmin, https://jitsi.org


#3

I meant /etc/nginx/sites-available/ of course :slight_smile:

···

On Fri, Sep 12, 2014 at 12:46 PM, Yasen Pramatarov <yasen@bluejimp.com> wrote:

[...] there should be a symlink to a file in /etc/nginx/sites/available/
[...]

--
Yasen Pramatarov
sysadmin, https://jitsi.org


#4

Hi, yhank you for your response, but when I installed nginx I did not found directory sites-available and sites-enabled, I created them and add the files

···

----- Original Message -----

From: "Yasen Pramatarov" <yasen@bluejimp.com>
To: "Jitsi Users" <users@jitsi.org>
Sent: Friday, September 12, 2014 11:48:11 AM
Subject: Re: [jitsi-users] Jitsi meet

On Fri, Sep 12, 2014 at 12:46 PM, Yasen Pramatarov < yasen@bluejimp.com > wrote:

[...] there should be a symlink to a file in /etc/nginx/sites/available/ [...]

I meant /etc/nginx/sites-available/ of course :slight_smile:

--

Yasen Pramatarov
sysadmin, https://jitsi.org
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

I have one more question:
in this line: proxy_pass http://localhost:5280/http-bind;
I replace port 5280 with 7070 because openfire use 7070 port http binding is that ok?

···

----- Original Message -----

From: "Yasen Pramatarov" <yasen@bluejimp.com>
To: "Jitsi Users" <users@jitsi.org>
Sent: Friday, September 12, 2014 11:48:11 AM
Subject: Re: [jitsi-users] Jitsi meet

On Fri, Sep 12, 2014 at 12:46 PM, Yasen Pramatarov < yasen@bluejimp.com > wrote:

[...] there should be a symlink to a file in /etc/nginx/sites/available/ [...]

I meant /etc/nginx/sites-available/ of course :slight_smile:

--

Yasen Pramatarov
sysadmin, https://jitsi.org
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#6

And do you have an
        include /etc/nginx/sites-enabled/*;
line in your /etc/nginx/nginx.conf file? The only configuration file that
the service looks for is it -- inside it you either include the other
config files or paste the virtual hosts configurations by hand.

···

On Fri, Sep 12, 2014 at 12:56 PM, MELLAH Khadija <kmellah@jouve.fr> wrote:

Hi, yhank you for your response, but when I installed nginx I did not
found directory sites-available and sites-enabled, I created them and add
the files

--
Yasen Pramatarov
sysadmin, https://jitsi.org


#7

no I don't have an
include /etc/nginx/sites-enabled/*; should I add it in http { } ? I have just include /etc/nginx/conf.d/*.conf;

···

----- Original Message -----

From: "Yasen Pramatarov" <yasen@bluejimp.com>
To: "Jitsi Users" <users@jitsi.org>
Sent: Friday, September 12, 2014 12:01:52 PM
Subject: Re: [jitsi-users] Jitsi meet

On Fri, Sep 12, 2014 at 12:56 PM, MELLAH Khadija < kmellah@jouve.fr > wrote:

Hi, yhank you for your response, but when I installed nginx I did not found directory sites-available and sites-enabled, I created them and add the files

And do you have an

include /etc/nginx/sites-enabled/*;
line in your /etc/nginx/nginx.conf file? The only configuration file that the service looks for is it -- inside it you either include the other config files or paste the virtual hosts configurations by hand.

--

Yasen Pramatarov
sysadmin, https://jitsi.org
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#8

Yes, just next to this other include, inside http{}, and reload nginx

···

On Fri, Sep 12, 2014 at 1:05 PM, MELLAH Khadija <kmellah@jouve.fr> wrote:

no I don't have an
        include /etc/nginx/sites-enabled/*; should I add it in http { } ?
I have just include /etc/nginx/conf.d/*.conf;

--
Yasen Pramatarov
sysadmin, https://jitsi.org


#9

one more thing I can't find path of my certificate of openfire, you did not tell me about port 5280 ?

···

----- Original Message -----

From: "Yasen Pramatarov" <yasen@bluejimp.com>
To: "Jitsi Users" <users@jitsi.org>
Sent: Friday, September 12, 2014 12:09:11 PM
Subject: Re: [jitsi-users] Jitsi meet

On Fri, Sep 12, 2014 at 1:05 PM, MELLAH Khadija < kmellah@jouve.fr > wrote:

no I don't have an
include /etc/nginx/sites-enabled/*; should I add it in http { } ? I have just include /etc/nginx/conf.d/*.conf;

Yes, just next to this other include, inside http{}, and reload nginx

--

Yasen Pramatarov
sysadmin, https://jitsi.org
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#10

well openfire has a keystore and truststore in /opt/openfire/resources/security/keystore and /opt/openfire/resources/security/truststore, how I can replace it in these lines:

ssl_certificate /var/lib/prosody/jitsi-meet.example.com.crt;
ssl_certificate_key /var/lib/prosody/jitsi-meet.example.com.key;

I mean what I should write instead of ssl-certificate? because I don't have file with .crt and .key ----- Original Message -----

···

From: "MELLAH Khadija" <kmellah@jouve.fr>
To: "Jitsi Users" <users@jitsi.org>
Sent: Friday, September 12, 2014 12:11:40 PM
Subject: Re: [jitsi-users] Jitsi meet

one more thing I can't find path of my certificate of openfire, you did not tell me about port 5280 ?

----- Original Message -----

From: "Yasen Pramatarov" <yasen@bluejimp.com>
To: "Jitsi Users" <users@jitsi.org>
Sent: Friday, September 12, 2014 12:09:11 PM
Subject: Re: [jitsi-users] Jitsi meet

On Fri, Sep 12, 2014 at 1:05 PM, MELLAH Khadija < kmellah@jouve.fr > wrote:

no I don't have an
include /etc/nginx/sites-enabled/*; should I add it in http { } ? I have just include /etc/nginx/conf.d/*.conf;

Yes, just next to this other include, inside http{}, and reload nginx

--

Yasen Pramatarov
sysadmin, https://jitsi.org
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#11

now I have this error: Error to connect to ssl , I added the keystore and trusstore path but it doesn't work, because I used ssl_certificate I don't know what to do, can you please help me .

···

----- Original Message -----

From: "MELLAH Khadija" <kmellah@jouve.fr>
To: "Jitsi Users" <users@jitsi.org>
Sent: Friday, September 12, 2014 12:24:21 PM
Subject: Re: [jitsi-users] Jitsi meet

well openfire has a keystore and truststore in /opt/openfire/resources/security/keystore and /opt/openfire/resources/security/truststore, how I can replace it in these lines:

ssl_certificate /var/lib/prosody/jitsi-meet.example.com.crt;
ssl_certificate_key /var/lib/prosody/jitsi-meet.example.com.key;

I mean what I should write instead of ssl-certificate? because I don't have file with .crt and .key ----- Original Message -----

From: "MELLAH Khadija" <kmellah@jouve.fr>
To: "Jitsi Users" <users@jitsi.org>
Sent: Friday, September 12, 2014 12:11:40 PM
Subject: Re: [jitsi-users] Jitsi meet

one more thing I can't find path of my certificate of openfire, you did not tell me about port 5280 ?

----- Original Message -----

From: "Yasen Pramatarov" <yasen@bluejimp.com>
To: "Jitsi Users" <users@jitsi.org>
Sent: Friday, September 12, 2014 12:09:11 PM
Subject: Re: [jitsi-users] Jitsi meet

On Fri, Sep 12, 2014 at 1:05 PM, MELLAH Khadija < kmellah@jouve.fr > wrote:

no I don't have an
include /etc/nginx/sites-enabled/*; should I add it in http { } ? I have just include /etc/nginx/conf.d/*.conf;

Yes, just next to this other include, inside http{}, and reload nginx

--

Yasen Pramatarov
sysadmin, https://jitsi.org
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#12

well openfire has a keystore and truststore in
/opt/openfire/resources/security/keystore
and /opt/openfire/resources/security/truststore, how I can replace it in
these lines:
ssl_certificate /var/lib/prosody/jitsi-meet.example.com.crt;
ssl_certificate_key /var/lib/prosody/jitsi-meet.example.com.key;

I mean what I should write instead of ssl-certificate? because I don't
have file with .crt and .key

I was referring to the web certificates, the ones for nginx. If you chose
to autogenerate them, they are in /var/lib/prosody/ and the example is ok
and if you chose to upload them, well... they are where you uploaded them :slight_smile:

one more thing I can't find path of my certificate of openfire, you did
not tell me about port 5280 ?

Ok just try with 7070

And I don't want to be rude but for general GNU/Linux configuration
questions there are tons of info on the net. I believe in community help
but you need to do your research too.

···

On Fri, Sep 12, 2014 at 1:24 PM, MELLAH Khadija <kmellah@jouve.fr> wrote:

--
Yasen Pramatarov
sysadmin, https://jitsi.org


#13

You did not understand my question, but thank you anyway, I don't use prosody, I use openfire, and there is no ssl_certificates or ssl_certificates_key for openfire so I asked what paramaeters to do in nginx to specify path for keystore and truststore type, beleive me I did a lot of research I generally don't ask questions in forums, but when it comes for something not very well documenting as jitsi meet and jitsi in general it's a little bit hard to find what we need.

so thank you again for your help

ps: sorry my English is not so good

···

----- Original Message -----

From: "Yasen Pramatarov" <yasen@bluejimp.com>
To: "Jitsi Users" <users@jitsi.org>
Sent: Friday, September 12, 2014 12:40:49 PM
Subject: Re: [jitsi-users] Jitsi meet

On Fri, Sep 12, 2014 at 1:24 PM, MELLAH Khadija < kmellah@jouve.fr > wrote:

well openfire has a keystore and truststore in /opt/openfire/resources/security/keystore and /opt/openfire/resources/security/truststore, how I can replace it in these lines:

ssl_certificate /var/lib/prosody/jitsi-meet.example.com.crt;
ssl_certificate_key /var/lib/prosody/jitsi-meet.example.com.key;

I mean what I should write instead of ssl-certificate? because I don't have file with .crt and .key

I was referring to the web certificates, the ones for nginx. If you chose to autogenerate them, they are in /var/lib/prosody/ and the example is ok and if you chose to upload them, well... they are where you uploaded them :slight_smile:

<blockquote>

one more thing I can't find path of my certificate of openfire, you did not tell me about port 5280 ?
</blockquote>

Ok just try with 7070

And I don't want to be rude but for general GNU/Linux configuration questions there are tons of info on the net. I believe in community help but you need to do your research too.

--

Yasen Pramatarov
sysadmin, https://jitsi.org
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#14

Ah I see, well, just a thought -- you don't have to use the save
certificate for the web service and for the xmpp service. It is ok, but it
is not mandatory. You can generate a separate self-signed certificate and
use its files in the nginx config for the web part (Jitsi Meet) and leave
the xmpp server in the background use it's own self-signed cert. :slight_smile:

···

On Fri, Sep 12, 2014 at 1:48 PM, MELLAH Khadija <kmellah@jouve.fr> wrote:

You did not understand my question, but thank you anyway, I don't use
prosody, I use openfire, and there is no ssl_certificates or
ssl_certificates_key for openfire so I asked what paramaeters to do in nginx
to specify path for keystore and truststore type, beleive me I did a lot of
research I generally don't ask questions in forums, but when it comes for
something not very well documenting as jitsi meet and jitsi in general it's
a little bit hard to find what we need.

--
Yasen Pramatarov
sysadmin, https://jitsi.org


#15

Yes I Know, but I thought there is another solution to avoid this hard and long work to generate a new one, but it's ok thank you anyway.

···

----- Original Message -----

From: "Yasen Pramatarov" <yasen@bluejimp.com>
To: "Jitsi Users" <users@jitsi.org>
Sent: Friday, September 12, 2014 3:19:21 PM
Subject: Re: [jitsi-users] Jitsi meet

On Fri, Sep 12, 2014 at 1:48 PM, MELLAH Khadija < kmellah@jouve.fr > wrote:

You did not understand my question, but thank you anyway, I don't use prosody, I use openfire, and there is no ssl_certificates or ssl_certificates_key for openfire so I asked what paramaeters to do in nginx to specify path for keystore and truststore type, beleive me I did a lot of research I generally don't ask questions in forums, but when it comes for something not very well documenting as jitsi meet and jitsi in general it's a little bit hard to find what we need.

Ah I see, well, just a thought -- you don't have to use the save certificate for the web service and for the xmpp service. It is ok, but it is not mandatory. You can generate a separate self-signed certificate and use its files in the nginx config for the web part (Jitsi Meet) and leave the xmpp server in the background use it's own self-signed cert. :slight_smile:

--

Yasen Pramatarov
sysadmin, https://jitsi.org
_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users