[jitsi-users] Jitsi-meet


#1

Hello,

I just upgraded Jitsi-meet on a Debian 9.2:

    ii� jitsi-meet 1.0.2635-1
    ii jitsi-meet-prosody 1.0.2441-1
    ii jitsi-meet-web 1.0.2441-1
    ii jitsi-meet-web-config 1.0.2441-1
    ii jitsi-videobridge������������������������������������ 1011-1

It works great on Firefox, but I have problems with Chrome and Safari: for Chrome I downloaded from Github and built Jidesha (Jitsi Desktop Streamer 0.1.6) chrome.crx and installed it, but when I click on desktop sharing icon an error appears: "Jitsi Desktop Streamer requires update. Changes will take effect after next Chrome restart." And: "Screen sharing extension failed to install." Nothing changes if I restart Chrome.

Then, how can I make the extention install when user clicks the desktop sharing icon, like on meet.jit.si?

Last, I do not have "Open / close share document" and "Start / stop live stream" icons: what can I do to add them?

Good day,
� M.


#2

Hi,

For the jidesha extension, you need to publish it on chrome webstore(
https://developer.chrome.com/webstore/publish), verify your site while
doing that as this is needed for inline install and take the ID and put it
in your config.js.
For document sharing, you need to install etherpad and configure its link
in config.js. For live streaming you need to install and configure jibri (
https://github.com/jitsi/jibri).

Regards
damencho

···

On Thu, Nov 23, 2017 at 4:11 AM, Matteo Calorio < matteo.calorio@linux.ors-tech.it> wrote:

Hello,

I just upgraded Jitsi-meet on a Debian 9.2:

ii jitsi-meet 1.0.2635-1
ii jitsi-meet-prosody 1.0.2441-1
ii jitsi-meet-web 1.0.2441-1
ii jitsi-meet-web-config 1.0.2441-1
ii jitsi-videobridge 1011-1

It works great on Firefox, but I have problems with Chrome and Safari: for
Chrome I downloaded from Github and built Jidesha (Jitsi Desktop Streamer
0.1.6) chrome.crx and installed it, but when I click on desktop sharing
icon an error appears: "Jitsi Desktop Streamer requires update. Changes
will take effect after next Chrome restart." And: "Screen sharing extension
failed to install." Nothing changes if I restart Chrome.

Then, how can I make the extention install when user clicks the desktop
sharing icon, like on meet.jit.si?

Last, I do not have "Open / close share document" and "Start / stop live
stream" icons: what can I do to add them?

Good day,
  M.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#3

Hi,

I tried to install the extension from disk and I get "Screen sharing extension failed to install"...

The I installed the extension from meet.jit.si and it worked perfectly.

Then I put the Id of that crome extension in my config.js file:

 desktopSharing: &#39;ext&#39;, // Desktop sharing method\. Can be set to &#39;ext&#39;, &#39;webrtc&#39; or false to disable\.
 chromeExtensionId: &#39;kglhbbefdnlheedjiejgomgmfplipfeb&#39;, // Id of desktop streamer Chrome extension
 desktopSharingChromeExtId: &#39;kglhbbefdnlheedjiejgomgmfplipfeb&#39;,
 desktopSharingSources: \[&#39;screen&#39;, &#39;window&#39;\],
 minChromeExtVersion: &#39;0\.1&#39;, // Required version of Chrome extension
 openSctp: true, // Toggle to enable/disable SCTP channels
 disableStats: false,
 disableAudioLevels: false,
 channelLastN: \-1, // The default value of the channel attribute last\-n\.
 adaptiveLastN: false,
 adaptiveSimulcast: false,
 useRtcpMux: true, // required for FF support
 useBundle: true, // required for FF support
 enableRecording: false,
 enableWelcomePage: true,
 enableSimulcast: false, // blocks FF support
 logStats: false, // Enable logging of PeerConnection stats via the focus

But again I get "Screen sharing extension failed to install"... Is the extension or its Id tied to the domain name?

Server: Debian 9.2, jitsi-meet 1.0.2635
Client: Debian buster/sid, chromium 62.0.3202.89

Which is the situation with Safari: is it compatible with desktop sharing?

Thanks,
Matteo

···

Il 23/11/2017 16:10, Damian Minkov ha scritto:

Hi,

For the jidesha extension, you need to publish it on chrome webstore(https://developer.chrome.com/webstore/publish), verify your site while doing that as this is needed for inline install and take the ID and put it in your config.js.
For document sharing, you need to install etherpad and configure its link in config.js. For live streaming you need to install and configure jibri (https://github.com/jitsi/jibri).

Regards
damencho

On Thu, Nov 23, 2017 at 4:11 AM, Matteo Calorio > <matteo.calorio@linux.ors-tech.it > <mailto:matteo.calorio@linux.ors-tech.it>> wrote:

    Hello,

    I just upgraded Jitsi-meet on a Debian 9.2:

        ii jitsi-meet 1.0.2635-1
        ii jitsi-meet-prosody 1.0.2441-1
        ii jitsi-meet-web 1.0.2441-1
        ii jitsi-meet-web-config 1.0.2441-1
        ii jitsi-videobridge 1011-1

    It works great on Firefox, but I have problems with Chrome and
    Safari: for Chrome I downloaded from Github and built Jidesha
    (Jitsi Desktop Streamer 0.1.6) chrome.crx and installed it, but
    when I click on desktop sharing icon an error appears: "Jitsi
    Desktop Streamer requires update. Changes will take effect after
    next Chrome restart." And: "Screen sharing extension failed to
    install." Nothing changes if I restart Chrome.

    Then, how can I make the extention install when user clicks the
    desktop sharing icon, like on meet.jit.si <http://meet.jit.si>?

    Last, I do not have "Open / close share document" and "Start /
    stop live stream" icons: what can I do to add them?

    Good day,
     M.


#4

Hi,

When you were installing the extension from disk, did you change the name
of the domain in the manifest file and after install take the id from your
chrome and put it in config.js?

In order to use the inline installation you need to upload your extension
to chrome webstore with verifying the site you are using and then adding
the extension id in the config.

Regards
damencho

···

On Thu, Dec 7, 2017 at 5:10 AM, Matteo Calorio < matteo.calorio@linux.ors-tech.it> wrote:

Hi,

I tried to install the extension from disk and I get "Screen sharing
extension failed to install"...

The I installed the extension from meet.jit.si and it worked perfectly.

Then I put the Id of that crome extension in my config.js file:

    desktopSharing: 'ext', // Desktop sharing method. Can be set to 'ext',
'webrtc' or false to disable.
    chromeExtensionId: 'kglhbbefdnlheedjiejgomgmfplipfeb', // Id of
desktop streamer Chrome extension
    desktopSharingChromeExtId: 'kglhbbefdnlheedjiejgomgmfplipfeb',
    desktopSharingSources: ['screen', 'window'],
    minChromeExtVersion: '0.1', // Required version of Chrome extension
    openSctp: true, // Toggle to enable/disable SCTP channels
    disableStats: false,
    disableAudioLevels: false,
    channelLastN: -1, // The default value of the channel attribute last-n.
    adaptiveLastN: false,
    adaptiveSimulcast: false,
    useRtcpMux: true, // required for FF support
    useBundle: true, // required for FF support
    enableRecording: false,
    enableWelcomePage: true,
    enableSimulcast: false, // blocks FF support
    logStats: false, // Enable logging of PeerConnection stats via the
focus

But again I get "Screen sharing extension failed to install"... Is the
extension or its Id tied to the domain name?

Server: Debian 9.2, jitsi-meet 1.0.2635
Client: Debian buster/sid, chromium 62.0.3202.89

Which is the situation with Safari: is it compatible with desktop sharing?

Thanks,
  Matteo

Il 23/11/2017 16:10, Damian Minkov ha scritto:

Hi,

For the jidesha extension, you need to publish it on chrome webstore(
https://developer.chrome.com/webstore/publish), verify your site while
doing that as this is needed for inline install and take the ID and put it
in your config.js.
For document sharing, you need to install etherpad and configure its link
in config.js. For live streaming you need to install and configure jibri (
https://github.com/jitsi/jibri).

Regards
damencho

On Thu, Nov 23, 2017 at 4:11 AM, Matteo Calorio <matteo.calorio@linux.ors- > tech.it> wrote:

Hello,

I just upgraded Jitsi-meet on a Debian 9.2:

ii jitsi-meet 1.0.2635-1
ii jitsi-meet-prosody 1.0.2441-1
ii jitsi-meet-web 1.0.2441-1
ii jitsi-meet-web-config 1.0.2441-1
ii jitsi-videobridge 1011-1

It works great on Firefox, but I have problems with Chrome and Safari:
for Chrome I downloaded from Github and built Jidesha (Jitsi Desktop
Streamer 0.1.6) chrome.crx and installed it, but when I click on desktop
sharing icon an error appears: "Jitsi Desktop Streamer requires update.
Changes will take effect after next Chrome restart." And: "Screen sharing
extension failed to install." Nothing changes if I restart Chrome.

Then, how can I make the extention install when user clicks the desktop
sharing icon, like on meet.jit.si?

Last, I do not have "Open / close share document" and "Start / stop live
stream" icons: what can I do to add them?

Good day,
  M.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Hi Damian,

yes, I did. I did it now again and the behavior is the same: when I click on the desktop sharing icon the message "Jitsi Desktop Streamer requires update. Changes will take effect after next Chrome restart." appears. If I click "OK" in the lower left corner I get "Screen sharing extension failed to install".

I have v.0.1.6 of the extension that I took from https://github.com/jitsi/jidesha

Thanks,
Matteo

···

Il 07/12/2017 15:15, Damian Minkov ha scritto:

Hi,

When you were installing the extension from disk, did you change the name of the domain in the manifest file and after install take the id from your chrome and put it in config.js?

In order to use the inline installation you need to upload your extension to chrome webstore with verifying the site you are using and then adding the extension id in the config.

Regards
damencho

On Thu, Dec 7, 2017 at 5:10 AM, Matteo Calorio > <matteo.calorio@linux.ors-tech.it > <mailto:matteo.calorio@linux.ors-tech.it>> wrote:

    Hi,

    I tried to install the extension from disk and I get "Screen
    sharing extension failed to install"...

    The I installed the extension from meet.jit.si
    <http://meet.jit.si> and it worked perfectly.

    Then I put the Id of that crome extension in my config.js file:

     desktopSharing: 'ext', // Desktop sharing method. Can be set
    to 'ext', 'webrtc' or false to disable.
     chromeExtensionId: 'kglhbbefdnlheedjiejgomgmfplipfeb', // Id
    of desktop streamer Chrome extension
     desktopSharingChromeExtId: 'kglhbbefdnlheedjiejgomgmfplipfeb',
     desktopSharingSources: ['screen', 'window'],
     minChromeExtVersion: '0.1', // Required version of Chrome
    extension
     openSctp: true, // Toggle to enable/disable SCTP channels
     disableStats: false,
     disableAudioLevels: false,
     channelLastN: -1, // The default value of the channel
    attribute last-n.
     adaptiveLastN: false,
     adaptiveSimulcast: false,
     useRtcpMux: true, // required for FF support
     useBundle: true, // required for FF support
     enableRecording: false,
     enableWelcomePage: true,
     enableSimulcast: false, // blocks FF support
     logStats: false, // Enable logging of PeerConnection stats via
    the focus

    But again I get "Screen sharing extension failed to install"... Is
    the extension or its Id tied to the domain name?

    Server: Debian 9.2, jitsi-meet 1.0.2635
    Client: Debian buster/sid, chromium 62.0.3202.89

    Which is the situation with Safari: is it compatible with desktop
    sharing?

    Thanks,
     Matteo

    Il 23/11/2017 16:10, Damian Minkov ha scritto:

    Hi,

    For the jidesha extension, you need to publish it on chrome
    webstore(https://developer.chrome.com/webstore/publish
    <https://developer.chrome.com/webstore/publish>), verify your
    site while doing that as this is needed for inline install and
    take the ID and put it in your config.js.
    For document sharing, you need to install etherpad and configure
    its link in config.js. For live streaming you need to install and
    configure jibri (https://github.com/jitsi/jibri
    <https://github.com/jitsi/jibri>).

    Regards
    damencho

    On Thu, Nov 23, 2017 at 4:11 AM, Matteo Calorio >> <matteo.calorio@linux.ors-tech.it >> <mailto:matteo.calorio@linux.ors-tech.it>> wrote:

        Hello,

        I just upgraded Jitsi-meet on a Debian 9.2:

            ii jitsi-meet 1.0.2635-1
            ii jitsi-meet-prosody 1.0.2441-1
            ii jitsi-meet-web 1.0.2441-1
            ii jitsi-meet-web-config 1.0.2441-1
            ii jitsi-videobridge 1011-1

        It works great on Firefox, but I have problems with Chrome
        and Safari: for Chrome I downloaded from Github and built
        Jidesha (Jitsi Desktop Streamer 0.1.6) chrome.crx and
        installed it, but when I click on desktop sharing icon an
        error appears: "Jitsi Desktop Streamer requires update.
        Changes will take effect after next Chrome restart." And:
        "Screen sharing extension failed to install." Nothing changes
        if I restart Chrome.

        Then, how can I make the extention install when user clicks
        the desktop sharing icon, like on meet.jit.si
        <http://meet.jit.si>?

        Last, I do not have "Open / close share document" and "Start
        / stop live stream" icons: what can I do to add them?

        Good day,
         M.


#6

Hi Matteo,

When you uploaded your own jidesha bundle to the Chrome store, you should
get your own random string, which is what you need to put in your system's
config.js desktopSharingChromeExtId. In the config.js snippet you provided,
you have the wrong ExtId -- that one is the official meet.jit.si one, were
you just showing that as an example?

For comparison to your own setup, if you look at
https://meet.jit.si/config.js, you will see:

    desktopSharingChromeExtId: '*kglhbbefdnlheedjiejgomgmfplipfeb*',
// Id of desktop streamer Chrome extension

This value must match the extension ID for the corresponding item in the
Chrome Store, and can be seen in the play store URL for the current one
that is locked to the "*://meet.jit.si/*" pattern:

    https://chrome.google.com/webstore/detail/jitsi-meetings/
*kglhbbefdnlheedjiejgomgmfplipfeb*

Cheers,
Simon

···

On Thu, Dec 7, 2017 at 10:45 AM, Matteo Calorio < matteo.calorio@linux.ors-tech.it> wrote:

Hi Damian,

yes, I did. I did it now again and the behavior is the same: when I click
on the desktop sharing icon the message "Jitsi Desktop Streamer requires
update. Changes will take effect after next Chrome restart." appears. If I
click "OK" in the lower left corner I get "Screen sharing extension failed
to install".

I have v.0.1.6 of the extension that I took from https://github.com/jitsi/
jidesha

Thanks,
  Matteo

Il 07/12/2017 15:15, Damian Minkov ha scritto:

Hi,

When you were installing the extension from disk, did you change the name
of the domain in the manifest file and after install take the id from your
chrome and put it in config.js?

In order to use the inline installation you need to upload your extension
to chrome webstore with verifying the site you are using and then adding
the extension id in the config.

Regards
damencho

On Thu, Dec 7, 2017 at 5:10 AM, Matteo Calorio <matteo.calorio@linux.ors- > tech.it> wrote:

Hi,

I tried to install the extension from disk and I get "Screen sharing
extension failed to install"...

The I installed the extension from meet.jit.si and it worked perfectly.

Then I put the Id of that crome extension in my config.js file:

    desktopSharing: 'ext', // Desktop sharing method. Can be set to
'ext', 'webrtc' or false to disable.
    chromeExtensionId: 'kglhbbefdnlheedjiejgomgmfplipfeb', // Id of
desktop streamer Chrome extension
    desktopSharingChromeExtId: 'kglhbbefdnlheedjiejgomgmfplipfeb',
    desktopSharingSources: ['screen', 'window'],
    minChromeExtVersion: '0.1', // Required version of Chrome extension
    openSctp: true, // Toggle to enable/disable SCTP channels
    disableStats: false,
    disableAudioLevels: false,
    channelLastN: -1, // The default value of the channel attribute
last-n.
    adaptiveLastN: false,
    adaptiveSimulcast: false,
    useRtcpMux: true, // required for FF support
    useBundle: true, // required for FF support
    enableRecording: false,
    enableWelcomePage: true,
    enableSimulcast: false, // blocks FF support
    logStats: false, // Enable logging of PeerConnection stats via the
focus

But again I get "Screen sharing extension failed to install"... Is the
extension or its Id tied to the domain name?

Server: Debian 9.2, jitsi-meet 1.0.2635
Client: Debian buster/sid, chromium 62.0.3202.89

Which is the situation with Safari: is it compatible with desktop sharing?

Thanks,
  Matteo

Il 23/11/2017 16:10, Damian Minkov ha scritto:

Hi,

For the jidesha extension, you need to publish it on chrome webstore(
https://developer.chrome.com/webstore/publish), verify your site while
doing that as this is needed for inline install and take the ID and put it
in your config.js.
For document sharing, you need to install etherpad and configure its link
in config.js. For live streaming you need to install and configure jibri (
https://github.com/jitsi/jibri).

Regards
damencho

On Thu, Nov 23, 2017 at 4:11 AM, Matteo Calorio < >> matteo.calorio@linux.ors-tech.it> wrote:

Hello,

I just upgraded Jitsi-meet on a Debian 9.2:

ii jitsi-meet 1.0.2635-1
ii jitsi-meet-prosody 1.0.2441-1
ii jitsi-meet-web 1.0.2441-1
ii jitsi-meet-web-config 1.0.2441-1
ii jitsi-videobridge 1011-1

It works great on Firefox, but I have problems with Chrome and Safari:
for Chrome I downloaded from Github and built Jidesha (Jitsi Desktop
Streamer 0.1.6) chrome.crx and installed it, but when I click on desktop
sharing icon an error appears: "Jitsi Desktop Streamer requires update.
Changes will take effect after next Chrome restart." And: "Screen sharing
extension failed to install." Nothing changes if I restart Chrome.

Then, how can I make the extention install when user clicks the desktop
sharing icon, like on meet.jit.si?

Last, I do not have "Open / close share document" and "Start / stop live
stream" icons: what can I do to add them?

Good day,
  M.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#7

Hi Simon,

so it's not the same to install the extension manually and put the id in config.js?

Anyway, I published the extension and put the ID in config.js file. I checked https://site/config.js and the ID is the one I got from Google.

But when I click the desktop sharing icon I again get "Screen sharing extension failed to install".

I zipped the "chrome" subfolder to upload on Google:

background.js
jitsi-logo-128x128.png
jitsi-logo-16x16.png
jitsi-logo-48x48.png
manifest.json
README.md

Is it correct?

Thanks,
Matteo

···

Il 07/12/2017 18:10, Simon Ditner ha scritto:

Hi Matteo,

When you uploaded your own jidesha bundle to the Chrome store, you should get your own random string, which is what you need to put in your system's config.js desktopSharingChromeExtId. In the config.js snippet you provided, you have the wrong ExtId -- that one is the official meet.jit.si <http://meet.jit.si> one, were you just showing that as an example?

For comparison to your own setup, if you look at https://meet.jit.si/config.js, you will see:
     desktopSharingChromeExtId: '*kglhbbefdnlheedjiejgomgmfplipfeb*', // Id of desktop streamer Chrome extension
This value must match the extension ID for the corresponding item in the Chrome Store, and can be seen in the play store URL for the current one that is locked to the "*://meet.jit.si/* <http://meet.jit.si/*>" pattern:

https://chrome.google.com/webstore/detail/jitsi-meetings/kglhbbefdnlheedjiejgomgmfplipfeb

Cheers,
Simon

On Thu, Dec 7, 2017 at 10:45 AM, Matteo Calorio > <matteo.calorio@linux.ors-tech.it > <mailto:matteo.calorio@linux.ors-tech.it>> wrote:

    Hi Damian,

    yes, I did. I did it now again and the behavior is the same: when
    I click on the desktop sharing icon the message "Jitsi Desktop
    Streamer requires update. Changes will take effect after next
    Chrome restart." appears. If I click "OK" in the lower left corner
    I get "Screen sharing extension failed to install".

    I have v.0.1.6 of the extension that I took from
    https://github.com/jitsi/jidesha

    Thanks,
     Matteo

    Il 07/12/2017 15:15, Damian Minkov ha scritto:

    Hi,

    When you were installing the extension from disk, did you change
    the name of the domain in the manifest file and after install
    take the id from your chrome and put it in config.js?

    In order to use the inline installation you need to upload your
    extension to chrome webstore with verifying the site you are
    using and then adding the extension id in the config.

    Regards
    damencho

    On Thu, Dec 7, 2017 at 5:10 AM, Matteo Calorio >> <matteo.calorio@linux.ors-tech.it >> <mailto:matteo.calorio@linux.ors-tech.it>> wrote:

        Hi,

        I tried to install the extension from disk and I get "Screen
        sharing extension failed to install"...

        The I installed the extension from meet.jit.si
        <http://meet.jit.si> and it worked perfectly.

        Then I put the Id of that crome extension in my config.js file:

         desktopSharing: 'ext', // Desktop sharing method. Can be
        set to 'ext', 'webrtc' or false to disable.
         chromeExtensionId: 'kglhbbefdnlheedjiejgomgmfplipfeb', //
        Id of desktop streamer Chrome extension
         desktopSharingChromeExtId:
        'kglhbbefdnlheedjiejgomgmfplipfeb',
         desktopSharingSources: ['screen', 'window'],
         minChromeExtVersion: '0.1', // Required version of Chrome
        extension
         openSctp: true, // Toggle to enable/disable SCTP channels
         disableStats: false,
         disableAudioLevels: false,
         channelLastN: -1, // The default value of the channel
        attribute last-n.
         adaptiveLastN: false,
         adaptiveSimulcast: false,
         useRtcpMux: true, // required for FF support
         useBundle: true, // required for FF support
         enableRecording: false,
         enableWelcomePage: true,
         enableSimulcast: false, // blocks FF support
         logStats: false, // Enable logging of PeerConnection
        stats via the focus

        But again I get "Screen sharing extension failed to
        install"... Is the extension or its Id tied to the domain name?

        Server: Debian 9.2, jitsi-meet 1.0.2635
        Client: Debian buster/sid, chromium 62.0.3202.89

        Which is the situation with Safari: is it compatible with
        desktop sharing?

        Thanks,
         Matteo

        Il 23/11/2017 16:10, Damian Minkov ha scritto:

        Hi,

        For the jidesha extension, you need to publish it on chrome
        webstore(https://developer.chrome.com/webstore/publish
        <https://developer.chrome.com/webstore/publish>), verify
        your site while doing that as this is needed for inline
        install and take the ID and put it in your config.js.
        For document sharing, you need to install etherpad and
        configure its link in config.js. For live streaming you need
        to install and configure jibri
        (https://github.com/jitsi/jibri
        <https://github.com/jitsi/jibri>).

        Regards
        damencho

        On Thu, Nov 23, 2017 at 4:11 AM, Matteo Calorio >>> <matteo.calorio@linux.ors-tech.it >>> <mailto:matteo.calorio@linux.ors-tech.it>> wrote:

            Hello,

            I just upgraded Jitsi-meet on a Debian 9.2:

                ii jitsi-meet 1.0.2635-1
                ii jitsi-meet-prosody 1.0.2441-1
                ii jitsi-meet-web 1.0.2441-1
                ii jitsi-meet-web-config 1.0.2441-1
                ii jitsi-videobridge 1011-1

            It works great on Firefox, but I have problems with
            Chrome and Safari: for Chrome I downloaded from Github
            and built Jidesha (Jitsi Desktop Streamer 0.1.6)
            chrome.crx and installed it, but when I click on desktop
            sharing icon an error appears: "Jitsi Desktop Streamer
            requires update. Changes will take effect after next
            Chrome restart." And: "Screen sharing extension failed
            to install." Nothing changes if I restart Chrome.

            Then, how can I make the extention install when user
            clicks the desktop sharing icon, like on meet.jit.si
            <http://meet.jit.si>?

            Last, I do not have "Open / close share document" and
            "Start / stop live stream" icons: what can I do to add them?

            Good day,
             M.


#8

Hi,

And you have changed manifest.json with your domain? You also need to
verify the site during the extension upload.

Regards
damencho

···

On Mon, Dec 11, 2017 at 4:55 AM, Matteo Calorio <matteo.calorio@linux.ors-tech.it> wrote:

Hi Simon,

so it's not the same to install the extension manually and put the id in
config.js?

Anyway, I published the extension and put the ID in config.js file. I
checked https://site/config.js and the ID is the one I got from Google.

But when I click the desktop sharing icon I again get "Screen sharing
extension failed to install".

I zipped the "chrome" subfolder to upload on Google:

background.js
jitsi-logo-128x128.png
jitsi-logo-16x16.png
jitsi-logo-48x48.png
manifest.json
README.md

Is it correct?

Thanks,
  Matteo

Il 07/12/2017 18:10, Simon Ditner ha scritto:

Hi Matteo,

When you uploaded your own jidesha bundle to the Chrome store, you should
get your own random string, which is what you need to put in your system's
config.js desktopSharingChromeExtId. In the config.js snippet you provided,
you have the wrong ExtId -- that one is the official meet.jit.si one, were
you just showing that as an example?

For comparison to your own setup, if you look at
https://meet.jit.si/config.js, you will see:

    desktopSharingChromeExtId: 'kglhbbefdnlheedjiejgomgmfplipfeb', // Id of
desktop streamer Chrome extension

This value must match the extension ID for the corresponding item in the
Chrome Store, and can be seen in the play store URL for the current one that
is locked to the "*://meet.jit.si/*" pattern:

https://chrome.google.com/webstore/detail/jitsi-meetings/kglhbbefdnlheedjiejgomgmfplipfeb

Cheers,
Simon

On Thu, Dec 7, 2017 at 10:45 AM, Matteo Calorio > <matteo.calorio@linux.ors-tech.it> wrote:

Hi Damian,

yes, I did. I did it now again and the behavior is the same: when I click
on the desktop sharing icon the message "Jitsi Desktop Streamer requires
update. Changes will take effect after next Chrome restart." appears. If I
click "OK" in the lower left corner I get "Screen sharing extension failed
to install".

I have v.0.1.6 of the extension that I took from
https://github.com/jitsi/jidesha

Thanks,
  Matteo

Il 07/12/2017 15:15, Damian Minkov ha scritto:

Hi,

When you were installing the extension from disk, did you change the name
of the domain in the manifest file and after install take the id from your
chrome and put it in config.js?

In order to use the inline installation you need to upload your extension
to chrome webstore with verifying the site you are using and then adding the
extension id in the config.

Regards
damencho

On Thu, Dec 7, 2017 at 5:10 AM, Matteo Calorio >> <matteo.calorio@linux.ors-tech.it> wrote:

Hi,

I tried to install the extension from disk and I get "Screen sharing
extension failed to install"...

The I installed the extension from meet.jit.si and it worked perfectly.

Then I put the Id of that crome extension in my config.js file:

    desktopSharing: 'ext', // Desktop sharing method. Can be set to
'ext', 'webrtc' or false to disable.
    chromeExtensionId: 'kglhbbefdnlheedjiejgomgmfplipfeb', // Id of
desktop streamer Chrome extension
    desktopSharingChromeExtId: 'kglhbbefdnlheedjiejgomgmfplipfeb',
    desktopSharingSources: ['screen', 'window'],
    minChromeExtVersion: '0.1', // Required version of Chrome extension
    openSctp: true, // Toggle to enable/disable SCTP channels
    disableStats: false,
    disableAudioLevels: false,
    channelLastN: -1, // The default value of the channel attribute
last-n.
    adaptiveLastN: false,
    adaptiveSimulcast: false,
    useRtcpMux: true, // required for FF support
    useBundle: true, // required for FF support
    enableRecording: false,
    enableWelcomePage: true,
    enableSimulcast: false, // blocks FF support
    logStats: false, // Enable logging of PeerConnection stats via the
focus

But again I get "Screen sharing extension failed to install"... Is the
extension or its Id tied to the domain name?

Server: Debian 9.2, jitsi-meet 1.0.2635
Client: Debian buster/sid, chromium 62.0.3202.89

Which is the situation with Safari: is it compatible with desktop
sharing?

Thanks,
  Matteo

Il 23/11/2017 16:10, Damian Minkov ha scritto:

Hi,

For the jidesha extension, you need to publish it on chrome
webstore(https://developer.chrome.com/webstore/publish), verify your site
while doing that as this is needed for inline install and take the ID and
put it in your config.js.
For document sharing, you need to install etherpad and configure its link
in config.js. For live streaming you need to install and configure jibri
(https://github.com/jitsi/jibri).

Regards
damencho

On Thu, Nov 23, 2017 at 4:11 AM, Matteo Calorio >>> <matteo.calorio@linux.ors-tech.it> wrote:

Hello,

I just upgraded Jitsi-meet on a Debian 9.2:

ii jitsi-meet 1.0.2635-1
ii jitsi-meet-prosody 1.0.2441-1
ii jitsi-meet-web 1.0.2441-1
ii jitsi-meet-web-config 1.0.2441-1
ii jitsi-videobridge 1011-1

It works great on Firefox, but I have problems with Chrome and Safari:
for Chrome I downloaded from Github and built Jidesha (Jitsi Desktop
Streamer 0.1.6) chrome.crx and installed it, but when I click on desktop
sharing icon an error appears: "Jitsi Desktop Streamer requires update.
Changes will take effect after next Chrome restart." And: "Screen sharing
extension failed to install." Nothing changes if I restart Chrome.

Then, how can I make the extention install when user clicks the desktop
sharing icon, like on meet.jit.si?

Last, I do not have "Open / close share document" and "Start / stop live
stream" icons: what can I do to add them?

Good day,
  M.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#9

Yes, I changed manifest.json and I verified the site...

···

Il 11/12/2017 15:45, Damian Minkov ha scritto:

Hi,

And you have changed manifest.json with your domain? You also need to
verify the site during the extension upload.

Regards
damencho

On Mon, Dec 11, 2017 at 4:55 AM, Matteo Calorio > <matteo.calorio@linux.ors-tech.it> wrote:

Hi Simon,

so it's not the same to install the extension manually and put the id in
config.js?

Anyway, I published the extension and put the ID in config.js file. I
checked https://site/config.js and the ID is the one I got from Google.

But when I click the desktop sharing icon I again get "Screen sharing
extension failed to install".

I zipped the "chrome" subfolder to upload on Google:

background.js
jitsi-logo-128x128.png
jitsi-logo-16x16.png
jitsi-logo-48x48.png
manifest.json
README.md

Is it correct?

Thanks,
   Matteo

Il 07/12/2017 18:10, Simon Ditner ha scritto:

Hi Matteo,

When you uploaded your own jidesha bundle to the Chrome store, you should
get your own random string, which is what you need to put in your system's
config.js desktopSharingChromeExtId. In the config.js snippet you provided,
you have the wrong ExtId -- that one is the official meet.jit.si one, were
you just showing that as an example?

For comparison to your own setup, if you look at
https://meet.jit.si/config.js, you will see:

     desktopSharingChromeExtId: 'kglhbbefdnlheedjiejgomgmfplipfeb', // Id of
desktop streamer Chrome extension

This value must match the extension ID for the corresponding item in the
Chrome Store, and can be seen in the play store URL for the current one that
is locked to the "*://meet.jit.si/*" pattern:

https://chrome.google.com/webstore/detail/jitsi-meetings/kglhbbefdnlheedjiejgomgmfplipfeb

Cheers,
Simon

On Thu, Dec 7, 2017 at 10:45 AM, Matteo Calorio >> <matteo.calorio@linux.ors-tech.it> wrote:

Hi Damian,

yes, I did. I did it now again and the behavior is the same: when I click
on the desktop sharing icon the message "Jitsi Desktop Streamer requires
update. Changes will take effect after next Chrome restart." appears. If I
click "OK" in the lower left corner I get "Screen sharing extension failed
to install".

I have v.0.1.6 of the extension that I took from
https://github.com/jitsi/jidesha

Thanks,
   Matteo

Il 07/12/2017 15:15, Damian Minkov ha scritto:

Hi,

When you were installing the extension from disk, did you change the name
of the domain in the manifest file and after install take the id from your
chrome and put it in config.js?

In order to use the inline installation you need to upload your extension
to chrome webstore with verifying the site you are using and then adding the
extension id in the config.

Regards
damencho

On Thu, Dec 7, 2017 at 5:10 AM, Matteo Calorio >>> <matteo.calorio@linux.ors-tech.it> wrote:

Hi,

I tried to install the extension from disk and I get "Screen sharing
extension failed to install"...

The I installed the extension from meet.jit.si and it worked perfectly.

Then I put the Id of that crome extension in my config.js file:

     desktopSharing: 'ext', // Desktop sharing method. Can be set to
'ext', 'webrtc' or false to disable.
     chromeExtensionId: 'kglhbbefdnlheedjiejgomgmfplipfeb', // Id of
desktop streamer Chrome extension
     desktopSharingChromeExtId: 'kglhbbefdnlheedjiejgomgmfplipfeb',
     desktopSharingSources: ['screen', 'window'],
     minChromeExtVersion: '0.1', // Required version of Chrome extension
     openSctp: true, // Toggle to enable/disable SCTP channels
     disableStats: false,
     disableAudioLevels: false,
     channelLastN: -1, // The default value of the channel attribute
last-n.
     adaptiveLastN: false,
     adaptiveSimulcast: false,
     useRtcpMux: true, // required for FF support
     useBundle: true, // required for FF support
     enableRecording: false,
     enableWelcomePage: true,
     enableSimulcast: false, // blocks FF support
     logStats: false, // Enable logging of PeerConnection stats via the
focus

But again I get "Screen sharing extension failed to install"... Is the
extension or its Id tied to the domain name?

Server: Debian 9.2, jitsi-meet 1.0.2635
Client: Debian buster/sid, chromium 62.0.3202.89

Which is the situation with Safari: is it compatible with desktop
sharing?

Thanks,
   Matteo

Il 23/11/2017 16:10, Damian Minkov ha scritto:

Hi,

For the jidesha extension, you need to publish it on chrome
webstore(https://developer.chrome.com/webstore/publish), verify your site
while doing that as this is needed for inline install and take the ID and
put it in your config.js.
For document sharing, you need to install etherpad and configure its link
in config.js. For live streaming you need to install and configure jibri
(https://github.com/jitsi/jibri).

Regards
damencho

On Thu, Nov 23, 2017 at 4:11 AM, Matteo Calorio >>>> <matteo.calorio@linux.ors-tech.it> wrote:

Hello,

I just upgraded Jitsi-meet on a Debian 9.2:

ii jitsi-meet 1.0.2635-1
ii jitsi-meet-prosody 1.0.2441-1
ii jitsi-meet-web 1.0.2441-1
ii jitsi-meet-web-config 1.0.2441-1
ii jitsi-videobridge 1011-1

It works great on Firefox, but I have problems with Chrome and Safari:
for Chrome I downloaded from Github and built Jidesha (Jitsi Desktop
Streamer 0.1.6) chrome.crx and installed it, but when I click on desktop
sharing icon an error appears: "Jitsi Desktop Streamer requires update.
Changes will take effect after next Chrome restart." And: "Screen sharing
extension failed to install." Nothing changes if I restart Chrome.

Then, how can I make the extention install when user clicks the desktop
sharing icon, like on meet.jit.si?

Last, I do not have "Open / close share document" and "Start / stop live
stream" icons: what can I do to add them?

Good day,
   M.


#10

Hi Matteo,

Your configuration appears to be correct now -- however you will see an
error message the first time the plugin is installed. There seems to be an
order of operation issue in the jitsi-meet plugin installation code for the
latest builds. I opened an issue regarding it on github:
https://github.com/jitsi/jitsi-meet/issues/2300

Cheers,
Simon

···

On Mon, Dec 11, 2017 at 10:45 AM, Matteo Calorio < matteo.calorio@linux.ors-tech.it> wrote:

Yes, I changed manifest.json and I verified the site...

Il 11/12/2017 15:45, Damian Minkov ha scritto:

Hi,

And you have changed manifest.json with your domain? You also need to
verify the site during the extension upload.

Regards
damencho

On Mon, Dec 11, 2017 at 4:55 AM, Matteo Calorio >> <matteo.calorio@linux.ors-tech.it> wrote:

Hi Simon,

so it's not the same to install the extension manually and put the id in
config.js?

Anyway, I published the extension and put the ID in config.js file. I
checked https://site/config.js and the ID is the one I got from Google.

But when I click the desktop sharing icon I again get "Screen sharing
extension failed to install".

I zipped the "chrome" subfolder to upload on Google:

background.js
jitsi-logo-128x128.png
jitsi-logo-16x16.png
jitsi-logo-48x48.png
manifest.json
README.md

Is it correct?

Thanks,
   Matteo

Il 07/12/2017 18:10, Simon Ditner ha scritto:

Hi Matteo,

When you uploaded your own jidesha bundle to the Chrome store, you should
get your own random string, which is what you need to put in your
system's
config.js desktopSharingChromeExtId. In the config.js snippet you
provided,
you have the wrong ExtId -- that one is the official meet.jit.si one,
were
you just showing that as an example?

For comparison to your own setup, if you look at
https://meet.jit.si/config.js, you will see:

     desktopSharingChromeExtId: 'kglhbbefdnlheedjiejgomgmfplipfeb', //
Id of
desktop streamer Chrome extension

This value must match the extension ID for the corresponding item in the
Chrome Store, and can be seen in the play store URL for the current one
that
is locked to the "*://meet.jit.si/*" pattern:

https://chrome.google.com/webstore/detail/jitsi-meetings/kgl
hbbefdnlheedjiejgomgmfplipfeb

Cheers,
Simon

On Thu, Dec 7, 2017 at 10:45 AM, Matteo Calorio >>> <matteo.calorio@linux.ors-tech.it> wrote:

Hi Damian,

yes, I did. I did it now again and the behavior is the same: when I
click
on the desktop sharing icon the message "Jitsi Desktop Streamer requires
update. Changes will take effect after next Chrome restart." appears.
If I
click "OK" in the lower left corner I get "Screen sharing extension
failed
to install".

I have v.0.1.6 of the extension that I took from
https://github.com/jitsi/jidesha

Thanks,
   Matteo

Il 07/12/2017 15:15, Damian Minkov ha scritto:

Hi,

When you were installing the extension from disk, did you change the
name
of the domain in the manifest file and after install take the id from
your
chrome and put it in config.js?

In order to use the inline installation you need to upload your
extension
to chrome webstore with verifying the site you are using and then
adding the
extension id in the config.

Regards
damencho

On Thu, Dec 7, 2017 at 5:10 AM, Matteo Calorio >>>> <matteo.calorio@linux.ors-tech.it> wrote:

Hi,

I tried to install the extension from disk and I get "Screen sharing
extension failed to install"...

The I installed the extension from meet.jit.si and it worked
perfectly.

Then I put the Id of that crome extension in my config.js file:

     desktopSharing: 'ext', // Desktop sharing method. Can be set to
'ext', 'webrtc' or false to disable.
     chromeExtensionId: 'kglhbbefdnlheedjiejgomgmfplipfeb', // Id of
desktop streamer Chrome extension
     desktopSharingChromeExtId: 'kglhbbefdnlheedjiejgomgmfplipfeb',
     desktopSharingSources: ['screen', 'window'],
     minChromeExtVersion: '0.1', // Required version of Chrome
extension
     openSctp: true, // Toggle to enable/disable SCTP channels
     disableStats: false,
     disableAudioLevels: false,
     channelLastN: -1, // The default value of the channel attribute
last-n.
     adaptiveLastN: false,
     adaptiveSimulcast: false,
     useRtcpMux: true, // required for FF support
     useBundle: true, // required for FF support
     enableRecording: false,
     enableWelcomePage: true,
     enableSimulcast: false, // blocks FF support
     logStats: false, // Enable logging of PeerConnection stats via the
focus

But again I get "Screen sharing extension failed to install"... Is the
extension or its Id tied to the domain name?

Server: Debian 9.2, jitsi-meet 1.0.2635
Client: Debian buster/sid, chromium 62.0.3202.89

Which is the situation with Safari: is it compatible with desktop
sharing?

Thanks,
   Matteo

Il 23/11/2017 16:10, Damian Minkov ha scritto:

Hi,

For the jidesha extension, you need to publish it on chrome
webstore(https://developer.chrome.com/webstore/publish), verify your
site
while doing that as this is needed for inline install and take the ID
and
put it in your config.js.
For document sharing, you need to install etherpad and configure its
link
in config.js. For live streaming you need to install and configure
jibri
(https://github.com/jitsi/jibri).

Regards
damencho

On Thu, Nov 23, 2017 at 4:11 AM, Matteo Calorio >>>>> <matteo.calorio@linux.ors-tech.it> wrote:

Hello,

I just upgraded Jitsi-meet on a Debian 9.2:

ii jitsi-meet 1.0.2635-1
ii jitsi-meet-prosody 1.0.2441-1
ii jitsi-meet-web 1.0.2441-1
ii jitsi-meet-web-config 1.0.2441-1
ii jitsi-videobridge 1011-1

It works great on Firefox, but I have problems with Chrome and Safari:
for Chrome I downloaded from Github and built Jidesha (Jitsi Desktop
Streamer 0.1.6) chrome.crx and installed it, but when I click on
desktop
sharing icon an error appears: "Jitsi Desktop Streamer requires
update.
Changes will take effect after next Chrome restart." And: "Screen
sharing
extension failed to install." Nothing changes if I restart Chrome.

Then, how can I make the extention install when user clicks the
desktop
sharing icon, like on meet.jit.si?

Last, I do not have "Open / close share document" and "Start / stop
live
stream" icons: what can I do to add them?

Good day,
   M.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#11

Sorry, I was incorrect regarding that ticket. The site I was testing
against didn't have an HTTP to HTTPS redirect, and I inadvertently went to
the HTTP site. I'm still not certain why yours successfully installs the
plugin, yet displays a red error message saying it failed...

···

--
Simon P. Ditner <spditner@gmail.com>
Office: +1 (416) 848-7573 / Mobile: +1 (647) 899-1293

On Thu, Dec 14, 2017 at 10:51 AM, Simon Ditner <spditner@gmail.com> wrote:

Hi Matteo,

Your configuration appears to be correct now -- however you will see an
error message the first time the plugin is installed. There seems to be an
order of operation issue in the jitsi-meet plugin installation code for the
latest builds. I opened an issue regarding it on github:
https://github.com/jitsi/jitsi-meet/issues/2300

Cheers,
Simon

On Mon, Dec 11, 2017 at 10:45 AM, Matteo Calorio < > matteo.calorio@linux.ors-tech.it> wrote:

Yes, I changed manifest.json and I verified the site...

Il 11/12/2017 15:45, Damian Minkov ha scritto:

Hi,

And you have changed manifest.json with your domain? You also need to
verify the site during the extension upload.

Regards
damencho

On Mon, Dec 11, 2017 at 4:55 AM, Matteo Calorio >>> <matteo.calorio@linux.ors-tech.it> wrote:

Hi Simon,

so it's not the same to install the extension manually and put the id in
config.js?

Anyway, I published the extension and put the ID in config.js file. I
checked https://site/config.js and the ID is the one I got from Google.

But when I click the desktop sharing icon I again get "Screen sharing
extension failed to install".

I zipped the "chrome" subfolder to upload on Google:

background.js
jitsi-logo-128x128.png
jitsi-logo-16x16.png
jitsi-logo-48x48.png
manifest.json
README.md

Is it correct?

Thanks,
   Matteo

Il 07/12/2017 18:10, Simon Ditner ha scritto:

Hi Matteo,

When you uploaded your own jidesha bundle to the Chrome store, you
should
get your own random string, which is what you need to put in your
system's
config.js desktopSharingChromeExtId. In the config.js snippet you
provided,
you have the wrong ExtId -- that one is the official meet.jit.si one,
were
you just showing that as an example?

For comparison to your own setup, if you look at
https://meet.jit.si/config.js, you will see:

     desktopSharingChromeExtId: 'kglhbbefdnlheedjiejgomgmfplipfeb', //
Id of
desktop streamer Chrome extension

This value must match the extension ID for the corresponding item in the
Chrome Store, and can be seen in the play store URL for the current one
that
is locked to the "*://meet.jit.si/*" pattern:

https://chrome.google.com/webstore/detail/jitsi-meetings/kgl
hbbefdnlheedjiejgomgmfplipfeb

Cheers,
Simon

On Thu, Dec 7, 2017 at 10:45 AM, Matteo Calorio >>>> <matteo.calorio@linux.ors-tech.it> wrote:

Hi Damian,

yes, I did. I did it now again and the behavior is the same: when I
click
on the desktop sharing icon the message "Jitsi Desktop Streamer
requires
update. Changes will take effect after next Chrome restart." appears.
If I
click "OK" in the lower left corner I get "Screen sharing extension
failed
to install".

I have v.0.1.6 of the extension that I took from
https://github.com/jitsi/jidesha

Thanks,
   Matteo

Il 07/12/2017 15:15, Damian Minkov ha scritto:

Hi,

When you were installing the extension from disk, did you change the
name
of the domain in the manifest file and after install take the id from
your
chrome and put it in config.js?

In order to use the inline installation you need to upload your
extension
to chrome webstore with verifying the site you are using and then
adding the
extension id in the config.

Regards
damencho

On Thu, Dec 7, 2017 at 5:10 AM, Matteo Calorio >>>>> <matteo.calorio@linux.ors-tech.it> wrote:

Hi,

I tried to install the extension from disk and I get "Screen sharing
extension failed to install"...

The I installed the extension from meet.jit.si and it worked
perfectly.

Then I put the Id of that crome extension in my config.js file:

     desktopSharing: 'ext', // Desktop sharing method. Can be set to
'ext', 'webrtc' or false to disable.
     chromeExtensionId: 'kglhbbefdnlheedjiejgomgmfplipfeb', // Id of
desktop streamer Chrome extension
     desktopSharingChromeExtId: 'kglhbbefdnlheedjiejgomgmfplipfeb',
     desktopSharingSources: ['screen', 'window'],
     minChromeExtVersion: '0.1', // Required version of Chrome
extension
     openSctp: true, // Toggle to enable/disable SCTP channels
     disableStats: false,
     disableAudioLevels: false,
     channelLastN: -1, // The default value of the channel attribute
last-n.
     adaptiveLastN: false,
     adaptiveSimulcast: false,
     useRtcpMux: true, // required for FF support
     useBundle: true, // required for FF support
     enableRecording: false,
     enableWelcomePage: true,
     enableSimulcast: false, // blocks FF support
     logStats: false, // Enable logging of PeerConnection stats via
the
focus

But again I get "Screen sharing extension failed to install"... Is the
extension or its Id tied to the domain name?

Server: Debian 9.2, jitsi-meet 1.0.2635
Client: Debian buster/sid, chromium 62.0.3202.89

Which is the situation with Safari: is it compatible with desktop
sharing?

Thanks,
   Matteo

Il 23/11/2017 16:10, Damian Minkov ha scritto:

Hi,

For the jidesha extension, you need to publish it on chrome
webstore(https://developer.chrome.com/webstore/publish), verify your
site
while doing that as this is needed for inline install and take the ID
and
put it in your config.js.
For document sharing, you need to install etherpad and configure its
link
in config.js. For live streaming you need to install and configure
jibri
(https://github.com/jitsi/jibri).

Regards
damencho

On Thu, Nov 23, 2017 at 4:11 AM, Matteo Calorio >>>>>> <matteo.calorio@linux.ors-tech.it> wrote:

Hello,

I just upgraded Jitsi-meet on a Debian 9.2:

ii jitsi-meet 1.0.2635-1
ii jitsi-meet-prosody 1.0.2441-1
ii jitsi-meet-web 1.0.2441-1
ii jitsi-meet-web-config 1.0.2441-1
ii jitsi-videobridge 1011-1

It works great on Firefox, but I have problems with Chrome and
Safari:
for Chrome I downloaded from Github and built Jidesha (Jitsi Desktop
Streamer 0.1.6) chrome.crx and installed it, but when I click on
desktop
sharing icon an error appears: "Jitsi Desktop Streamer requires
update.
Changes will take effect after next Chrome restart." And: "Screen
sharing
extension failed to install." Nothing changes if I restart Chrome.

Then, how can I make the extention install when user clicks the
desktop
sharing icon, like on meet.jit.si?

Last, I do not have "Open / close share document" and "Start / stop
live
stream" icons: what can I do to add them?

Good day,
   M.

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users