[jitsi-users] jitsi meet with 15 users


#1

hi,

i have this issue with jitsi meet webconference, so please help me.

i have a jitsi meet server on our internal network - Dual-Core AMD Opteron - 2800 Mhz, ubuntu, 4Gb Ram, 1Gbit network card
15 users today in a webconference.

from 12 users up the users computers procs went to 100% usage and chrome/opera/firefox-night browsers crashed.with 10 users the conference was quite ok.

my computer : core2duo 2.53Ghz, 4Ghz, with 10 users i have 80% load on CPU.
my computer : core2duo 2.53Ghz, 4Ghz, with 15 users i have 100% load on CPU, after ten minutes i manage to enter the conference, but with lag and very poor quality.

also tested with intel core i5, same problems, crash of chrome browser.

the load on the jitsi meet server was around 50%, 130Mbps, and 20k pps with 15 users.

in the server logs all that i see strange is this:

2015-04-05 10:42:58.405 INFO: [45] org.jitsi.videobridge.Content.info() Created channel db9512794e0850b of content video of conference 672a1f547366b242. The total number of conferences is now 2, channels 29, video streams 100.
2015-04-05 10:43:49.215 INFO: [12] org.jitsi.videobridge.Conference.info() Expired conference ceb6c0583f0cac15. The total number of conferences is now 1, channels 30, video streams 100.
2015-04-05 10:43:49.222 INFO: [12] org.jitsi.videobridge.Channel.info() Expired channel f4f64124f872b58 of content audio of conference 672a1f547366b242. The total number of conferences is now 1, channels 29, video streams 100.

……………..

2015-04-05 10:46:59.150 WARNING: [7397] org.jitsi.impl.neomedia.rtp.translator.PushSourceStreamImpl.warn() Discarded an RTP packet because the read queue is full.
2015-04-05 10:46:59.150 WARNING: [7580] org.jitsi.impl.neomedia.rtp.translator.PushSourceStreamImpl.warn() Discarded an RTP packet because the read queue is full.

Thanks in advanced,

Stefan Szabo
Romania


#2

You can try to limit the visible thumbnails of the peers with the
LastN configuration option in the config file, so your browser won't
have to deal with a very large number of streams. You'll see
thumbnails of the last active N speakers plus yourself.

Also hiding the thumbnails film strip, even temporarily, helps when
you have such load.

···

On Tue, 5 May 2015 12:15:47 +0300 Stefan Szabo wrote:

from 12 users up the users computers procs went to 100% usage and
chrome/opera/firefox-night browsers crashed.with 10 users the
conference was quite ok.

--

Yasen Pramatarov
CEO at Lindeas Ltd. https://lindeas.com
Professional Jitsi Meet services


#3

Hi, i just did a small calculations: 130 Mbps with just 15 users means
8.6 Mbps per user. I have no clue what you used as video cam but 8.6
Mbps is a DVD raw stream.

Turn down your screenresolution and video bandwith to max 1.5 mbps per
user.. for a 640x480 resolution 700 Kbps would be enough.
I bet, your problems will go away.

Pls keep me updated if it worked or not.

Marius

···

Am 05.05.2015 um 11:15 schrieb Stefan Szabo:

hi,

i have this issue with jitsi meet webconference, so please help me.

i have a jitsi meet server on our internal network - Dual-Core AMD Opteron - 2800 Mhz, ubuntu, 4Gb Ram, 1Gbit network card
15 users today in a webconference.

from 12 users up the users computers procs went to 100% usage and chrome/opera/firefox-night browsers crashed.with 10 users the conference was quite ok.

my computer : core2duo 2.53Ghz, 4Ghz, with 10 users i have 80% load on CPU.
my computer : core2duo 2.53Ghz, 4Ghz, with 15 users i have 100% load on CPU, after ten minutes i manage to enter the conference, but with lag and very poor quality.

also tested with intel core i5, same problems, crash of chrome browser.

the load on the jitsi meet server was around 50%, 130Mbps, and 20k pps with 15 users.


#4

ok, default i see this value:

    channelLastN: -1, // The default value of the channel attribute last-n.

what means -1, or what values to use for? is 5 ok?

···

On 05 May 2015, at 12:32, Yasen Pramatarov <yasen@lindeas.com> wrote:

On Tue, 5 May 2015 12:15:47 +0300 Stefan Szabo wrote:

from 12 users up the users computers procs went to 100% usage and
chrome/opera/firefox-night browsers crashed.with 10 users the
conference was quite ok.

You can try to limit the visible thumbnails of the peers with the
LastN configuration option in the config file, so your browser won't
have to deal with a very large number of streams. You'll see
thumbnails of the last active N speakers plus yourself.

Also hiding the thumbnails film strip, even temporarily, helps when
you have such load.

--
> Yasen Pramatarov
> CEO at Lindeas Ltd. https://lindeas.com
> Professional Jitsi Meet services

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#5

Hi Marius,

how do you do you turn down screen resolution and video bandwith in Jitsi meet ?

Thank you


#6

Since in this configuration everyone receives everyone else's streams, this 8.6Mbps includes the streams of all other 14 participants.

Boris

···

On 05/05/15 07:58, Cyborg wrote:

Am 05.05.2015 um 11:15 schrieb Stefan Szabo:

hi,

i have this issue with jitsi meet webconference, so please help me.

i have a jitsi meet server on our internal network - Dual-Core AMD Opteron - 2800 Mhz, ubuntu, 4Gb Ram, 1Gbit network card
15 users today in a webconference.

from 12 users up the users computers procs went to 100% usage and chrome/opera/firefox-night browsers crashed.with 10 users the conference was quite ok.

my computer : core2duo 2.53Ghz, 4Ghz, with 10 users i have 80% load on CPU.
my computer : core2duo 2.53Ghz, 4Ghz, with 15 users i have 100% load on CPU, after ten minutes i manage to enter the conference, but with lag and very poor quality.

also tested with intel core i5, same problems, crash of chrome browser.

the load on the jitsi meet server was around 50%, 130Mbps, and 20k pps with 15 users.

Hi, i just did a small calculations: 130 Mbps with just 15 users means
8.6 Mbps per user. I have no clue what you used as video cam but 8.6
Mbps is a DVD raw stream.


#7

-1 means unlimited

You can test with 5, yes -- then you'll be seeing yourself + the last
4 active participants. Just test and find your best choice :slight_smile: Anyway,
looking at more than 10 or 20 thumbnails at the same time is not
exactly perfect user experience, so if you don't need them, just lower
this number.

You can always see the full list of participants in the contact list
(the small button on lower right, right above the filmstrip show/hide
button). The lastN limits the thumbnails and the received media
streams, you still have everyone in the contact list.

···

On Tue, 5 May 2015 12:35:58 +0300 Stefan Szabo wrote:

ok, default i see this value:

   channelLastN: -1, // The default value of the channel attribute
last-n.

what means -1, or what values to use for? is 5 ok?

--

Yasen Pramatarov
CEO at Lindeas Ltd. https://lindeas.com
Professional Jitsi Meet services


#8

i dont think you can do that, it is done automatically if you have loss or jitter.

so in normal condition with a resolution of 640X360 bitrate in jitsi meet is aprox. 2Mbps down, and 2Mbps up.

estimated bandwith reported by jitsi info is 3,7Mbps down and 4Mbps up.

i will test with what Yasen said, modifying “channelLastN: -1”, where -1 is infinite.

now i’m waiting to see the result with channelLastN: 5, after test i will let you know how it worked it out.

Thank you very much all of you!

Stefan Szabo

···

On 05 May 2015, at 17:21, Frédéric <subtildream@gmail.com> wrote:

Hi Marius,

how do you do you turn down screen resolution and video bandwith in Jitsi meet ?

Thank you

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users


#9

hi all,

thanks for the tip, now everything is ok, my value is channelLastN: 10, because the conference owner wants to see as many as he can.
“is important to see their faces, if they are listening or they sleep"

with this value my computer enters in conference with a delay of 30s, but after waiting 30s, everything is working fine.core2duo-2,53Ghz-macos.

thank you to you all!

···

On 05 May 2015, at 13:00, Yasen Pramatarov <yasen@lindeas.com> wrote:

On Tue, 5 May 2015 12:35:58 +0300 Stefan Szabo wrote:

ok, default i see this value:

  channelLastN: -1, // The default value of the channel attribute
last-n.

what means -1, or what values to use for? is 5 ok?

-1 means unlimited

You can test with 5, yes -- then you'll be seeing yourself + the last
4 active participants. Just test and find your best choice :slight_smile: Anyway,
looking at more than 10 or 20 thumbnails at the same time is not
exactly perfect user experience, so if you don't need them, just lower
this number.

You can always see the full list of participants in the contact list
(the small button on lower right, right above the filmstrip show/hide
button). The lastN limits the thumbnails and the received media
streams, you still have everyone in the contact list.

--
> Yasen Pramatarov
> CEO at Lindeas Ltd. https://lindeas.com
> Professional Jitsi Meet services

_______________________________________________
users mailing list
users@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/users